•   
  • 1
  • 15
  • 16
  • 17(current)
  • 18
  • 19
  • 49
  •   
[FRODO release] Skin Widgets
(2012-12-17, 01:01)tungmeister Wrote: Where does Skin widgets get series posters from? the posters its displaying for my shows aren't the ones that I've got set in my library?

Your library
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
How is it possible for the posters it displays to be different from the ones I've got set in my library then?
Reply
Frodo RC still shows this as broken... I manually DL'd and Installed .17 from the repo, and previously tried .14 -- both show as broken.

Any ETA for a fix?
I'm not an expert but I play one at work.
Reply
(2012-12-17, 01:13)Livin Wrote: Frodo RC still shows this as broken... I manually DL'd and Installed .17 from the repo, and previously tried .14 -- both show as broken.

Any ETA for a fix?
it shouldn't be marked as broken in RC1.

if could you try this:
- enable debug logging
- quit xbmc
- delete Addon15.db
- start xbmc
- post Debug Log

Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
So I'm still getting script error for the skin widget. im running Ubuntu 12.04 LTS with xbmc RC1. Here is my debug file. http://pastebin.com/qt6pUDw0
Reply
(2012-12-18, 11:42)Vinnie85 Wrote: So I'm still getting script error for the skin widget. im running Ubuntu 12.04 LTS with xbmc RC1. Here is my debug file. http://pastebin.com/qt6pUDw0

I also get a script error for versions .14 & .17

Usually right in the middle of watching a video... Sad
I'm not an expert but I play one at work.
Reply
my script error only shows up when i start xbmc
(2012-12-18, 17:39)Livin Wrote:
(2012-12-18, 11:42)Vinnie85 Wrote: So I'm still getting script error for the skin widget. im running Ubuntu 12.04 LTS with xbmc RC1. Here is my debug file. http://pastebin.com/qt6pUDw0

I also get a script error for versions .14 & .17

Usually right in the middle of watching a video... Sad

Mine only shows up when I first start xbmc
Reply
I am getting the following error:
Code:
Code:
13:19:33 T:4625797120   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.AttributeError'>
                                            Error Contents: 'MyPlayer' object has no attribute 'type'
                                            Traceback (most recent call last):
                                              File "/Volumes/iMac_27 HD/Users/mwinestock/Library/Application Support/XBMC/addons/service.skin.widgets/default.py", line 685, in onPlayBackStopped
                                                if self.type == 'movie':
                                            AttributeError: 'MyPlayer' object has no attribute 'type'
                                            -->End of Python script error report<--

Debug Log: http://pastebin.com/CNFv6Lwp
Kodi 17, Transparency Skin
PogoPlug v4 running Arm Linux 4.4.63 as MySQL (mariadb) server.
Mac OS 10.12.5
2015 27" iMac 3.3 GHz Quad, 16GB RAM, 1TB SSD
2015 13" Macbook Pro, 8GB RAM, 256GB SSD
AppleTV 4 TV OS 10
Reply
Does that always happen? Only way it could maybe happen is if you stop the video within one second after playing it.

@Martijn
Maybe adding self.type="" to the init method of MyPlayer could prevent such errors.
[Image: xp1080-21.png]
Reply
(2012-12-20, 15:16)`Black Wrote: Does that always happen? Only way it could maybe happen is if you stop the video within one second after playing it.

@Martijn
Maybe adding self.type="" to the init method of MyPlayer could prevent such errors.

It is always happening. I am not stopping the video early.
Kodi 17, Transparency Skin
PogoPlug v4 running Arm Linux 4.4.63 as MySQL (mariadb) server.
Mac OS 10.12.5
2015 27" iMac 3.3 GHz Quad, 16GB RAM, 1TB SSD
2015 13" Macbook Pro, 8GB RAM, 256GB SSD
AppleTV 4 TV OS 10
Reply
(2012-12-20, 04:45)winestock Wrote: I am getting the following error:
Code:
Code:
13:19:33 T:4625797120   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.AttributeError'>
                                            Error Contents: 'MyPlayer' object has no attribute 'type'
                                            Traceback (most recent call last):
                                              File "/Volumes/iMac_27 HD/Users/mwinestock/Library/Application Support/XBMC/addons/service.skin.widgets/default.py", line 685, in onPlayBackStopped
                                                if self.type == 'movie':
                                            AttributeError: 'MyPlayer' object has no attribute 'type'
                                            -->End of Python script error report<--

Debug Log: http://pastebin.com/CNFv6Lwp

Not a Debug Log and NEVER post snippets
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
Is it possible to show album tracks when click on recent/random album ?

Reply
(2012-12-20, 15:16)`Black Wrote: Does that always happen? Only way it could maybe happen is if you stop the video within one second after playing it.

@Martijn
Maybe adding self.type="" to the init method of MyPlayer could prevent such errors.

My guess is that intro script (log line 91) is the problem.
Will move the variable cause indeed it belongs there but I just copied this part of code from watchlist Wink

Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
(2012-12-20, 19:09)Martijn Wrote: but I just copied this part of code from watchlist Wink

that's no excuse ;-p
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
(2012-12-20, 19:11)ronie Wrote:
(2012-12-20, 19:09)Martijn Wrote: but I just copied this part of code from watchlist Wink

that's no excuse ;-p

Yes it is Big Grin
I just used that excuse so it's possible
Read/follow the forum rules.
For troubleshooting and bug reporting, read this first
Interested in seeing some YouTube videos about Kodi? Go here and subscribe
Reply
  •   
  • 1
  • 15
  • 16
  • 17(current)
  • 18
  • 19
  • 49
  •   
 
Thread Rating:
  • 8 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[FRODO release] Skin Widgets58
This forum uses Lukasz Tkacz MyBB addons.