•   
  • 1
  • 93
  • 94
  • 95(current)
  • 96
  • 97
  • 109
  •   
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC
(2013-04-05, 17:28)captaintrap Wrote: I have a paid netfli account, do i still need someone else's API key? When I get the key how do I get the adding working? Thanks for the info


Yeah, Netflix stopped handing out Developer Keys as part of a change up in their API, and until the Plugin gets reworked, either through scraping the website or the RSS feeds, (which is the way I'd go if I ran the zoo) everyone who didn't get one is out in the cold.
Reply
Ok so who's gonna help their good old buddy Captaintrap with an API key
Reply
I think the API key in the plex plugin is still good... go check the code and use that one.
Reply
https://github.com/jimdoescode/CodeIgnit...PI-Library

There should be something in there of value. Ask Jim on the issues page?
Reply
(2013-03-03, 17:54)jeoff Wrote: Hello I am running Frodo on Windows XP.
I installed the XBMC flicks addon and everything looks OK untill I try to play a video. I see XBMC getting minimized and IE opens. But after that I only see a white screen with a red bar accross the top with the Netflix logo in the top left. I hear constant clicking in the background and the video never starts playing.

Anyone seen this before? thanks!

(2013-03-07, 04:42)tegat Wrote: To those hearing that ticking sound when launching a video:

You may be able to fix it by changing your Audio Output settings.For me this issue mysteriously began when I upgraded from Frodo RC3 to Final. I went to this page http://wiki.xbmc.org/index.php?title=Aud...gure_audio and followed the Audio Output Settings Guide for TV since the audio output from my computer goes to my TV. If you have a different speaker setup you probably have to adjust accordingly. For Audio output device, WASAPI worked for me. DirectSound caused the ticking to occur.

Hope that helps.

according to the information in that link, it seems WASAPI was introduced with Vista SP1, so jeoff and myself might be out of luck getting rid of that ticking sound running XP? i couldn't find any other options or settings that affected it... any other ideas?

when my budget allows i plan on building a new HTPC which should fix a lot of these issues, but until then i'll keep limping my Dell XP machine along Tongue
Reply
Well, these surely are great news for this addon: Netflix will switch from Silverlight to HTML5 soon

http://www.engadget.com/2013/04/15/netfl...ght-html5/
Reply
(2013-04-16, 05:33)baruchin Wrote: Well, these surely are great news for this addon: Netflix will switch from Silverlight to HTML5 soon

http://www.engadget.com/2013/04/15/netfl...ght-html5/

See as I have this working right now, I don't want to see any changes... Especially now that Amazon is dead.
Reply
(2013-04-21, 03:57)locoguano Wrote:
(2013-04-16, 05:33)baruchin Wrote: Well, these surely are great news for this addon: Netflix will switch from Silverlight to HTML5 soon

http://www.engadget.com/2013/04/15/netfl...ght-html5/

See as I have this working right now, I don't want to see any changes... Especially now that Amazon is dead.

What plugin are you using? could you provide a link? I used to use XBMCFlicks to watch netflix for a couple of years, it broke a few months ago and was updated and worked again, but just recently (last month or so?) broke again.

has XBMCFlicks been updated to work again? or are you using another plugin? a link to what you have this working with would be much appreciated Smile

I read a page back that you said if you have a plex key it works? I wasnt sure what that meant so I installed plex server and plex media player. and then I installed Plex plugin in the server browser, then restarted plex media player and BAM, Netflix works.

Now my question is, does this mean I can get my XBMC to work? because I dont really want to switch to plex, some of my local x264 encoded files stutter and buffer when played in plex but play smoothly in XBMC, I think it has to do with the method plex uses to decode... either crappy software or not utilizing both cores, no idea.
Reply
(2013-04-23, 06:39)xekon Wrote:
(2013-04-21, 03:57)locoguano Wrote:
(2013-04-16, 05:33)baruchin Wrote: Well, these surely are great news for this addon: Netflix will switch from Silverlight to HTML5 soon

http://www.engadget.com/2013/04/15/netfl...ght-html5/

See as I have this working right now, I don't want to see any changes... Especially now that Amazon is dead.

What plugin are you using? could you provide a link? I used to use XBMCFlicks to watch netflix for a couple of years, it broke a few months ago and was updated and worked again, but just recently (last month or so?) broke again.

has XBMCFlicks been updated to work again? or are you using another plugin? a link to what you have this working with would be much appreciated Smile

I read a page back that you said if you have a plex key it works? I wasnt sure what that meant so I installed plex server and plex media player. and then I installed Plex plugin in the server browser, then restarted plex media player and BAM, Netflix works.

Now my question is, does this mean I can get my XBMC to work? because I dont really want to switch to plex, some of my local x264 encoded files stutter and buffer when played in plex but play smoothly in XBMC, I think it has to do with the method plex uses to decode... either crappy software or not utilizing both cores, no idea.

I've had it working for so long that I don't really remember the process. I think I used spudsdude-XBMC-Flicks. I then downloaded the Plex plugin and got the keys that I needed from that and did the http://developer.netflix.com/walkthrough .
Reply
i cant believe there is not more documentation on this plug-in. you would think it was the most popular add-on for xbmc. does anyone have this working?
Reply
Quote:I've had it working for so long that I don't really remember the process. I think I used spudsdude-XBMC-Flicks. I then downloaded the Plex plugin and got the keys that I needed from that and did the http://developer.netflix.com/walkthrough .

Hi Locoguano, excuse my ignorance but could you help me with retrieving the keys needed from the plex plugin?
Reply
See if you can make some use of this...
Code:
NETFLIX_SERVER = 'api-public.netflix.com'
NETFLIX_PORT   = 80

NETFLIX_VERSION = '1.5'

REQUEST_TOKEN_URL = 'http://api-public.netflix.com/oauth/request_token'
ACCESS_TOKEN_URL  = 'http://api-public.netflix.com/oauth/access_token'
AUTHORIZATION_URL = 'https://api-public.netflix.com/oauth/login'
API_URL = 'http://api-public.netflix.com/'

CONSUMER_KEY    = 'nfeafbf2hpdnyfvr5dd32ka6'
CONSUMER_SECRET = 'bBsa6TqYab'
Reply
Thanks mate, extremely helpful.

Mind if I PM you for a little more assistance? I'm a novices at best and would like to learn without being told out right what to do. Smile

Thanks
Reply
(2013-05-03, 23:09)demannu Wrote: Thanks mate, extremely helpful.

Mind if I PM you for a little more assistance? I'm a novices at best and would like to learn without being told out right what to do. Smile

Thanks


please no pm !share the info to the rest of the world thanks you
Reply
I followed the directions on page 133 of this thread and used the above.
Reply
  •   
  • 1
  • 93
  • 94
  • 95(current)
  • 96
  • 97
  • 109
  •   
 
Thread Rating:
  • 16 Vote(s) - 4.44 Average



Logout Mark Read Team Forum Stats Members Help
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC4.4416