•   
  • 1
  • 215
  • 216
  • 217(current)
  • 218
  • 219
  • 315
  •   
  Thread Closed
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
Question about playing a video via .strm file in XBMC. I know I have to take the Video ID and place it in the code (3rd line below). The problem here is the Video ID keeps changing every few days. Is there a code to put username fashiontvUSA instead? This way I do not have to update the Video ID when it changes.

http://www.youtube.com/watch?v=KoBK7jBnVAc

plugin://plugin.video.youtube/?action=play_video&videoid=KoBK7jBnVAc

http://www.youtube.com/user/fashiontvUSA

Thanks!
XBMC Eden 12.3 (Dec 24, 2014) on ATV2 JB 5.3 and Nexus 7. One-for-All IR/RF/x10 Remote URC-9911.
Hello. I need help,
youtube does not work

I've been using the 4.4.4 version,
xbmc eden12.2
mac os x snow leopard 10.6.8

youtube download works,
vimeo works,
any other addons streaming works,

and the third time I write, Please answer a some.
(sorry for my english, I do not speak well, )

Thanks!


18:47:57 T:140735087889600 NOTICE: DVDPlayer: Opening: http://r3---sn-5cjvh-up5e.c.youtube.com/...1363024036 | Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:16.0.1) Gecko/20121011 Firefox/16.0.1
18:47:57 T:140735087889600 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
18:47:57 T:4877529088 NOTICE: Thread CDVDPlayer start, auto delete: false
18:47:57 T:4877529088 NOTICE: Creating InputStream
18:47:58 T:4877529088 WARNING: FillBuffer: curl failed with code 22
18:47:58 T:4877529088 ERROR: CCurlFile::CReadState::Open, didn't get any data from stream.
18:47:58 T:4877529088 ERROR: Open - failed to open source <http://r3---sn-5cjvh-up5e.c.youtube.com/videoplayback?expire=1363044648&itag=22&ratebypass=yes&source=youtube&mv=m&id=28b024c528ecf196&key=yt1&upn=qz4ebltcCMk&ms=au&sparams=cp,id,ip,ipbits,itag,ratebypass,source,upn,expire&ipbits=8&newshard=yes&fexp=919111,931006,913564,914030,916611,920704,912806,902000,919512,929901,913605,925006,906938,931202,931203,931401,913566,908529,930803,920201,930101,930603,906834,926403&sver=3&cp=U0hVSFBPUl9JUkNONV9ISVZHOnlMS2R2c0x4MjFV&ip=80.78.79.254&mt=1363024036 | Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:16.0.1) Gecko/20121011 Firefox/16.0.1>
(2013-06-11, 22:59)Morphy99 Wrote:
(2013-05-31, 04:59)metatime Wrote: I'm having trouble with when I want to fast forward on the video in youtube but the app stalls. Like for example if I want to start at 5 mins into a video, the app stalls and nothing happens.
I'm having this issue too. Skipping 30 secs and by the timeline bar freezes the video. Is this a recent issue or known?

This is only present on my windows machine. Openelec on the pi works fine
I'm not able to play the youtube videos, due to script is failed and the XBMC.log error is:

07:09:15 T:1178776760 ERROR: Error Type: <type 'exceptions.IndexError'>
07:09:15 T:1178776760 ERROR: Error Contents: list index out of range
07:09:15 T:1178776760 ERROR: Traceback (most recent call last):
File "/root/.xbmc/addons/plugin.video.youtube/default.py", line 52, in <module>
navigator.executeAction(params)
File "/root/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py", line 196, in executeAction
player.playVideo(params)
File "/root/.xbmc/addons/plugin.video.youtube/YouTubePlayer.py", line 52, in playVideo
(video, status) = self.getVideoObject(params);
File "/root/.xbmc/addons/plugin.video.youtube/YouTubePlayer.py", line 254, in getVideoObject
(links, video) = self._getVideoLinks(video, params)
File "/root/.xbmc/addons/plugin.video.youtube/YouTubePlayer.py", line 307, in _getVideoLinks
player_object = self._convertFlashVars(data[0])
File "/root/.xbmc/addons/plugin.video.youtube/YouTubePlayer.py", line 278, in _convertFlashVars
obj["PLAYER_CONFIG"]["args"][it[0]] = urllib.unquote_plus(it[1])
IndexError: list index out of range
07:09:15 T:1178776760 INFO: -->End of Python script error report<--
07:09:15 T:728645952 DEBUG: ------ Window Init (DialogKaiToast.xml) ------
07:09:15 T:728645952 DEBUG: Alloc resources: 0.04ms (0.03 ms skin load)
07:09:15 T:1178776760 INFO: Python script stopped

If anyone facing this kind of error please let me know, how to solve this.

Thanks
Youtube definitely changed something again. Even my DownloadHelper plugin doesn't work anymore.
I have the same issue. It seems to be with videos that have been played often (like those in my playlist). Once the video does not play in the playlist, it does not play anywhere in the plugin. Everything plays OK in a browser. Win7/Frodo 12.2

I've tried the following; nothing worked:
- deleting 2 plugin folders, reinstalling
- the previous 3 down-rev youtube plugins
- playing unplayable videos when not logged in
- clearing xbmc cache
- all possible resolutions
- disabling youtube cache server in plugin

On my client, same error occurs, so it is not an issue with my system, the plugin is broken.

Thanks

(2013-06-13, 10:24)ujku10 Wrote: Hello. I need help,
youtube does not work

I've been using the 4.4.4 version,
xbmc eden12.2
mac os x snow leopard 10.6.8

youtube download works,
vimeo works,
any other addons streaming works,

and the third time I write, Please answer a some.
(sorry for my english, I do not speak well, )

Thanks!


18:47:57 T:140735087889600 NOTICE: DVDPlayer: Opening: http://r3---sn-5cjvh-up5e.c.youtube.com/...1363024036 | Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:16.0.1) Gecko/20121011 Firefox/16.0.1
18:47:57 T:140735087889600 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
18:47:57 T:4877529088 NOTICE: Thread CDVDPlayer start, auto delete: false
18:47:57 T:4877529088 NOTICE: Creating InputStream
18:47:58 T:4877529088 WARNING: FillBuffer: curl failed with code 22
18:47:58 T:4877529088 ERROR: CCurlFile::CReadState::Open, didn't get any data from stream.
18:47:58 T:4877529088 ERROR: Open - failed to open source <http://r3---sn-5cjvh-up5e.c.youtube.com/videoplayback?expire=1363044648&itag=22&ratebypass=yes&source=youtube&mv=m&id=28b024c528ecf196&key=yt1&upn=qz4ebltcCMk&ms=au&sparams=cp,id,ip,ipbits,itag,ratebypass,source,upn,expire&ipbits=8&newshard=yes&fexp=919111,931006,913564,914030,916611,920704,912806,902000,919512,929901,913605,925006,906938,931202,931203,931401,913566,908529,930803,920201,930101,930603,906834,926403&sver=3&cp=U0hVSFBPUl9JUkNONV9ISVZHOnlMS2R2c0x4MjFV&ip=80.78.79.254&mt=1363024036 | Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:16.0.1) Gecko/20121011 Firefox/16.0.1>
I'm also having the same issue. For some reason it doesn't apply to all of my playlist videos....cant figure out why it affects some but not all.
If I try to use wget to get the URL that this plugin or DownloadHelper expect to use, I get 403 Forbidden.

Code:
Connecting to r10---sn-ab5e6ner.c.youtube.com (r10---sn-ab5e6ner.c.youtube.com)|173.194.31.15|:80... connected.
HTTP request sent, awaiting response... 403 Forbidden
2013-06-15 21:58:11 ERROR 403: Forbidden.
Id like to request a few things.

1. My subscriptions should be sorted in order by the time they were uploaded. Right now I need to check the same list over and over again, so I dont miss any new videos among the older ones.

2. Option to mark videos as watched.

3. Hide watched videos.
Is there any update on a fix. Seems like youtube is slowly implimenting something new. I can play some videos but not others.

Code:
22:45:47 T:2456  NOTICE: -->Python Interpreter Initialized<--
22:45:47 T:2456  NOTICE: YouTube-4.4.4
22:45:47 T:2456  NOTICE: CommonFunctions-2.5.1
22:45:54 T:2456  NOTICE: links: 'dict'
22:45:55 T:1108  NOTICE: DVDPlayer: Opening: http://r10---sn-hp576nez.c.youtube.com/videoplayback?id=ff08c56a150b08af&ms=au&factor=1.25&mt=1371350735&ipbits=8&algorithm=throttle-factor&burst=40&sver=3&expire=1371372583&source=youtube&newshard=yes&mv=m&upn=UaODNJFSRA4&cp=U0hWRlNSUF9NTUNONl9LTFRGOlZwRXdCYVZaUmJQ&key=yt1&ip=72.224.72.212&gcr=us&sparams=algorithm,burst,cp,factor,gcr,id,ip,ipbits,itag,source,upn,expire&fexp=919359,914051,916612,913819,900352,921047,924605,928201,901208,929117,929123,929915,929906,929907,929125,925714,929919,931202,928017,912512,912515,912521,906906,904488,931910,931913,932227,904830,919373,906836,933701,904122,900816,912711,930618,930621,929606,910075&itag=35|User-Agent=Mozilla%2F5.0+%28Windows+NT+6.2%3B+Win64%3B+x64%3B+rv%3A16.0.1%29+Gecko%2F20121011+Firefox%2F16.0.1
22:45:55 T:1108 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
22:45:55 T:2804  NOTICE: Thread CDVDPlayer start, auto delete: false
22:45:55 T:2804  NOTICE: Creating InputStream
22:45:56 T:2804 WARNING: XFILE::CCurlFile::CReadState::FillBuffer: curl failed with code 22
22:45:56 T:2804   ERROR: CCurlFile::CReadState::Open, didn't get any data from stream.
22:45:56 T:2804   ERROR: XFILE::CFileCache::Open - failed to open source <http://r10---sn-hp576nez.c.youtube.com/videoplayback?id=ff08c56a150b08af&ms=au&factor=1.25&mt=1371350735&ipbits=8&algorithm=throttle-factor&burst=40&sver=3&expire=1371372583&source=youtube&newshard=yes&mv=m&upn=UaODNJFSRA4&cp=U0hWRlNSUF9NTUNONl9LTFRGOlZwRXdCYVZaUmJQ&key=yt1&ip=72.224.72.212&gcr=us&sparams=algorithm,burst,cp,factor,gcr,id,ip,ipbits,itag,source,upn,expire&fexp=919359,914051,916612,913819,900352,921047,924605,928201,901208,929117,929123,929915,929906,929907,929125,925714,929919,931202,928017,912512,912515,912521,906906,904488,931910,931913,932227,904830,919373,906836,933701,904122,900816,912711,930618,930621,929606,910075&itag=35|User-Agent=Mozilla%2F5.0+%28Windows+NT+6.2%3B+Win64%3B+x64%3B+rv%3A16.0.1%29+Gecko%2F20121011+Firefox%2F16.0.1>
22:45:56 T:2804   ERROR: CDVDPlayer::OpenInputStream - error opening [http://r10---sn-hp576nez.c.youtube.com/videoplayback?id=ff08c56a150b08af&ms=au&factor=1.25&mt=1371350735&ipbits=8&algorithm=throttle-factor&burst=40&sver=3&expire=1371372583&source=youtube&newshard=yes&mv=m&upn=UaODNJFSRA4&cp=U0hWRlNSUF9NTUNONl9LTFRGOlZwRXdCYVZaUmJQ&key=yt1&ip=72.224.72.212&gcr=us&sparams=algorithm,burst,cp,factor,gcr,id,ip,ipbits,itag,source,upn,expire&fexp=919359,914051,916612,913819,900352,921047,924605,928201,901208,929117,929123,929915,929906,929907,929125,925714,929919,931202,928017,912512,912515,912521,906906,904488,931910,931913,932227,904830,919373,906836,933701,904122,900816,912711,930618,930621,929606,910075&itag=35|User-Agent=Mozilla%2F5.0+%28Windows+NT+6.2%3B+Win64%3B+x64%3B+rv%3A16.0.1%29+Gecko%2F20121011+Firefox%2F16.0.1]
22:45:56 T:2804  NOTICE: CDVDPlayer::OnExit()
22:45:56 T:2804  NOTICE: CDVDPlayer::OnExit() deleting input stream
22:45:56 T:1108   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.youtube/?action=play_video&videoid=_wjFahULCK8]
22:45:56 T:1108  NOTICE: CDVDPlayer::CloseFile()
22:45:56 T:1108 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
22:45:56 T:1108  NOTICE: DVDPlayer: waiting for threads to exit
22:45:56 T:1108  NOTICE: DVDPlayer: finished waiting
22:46:13 T:1988  NOTICE: Thread XBPyThread start, auto delete: false

The full log is here: xbmclogs.com
I have the same issue - some videos will play and others will not. I am unsure as to where the log file is located (otherwise I would have posted it), but it seems to me that it is the VIVO hosted videos which are principally affected.

I am using OpenElec V3.0.6, XMBC Frodo 12.2 and You Tube add-on V 4.4.4

I would welcome news regarding any fix.

Thanks
it's on copyrighted videos. those are the ones that don't play. They won't play on my ipad either.
I got some kind of youtube google+ update on the site yesterday, which I updated to the new version

Since this morning, I haven't been able to view my Watch Later or any of my playlists. Anyone else getting the same problem? Can't even go into my subs
I had to edit my login details stored in the plugin to use my email address, rather than my existing username.
not just copyrighted videos.
almost none work at the moment.
  •   
  • 1
  • 215
  • 216
  • 217(current)
  • 218
  • 219
  • 315
  •   
  Thread Closed
 
Thread Rating:
  • 28 Vote(s) - 4.14 Average



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only4.1428