•   
  • 1
  • 217
  • 218
  • 219(current)
  • 220
  • 221
  • 315
  •   
  Thread Closed
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
How do we get this discourse to the attention of the developers?

It has already been thrown out once when a ticket was raised recently but maybe the issue was that it is not a bug which needs to be corrected, but rather a request for new coding to reflect what is the current reality - for example emulating the protocols of the vevo / bluecop app that Navigates refers to in his post below.

Is there a different channel for requesting developments / specification changes rather than the usual one for bug fixes?
I just found out, totally by accident mind you, that the plugin does work!

When I click on "Play Now" in the "Play to XBMC" chome plugin, the "opening stream" window pops up on XBMC... and stays there, with no progress whatsoever, for EIGHT MINUTES... The screen saver even kicks in. But the video eventually start playing.

I tried a few different videos, from a 27min 1080p video, down to a 28 seconds, 360p video. They all take about 8 min to show up on screen.

Hope that helps debugging?
is there any solution and method in this addon for watching youtube videos in countries where it is Geo-blocked, thanks.
I can't seem to find this scenario or issue stated anywhere (excuse me if it is) but sometimes when XBMC is idle or not being used, I randomly get a Youtube video being played, usually a trailer, sometimes not. I assume it's this, because my remote shows a url for Youtube plugin. I don't know if it's the settings or related to another add - on or something else. Any ideas? (Apologies if the problem is remotely obvious - I'm new Wink


N: Sometimes I also get a cache video randomly playing (when XBMC is idle,) opening curtains and then it stops. I don't know if that's related to cinema experience (I've just added).
Well unfortunately there are places where youtube service is not working and blockedConfused does any one know how to coupe with this issue.
Dear,

    When I try to run a youtube video marked the vevo, he does not play any other video works perfectly put videos channel vevo not playing! I think that is rights issue .... Anyone know of any solution?
Hi

I have problem with Youtube videos not working in external player on Windows, my netbook is to slow to play in XBMC native player but it plays just fine in external players like WMP or GOM, however when I try to play Youtube video I get an error access denied, why is that? Even if I copy&paste YT video URL from xbmc.log (no errors in log) to IE it shows HTTP Error 403 Access Denied, why is that? Video plays in internal XBMC player but is too slow to be watchable, please help THANKS.
(2013-07-01, 20:39)maronn Wrote: Hi

I have problem with Youtube videos not working in external player on Windows, my netbook is to slow to play in XBMC native player but it plays just fine in external players like WMP or GOM, however when I try to play Youtube video I get an error access denied, why is that? Even if I copy&paste YT video URL from xbmc.log (no errors in log) to IE it shows HTTP Error 403 Access Denied, why is that? Video plays in internal XBMC player but is too slow to be watchable, please help THANKS.

Duplicate of this: http://forum.xbmc.org/showthread.php?tid=168232
(2013-07-01, 22:47)artrafael Wrote: Duplicate of this: http://forum.xbmc.org/showthread.php?tid=168232

Yeah I know, I tried to delete that post because I found this topic, but I got permission denied.

(2013-07-01, 22:36)artrafael Wrote: If the URL doesn't work using Internet Explorer (outside of XBMC), then it's not an XBMC issue. Have you tried accessing the same URL on a different system via a web browser?

Yes I tried that and got same result - OK in internal player, error 403 acces denied in external player/ IE.
It looks like that video URL somehow expires before it's handled by an external playerHuh
Since a few days, when I try to play a video from my watch later or my subscription, I get a keypad appearing besides the loading screen. After clicking OK a few times, I get an url cannot be loaded error.

I thought it might be a Google Authenticator prompt but when entering correct code it does not work better.

I have tried erasing my login info and re-entering them. Upon first play I got the keypad, entered a Google Authenticator code and the video played. After exiting the plugin and getting back in, I am back with the same problem.

Is this something known or resulting from recent change?
And nothing relevant on the log:

Code:
23:17:00 T:140409527334656   DEBUG: CecLogMessage - >> 04:44:00
23:17:00 T:140409527334656   DEBUG: CecLogMessage - >> TV (0) -> Playback 1 (4): user control pressed (44)
23:17:00 T:140409527334656   DEBUG: CecLogMessage - key pressed: select (0)
23:17:00 T:140409527334656   DEBUG: PushCecKeypress - received key  b duration 0
23:17:00 T:140410173593536   DEBUG: OnKey: 11 (0x0b) pressed, action is Select
23:17:00 T:140410173593536   DEBUG: OnPlayMedia plugin://plugin.video.youtube/?path=/root/video&action=play_video&videoid=GLKjlXN83UE
23:17:00 T:140410173593536   DEBUG: CAnnouncementManager - Announcement: OnClear from xbmc
23:17:00 T:140410173593536   DEBUG: GOT ANNOUNCEMENT, type: 2, from xbmc, message OnClear
23:17:00 T:140410173593536   DEBUG: CAnnouncementManager - Announcement: OnAdd from xbmc
23:17:00 T:140410173593536   DEBUG: GOT ANNOUNCEMENT, type: 2, from xbmc, message OnAdd
23:17:00 T:140410173593536   DEBUG: StartScript - calling plugin YouTube('plugin://plugin.video.youtube/','6','?path=/root/video&action=play_video&videoid=GLKjlXN83UE')
23:17:00 T:140410173593536    INFO: initializing python engine.
23:17:00 T:140410173593536   DEBUG: new python thread created. id=52
23:17:00 T:140410173593536   DEBUG: WaitOnScriptResult - waiting on the YouTube (id=52) plugin...
23:17:00 T:140407120271104  NOTICE: Thread XBPython start, auto delete: false
23:17:00 T:140407120271104   DEBUG: Python thread: start processing
23:17:00 T:140407120271104  NOTICE: -->Python Interpreter Initialized<--
23:17:00 T:140407120271104   DEBUG: Process - The source file to load is /home/xbmc/.xbmc/addons/plugin.video.youtube/default.py
23:17:00 T:140407120271104   DEBUG: Process - Setting the Python path to /home/xbmc/.xbmc/addons/plugin.video.youtube:/home/xbmc/.xbmc/addons/script.module.pyamf/lib:/home/xbmc/.xbmc/addons/script.module.dialogaddonscan/lib:/home/xbmc/.xbmc/addons/script.module.demjson/lib:/home/xbmc/.xbmc/addons/weather.wunderground/resources/lib/wunderground:/home/xbmc/.xbmc/addons/script.module.myconnpy/lib:/home/xbmc/.xbmc/addons/script.module.beautifulsoup/lib:/home/xbmc/.xbmc/addons/script.common.plugin.cache/lib:/home/xbmc/.xbmc/addons/script.module.free.cable.database/lib:/home/xbmc/.xbmc/addons/script.module.coveapi/lib:/home/xbmc/.xbmc/addons/script.module.buggalo/lib:/home/xbmc/.xbmc/addons/script.module.mechanize/lib:/usr/share/xbmc/addons/xbmc.debug/:/home/xbmc/.xbmc/addons/script.module.xbmcswift2/lib:/home/xbmc/.xbmc/addons/script.module.xbmcswift/lib:/home/xbmc/.xbmc/addons/script.module.simplejson/lib:/usr/share/xbmc/addons/script.module.pil/lib:/home/xbmc/.xbmc/addons/script.module.simple.downloader/lib:/home/xbmc/.xbmc/addons/script.module.requests/lib:/home/xbmc/.xbmc/addons/script.module.rssengine/lib:/home/xbmc/.xbmc/addons/script.module.parsedom/lib:/home/xbmc/.xbmc/addons/script.module.elementtree/lib:/usr/share/xbmc/addons/script.module.pysqlite/lib:/usr/lib/python27.zip:/usr/lib/python2.7:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload:/usr/lib/python2.7/site-packages:/usr/lib/python2.7/site-packages/gst-0.10:/usr/lib/python2.7/site-packages/gtk-2.0:/usr/lib/python2.7/site-packages/setuptools-0.6c11.egg-info:/usr/lib/python2.7/site-packages/wx-2.8-gtk2-unicode:
23:17:00 T:140407120271104   DEBUG: Process - Entering source directory /home/xbmc/.xbmc/addons/plugin.video.youtube
23:17:00 T:140407120271104   DEBUG: Instantiating addon using automatically obtained id of "plugin.video.youtube" dependent on version 2.1.0 of the xbmc.python api
23:17:00 T:140409527334656   DEBUG: CecLogMessage - >> 04:45
23:17:00 T:140409527334656   DEBUG: CecLogMessage - >> TV (0) -> Playback 1 (4): user control release (45)
23:17:00 T:140409527334656   DEBUG: CecLogMessage - key released: select (0)
23:17:00 T:140409527334656   DEBUG: PushCecKeypress - received key  b duration 73
23:17:00 T:140407120271104  NOTICE: YouTube-4.4.4
23:17:00 T:140407120271104  NOTICE: CommonFunctions-2.5.1
23:17:00 T:140407120271104   DEBUG: LocalizeStrings: no strings.po file exist at /home/xbmc/.xbmc/addons/plugin.video.youtube/resources/language/English, fallback to strings.xml
23:17:01 T:140410173593536   DEBUG: DialogProgress::StartModal called
23:17:01 T:140410173593536   DEBUG: ------ Window Init (DialogProgress.xml) ------
23:17:01 T:140410173593536   DEBUG: Window DialogProgress.xml was already loaded
23:17:01 T:140410173593536   DEBUG: Alloc resources: 0.54m
23:17:01 T:140407170131712   DEBUG: webserver: request received for /jsonrpc
23:17:01 T:140407170131712   DEBUG: JSONRPC: Incoming request: [{"id":0,"jsonrpc":"2.0","method":"Player.GetActivePlayers"},{"id":1,"jsonrpc":"2.0","method":"Application.GetProperties","params":{"properties":["volume","muted"]}}]
23:17:02 T:140410173593536    INFO: Loading skin file: DialogNumeric.xml, load type: KEEP_IN_MEMORY
23:17:02 T:140410173593536   DEBUG: Load DialogNumeric.xml: 4.71ms
23:17:02 T:140410173593536   DEBUG: Alloc resources: 5.14ms  (4.82 ms skin load)
23:17:02 T:140410173593536   DEBUG: ------ Window Init (DialogNumeric.xml) ------
23:17:02 T:140410173593536   DEBUG: Window DialogNumeric.xml was already loaded
23:17:02 T:140410173593536   DEBUG: Alloc resources: 0.00m
23:17:02 T:140410173593536   DEBUG: CAnnouncementManager - Announcement: OnInputRequested from xbmc
23:17:02 T:140410173593536   DEBUG: GOT ANNOUNCEMENT, type: 128, from xbmc, message OnInputRequested
23:17:04 T:140406948378368   DEBUG: webserver: request received for /jsonrpc
23:17:04 T:140406948378368   DEBUG: JSONRPC: Incoming request: [{"id":0,"jsonrpc":"2.0","method":"Player.GetActivePlayers"},{"id":1,"jsonrpc":"2.0","method":"Application.GetProperties","params":{"properties":["volume","muted"]}}]
23:17:06 T:140407170131712   DEBUG: webserver: request received for /jsonrpc
23:17:06 T:140407170131712   DEBUG: JSONRPC: Incoming request: [{"id":0,"jsonrpc":"2.0","method":"Player.GetActivePlayers"},{"id":1,"jsonrpc":"2.0","method":"Application.GetProperties","params":{"properties":["volume","muted"]}}]
23:17:08 T:140406948378368   DEBUG: webserver: request received for /jsonrpc
23:17:08 T:140406948378368   DEBUG: JSONRPC: Incoming request: [{"id":0,"jsonrpc":"2.0","method":"Player.GetActivePlayers"},{"id":1,"jsonrpc":"2.0","method":"Application.GetProperties","params":{"properties":["volume","muted"]}}]
23:17:10 T:140407170131712   DEBUG: webserver: request received for /jsonrpc
23:17:10 T:140407170131712   DEBUG: JSONRPC: Incoming request: [{"id":0,"jsonrpc":"2.0","method":"Player.GetActivePlayers"},{"id":1,"jsonrpc":"2.0","method":"Application.GetProperties","params":{"properties":["volume","muted"]}}]
23:17:12 T:140406948378368   DEBUG: webserver: request received for /jsonrpc
23:17:12 T:140406948378368   DEBUG: JSONRPC: Incoming request: [{"id":0,"jsonrpc":"2.0","method":"Player.GetActivePlayers"},{"id":1,"jsonrpc":"2.0","method":"Application.GetProperties","params":{"properties":["volume","muted"]}}]
23:17:14 T:140407170131712   DEBUG: webserver: request received for /jsonrpc
23:17:14 T:140407170131712   DEBUG: JSONRPC: Incoming request: [{"id":0,"jsonrpc":"2.0","method":"Player.GetActivePlayers"},{"id":1,"jsonrpc":"2.0","method":"Application.GetProperties","params":{"properties":["volume","muted"]}}]
23:17:16 T:140406948378368   DEBUG: webserver: request received for /jsonrpc
:{"properties":["volume","muted"]}}]
23:17:26 T:140409527334656   DEBUG: CecLogMessage - >> 04:44:26
23:17:26 T:140409527334656   DEBUG: CecLogMessage - >> TV (0) -> Playback 1 (4): user control pressed (44)
23:17:26 T:140409527334656   DEBUG: CecLogMessage - key pressed: 6 (26)
23:17:26 T:140409527334656   DEBUG: PushCecKeypress - received key c9 duration 0
23:17:26 T:140410173593536   DEBUG: OnKey: 201 (0xc9) pressed, action is Number6
23:17:26 T:140409527334656   DEBUG: CecLogMessage - >> 04:45
23:17:26 T:140409527334656   DEBUG: CecLogMessage - >> TV (0) -> Playback 1 (4): user control release (45)
23:17:26 T:140409527334656   DEBUG: CecLogMessage - key released: 6 (26)
23:17:26 T:140409527334656   DEBUG: PushCecKeypress - received key c9 duration 203
23:17:27 T:140409527334656   DEBUG: CecLogMessage - >> 04:44:29
23:17:27 T:140409527334656   DEBUG: CecLogMessage - >> TV (0) -> Playback 1 (4): user control pressed (44)
23:17:27 T:140409527334656   DEBUG: CecLogMessage - key pressed: 9 (29)
23:17:27 T:140409527334656   DEBUG: PushCecKeypress - received key c6 duration 0
23:17:27 T:140410173593536   DEBUG: OnKey: 198 (0xc6) pressed, action is Number9
23:17:27 T:140409527334656   DEBUG: CecLogMessage - >> 04:45
23:17:27 T:140409527334656   DEBUG: CecLogMessage - >> TV (0) -> Playback 1 (4): user control release (45)
23:17:27 T:140409527334656   DEBUG: CecLogMessage - key released: 9 (29)
23:17:27 T:140409527334656   DEBUG: PushCecKeypress - received key c6 duration 207
23:17:28 T:140409527334656   DEBUG: CecLogMessage - >> 04:44:00
23:17:28 T:140409527334656   DEBUG: CecLogMessage - >> TV (0) -> Playback 1 (4): user control pressed (44)
23:17:28 T:140409527334656   DEBUG: CecLogMessage - key pressed: select (0)
23:17:28 T:140409527334656   DEBUG: PushCecKeypress - received key  b duration 0
23:17:28 T:140406948378368   DEBUG: webserver: request received for /jsonrpc
23:17:28 T:140410173593536   DEBUG: OnKey: 11 (0x0b) pressed, action is Select
23:17:28 T:140406948378368   DEBUG: JSONRPC: Incoming request: [{"id":0,"jsonrpc":"2.0","method":"Player.GetActivePlayers"},{"id":1,"jsonrpc":"2.0","method":"Application.GetProperties","params":{"properties":["volume","muted"]}}]
23:17:28 T:140409527334656   DEBUG: CecLogMessage - >> 04:45
23:17:28 T:140409527334656   DEBUG: CecLogMessage - >> TV (0) -> Playback 1 (4): user control release (45)
23:17:28 T:140409527334656   DEBUG: CecLogMessage - key released: select (0)
23:17:28 T:140409527334656   DEBUG: PushCecKeypress - received key  b duration 77
23:17:28 T:140410173593536   DEBUG: ------ Window Deinit (DialogNumeric.xml) ------
23:17:28 T:140410173593536   DEBUG: CAnnouncementManager - Announcement: OnInputFinished from xbmc
23:17:28 T:140410173593536   DEBUG: GOT ANNOUNCEMENT, type: 128, from xbmc, message OnInputFinished
23:17:30 T:140407170131712   DEBUG: webserver: request received for /jsonrpc
23:17:30 T:140407170131712   DEBUG: JSONRPC: Incoming request: [{"id":0,"jsonrpc":"2.0","method":"Player.GetActivePlayers"},{"id":1,"jsonrpc":"2.0","method":"Application.GetProperties","params":{"properties":["volume","muted"]}}]
23:17:32 T:140407120271104  NOTICE: links: 'dict'
23:17:32 T:140407120271104    INFO: Scriptresult: Success
23:17:32 T:140410173593536   DEBUG: ------ Window Init (DialogKaiToast.xml) ------
23:17:32 T:140410173593536   DEBUG: Window DialogKaiToast.xml was already loaded
23:17:32 T:140410173593536   DEBUG: Alloc resources: 0.00m
23:17:32 T:140407120271104    INFO: Python script stopped
23:17:32 T:140407120271104   DEBUG: Thread XBPython 140407120271104 terminating
23:17:32 T:140410173593536   DEBUG:  WaitOnScriptResult - plugin exited prematurely - terminating
23:17:32 T:140410173593536   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.youtube/?path=/root/video&action=play_video&videoid=GLKjlXN83UE]
23:17:32 T:140410173593536   DEBUG: Playlist Player: one or more items failed to play... aborting playback
I like the addon but autoplay isn't working, when a video finishes it just goes back to the page with video thumbnails. Also when a video is playing and I click the play next video button a small box pops up that states "Can't find a next item to play".
Also the "New Subscription Videos" section is limited to 24 videos, you can't load more videos like you can in the other sections, please fix this.

With autoplay working this would be an awesome addon!

Edit: Seems that the "Play from here" option works with autoplay, great. Smile

Still would like "New Subscription Videos" to show more than 24 videos though.
(2013-06-17, 03:51)emjayuu Wrote: I have the same issue - some videos will play and others will not. I am unsure as to where the log file is located (otherwise I would have posted it), but it seems to me that it is the VIVO hosted videos which are principally affected.

I am using OpenElec V3.0.6, XMBC Frodo 12.2 and You Tube add-on V 4.4.4

I would welcome news regarding any fix.

Thanks

its due to html 5.. i ran a packet trace on some failing videso, and the difference is html5.

working videos are those delivered through one large video file.

(2013-06-17, 13:13)guy999 Wrote: it's on copyrighted videos. those are the ones that don't play. They won't play on my ipad either.

that may be the case at times.. but for the most part it is due to html5 being the default delievery method for that specific video.

this can be proven with a packet trace.

(2013-06-19, 23:42)ivseenbetter Wrote: Does the issue have anything to do with the html5 testing youtube is doing?




yes.. its due to html 5.. i ran a packet trace on some failing videso, and the difference is html5.

working videos are those delivered through one large video object.
Does the developer already knows this problem?
Thanks morelife for confirming that. I tried opting out of the testing but it didn't fix the problem. Perhaps it was too late to opt out. Any ideas on how it can be fixed?
  •   
  • 1
  • 217
  • 218
  • 219(current)
  • 220
  • 221
  • 315
  •   
  Thread Closed
 
Thread Rating:
  • 28 Vote(s) - 4.14 Average



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only4.1428