•   
  • 1
  • 103
  • 104
  • 105(current)
  • 106
  • 107
  • 109
  •   
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC
The very first post says you can download this from the default XBMC repository, but I do not see this listed anywhere at all. HOW DO I GET THIS?!
Reply
(2013-07-13, 08:51)fabes253 Wrote: The very first post says you can download this from the default XBMC repository, but I do not see this listed anywhere at all. HOW DO I GET THIS?!

Follow what this post says : http://forum.xbmc.org/showthread.php?tid...pid1445562
Image

If my replies help you, please click on my reputation Image below :) thanks :)
Reply
(2013-06-18, 04:58)Vaslo Wrote: Sorry to be dense but using 12.2 and everytime i try to install it keeps telling me the add-on is not the correct structure. What am I doing wrong?

Same problem here. Tried on two different installation of XBMC.
Any suggestions?

Thanks
Reply
(2013-05-25, 02:29)Tim. Wrote: I was using XBMCFlicks for quite a while before Frodo launched. Unfortunately XBMCFlicks broke shortly before, and I just gave up and spent $50 on an Xbox Live Gold account and have been using my Xbox 360 to stream Netflix. This afternoon I had some time to kill and read through the past 25 pages or so of this thread and was able to get XBMCFlicks working! Granted, only Instant Queue and Search. I even went so far as to use my new-found Python abilities to tweak the menu to skip right to the options that work. No more clicking passed the disc options. I also removed Genre, Top 25, etc as they are broken due to the ODATA change in the Netflix API. I also modified the iqueue.py to use the Plex developer credentials already.

If you follow the instructions below, you should be able to get XBMCFlicks working on Frodo with Windows 7. I’m not the original developer of this code, and am just trying to help. If Netflix continues messing with the API, this will break again and I may not have the knowledge to fix it. Good luck!

How to get XBMCFlicks working on Frodo!

  1. Install the modified addon uploaded here. (Based on yabsie's recent release, modified to remove broken options)
  2. In XBMC navigate to XBMCFlicks and attempt to view the instant queue. It will take you to the Netflix webpage to associate with an account. Just close the page, do not try to authenticate here! Go back to XBMC, press OK. You will get a script error. No problem, just close XBMC.
  3. Navigate to C:\users\user_name\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\ and open userinfo.txt
  4. The file should be blank, no problem! For now paste in the following text:
    Code:
    requestKey=consumer_key
    requestSecret=consumer_secret
    accessKey=oauth_token
    accessSecret=oauth_token_secret
  5. Save the file, and keep it open for now. Just minimize it.
  6. Navigate to the API Walkthrough here: http://developer.netflix.com/walkthrough
  7. Step 1, input the following developer information (Borrowed from Plex):
    Code:
    Key: nfeafbf2hpdnyfvr5dd32ka6
    Shared Secret: bBsa6TqYab
    Click request a token to move onto the next step.
  8. Step 2, look in the block of text Step 1 just generated and copy the line of text from after “oauth_token_secret=” and before the “&”. Do not include the “&”! Press “Save OAuth Token Secret” to move on to the next step.
  9. Step 3, input the information based on the text block generated in Step 1.
    oauth_token: Copy the line of text from after “oauth_token=” and before the “&”. Do not include the “&”!
    application_name: Plex
    Leave the rest of the fields alone and press “Generate the OAuth Login Page” to be redirected to the normal API access page. Press the ‘Yes, Link This Account’ button to proceed. There will be a short loading time before returning to the walkthrough page. Please be patient!
  10. Step 4 is easy, just press “Request Access Token” to proceed.
  11. Step 5, input the oauth_token and oauth_token_secret in the same way you did in Step 2 and 3 of the API Walkthrough. This time, however, use the text block generated after Step 4.
  12. Step 6, congratulations! You just got the proper API information generated using the Plex developer keys for use with XBMCFlicks. These strings of text are unique to you, don’t share them!
  13. Now that we are done with the API Walkthrough, we pull back up the userdata.txt we minimized earlier. Copy and paste the strings of text and replace the placeholder (for example consumer_key) of the matching field in userdata.txt. No space after the “=” is needed. Save the file and close. Close your browser window with the API Walkthrough open.
  14. Open XBMC, goto Video Addons, open XBMCFlicks, click on Instant Queue, and start watching!
I took these notes as I was setup XBMCFlicks on my laptop which had a fresh Frodo install, so it should work for anyone. I would suggest deleting any old XBMCFlicks folders/addons you may already have before beginning.

Hope I could help someone, and lets hope Netflix leaves us alone for a while!

EDIT: So while Netflix does definitely work, I ran into 2 other issues. The first has been mentioned here a few times: navigation sounds looping (clicking) when choosing a video file. This was apparently added in sometime between the RC's and Final for Frodo. There's a small thread about it over here that I commented in. We should probably make some noise and try to help the devs find what is causing it. The second issue is WASAPI. Some users have suggested enabling WASAPI to "fix" the navigation looping (clicking). Unfortunately, on both of my systems when WASAPI is enabled the Netflix stream will load, but then give me a playback error (several different errors). I can hope that when the devs fix the navigation looping, that they may find a solution to the WASAPI/Netflix incompatibility, but I doubt it.

My solution provided here definitely gets Netflix working again but at least in my case I would have to disable navigation sounds and switch from WASAPI to DirectSound. Maybe you'll get lucky and your system will work fine. Let me know if anyone's got any ideas!

step 1 on developer.netflix.com tells me "invalid signature." Please help!!!
Reply
(2013-07-15, 15:49)theplasticbling Wrote: step 1 on developer.netflix.com tells me "invalid signature." Please help!!!

I've just tried this and got the same error. The Netflix page does say "This walkthrough will only work if you have already registered your application and received your developer credentials. Note that no new applications can be registered at this time."

Are you a registered developer?
Reply
If you are getting "invalid signature" you are copying and pasting incorrectly. Try again.
Reply
I thought this information might come in handy in this thread. Netflix is moving to HTML5 streaming and has given information on how it is authenticating users. See below...

http://techblog.netflix.com/2013/07/nfwe...ative.html
Reply
(2013-07-18, 23:01)locoguano Wrote: If you are getting "invalid signature" you are copying and pasting incorrectly. Try again.

Nope, this is happening to me too - triple checked.
Reply
I'm also getting "Invalid Signature." Tried it multiple times. Any help would be appreciated.
Reply
(2013-07-21, 18:25)ReptilianTuxedo Wrote: I'm also getting "Invalid Signature." Tried it multiple times. Any help would be appreciated.

Same here.Sad
Reply
This is the end of this addon...
Image

If my replies help you, please click on my reputation Image below :) thanks :)
Reply
So no netflix for xbmc?
Reply
Still works fine for me...
Reply
Still works if you already went thru the process. but anyone trying to do the process currently isnt getting it to work.

Now i use Playon with XBMC Library supplemetal tool and that does the job. Yes there is no HD with playon but eventually it will come.
Image

If my replies help you, please click on my reputation Image below :) thanks :)
Reply
Hey guys, I'm new to XBMC and I'm working on my first HTPC. I've done a lot of research for the NetFlix addon and from what I understand it doesn't work through the XBMC software anymore.

I recently found the NetFlix Yabsie hack which opens a web browser from XBMC which I tested on my main PC and works great. However, on the HTPC I am building, I get to Queue:All and I just see a blank default screen, the web browser never opens. Does anyone know why the browser fails to launch?

I've tried re-installing, copying the files from my main PC to my HTPC, and nothing seems to work. My HTPC has Microsoft Silverlight installed as well as all of the Windows Updates.

Here is the link to the XBMC NetFlix - Yabsie download:
https://code.google.com/p/netflixbmc/dow...ip&can=2&q=
Reply
  •   
  • 1
  • 103
  • 104
  • 105(current)
  • 106
  • 107
  • 109
  •   
 
Thread Rating:
  • 16 Vote(s) - 4.44 Average



Logout Mark Read Team Forum Stats Members Help
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC4.4416