•   
  • 1
  • 30
  • 31
  • 32(current)
  • 33
  • 34
  • 83
  •   
WIP -  Stereoscopic 3D support for half/full SBS, over/under, etc
So you're 100% sure that you have tested the settings combination 'windows aero + use a full screen window rather than true fullscreen + adjust refresh rate to match video' on 24p non-3D video? And it played back fine with no stuttering?

If so, very odd! It's golden oldie of a problem that I thought effected everyone (hence the pull request 747), and wasn't hardware or audio settings dependant. I believe it's to do with xbmc requiring directx to be enabled, and with no aero on directx is off. Something like that anyway!?

Can you double/triple check! Wink

I haven't had chance yet to test this combination in stereo mode by the way. Will try soon.

Cheers
Reply
I have win7 with Aero is on. I never turn off Aero.

I enabled fake full screen and adjust display refresh rate to match video. When I started playback mono movie with 23.976 fps my TV switched to 1080p24 mode (I saw it at information page on TV) and movie played with no stuttering. So, yes, I'm 100% sure.

If you don't belive me, I can make a video.

Edit: And all this I have made with my version of xbmc with support Intel S3D.

Edit #2: I'll test again with version without stereoscopic 3d rendering this night.
Reply
No no, that's cool! Wink Just wondering what can be different from the normal circumstances of that problem.

I tested this earlier today using your build, on a 2D h264 24p movie and had the problem. Obviously that wasn't in stereo mode rendering though!

See what you get with your tests tonight. Maybe try your build, but with a 2D video and that settings combo? Also maybe test 12.2 in portable mode... will be real curious if you see the issue or not!

Thanks for your hard work!

[edit:] I wonder if the difference is due to the 2 channel audio you're running, as opposed to decoded over an av receiver? Are you running that 2 channel audio direct over HDMI to your TV?

[edit2:] Ah, here's the other pull request relating to this... 598 (PR) . Explains the cause better than I did!
Reply
I'll test if my wife will not make to hurt me Wink
Reply
(2013-07-22, 15:29)afedchin Wrote: I'll test if my wife will not make to hurt me Wink

Ha ha! I usually have to wait until the other half goes to bed, then I end up staying up until 3:00am messing about with XBMC. Not great when the kids then get me up at 6:30!!!!
Reply
(2013-07-19, 21:49)liquidskin76 Wrote:
(2013-07-17, 13:45)afedchin Wrote: I think possible way to drop this requirement is to switch to fake full screen mode (if it's switched off in settings) for hardwarebased stereo mode and switch back to true full screen after playback is stopped.

Hey afedchin,

If the setting combo 'fake full screen / match refresh rate' issue isn't present during Intel stereo mode, then go for it!

I'll check during stereo mode and let you know if it's there.

Thanks

Hi afedchin,

Good news... the 'aero + fake full screen + match refresh rate' problem isn't happening during Intel stereo mode!

So a fix of switch to fake full screen mode during playback will be the solution.

Many thanks Wink
Reply
Hi liquidskin76,

Thanks for your feedback. Yes, I know that. With Intel S3D there are no problems.

So.. I did more complex testing with fake full screen + adjust refresh rate on 2D movies last night. I tested three versions of xbmc: version with Intel S3D, last nightly build and Frodo 12.2. And I have a couple of conclusions:
1) Issue is not depending on version of xbmc and it occurs on all versions but very rarely (on my hardware).
2) Issue occurs when I quickly start/stop playback (more faster than common behavior).
3) After some time the issue occurs on every playback, when I restarted PC and TV or I made a little change in video driver settings then issue disappears until ... look at 2nd conclusion.

So, very old bug still exists and switch to fake full screen before 3D playback will be the solution.
Reply
3D Mode auto switch for Sony TVs

With the help of sony virtual remote control by falcosoft I can switch my Sony TV to SBS or OU mode automatically. Those who want to try it can download the script from https://app.box.com/s/3tuy0plh9gi89ebjppyc and install it from addons or extract the content to your addon folder. Follow the steps to configure the virtual remote:

1. Open the addon folder 'script.custom.sonytv3dmode' and double click the Vremote.exe file to start the virtual remote. Make sure that your TV is connected to the network and appearing as DLNA device. Select the TV device from the drop down list. Right click the remote control window and 'Register Server'. You can click on a button to see if the remote works. Click the power button to close the remote.

2. Open vremote.js file in notepad and change the time delay and number of times the IRCC command to be send to change the 3D mode to your preferred mode. I use SBS which needs two button clicks.

Code:
vr1.SendIRCC("AAAAAgAAAHcAAABNAw==");
WScript.Sleep(500);
vr1.SendIRCC("AAAAAgAAAHcAAABNAw==");

3. Double click vremote.js and see if the 3D mode is changed.

4. Open default.py in notepad and edit the lines

Code:
if re.search(r'3D', currentPlayingFile, re.I):
                response = os.startfile("C:\\Users\\baijuxavior\\AppData\\Roaming\\XBMC\\addons\\script.custom.sonytv3dmode\\vremote.js")

Here r'3D' is the file name condition to detect 3D file. You can add more specific conditions like r'3D.SBS'

5. In XBMC Video settings set the option 'Adjust display refresh rate to match video' to 'on start/stop'. This will turn off the 3D mode when you stop playback.

Now play any 3D movie and see if the TV 3D mode is changed.
Reply
Hi just done a quick test on my laptop and the auto switching seems to work really well for hsbs and htab. One thing I have noticed is that sometimes after briefly watching the video and stopping it the GUI sounds like static. Is this something to do with xbmc or the 3d switching?

The laptop is a HP probook 4530s with i5-2450m and HD 3000 graphics running windows 7 32bit
Reply
(2013-07-23, 07:37)afedchin Wrote: Hi liquidskin76,

Thanks for your feedback. Yes, I know that. With Intel S3D there are no problems.

So.. I did more complex testing with fake full screen + adjust refresh rate on 2D movies last night. I tested three versions of xbmc: version with Intel S3D, last nightly build and Frodo 12.2. And I have a couple of conclusions:
1) Issue is not depending on version of xbmc and it occurs on all versions but very rarely (on my hardware).
2) Issue occurs when I quickly start/stop playback (more faster than common behavior).
3) After some time the issue occurs on every playback, when I restarted PC and TV or I made a little change in video driver settings then issue disappears until ... look at 2nd conclusion.

So, very old bug still exists and switch to fake full screen before 3D playback will be the solution.

Hi afedchin,

One thing I've noticed with the way Intel switches to Stereo Mode is that it's not the smoothest or most elegant thing to look at! For example, with AMD's switching to AMD HD3D, you get a nice black screen whilst it's switching. With Intel, you a grey screen, then a black screen, then a smaller grey screen, then a flicker, etc. It's looks horrible!

Anyway, is that something you can cure with a fancy bit of coding? So you only see a plain black screen until playback starts?

Call it a job to improve the user experience!

Thanks Wink
Reply
Strange.. While my TV is switching to 3D i see picture from movie, then black screen and then stereo movie.

One thing I think is needed pause playback while switching to 3d. There are no tons of code for switching, just one call to intel's method.
Reply
(2013-07-25, 20:55)afedchin Wrote: One thing I think is needed pause playback while switching to 3d. There are no tons of code for switching, just one call to intel's method.

Great stuff... looking forward to a new build. Thanks man! Wink
Reply
Latest version uploaded.
Reply
(2013-07-27, 14:16)TeKo Wrote: Latest version uploaded.

I Think there's a bug in the last build - When setting adjust display refresh rate to match video is enabled the display won't adjust to true refresh rate.
60hz instead 24hz in my case.

Reinstalled previous XBMC version - Everything works fine.
Reply
Confirmed. It sets max supported refresh rate. In OS I set 50p refresh rate, when I enable adjust refresh rate to match video with 24p movie refresh rate sets to 60p.

(2013-07-29, 16:24)skydancer Wrote:
(2013-07-27, 14:16)TeKo Wrote: Latest version uploaded.

I Think there's a bug in the last build - When setting adjust display refresh rate to match video is enabled the display won't adjust to true refresh rate.
60hz instead 24hz in my case.

Reinstalled previous XBMC version - Everything works fine.
Reply
  •   
  • 1
  • 30
  • 31
  • 32(current)
  • 33
  • 34
  • 83
  •   
 
Thread Rating:
  • 11 Vote(s) - 4.73 Average



Logout Mark Read Team Forum Stats Members Help
Stereoscopic 3D support for half/full SBS, over/under, etc4.7311