Win TVHeadend - left side menu in live tv crash
#16
(2013-05-24, 11:16)opdenkamp Wrote: looks like a bug in CGUIEPGGridContainer. whatever version of tvheadend you use, it should not be able to crash xbmc.
and asking you to run things in gdb and provide a backtrace will be hard on windows ;-) any dev who can repro this? or someone who can create a trace for me from a .dmp file on windows please.

I get this error with linux version of xbmc - the skins Titan 0.7.5 and nBox trigger it too .. they crash xbmc when opening epg grid view ..

Greetz

LCS
HTPC Specs: Silverstone GD05B Case, ASUS P8H61-M LE/USB3, i5-3470S, GT1030, 8 GB RAM , 2 TB HDD, iHOS104 BluRay Drive, TT DVBS2-1600, Sony PS3 BD Remote control
PS3 BD Remote Control Daemon for Kodi/Linux
UNCHAINED Demo Group
Reply
#17
Maybe this is the issue (found in WIP Skins->Titan Thread):

Quote:Thx (It never crash at PVR Demo) I think I know what the error is. The Menu-Panel in Titan isn´t open at startup LiveTV and it jump directly into the EPG.
In Confluence it´s open an you can choose what it jump: EPG, Channel, ....
I hope this is the bug.

ReazorFX
HTPC Specs: Silverstone GD05B Case, ASUS P8H61-M LE/USB3, i5-3470S, GT1030, 8 GB RAM , 2 TB HDD, iHOS104 BluRay Drive, TT DVBS2-1600, Sony PS3 BD Remote control
PS3 BD Remote Control Daemon for Kodi/Linux
UNCHAINED Demo Group
Reply
#18
I'm experiencing the same issue on my XBMC/Media Portal EPG. I use XMLTV to generate the guide and it worked great for a few months and then all of a sudden about a week or so ago it stopped working. When I try to view the EPG in XBMC, the system freezes and the hard drive activity goes through the roof until I reboot the system. I'm using XBMC Frodo 12.2 on Windows 7 Ultimate.
Reply
#19
i need someone to provide a crashlog with a trace. or some windows dev tracking it down. i can't reproduce this with the default settings and tvheadend
opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
Reply
#20
I see this problem as well, but only when using the nbox skin. Confluence and Aeon work fine. I played around a little bit and managed to get it working for nbox at least. All I had to do was slightly reduce the width (from 1204 to 1190) of the epggrid control in skin.nbox/720p/Viewtype_PVR.xml:

Code:
<control type="epggrid" id="10">
    <description>EPG Grid</description>
    <posx>76</posx>
    <posy>288</posy>
    <width>1190</width>

I don't know why this works - I haven't had a chance to look too closely at the xbmc source - but it's an easy workaround for now.
Reply
#21
Not sure if this is the correct fix or not, but I experienced similar problems when setting up my system. The problem was an empty EPG. Once I populated the EPG everything was fine.
Reply
#22
Bug still there - happens only with some skins, like nobx or now with [WIP] Maxmalism

@bitterpeanut: EPG is not empty, just switched between skins, Aeon Nox works, Maximalism crashes ..

XBMC.log

Code:
23:16:00 T:3007039296   DEBUG: OnKey: down (f081) pressed, action is Down
23:16:00 T:3007039296   DEBUG: CGUIWindowPVRCommon - OnMessageFocus - focus set to window 'epg'
23:16:00 T:3007039296   DEBUG: CGUIWindowPVRGuide - UpdateData - update window 'epg'. set view to 16
23:16:00 T:3007039296   DEBUG: CGUIEPGGridContainer - SetStartEnd - start=28.10.2013 22:00:00 end=31.10.2013 22:00:00
23:16:00 T:3007039296   DEBUG: UpdateItems completed successfully in 25 ms
23:16:07 T:2939738944   DEBUG: Suspended the Sink

OnKey; down - > from "Channels" -> "EPG"

last line in log (crash): "Suspended the Sink"

Greetz

LastCoder
HTPC Specs: Silverstone GD05B Case, ASUS P8H61-M LE/USB3, i5-3470S, GT1030, 8 GB RAM , 2 TB HDD, iHOS104 BluRay Drive, TT DVBS2-1600, Sony PS3 BD Remote control
PS3 BD Remote Control Daemon for Kodi/Linux
UNCHAINED Demo Group
Reply
#23
@LastCoder: does the workaround I posted work for you? I haven't had a chance to look into it properly (and with the workaround don't have much cause to do so) but it might be a hint into what is actually wrong.
Reply
#24
(2013-10-22, 08:04)chrisr Wrote: All I had to do was slightly reduce the width (from 1204 to 1190)

This worked for me when playing with nbox, which is the only skin I've personally seen this in. Thanks chrisr.

One does wonder how you managed to get to that workaround, it's rather left field, but definitely works Smile

EDIT: Cross posted chrisr's workaround to the nbox forum / thread to save people hunting.
'Zero

-----
Kodi Krypton 17.6 | Linux | FTV w/LiveTV 'Fred edition' | Maraschino Git | Kore v 2 | Chorus2
-----
On a long enough timeline. The survival rate for everyone drops to zero.
Reply
#25
It does seem a bit odd in isolation, but was easy enough to come to. I noticed that the grid worked fine in Confluence, so just copied the entire timeline view from there to nbox and successively restored parts of it until it stopped working again. Converged on the epggrid width.
Reply
#26
I'm seeing this same issue on XBMC 12.2 with MythTV backend. Windows 7 ultimate.

Issue didn't used to happen, but nothing that I'm aware of has changed in setup.

Tried rebooting backend.
Disabling add on then re enabling.
Turning live TV off then back on
Rebooted xbmc host

The behavior I see is that when selecting epg xbmc freezes. If I turn on task manager it has been seen to use as much as 3.8 gb of ram.. then totally crashed and closed.

I'll upload logs when at home. This is from my phone.
Reply
#27
Also.. I'm using transparency skin. I tried to do the equivalent of chrisr workaround.. but it didn't work so I reverted.
Reply
#28
My Windows and Mac computers are fine, but on my AppleTV 2 and Raspberry Pi, when I go to the EPG:Timeline menu on the left it freezes for a little bit then finally comes up. Also when I am scrolling up and down in the menu list the lower channel numbers work fine but once I get to my HD channel numbers is freezes while I am trying to go up and down.

I love this setup but this part is a little annoying.

My setup:
MythBuntu Back end PVR
Windows XBMC- Works Great
MacBook XBMC - works great
Raspberry Pi (OpenElec) - freezing issue
AppleTV 2 jailbroken - freezing issue
Reply

Logout Mark Read Team Forum Stats Members Help
TVHeadend - left side menu in live tv crash0
This forum uses Lukasz Tkacz MyBB addons.