•   
  • 1
  • 89
  • 90
  • 91(current)
  • 92
  • 93
  • 694
  •   
  Thread Closed
[OLD/CLOSED] PseudoTV Live - Set-Top box solution
(2013-12-01, 18:14)photo848 Wrote: Hi,

First let me say what a tremendous job you have done on this and I am really looking forward to using it but I am hoping you can help me with a problem I am having with trying to set up my live tv with my HDHomerun Dual Tuner. When I first launched PTVL it added the 4 streaming stations and works great. I then added a number of custom playlists which also works great. I am now trying to add my live tv channels as per your example on page 1 however I run into the blank page issue. I have followed the example and read through this entire post at least a half dozen times trying to compare examples and my syntax appears good but I still am unable to get past the blank screen when I try to add a channel. Here is what I am adding to my setting2.xml file:

<setting id="Channel_20_type" value="8" />
<setting id="Channel_20_1" value="I16689.labs.zap2it.com" />
<setting id="Channel_20_2" value="hdhomerun://103AC965-0/tuner0?channel=8vsb:587000000&program=1" />
<setting id="Channel_20_3" value="xmltv" />
<setting id="Channel_20_rulecount" value="1" />
<setting id="Channel_20_changed" value="True" />
<setting id="Channel_20_time" value="0" />
<setting id="Channel_20_rule_1_id" value="1" />
<setting id="Channel_20_rule_1_opt_1" value="WCBSDT" />

The channel id for the epg is correct as is the 587000000&program=1. The remainder of lines are just a copy of your example. The xmltv.xml file is located in my /storage folder which I added to the settings and is in the "ISO-8859-1" format. I appreciate any debugging help you can provide. I have included my settings2.xml and xbmc.log files below.

http://pastebin.com/WsqK6TBV <- setting2.xml file
http://pastebin.com/KQ790sx3 <- log file

Thanks

I appreciate all the info and logs!!, very helpful... but are you sure you're running the latest master?
Try deleting the files in script.pseudotv.live, then moving the new files over.

Because the log looks outdated? and try enabling debugging for your logs and repost with new information, So I can get a detailed look at the problem...
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
I must say that i have been dreaming of this for a couple of years. But I am having some problems with configuring the channels like I want. I have tried to configure a channel to use Hulu but I have not figured out what i have been doing wrong. I will take any pointers you can. Below is an example of what i have tried. I believe that i am using the wrong type of channel.

<setting id="Channel_8_type" value="9" />
<setting id="Channel_8_1" value="5400" />
<setting id="Channel_8_2" value="plugin://plugin.video.hulu/?art=%22http%3a%2f%2fassets.huluim.com%2fcompanies%2fkey_art_abc.jpg%22&amp;fanart=%22http%3a%2f%2fassets.huluim.com%2fcompanies%2fkey_art_abc.jpg%22&amp;mode=%22Menu%22&amp;name=%22ABC%22&amp;page=%221%22&amp;popular=%22false%22&amp;updatelisting=%22false%22&amp;url=%22http%3a%2f%2fm.hulu.com%2fmenu%2f513281%3fcompany_id%3d231%22&quot;" />
<setting id="Channel_8_3" value="abc" />
<setting id="Channel_8_4" value="abcabcabcabcabcabcabc" />
<setting id="Channel_8_rulecount" value="1" />
<setting id="Channel_8_changed" value="True" />
<setting id="Channel_8_time" value="0" />
<setting id="Channel_8_rule_1_id" value="1" />
<setting id="Channel_8_rule_1_opt_1" value="abc" />

Also when i tried to install the repository onto my XBMC12.2 I get errors. so i ended up downloading the plugin and installing that from Page 1.
(2013-12-01, 22:03)charless01 Wrote: I must say that i have been dreaming of this for a couple of years. But I am having some problems with configuring the channels like I want. I have tried to configure a channel to use Hulu but I have not figured out what i have been doing wrong. I will take any pointers you can. Below is an example of what i have tried. I believe that i am using the wrong type of channel.

<setting id="Channel_8_type" value="9" />
<setting id="Channel_8_1" value="5400" />
<setting id="Channel_8_2" value="plugin://plugin.video.hulu/?art=%22http%3a%2f%2fassets.huluim.com%2fcompanies%2fkey_art_abc.jpg%22&amp;fanart=%22http%3a%2f%2fassets.huluim.com%2fcompanies%2fkey_art_abc.jpg%22&amp;mode=%22Menu%22&amp;name=%22ABC%22&amp;page=%221%22&amp;popular=%22false%22&amp;updatelisting=%22false%22&amp;url=%22http%3a%2f%2fm.hulu.com%2fmenu%2f513281%3fcompany_id%3d231%22&quot;" />
<setting id="Channel_8_3" value="abc" />
<setting id="Channel_8_4" value="abcabcabcabcabcabcabc" />
<setting id="Channel_8_rulecount" value="1" />
<setting id="Channel_8_changed" value="True" />
<setting id="Channel_8_time" value="0" />
<setting id="Channel_8_rule_1_id" value="1" />
<setting id="Channel_8_rule_1_opt_1" value="abc" />

Also when i tried to install the repository onto my XBMC12.2 I get errors. so i ended up downloading the plugin and installing that from Page 1.

This configuration would never work... _1 has to point directly to a media file... Chtype 0 is the only one that can build from a directory and I didn't add the ability to directly populate a channel from a plugin YET!!

You would need to scrape hulu, abc with a program like my.library then you can create a channel using the generated strm files.
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
Luna, on the epg how can you remove channel listings without it crashing? I can hide them but it pretty worthless when the focusbar is offscreen and info isn't lined up right.

Image
(2013-12-01, 22:43)Redkiller223 Wrote: Luna, on the epg how can you remove channel listings without it crashing? I can hide them but it pretty worthless when the focusbar is offscreen and info isn't lined up right.

you can't... skin needs fill all epg info...

this doesn't mean it has to be visible... try playing around with height/width and visibility conditions...

Update:: on second thought... if you comment out the code for the last three epg labels what happens? let me know...
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
(2013-12-01, 20:15)Lunatixz Wrote:
(2013-12-01, 18:14)photo848 Wrote: Hi,

First let me say what a tremendous job you have done on this and I am really looking forward to using it but I am hoping you can help me with a problem I am having with trying to set up my live tv with my HDHomerun Dual Tuner. When I first launched PTVL it added the 4 streaming stations and works great. I then added a number of custom playlists which also works great. I am now trying to add my live tv channels as per your example on page 1 however I run into the blank page issue. I have followed the example and read through this entire post at least a half dozen times trying to compare examples and my syntax appears good but I still am unable to get past the blank screen when I try to add a channel. Here is what I am adding to my setting2.xml file:

<setting id="Channel_20_type" value="8" />
<setting id="Channel_20_1" value="I16689.labs.zap2it.com" />
<setting id="Channel_20_2" value="hdhomerun://103AC965-0/tuner0?channel=8vsb:587000000&program=1" />
<setting id="Channel_20_3" value="xmltv" />
<setting id="Channel_20_rulecount" value="1" />
<setting id="Channel_20_changed" value="True" />
<setting id="Channel_20_time" value="0" />
<setting id="Channel_20_rule_1_id" value="1" />
<setting id="Channel_20_rule_1_opt_1" value="WCBSDT" />

The channel id for the epg is correct as is the 587000000&program=1. The remainder of lines are just a copy of your example. The xmltv.xml file is located in my /storage folder which I added to the settings and is in the "ISO-8859-1" format. I appreciate any debugging help you can provide. I have included my settings2.xml and xbmc.log files below.

http://pastebin.com/WsqK6TBV <- setting2.xml file
http://pastebin.com/KQ790sx3 <- log file

Thanks

I appreciate all the info and logs!!, very helpful... but are you sure you're running the latest master?
Try deleting the files in script.pseudotv.live, then moving the new files over.

Because the log looks outdated? and try enabling debugging for your logs and repost with new information, So I can get a detailed look at the problem...


I downloaded the latest master and reinstalled it (still shows as version 0.1.9) after deleting all the files in script.pseudotv.live. I turned on the debugging and started up PTVL. It created the four channels again as expected and worked fine. I then added just the Channel 20 settings from above and restarted but unfortunately it went right back to a black screen.
Thanks for your help!

On a side note I am unable to enter into the Channel configuration within settings, I get a script config.py error.

http://pastebin.com/bpCtEGkF <-with Debugging on
[quote=
Update:: on second thought... if you comment out the code for the last three epg labels what happens? let me know...
[/quote]

Epg crashes. Theres a few id's if commented out will crash it, such as


<control type="label" id="502">
<description>Show Description Label</description>

^One that you think would be okay, but nope.
FWIW...

I attempted changing the amount of channels displayed awhile back and no matter what I did it always caused the EPG to crash, eventually I just gave up and assumed it was a limitation of PTV.

However if anyone can figure out that would be sweet...I've always wanted the ability to display 8 channels on the EPG personally.
(2013-12-01, 23:49)ARYEZ Wrote: FWIW...

I attempted changing the amount of channels displayed awhile back and no matter what I did it always caused the EPG to crash, eventually I just gave up and assumed it was a limitation of PTV.

However if anyone can figure out that would be sweet...I've always wanted the ability to display 8 channels on the EPG personally.

changing the visibility condition should work... since the code is still there but since its not meeting the condition you set in place it won't be displayed...
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
i made a skin with only 3 rows at the bottom before but you have to edit ptvl itself so if/when you update to a new build that luna put's out it will go back to 6 rows. you can hide the bottom 3 of the 6 rows tho without editing ptvl but pushing down will still go down to them you just cant see it. (kinda anoying) so basicly if you are only concerned with making 3 rows for just you it's posible but only way to make skin for others is if luna changes the code and if he would do that then the great skins that ARYEZ made would not work. if you still want to make the 3 row skin (for yourself) the info is in a thread on here somewhere i think it was the ptv skin thread with tmans skin ect.
(2013-12-01, 23:20)photo848 Wrote:
(2013-12-01, 20:15)Lunatixz Wrote:
(2013-12-01, 18:14)photo848 Wrote: Hi,

First let me say what a tremendous job you have done on this and I am really looking forward to using it but I am hoping you can help me with a problem I am having with trying to set up my live tv with my HDHomerun Dual Tuner. When I first launched PTVL it added the 4 streaming stations and works great. I then added a number of custom playlists which also works great. I am now trying to add my live tv channels as per your example on page 1 however I run into the blank page issue. I have followed the example and read through this entire post at least a half dozen times trying to compare examples and my syntax appears good but I still am unable to get past the blank screen when I try to add a channel. Here is what I am adding to my setting2.xml file:

<setting id="Channel_20_type" value="8" />
<setting id="Channel_20_1" value="I16689.labs.zap2it.com" />
<setting id="Channel_20_2" value="hdhomerun://103AC965-0/tuner0?channel=8vsb:587000000&program=1" />
<setting id="Channel_20_3" value="xmltv" />
<setting id="Channel_20_rulecount" value="1" />
<setting id="Channel_20_changed" value="True" />
<setting id="Channel_20_time" value="0" />
<setting id="Channel_20_rule_1_id" value="1" />
<setting id="Channel_20_rule_1_opt_1" value="WCBSDT" />

The channel id for the epg is correct as is the 587000000&program=1. The remainder of lines are just a copy of your example. The xmltv.xml file is located in my /storage folder which I added to the settings and is in the "ISO-8859-1" format. I appreciate any debugging help you can provide. I have included my settings2.xml and xbmc.log files below.

http://pastebin.com/WsqK6TBV <- setting2.xml file
http://pastebin.com/KQ790sx3 <- log file

Thanks

I appreciate all the info and logs!!, very helpful... but are you sure you're running the latest master?
Try deleting the files in script.pseudotv.live, then moving the new files over.

Because the log looks outdated? and try enabling debugging for your logs and repost with new information, So I can get a detailed look at the problem...


I downloaded the latest master and reinstalled it (still shows as version 0.1.9) after deleting all the files in script.pseudotv.live. I turned on the debugging and started up PTVL. It created the four channels again as expected and worked fine. I then added just the Channel 20 settings from above and restarted but unfortunately it went right back to a black screen.
Thanks for your help!

On a side note I am unable to enter into the Channel configuration within settings, I get a script config.py error.

http://pastebin.com/bpCtEGkF <-with Debugging on

Your debug log holds no information for the addon... You need to make sure you are using level 1, and check with the openelec forum on how to increase plugin debugging...

Take a look for yourself, search script.pseudotv.live and you will see the only logs for it are basic startup logs...

When your log is setup you should see tons of entries when you search...
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
(2013-12-01, 23:58)scilz Wrote: i made a skin with only 3 rows at the bottom before but you have to edit ptvl itself so if/when you update to a new build that luna put's out it will go back to 6 rows. you can hide the bottom 3 of the 6 rows tho without editing ptvl but pushing down will still go down to them you just cant see it. (kinda anoying) so basicly if you are only concerned with making 3 rows for just you it's posible but only way to make skin for others is if luna changes the code and if he would do that then the great skins that ARYEZ made would not work. if you still want to make the 3 row skin (for yourself) the info is in a thread on here somewhere i think it was the ptv skin thread with tmans skin ect.

Yup just figured that out. self.rowCount = 3
yup but like i said if you update to new ptvl build it will either crash or display 6 rows.
(2013-11-30, 07:05)Lunatixz Wrote:
(2013-11-29, 23:13)Grbspltt Wrote:
(2013-11-29, 21:49)Lunatixz Wrote: Did you disable all tvdb/tmdb settings? its in beta so you really should try disabling anything that says (coming soon).
If after disabling you still have issues, send me a new log...

I updated the pastebin link with the new log. http://pastebin.com/TFmBFyTr
Thanks!

Can't say I've ever seen that problem before... Its an easy fix, but it requires me to update code... I will fix in the next master push...

just one question what kind of xmltv id is "NA_SD_CA04486:-_10743_5 " what xmltv grabber are you using and what country?

This is my XMLTV file if that helps. http://pastebin.com/6bQnBjDH

I use XMLTV Gui from: http://www.birtles.org.uk/xmltv/

Using NA_SD grabber for Schedules Direct in San Diego CA. It was working fine up until I updated from the master a few days ago.
(2013-12-02, 00:08)Grbspltt Wrote:
(2013-11-30, 07:05)Lunatixz Wrote:
(2013-11-29, 23:13)Grbspltt Wrote: I updated the pastebin link with the new log. http://pastebin.com/TFmBFyTr
Thanks!

Can't say I've ever seen that problem before... Its an easy fix, but it requires me to update code... I will fix in the next master push...

just one question what kind of xmltv id is "NA_SD_CA04486:-_10743_5 " what xmltv grabber are you using and what country?

This is my XMLTV file if that helps. http://pastebin.com/6bQnBjDH

I use XMLTV Gui from: http://www.birtles.org.uk/xmltv/

Using NA_SD grabber for Schedules Direct. It was working fine up until I updated from the master a few days ago.

I fixed this already, you tried last nights master??

(2013-12-02, 00:04)Redkiller223 Wrote:
(2013-12-01, 23:58)scilz Wrote: i made a skin with only 3 rows at the bottom before but you have to edit ptvl itself so if/when you update to a new build that luna put's out it will go back to 6 rows. you can hide the bottom 3 of the 6 rows tho without editing ptvl but pushing down will still go down to them you just cant see it. (kinda anoying) so basicly if you are only concerned with making 3 rows for just you it's posible but only way to make skin for others is if luna changes the code and if he would do that then the great skins that ARYEZ made would not work. if you still want to make the 3 row skin (for yourself) the info is in a thread on here somewhere i think it was the ptv skin thread with tmans skin ect.

Yup just figured that out. self.rowCount = 3

@redkiller try the visible condition... and let me know if it works....

I highly recommend not editing the script... if you find a few "skinning" variables within a script you would like to control from within a skin... send me a list (ie fonts, rowcount, etc).
Image Lunatixz - Kodi / Beta repository
Image PseudoTV - Forum | Website | Youtube | Twitter | Help?
  •   
  • 1
  • 89
  • 90
  • 91(current)
  • 92
  • 93
  • 694
  •   
  Thread Closed
 
Thread Rating:
  • 45 Vote(s) - 4.29 Average



Logout Mark Read Team Forum Stats Members Help
[OLD/CLOSED] PseudoTV Live - Set-Top box solution4.2945
This forum uses Lukasz Tkacz MyBB addons.