•   
  • 1
  • 35
  • 36
  • 37(current)
  • 38
  • 39
  • 95
  •   
DSPlayer (DirectShow Player for XBMC) Frodo build available
Ok thank you folks for your reply's.

One more question. Will the display refreshrate be set automatically with DS?
HTPC: AMD A10-7850K - MSI A78M-E45 V2 - HyperX Genesis 8GB DDR3 1866Mhz - 120GB+240GB HyperX SSD + 86TB HGST HDD
Plasma: Panasonic TX-P65VT60 Receiver: Yamaha RX-A3020 Surround: Jamo S608, Jamo C60 Center + C60 Surround Subwoofer: XTZ W12.18 ICE
Kodi 14.2 w/Shednox v.3.0
Reply
(2014-02-04, 13:46)Simkin84 Wrote: Ok thank you folks for your reply's.

One more question. Will the display refreshrate be set automatically with DS?
If you set xbmc to 'adjust refresh rate' then yes it will.
Reply
Dear all,

should the DSPlayer based on 12.3, work "out of the box"?

No configuration needed?

With settings and library from previous Frodo 12.3 original install?

thanks in advance

Per
Reply
(2014-02-04, 17:32)pjakesson Wrote: Dear all,

should the DSPlayer based on 12.3, work "out of the box"?

No configuration needed?

With settings and library from previous Frodo 12.3 original install?

thanks in advance

Per
Hmmm. This questions gets asked and answered frequently. If you go back a few pages to post #520 you can see what has recently been said.

My question to you is: What is driving you to want to use DSPlayer?

It seems to me that the main reason to use it is because it offers more configuration options than the native DVDPlayer in XBMC by allowing you to pick which splitters, audio and video codecs you want to utilize and also have access to the configuration settings for those DS codecs. It's made for tweaking. To use those codecs you have to have them installed on your system. Might it work just 'out of the box'? Maybe, depending on what you already have installed on your system. Will it give you what you want? That all depends on what you are looking to achieve.
Reply
(2014-02-04, 17:54)KenV99 Wrote: Hmmm. This questions gets asked and answered frequently. If you go back a few pages to post #520 you can see what has recently been said.

My question to you is: What is driving you to want to use DSPlayer?

Thanks, but I have read that post and the answers, but it is not really clear for me.
On the wiki it says

"....thus eliminating the need for XML config tweaking, which may be difficult for inexperienced users. To enable this mode simply check the option "Use system filters (DirectShow merits)".

But still I get error when trying to play videos:

16:09:55 T:4192 NOTICE: Loading filter core factory settings from special://xbmc/system/players/dsplayer/mediasconfig.xml (medias configuration).
16:09:55 T:4192 NOTICE: Successfully loaded rules
16:09:55 T:4192 NOTICE: CFGLoader::InsertAudioRenderer Successfully added "" to the graph
16:09:56 T:4192 ERROR: CDSPlayer:Tonguerocess - Failed creating DS Graph
16:09:56 T:1280 ERROR: XBMC.PlayMedia could not play media: smb://SERVER/Videos/XXX.mkv

I would like to try DSPlayer to see if it fixes my problems with stutter after resume from sleep.

regards

Per
Reply
(2014-02-04, 18:55)pjakesson Wrote:
(2014-02-04, 17:54)KenV99 Wrote: Hmmm. This questions gets asked and answered frequently. If you go back a few pages to post #520 you can see what has recently been said.

My question to you is: What is driving you to want to use DSPlayer?

Thanks, but I have read that post and the answers, but it is not really clear for me.
On the wiki it says

"....thus eliminating the need for XML config tweaking, which may be difficult for inexperienced users. To enable this mode simply check the option "Use system filters (DirectShow merits)".

But still I get error when trying to play videos:

16:09:55 T:4192 NOTICE: Loading filter core factory settings from special://xbmc/system/players/dsplayer/mediasconfig.xml (medias configuration).
16:09:55 T:4192 NOTICE: Successfully loaded rules
16:09:55 T:4192 NOTICE: CFGLoader::InsertAudioRenderer Successfully added "" to the graph
16:09:56 T:4192 ERROR: CDSPlayer:Tonguerocess - Failed creating DS Graph
16:09:56 T:1280 ERROR: XBMC.PlayMedia could not play media: smb://SERVER/Videos/XXX.mkv

I would like to try DSPlayer to see if it fixes my problems with stutter after resume from sleep.

regards

Per

So that's where it becomes difficult to troubleshoot. If you use merits, then without further investigating it's unclear which DS filters are set to be used when you try to play an mkv file. Do you know what DS filters you have installed on your system?

Perhaps more useful to you would be to use a DS based player such as MPC-HC to play back a file after resuming from sleep. If it still stutters using that, then it's going to stutter with DSPlayer unless you find a set of specific filters that eliminates your stutter and you then specify those filters in DSPlayer's xml configuration files and turn off the switch for using merits.
Reply
System filters (directshow merits) should work out of the box assuming u have those basic system filters on ur side and they have no problem, i guess.
Tweaking ur own mediasconfig and playercorefactory is not complicated if u read a lil, and have bit patience, but it's not "out of the box" solution then.
Now, be warned, on this case , it uses to happen than a minimal error gets to days of headache trying to guess what's happening. Read and watch others xml.
If u install filters as LAV Filters,u have to config their stand alone interfaces, too.
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
(2014-02-04, 19:19)KenV99 Wrote: Do you know what DS filters you have installed on your system?

It is a vanilla Windows 7 Pro on Intel NUC (Intel HD 4000 gpu).
No third party codecs installed.


(2014-02-04, 20:50)vicmanpergar Wrote: System filters (directshow merits) should work out of the box assuming u have those basic system filters on ur side and they have no problem, i guess.

Should I install Haali splitter (and also AC3 Filter) to have it working?


Thank you both for taking interest in my problem.

Per
Reply
(2014-02-04, 21:21)pjakesson Wrote: It is a vanilla Windows 7 Pro on Intel NUC (Intel HD 4000 gpu).
No third party codecs installed.

Should I install Haali splitter (and also AC3 Filter) to have it working?

Thank you both for taking interest in my problem.

Per

If anything, I would just install the latest LAV filters. http://forum.doom9.org/showthread.php?t=156191

The problem with stutter after resuming from sleeps seems to very common if you google it. For many, it seems to occur independent of what player is used. Also, for many, it seems to be an HDMI handshake issue. I, too experience this when I use WMC to playback DRM'd wtv files that I have recorded and power cycling my receiver solves the issue. There are other solutions out there including a program I've never used called HDMIyo and hardware solutions http://www.amazon.com/gp/product/B001RIM...PDKIKX0DER.

I would again suggest trying to see if you have these same issues independent of the player or if power cycling your equipment helps. It might be pretty painful to get everything set perfectly using DSPlayer only to find that you have the same issue.
Reply
(2014-02-04, 21:29)KenV99 Wrote: I would again suggest trying to see if you have these same issues independent of the player or if power cycling your equipment helps. It might be pretty painful to get everything set perfectly using DSPlayer only to find that you have the same issue.

I have "fixed" the problem by restarting XBMC on resume.

I thought that if DSPlayer was a separate .exe embedded in XBMC i wouldn't
have to restart on resume. Do follow me?

Then it would be cleaner fix.

Per
Reply
(2014-02-04, 22:05)pjakesson Wrote:
(2014-02-04, 21:29)KenV99 Wrote: I would again suggest trying to see if you have these same issues independent of the player or if power cycling your equipment helps. It might be pretty painful to get everything set perfectly using DSPlayer only to find that you have the same issue.

I have "fixed" the problem by restarting XBMC on resume.

I thought that if DSPlayer was a separate .exe embedded in XBMC i wouldn't
have to restart on resume. Do follow me?

Then it would be cleaner fix.

Per

You might want to give this a try: http://babgvant.com/files/folders/random...16744.aspx
You can configure it to shutdown XBMC on sleep and then restart it on resume.

I'm quite sure that most of what DSPlayer does is embedded directly in the build of XBMC and rest is done via DLL's. That is the reason that it is not available as an add-on and distinguishes it from an external player. The additional code is added at compilation time. An external player might be the other route you could go if simple restarts fix this issue. I use MPC-HC and even WMC as external players routinely. You do lose the overlays and other functionality that XBMC brings by going to the external player though.
Reply
(2014-02-04, 22:40)KenV99 Wrote: I use MPC-HC and even WMC as external players routinely. You do lose the overlays and other functionality that XBMC brings by going to the external player though.


OK thanks, I will tryout the MPC-HC external player and see.

regards

Per
Reply
(2014-02-04, 12:57)KenV99 Wrote:
(2014-02-04, 09:06)Simkin84 Wrote: Thank you so much.

If i delete xbmc, will all my custom menus, movies and such be gone?

And with your xml files, will my receiver be encoding the audio?

If you have edited any of the xml files directly in the Programs (x86)/XBMC/ directory, those will be overwritten (which I doubt that you have done, reading your posts).

To ensure that your receiver DECODES the audio, you need to go into the settings for your audio codec (in this case LAV audio - Start - Programs - LAV Filters - LAV audio configuration).
Check off BitStreaming for any formats that your receiver is capable of decoding.

Thanks Ken I forgot to mention that... Ive set my LAV settings quite a while ago now

TIP: when you've found the xml files your happy with make a back up of them as every new install of DSPlayer overwrites them
Optoma HD Projector, Panasonic TX-P65VT65 Plasma, Pioneer SC2023 AVR, Kef Q65 main, iQ8ds rear, XQ2C centre, XBOX 360 Elite, Samsung LE40C650, SKY HD, Lutron Lighting, Crestron AV2 control

(Server)CPU - AMD Phenom ii 560, MB - M4A78LT-M, 32GB Corsair SSD, 4GB Corsair DDR3, 6x 1.5TB HDD's

XBMC Clients x2 (DSPlayer)
Reply
(2014-02-05, 18:03)indiejones Wrote:
(2014-02-04, 12:57)KenV99 Wrote:
(2014-02-04, 09:06)Simkin84 Wrote: Thank you so much.

If i delete xbmc, will all my custom menus, movies and such be gone?

And with your xml files, will my receiver be encoding the audio?

If you have edited any of the xml files directly in the Programs (x86)/XBMC/ directory, those will be overwritten (which I doubt that you have done, reading your posts).

To ensure that your receiver DECODES the audio, you need to go into the settings for your audio codec (in this case LAV audio - Start - Programs - LAV Filters - LAV audio configuration).
Check off BitStreaming for any formats that your receiver is capable of decoding.

Thanks Ken I forgot to mention that... Ive set my LAV settings quite a while ago now

TIP: when you've found the xml files your happy with make a back up of them as every new install of DSPlayer overwrites them

Indie - not if you copy them to your userdata folder

C:\Users\[username]\AppData\Roaming\XBMC\userdata\dsplayer
Reply
(2014-02-05, 19:00)steelman1991 Wrote: Indie - not if you copy them to your userdata folder

C:\Users\[username]\AppData\Roaming\XBMC\userdata\dsplayer

You are correct steelman but you know how many times I've deleted my userdata folder when doing a clean un-install/re-installing of XBMC... I always keep a backup of what worked for me I've tried many xml files in the past that never seemed to work for me
Optoma HD Projector, Panasonic TX-P65VT65 Plasma, Pioneer SC2023 AVR, Kef Q65 main, iQ8ds rear, XQ2C centre, XBOX 360 Elite, Samsung LE40C650, SKY HD, Lutron Lighting, Crestron AV2 control

(Server)CPU - AMD Phenom ii 560, MB - M4A78LT-M, 32GB Corsair SSD, 4GB Corsair DDR3, 6x 1.5TB HDD's

XBMC Clients x2 (DSPlayer)
Reply
  •   
  • 1
  • 35
  • 36
  • 37(current)
  • 38
  • 39
  • 95
  •   
 
Thread Rating:
  • 8 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
DSPlayer (DirectShow Player for XBMC) Frodo build available58
This forum uses Lukasz Tkacz MyBB addons.