20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

  •   
  • 1
  • 130
  • 131
  • 132(current)
  • 133
  • 134
  • 244
  •   
  Thread Closed
Linux Radeon OSS with vdpau (howto)
just a quick question, i've already asked in another thread specific to this setup but i had an idea that it may have something to do with the setup i used from this tutorial.

all info is here: http://forum.xbmc.org/showthread.php?tid...pid1620906

i can't seem to get SD channels to work. HD channels work just fine but SD channels crash xbmc. i thought it may have something to do with mpeg2 not being properly decoded?

any thoughts?

thx in advance
sorry repost
Hi there,

i just wanted to ask if there is already a release date for libg3dvl-mesa for Ubuntu 14.04 in the wsnipex mesa ppa?
As of now, i have a perfectly working XBMC 13 VDPAU build with radeon oss drivers on the Trusty Alpha 2 release, yet i had to install libg3dvl-mesa from the oibaf graphics-drivers ppa. Nod

Regards,
Markus
undefined
(2014-02-07, 03:35)emmjott Wrote: Hi there,

i just wanted to ask if there is already a release date for libg3dvl-mesa for Ubuntu 14.04 in the wsnipex mesa ppa?
As of now, i have a perfectly working XBMC 13 VDPAU build with radeon oss drivers on the Trusty Alpha 2 release, yet i had to install libg3dvl-mesa from the oibaf graphics-drivers ppa. Nod

Regards,
Markus

no, I didn't have time to port all the DRI3 dependencies yet. Oibaf just builds without that.
(2014-02-06, 20:37)uuzi Wrote: just a quick question, i've already asked in another thread specific to this setup but i had an idea that it may have something to do with the setup i used from this tutorial.

all info is here: http://forum.xbmc.org/showthread.php?tid...pid1620906

i can't seem to get SD channels to work. HD channels work just fine but SD channels crash xbmc. i thought it may have something to do with mpeg2 not being properly decoded?

any thoughts?

thx in advance

Yup, you're tripping the MPEG-2 VDPAU bug (happens with certain cards)... https://bugs.freedesktop.org/show_bug.cgi?id=71796

This was showing improvement with 10.1-devel see here: http://forum.xbmc.org/showthread.php?tid...pid1613084
Quick question - when will this code get into mainline? In time for gotham? And when it ultimately does, will there be support (software decode maybe?) for those WMV files that seem to never be playable? Other than that I am loving this new code. Runs on my APU fantastically, thanks a lot for all the hard work!
It's already in ... and a PR to "deselect" specific codecs is also currently on github.

Most packages of this howto help users to install Mesa + vdpau packages, which Ubuntu - even 14.04 refuses to ship.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
I've been running smooth since initial build using this guide, however haven't updated mesa yet but doesn't appear I need to as I'm already getting great performance on an A6 6400k.

However I do notice a high volume of the following error which doesnt appear to be affecting playback, before I post the full debugs I thought I'd check if anyone knows.

15:06:32 T:140473926665984 ERROR: VDPAU::COutput error mapping surface
15:06:32 T:140473926665984 ERROR: VDPAU::COutput error mapping surface
15:06:32 T:140473926665984 ERROR: VDPAU::COutput error mapping surface
15:06:32 T:140473926665984 ERROR: VDPAU::COutput error mapping surface
15:06:32 T:140473926665984 ERROR: VDPAU::COutput error mapping surface
15:06:32 T:140473926665984 ERROR: VDPAU::COutput error mapping surface
Post logfiles as the first page wants you to do.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2014-02-07, 17:09)fritsch Wrote: Post logfiles as the first page wants you to do.

Yeah yeah I know, thought it would be a quickie, I'll post Wink

[email protected]:/home/xbmc/.xbmc/temp# dmesg|pastebinit
http://paste.ubuntu.com/6891766/
[email protected]:/home/xbmc/.xbmc/temp# cat xbmc.log |pastebinit
http://paste.ubuntu.com/6891765/
[email protected]:/home/xbmc/.xbmc/temp# cat /var/log/Xorg.0.log|pastebinit
http://paste.ubuntu.com/6891774/
[email protected]:/home/xbmc/.xbmc/temp# DISPLAY=:0 vdpauinfo|pastebinit
http://paste.ubuntu.com/6891775/
Please update your xbmc, you are on a January 20th build which had some "experimental AMD unmapping / mapping fixes" which were not 100% right.

If you are at it, make sure you run 10.0.3 mesa by wsnipex (you did not post those) cause there we included the 1.5 times faster "performance fix" by christian of amd.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Many thanks fritsch for taking a look at this!

The XBMC update seems to have done the trick, not had a single error yet and typically these would of been almost instantaneous.

I'd been following the mesa updates via this thread but is it under a different ppa as apt is telling me its up to date?
dpkg -l |grep mesa will tell
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
I know it's not the latest as I hadn't updated since I built this system on the 20th January but apt states its up to date

ii libg3dvl-mesa 10.0~git1310201320.c325aa5d+glvdpau~raring amd64 xvmc and vdpau Gallium3D video acceleration drivers

[email protected]:/etc/apt/sources.list.d# more wsnipex-mesa-raring.list
deb http://ppa.launchpad.net/wsnipex/mesa/ubuntu raring main

Maybe because I'm still running Raring?
  •   
  • 1
  • 130
  • 131
  • 132(current)
  • 133
  • 134
  • 244
  •   
  Thread Closed
 
Thread Rating:
  • 26 Vote(s) - 4.58 Average



Logout Mark Read Team Forum Stats Members Help
Radeon OSS with vdpau (howto)4.5826