Thread Rating:
  • 0 Vote(s) - 0 Average
Video tearing on Nightly/Maverick
#16
I have mid-2010 Macbook Pro with NVIDIA GeForce 320M and haven't been able to stop video tearing since updating to 10.9. I've tried monthlies, nightlies and ultimately deleted userdata and went back to Frodo 12.3. Vsync enabled but it doesn't help much, still tearing in most videos.
Reply
#17
Surprisingly (?) 2009 MacBook with Geforce 9400M is fine with 10.9.2. Huh
Reply
#18
Any updates?

As of now, there are both audio issues (HDMI disconnect issues) and video tearing issues on the latest 3/8 nightly.

Will going back to Snow Leopard from Mavericks fix all these issues.

This sucks that my expensive Apple computer cannot even correctly play a movie while my $35 Raspberry Pi can do so without any issues at all.
Reply
#19
We don't have any developers with a development device featuring this "very special" nvidia 320m gpu. Not much can be expected from our side sadly.
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#20
(2014-03-10, 00:25)Memphiz Wrote: We don't have any developers with a development device featuring this "very special" nvidia 320m gpu. Not much can be expected from our side sadly.

Why is this Mac mini considered 'very special'??
Reply
#21
The GPU is considered very special - as the tearing effect is only reported on macs with this gpu ... very special it is only because no one of us has a mac with that gpu Wink
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#22
Just checked the stable, I have a MacMini with nvidia 320m gpu but it's running 10.6.8 and I have no plans right now to move it to 10.9 Sad
MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
Reply
#23
(2014-03-10, 22:40)davilla Wrote: Just checked the stable, I have a MacMini with nvidia 320m gpu but it's running 10.6.8 and I have no plans right now to move it to 10.9 Sad

I just reinstalled 10.6 on my Mac mini with 320m gpu and the video issues are clear on the latest nightly. However, the sound engine is still screwy on this latest nightly.

Davila- what version of XBMC are you using? What skin do you use? I'm tired of tinkering with this thing and just need something that works that I don't have to give special handling instructions to my wife about.
Reply
#24
(2014-03-11, 19:40)noone Wrote: However, the sound engine is still screwy on this latest nightly.

We can't fix without a proper bug report. So if you feel like helping us - create a new thread and attach a debug log (wiki) about your screwyness Wink
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#25
I'm having the exact same issue. I'm also using a mac with an nVidia 320m on OS X 10.9.2.

I filled a bug report there : http://trac.xbmc.org/ticket/15039 , including a debug log and a system profile.

Being a developer myself, let me know if there's anything I could do to help :-)
Reply
#26
Debug and fix - thx ? *kidding* - well still not mich to be expected from our side without the possibility to reproduce it...
AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
Reply
#27
(2014-03-10, 22:40)davilla Wrote: Just checked the stable, I have a MacMini with nvidia 320m gpu but it's running 10.6.8 and I have no plans right now to move it to 10.9 Sad
Mac OS will happily install to and boot from an external USB hard drive without interfering with the OS on the internal hard drive. I've done this many times when testing potential OS upgrades for compatibility, so if you've got a spare external hard drive it shouldn't be too hard to install Mavericks onto that for testing.
Kodi 15.2 - Mid 2007 Mac Mini, 4GB, 2TB HD, OS X 10.7.5.
Kodi 15.2 - Raspberry Pi Models B, B+, Pi 2. OSMC.
Kodi 15.2 - Fire TV Stick.
Reply
#28
Good news, it seems like we have a workaround! Apparently this is an issue with vsync not being really enabled.

I was asked to edit "guisettings.xml" and to turn "<vsync>3</vsync>" into "<vsync>2</vsync>". And for me it seems to have fixed things. Tell me if that works for you guys as well!

FYI, here's the bug report : http://trac.xbmc.org/ticket/15039
Reply
#29
Have anyone of you who had this issue found a workaround or fix for it?

I'm also running a Mac mini mid 2010 with nvidia 320m gpu and is experiencing tearing with XBMC Gotham. I did experience tearing with back when using OS X 10.8 and Gotham so I'm not sure this is related to the OS X version. I suspect it's Gotham.

I was running OS X Mountain Lion 10.8 and never had any vsync or tearing issues with Dharma, Eden or Frodo. I updated to Gotham when the first 13.0 stable version was released but experienced these issues immediately. So I switched back to Frodo, used the same settings, and the tearing was gone.

Yesterday I did a clean install of OS X 10.9 Mavericks and installed Gotham 13.2 hoping that it would work better than 13.0. But I'm experiencing the tearing again so I'm of thinking of downgrading to Frodo hoping it will go away.

What's frustrating is that it's not 100% reproducible for me. Sometimes I can watch an 30 minutes of video before the tearing begins and sometimes only 30 seconds. When the tearing have begun it's noticeable in almost every scene and continues until I restart XBMC.

The sync value in my "guisettings.xml" is already set to <vsync default="true">2</vsync> so the workaround that worked for Ecco does not appear to work for me.
Reply
#30
Hi manhas,

i had exact the same issue and tried a lot. Here is my configuration which works well for me. But it's in german language, sorry for that but hope it helps you too.

# KODI Helix - Optimale Video- und Audio-Einstellungen (keine Ruckler, Off-Sync, etc.)


EINSTELLUNGEN -> VIDEOS -> WIEDERGABE

Bildwiederholfrequent automatisch an Video anpassen -> IMMER

- Pause während der Widerholfrequent Änderung -> AUS

Synchronisiere Wiedergabe mit Anzeige -> AKTIVIERT

- A/V Sync Methode -> VIDEO TAKT (VERWERFE/DUPLIZIERE AUDIO)


EINSTELLUNGEN -> VIDEOS -> BESCHLEUNIGUNG

Render-Methode -> AUTO-ERKENNUNG

- Aktiviere HQ Scaler für höhere Skalierungen -> 0 %

Dekodiermethode -> SOFTWARE

- Erlaube Multi-Prozessor-Software-Dekodierung -> AKTIVIERT


EINSTELLUNGEN - SYSTEM - AUDIO-AUSGABE

Audio-Ausgabegerät -> DEFAULT, BUILT-IN OUTPUT

Ausgabekonfiguration -> OPTIMIERT

Beschränke Samplingrate (kHz) -> 48.0

Stereo upmix -> DEAKTIVIERT

Pegel beim Heruntermischen normalisieren -> DEAKTIVIERT

Qualität der Anpassung -> MITTEL

Audiogerät aktiv halten -> 1 Minute

Sounds der Benutzeroberfläche abspielen -> NUR BEI GESTOPPTER WIEDERGABE

Verwende Passthrough -> AKTIVIERT

Digitales Ausgabegerät für Passthrough -> DEFAULT, BUILT-IN OUTPUT

Dolby Digital (AC3)-fähiger Receiver -> AKTIVIERT

- Dolby Digital Umwandlung einschalten -> DEAKTIVIERT

DTS-fähiger Receiver -> AKTIVIERT


Good luck.

Efty
Reply



Video tearing on Nightly/Maverick00