•   
  • 1
  • 234
  • 235
  • 236(current)
  • 237
  • 238
  • 277
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi Part 2
(2014-03-15, 18:16)606u Wrote: With OpenELEC-RPi.arm-Milhouse-20140315060244-r17928-g2bbee7c I walked thru my kids movies collection and find one file that doesn't start: here is xbmc.log and MediaInfo output.

Clarification about doesn't start: starting that movie causes "Working..." label to appear bottom right, after several second screen background behind movies list changes to something like dark grey wall, "Working..." label disappears and play icon, movie title and a clock stuck at "(00:00/)" to appear at bottom left. Tested with DVDPlayer and OMXPlayer, log is from the former.

You'll need to enable logging in setting/system/deugging.
The file should play. The only suspicious thing is the JPEG stream, but that be ignored.

The only other possibility is the file contains DRM - it's not been bought form iTunes? It does play on other players (e.g. VLC or xbmc on windows?)

If you can make a sample (e.g. cut 200MB using something like mp4box gui) and upload it, I can test it here.
@popcornmix

Spelling error on log.

DEBUG: CecLogMessage - << Playback 1 (4) -> broadcast (F): physical adddress 2700

Thanks.
@popcornmix

This shows in the log when I stopped playing a movie with debug on. I do not have any ALSA devices connected to my Pi. Sorry if this is normal.

00:53:40 1334.935791 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:768Sadparse_card) cannot find card '0'
00:53:40 1334.936401 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
00:53:40 1334.936890 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:392Sadsnd_func_concat) error evaluating strings
00:53:40 1334.937256 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
00:53:40 1334.937622 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:1251Sadsnd_func_refer) error evaluating name
00:53:40 1334.937988 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
00:53:40 1334.938354 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4727Sadsnd_config_expand) Evaluate error: No such file or directory
00:53:40 1334.938721 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/pcm/pcm.c:2239Sadsnd_pcm_open_noupdate) Unknown PCM default
00:53:40 1334.939087 T:3057865808 INFO: CAESinkALSA - Unable to open device "default" for playback
00:53:40 1334.979004 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:768Sadparse_card) cannot find card '$CARD'
00:53:40 1334.979614 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_card_driver returned error: No such device
00:53:40 1334.980225 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:392Sadsnd_func_concat) error evaluating strings
00:53:40 1334.980591 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_concat returned error: No such device
00:53:40 1334.980957 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:1251Sadsnd_func_refer) error evaluating name
00:53:40 1334.981445 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_refer returned error: No such device
00:53:40 1334.981812 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4727Sadsnd_config_expand) Evaluate error: No such device
00:53:40 1334.984131 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:768Sadparse_card) cannot find card '0'
00:53:40 1334.984741 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
00:53:40 1334.985229 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:392Sadsnd_func_concat) error evaluating strings
00:53:40 1334.985474 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
00:53:40 1334.985840 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:1251Sadsnd_func_refer) error evaluating name
00:53:40 1334.986206 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
00:53:40 1334.986572 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4727Sadsnd_config_expand) Evaluate error: No such file or directory
00:53:40 1334.988281 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:768Sadparse_card) cannot find card '0'
00:53:40 1334.988647 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
00:53:40 1334.989136 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:392Sadsnd_func_concat) error evaluating strings
00:53:40 1334.989502 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
00:53:40 1334.990356 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:1251Sadsnd_func_refer) error evaluating name
00:53:40 1334.990845 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
00:53:40 1334.991211 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4727Sadsnd_config_expand) Evaluate error: No such file or directory
00:53:40 1334.994141 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:768Sadparse_card) cannot find card '0'
00:53:40 1334.994507 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
00:53:40 1334.994995 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:392Sadsnd_func_concat) error evaluating strings
00:53:40 1334.995361 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
00:53:40 1334.995605 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:1251Sadsnd_func_refer) error evaluating name
00:53:40 1334.995850 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
00:53:40 1334.996094 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4727Sadsnd_config_expand) Evaluate error: No such file or directory
00:53:40 1334.998291 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:768Sadparse_card) cannot find card '0'
00:53:40 1334.998657 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
00:53:40 1334.998901 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:392Sadsnd_func_concat) error evaluating strings
00:53:40 1334.999146 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
00:53:40 1334.999390 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/confmisc.c:1251Sadsnd_func_refer) error evaluating name
00:53:40 1334.999634 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4248Sad_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
00:53:40 1335.000122 T:3057865808 INFO: CAESinkALSA - ALSA: /home/neil/projects/OpenELEC.tv/build.OpenELEC-RPi.arm-devel/alsa-lib-1.0.27.2/src/conf.c:4727Sadsnd_config_expand) Evaluate error: No such file or directory
(2014-03-15, 18:57)b1m1 Wrote: This shows in the log when I stopped playing a movie with debug on. I do not have any ALSA devices connected to my Pi. Sorry if this is normal.

Yes, I get that too. I think you only get it when no alsa cards are detected. I believe it is harmless (although ugly).
Not sure what the solution is.
(2014-03-11, 23:24)606u Wrote:
(2014-03-11, 04:23)MilhouseVH Wrote: ... Testers should try adding the following entry to their advancedsettings.xml:
Code:
<advancedsettings>
  <video>
    <defaultplayer>dvdplayer</defaultplayer>
    <defaultdvdplayer>dvdplayer</defaultdvdplayer>
  </video>
</advancedsettings>
and report if it is better/worse than omxplayer. You can still play files with omxplayer using the context-menu "Play using... OMXPlayer"...
Worse at my end: video frequently freezes for few seconds, while audio continues to play. If playback status is displayed (don't know how exactly is called, opened by holding info key in iOS remote app) a/v delta increases up to several seconds, then resets when video resumes. Freezes repeats every 10 seconds or so, seems not to be connected with a particular video or audio CODECs.
DVDPlayer works flawlessly so far with OpenELEC-RPi.arm-Milhouse-20140315060244-r17928-g2bbee7c, tested with two complete movies: SD and 720p, h.264 + AAC in MP4 container.
Hello guys. I then installed the latest version and problems passthrough DTS and AC-3 are solved respect to the last three releases only created another problem is that the playback of MP3 music files no longer works ie the sound is completely distorted. The strange thing is that I tried to play a video file with MP3 audio and it works perfectly while the MP3 music files give problems. To you it is? Hello.
(2014-03-15, 19:30)marcavatar Wrote: Hello guys. I then installed the latest version and problems passthrough DTS and AC-3 are solved respect to the last three releases only created another problem is that the playback of MP3 music files no longer works ie the sound is completely distorted. The strange thing is that I tried to play a video file with MP3 audio and it works perfectly while the MP3 music files give problems. To you it is? Hello.

Is it fixed by going fullscreen (press tab)?
(2014-03-15, 15:56)606u Wrote: Still no 88,2 kHz audio playback with OpenELEC-RPi.arm-Milhouse-20140315060244-r17928-g2bbee7c; more info at posts 3503 and 3506.

The #0315 build doesn't include the latest March 15 firmware with the 88.2kHz and 176.4kHz fix - it will be in the next build.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Has anyone else successfully tried out Memphiz's AirPlay fix?

I'm on iOS 7.1 and I'm only seeing an audio only "XBMC (OpenELEC)" AirPlay source (er...destination?).

Reports say that it starts off as audio only but then switches to video after 10 seconds but mine stays audio indefinitely.

The weird thing is, I've run his test build 10 for Windows and it's working fine (shows as video), so something with OpenELEC on my PI isn't playing nice. I've rebooted my router, PI, iDevice as suggested, so I'm stumped.

I'm on OpenELEC-RPi.arm-Milhouse-20140313233333-r17917-g5bef63b but I've seen it since the latest AirPlay changes around OpenELEC-RPi.arm-Milhouse-20140312020133-r17896-g10b90c5.

AirPlay prior to 20140312 was flaky (I usually had to reboot something to get it to work) but it would work eventually with video.
(2014-03-15, 18:27)popcornmix Wrote:
(2014-03-15, 18:16)606u Wrote: With OpenELEC-RPi.arm-Milhouse-20140315060244-r17928-g2bbee7c I walked thru my kids movies collection and find one file that doesn't start: here is xbmc.log and MediaInfo output.

Clarification about doesn't start: starting that movie causes "Working..." label to appear bottom right, after several second screen background behind movies list changes to something like dark grey wall, "Working..." label disappears and play icon, movie title and a clock stuck at "(00:00/)" to appear at bottom left. Tested with DVDPlayer and OMXPlayer, log is from the former.

You'll need to enable logging in setting/system/deugging.
The file should play. The only suspicious thing is the JPEG stream, but that be ignored.

The only other possibility is the file contains DRM - it's not been bought form iTunes? It does play on other players (e.g. VLC or xbmc on windows?)

If you can make a sample (e.g. cut 200MB using something like mp4box gui) and upload it, I can test it here.
Seems like it's metadata related problem: after I cut 1st 10 minutes with mp4box, the result works just fine. When I add metadata with an up to date version of Subler (for Mac) it also works. Will try to trim and re-add metadata or to remux the movie. File is 1,5 Gbytes, will take awhile to upload it to Dropbox, but can do it, its not a problem.
(2014-03-15, 20:15)606u Wrote: Seems like it's metadata related problem: after I cut 1st 10 minutes with mp4box, the result works just fine. When I add metadata with an up to date version of Subler (for Mac) it also works. Will try to trim and re-add metadata or to remux the movie. File is 1,5 Gbytes, will take awhile to upload it to Dropbox, but can do it, its not a problem.

Okay. If you can't get the cut down version to fail, then I can download the big version.
(2014-03-15, 19:51)ahplk Wrote: Has anyone else successfully tried out Memphiz's AirPlay fix?

I'm on iOS 7.1 and I'm only seeing an audio only "XBMC (OpenELEC)" AirPlay source (er...destination?).

Reports say that it starts off as audio only but then switches to video after 10 seconds but mine stays audio indefinitely.

The weird thing is, I've run his test build 10 for Windows and it's working fine (shows as video), so something with OpenELEC on my PI isn't playing nice. I've rebooted my router, PI, iDevice as suggested, so I'm stumped.

I'm on OpenELEC-RPi.arm-Milhouse-20140313233333-r17917-g5bef63b but I've seen it since the latest AirPlay changes around OpenELEC-RPi.arm-Milhouse-20140312020133-r17896-g10b90c5.

AirPlay prior to 20140312 was flaky (I usually had to reboot something to get it to work) but it would work eventually with video.

The Milhouse builds include a couple of iOS7 airplay fixes, the latest from Memphiz (PR4414) but also this older commit from newclock3 - is the older commit still required?

I've only got an old 3GS test device, running iOS 6.0.something. Audio and video (from the youtube app) are both working fine.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2014-03-15, 18:20)popcornmix Wrote:
(2014-03-15, 18:08)606u Wrote: Glad of being of help. Can I get the new firmware somehow or should I wait for the next build?

Download these two files:
https://github.com/Hexxeh/rpi-firmware/r...tart_x.elf
https://github.com/Hexxeh/rpi-firmware/r...ixup_x.dat

rename to start.elf and fixup.dat and copy to FAT partition of sdcard (e.g. using windows sdcard reader).
Did what you said. Now stereo, 24-bit, 88,2 kHz files plays fine, multi-channel file, however, does not sound so well -- it plays, but with lots of distortions. It's hard to describe: I take output audio data is a sequence of frames, each is a pre-set number of samples; it sounds like frames for some channels (left, right, center) are not cleared and retains some of past samples -- sounds like a recurrent loop, mixed with the new samples, but loop itself sounds louder than the samples that should be heard. I've uploaded a media file in the same Dropbox folder I gave you link to in a PM earlier today.

Update: possibly related to CPU utilization, works better if switched to full screen with no info ribbon quickly; breaks sooner if left on songs/files list screen.
(2014-03-15, 20:23)MilhouseVH Wrote: The Milhouse builds include a couple of iOS7 airplay fixes, the latest from Memphiz (PR4414) but also this older commit from newclock3 - is the older commit still required?

I've only got an old 3GS test device, running iOS 6.0.something. Audio and video (from the youtube app) are both working fine.

No, I think that (and one other airplay commit) should be removed (newclock3 is updated).
(2014-03-15, 20:30)popcornmix Wrote: No, I think that (and one other airplay commit) should be removed (newclock3 is updated).

Thanks, the next build will include only the fixes from PR4414.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 234
  • 235
  • 236(current)
  • 237
  • 238
  • 277
  •   
  Thread Closed
 
Thread Rating:
  • 23 Vote(s) - 4.48 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi Part 24.4823
This forum uses Lukasz Tkacz MyBB addons.