•   
  • 1
  • 23
  • 24
  • 25(current)
  • 26
  • 27
  • 57
  •   
XBMC Video Server: stream/download your library contents
Not exactly hard but it would involve quite a lot of work since a music interface would be different from a video interface. You'd want an in-browser player etc., none of which is exactly trivial. Like I said there are many other solutions for this problem, this software is designed from streaming video only.
Reply
I installed this on my linux server. But when I try to open the page, I only get to a Index of view of the folder.
Any help?
Reply
@ziggurat: you seem to be missing the mod_rewrite module, and/or you're not allowing the use of .htaccess files. Did you follow the instructions?
Reply
(2014-04-26, 18:24)negge Wrote: @ziggurat: you seem to be missing the mod_rewrite module, and/or you're not allowing the use of .htaccess files. Did you follow the instructions?

Yes I did follow the instructions, let me see (doing as Im typing).
Code:
Module rewrite already enabled
Module expires already enabled
Is what a2enmod returns when I try to enable the mods.

Code:
Options FollowSymLinks
AllowOverride All
Require all granted
Is inside my <Directory /var/www/html/xbmc-video-server/>

You can see that i have it inside /var/www/html/xbmc-video-server/ because my document root (default for ubuntu 14.04 at least?) is /var/www/html

Trying to rerun the sum of the installation process and i get this when i do php composer.phar install
Code:
Installing dependencies (including require-dev) from lock file
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.

Also this is what I see in the index of view
http://imgur.com/QEU79jX

Can you see any fault?
Reply
Pastebin the whole default.conf Apache file. Maybe something has changed once again in 14.04 compared to the previous versions.
Reply
(2014-04-26, 19:10)negge Wrote: Pastebin the whole default.conf Apache file. Maybe something has changed once again in 14.04 compared to the previous versions.

http://paste.ubuntu.com/7347541/
Reply
@ziggurat: strange, I'm gonna have to try out 14.04 in a VM to see what is going on, the wiki needs updating (again) in any case.
Reply
(2014-04-27, 23:31)negge Wrote: @ziggurat: strange, I'm gonna have to try out 14.04 in a VM to see what is going on, the wiki needs updating (again) in any case.

I did not do or change anything, I have no explanation of anything that changed, It just started to work.

Now I just need to do NATing on my home network, since I use pagekite now Tongue I don't want to max out that account hehe.
Reply
Perhaps you forgot to restart Apache after changing the configuration?
Reply
(2014-04-28, 14:12)negge Wrote: Perhaps you forgot to restart Apache after changing the configuration?

I do not believe so, because I am really trigger happy with that particular services command. Maybe the PHP mod was hanging so that it displayed the index of view instead.
Reply
Has anyone got this working on Windows? Would love to set this up so I can watch my library at work. Any help on what I need to do would be greatly appreciated
Image
Reply
@frieten: read the instructions on Github, it's all there.
Reply
(2014-04-28, 22:17)negge Wrote: @frieten: read the instructions on Github, it's all there.

oh cheers i didn't look as i thought it was just linux.

edit: ok had a read, one thing im wondering still though is do i install this on my PC that has XBMC on it, or my server that has the files on it?
Image
Reply
@frieten: it doesn't matter which machine you install it on as long as it's on the same network as the computer that runs XBMC.
Reply
Cheers I got it all running. Works good Smile
Image
Reply
  •   
  • 1
  • 23
  • 24
  • 25(current)
  • 26
  • 27
  • 57
  •   



Logout Mark Read Team Forum Stats Members Help
XBMC Video Server: stream/download your library contents9
This forum uses Lukasz Tkacz MyBB addons.