•   
  • 1
  • 39
  • 40
  • 41(current)
  • 42
  • 43
  • 86
  •   
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)
(2014-04-11, 03:44)rmrende Wrote: I am getting "Could not connect to remote server" using both Frodo and Gothem Beta 3. I am running the newest OSX. I tried the recommendation above about changing the login URL. The error in the Xbmc logs is the same either way:

Quote:21:33:16 T:2953924608 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <class 'urllib2.URLError'>
Error Contents: <urlopen error [Errno 8] _ssl.c:480: EOF occurred in violation of protocol>
Traceback (most recent call last):
File "/Users/rmrende/Library/Application Support/XBMC/addons/plugin.video.netflixbmc/default.py", line 771, in <module>
index()
File "/Users/rmrende/Library/Application Support/XBMC/addons/plugin.video.netflixbmc/default.py", line 101, in index
if login():
File "/Users/rmrende/Library/Application Support/XBMC/addons/plugin.video.netflixbmc/default.py", line 473, in login
content = opener.open("http://movies.netflix.com/Login").read()
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 397, in open
response = meth(req, response)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 510, in http_response
'http', request, response, code, msg, hdrs)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 429, in error
result = self._call_chain(*args)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 369, in _call_chain
result = func(*args)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 605, in http_error_302
return self.parent.open(new, timeout=req.timeout)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 397, in open
response = meth(req, response)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 510, in http_response
'http', request, response, code, msg, hdrs)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 429, in error
result = self._call_chain(*args)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 369, in _call_chain
result = func(*args)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 605, in http_error_302
return self.parent.open(new, timeout=req.timeout)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 391, in open
response = self._open(req, data)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 409, in _open
'_open', req)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 369, in _call_chain
result = func(*args)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 1169, in https_open
return self.do_open(httplib.HTTPSConnection, req)
File "/Applications/XBMC Frodo.app/Contents/Frameworks/lib/python2.6/urllib2.py", line 1136, in do_open
raise URLError(err)
URLError: <urlopen error [Errno 8] _ssl.c:480: EOF occurred in violation of protocol>
-->End of Python script error report<--

I've had this problem for a while too - every upgrade to this script caused the above error. Now that I want to do a clean upgrade to Gotham I spent a little time on how to fix this so I can continue to use this plugin with a new install.

Edit the default.py file and look for

content = opener.open("http://movies.netflix.com/Login").read()

and change to :

content = opener.open("http://movies.netflix.com/").read()

Worked ok for me after that.
Reply
For anyone having issues with XBMC re-maximizing over Chrome, the issue turned out to be (in my case) a conflict between Chrome Launcher and XBMC Launcher.

XBMC Launcher attempts to return focus to XBMC after anything it deems a "popup" steals focus. One of the tabs in the XBMC Launcher GUI has an option to Disable Focus Permanently. Make sure that's checked and it won't refocus after launching Chrome.

The empty "Genres" and "TV Shows" lists can be chalked up to Netflix asking "Who's Watching?" when the addon makes the HTTP request. Unless you can somehow select the profile via the URL, the only way around this that I figured out is to only have one Netflix profile.
Reply
(2014-05-03, 07:08)urashimakt Wrote: The empty "Genres" and "TV Shows" lists can be chalked up to Netflix asking "Who's Watching?" when the addon makes the HTTP request. Unless you can somehow select the profile via the URL, the only way around this that I figured out is to only have one Netflix profile.

That's not the case, I have only one Netflix profile and the problem is there. If this was the problem why would some list show up oke and others don't?
Reply
(2014-05-03, 15:26)ricardosunnie Wrote: That's not the case, I have only one Netflix profile and the problem is there. If this was the problem why would some list show up oke and others don't?

Because http://movies.netflix.com/WiHome requires a profile selection and the JSON extraction calls for latest and viewing history do not. I fiddled with the script to dump the "content" string it was receiving and found it to be the case. Cutting down to one profile predictably solved the problem. If you have only one profile and are still experiencing empty genres then you have an older problem that can be fixed by doing the following.

Open default.py and find the following under def listVideos:

Code:
...
            match1 = re.compile('<span id="dbs(.+?)_.+?alt=".+?" src="(.+?)"', re.DOTALL).findall(content)
            match2 = re.compile('<span class="title "><a id="b(.+?)_', re.DOTALL).findall(content)
...

Append this match3 below match1 and match2:

Code:
...
            match1 = re.compile('<span id="dbs(.+?)_.+?alt=".+?" src="(.+?)"', re.DOTALL).findall(content)
            match2 = re.compile('<span class="title "><a id="b(.+?)_', re.DOTALL).findall(content)
            match3 = re.compile('<img class="boxart" src="(.+?)" alt="(.+?)".+?/><a class="playHover" href=".+?WiPlayer\\?movieid=(.+?)&', re.DOTALL).findall(content)
...

Right below is an if/elif statement like so:

Code:
...
            if match1:
                for videoID, thumbUrl in match1:
                    listVideo(videoID, "", thumbUrl, False, False)
            elif match2:
                for videoID in match2:
                    listVideo(videoID, "", "", False, False)
...

Add the following elif to the end of it:

Code:
...
            if match1:
                for videoID, thumbUrl in match1:
                    listVideo(videoID, "", thumbUrl, False, False)
            elif match2:
                for videoID in match2:
                    listVideo(videoID, "", "", False, False)
            elif match3:
                for thumbUrl, vidTitle, videoID in match3:
                    listVideo(videoID, vidTitle, thumbUrl, False, False)
...

And that should correctly scrape a genre until Netflix decides to change their website again. It is still important to only have one Netflix profile (at least on Windows 7/Chrome) or these page requests will be answered with a "Who's watching now?" popup.
Reply
So as far as I understand you, for some people with only one profile it's working oke? I've tried both clean installs from XBMC 12.3 en 13 rc 1 and installed the plugin from the testing.repo from post 1. It installs 1.2.6. The only thing i do is enter my email and pass and let everything else as is (single user account etc). I have only one profile in Netflix. But in both casses nothing shows up in for instance genres and tv-shows. I'm running on Windows 7 and connecting in the Netherlands.
Is there anything that I can change to make this work again? I really love the plugin and hope someone can fix this.

Any help would be appreciated!

Thanks.
Reply
(2014-05-03, 20:36)ricardosunnie Wrote: So as far as I understand you, for some people with only one profile it's working oke? I've tried both clean installs from XBMC 12.3 en 13 rc 1 and installed the plugin from the testing.repo from post 1. It installs 1.2.6. The only thing i do is enter my email and pass and let everything else as is (single user account etc). I have only one profile in Netflix. But in both casses nothing shows up in for instance genres and tv-shows. I'm running on Windows 7 and connecting in the Netherlands.
Is there anything that I can change to make this work again? I really love the plugin and hope someone can fix this.

Any help would be appreciated!

Thanks.

I edited in a solution to the problem I think you're having in the other post. Try that out.
Reply
(2014-05-03, 20:46)urashimakt Wrote:
(2014-05-03, 20:36)ricardosunnie Wrote: So as far as I understand you, for some people with only one profile it's working oke? I've tried both clean installs from XBMC 12.3 en 13 rc 1 and installed the plugin from the testing.repo from post 1. It installs 1.2.6. The only thing i do is enter my email and pass and let everything else as is (single user account etc). I have only one profile in Netflix. But in both casses nothing shows up in for instance genres and tv-shows. I'm running on Windows 7 and connecting in the Netherlands.
Is there anything that I can change to make this work again? I really love the plugin and hope someone can fix this.

Any help would be appreciated!

Thanks.

I edited in a solution to the problem I think you're having in the other post. Try that out.


IT Works! YEHHHH!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Is there a general way I can do the same for the others not working? Specially TV shows?

Thanks very very much!

edit:

Oops only worked once, checking into it.
Reply
TV Shows, Documentaries, etc are just Genre shortcuts really. They've been working for me ever since I implemented that fix.

If your genres come and go, I can only think to recommend making sure there is only ONE profile on your Netflix account. If Netflix forgets whose profile is logged in it'll gum the scraping up by asking "Who's watching now?".

Hopefully the addon author has a solution to that problem.
Reply
Found what's going wrong. When I go to the netflix site via Chrome or Internet Explorer and I choose genres it also works only once. The second genre I choose gives:

An error occurred.
Sorry, the page you are looking for is currently unavailable.
Please try again later.
If you are the system administrator of this resource then you should check the error log for details.
Faithfully yours, nginx.


Damn netfix!
Reply
Hi All,

U have video tearing issues.. only way to solve this is to "Composite" "Disable" in xorg.conf.. I'm using Xfce4

But for some when i do this and try to launch NetfliXBMC to watch a video chrome loads but when it goes to play the video the screen is blank.. i can hear the audio tho?? any ideas
Reply
(2014-05-03, 07:08)urashimakt Wrote: For anyone having issues with XBMC re-maximizing over Chrome, the issue turned out to be (in my case) a conflict between Chrome Launcher and XBMC Launcher.

XBMC Launcher attempts to return focus to XBMC after anything it deems a "popup" steals focus. One of the tabs in the XBMC Launcher GUI has an option to Disable Focus Permanently. Make sure that's checked and it won't refocus after launching Chrome.

The empty "Genres" and "TV Shows" lists can be chalked up to Netflix asking "Who's Watching?" when the addon makes the HTTP request. Unless you can somehow select the profile via the URL, the only way around this that I figured out is to only have one Netflix profile.

Are you able to make XBMC relaunch after exiting Chrome Launcher (via NetfliXBMC)?
Reply
I think im on the right track for this.

I have installed the just released xbmcbuntu, version 13. Which appears to be running on Ubuntu 14.04.

I can launch the Netflixbmc application in xbmc, the Chrome browser, nearly full screen, pops up in front of xbmc.

1. It shows the Netflix login page. is it supposed to do this??; I've also entered the login info into the netflixbmc application.

2. I lose total mouse and keyboard control. I can see a bit of xbmc behind the not quite full screen Chrome window, and it appears that xbmc still has the keyboard focus, and probably mouse focus, but im not seeing the cursor move at all.

What am I missing here? I haven't installed the xdotool yet, that was mentioned on the first page of this thread. Is that a path to follow??

thanks.
Reply
I know this is a pipelight issue and not with this add-on, but I can't play anything in netflix anymore. At first it just started taking me to the sys req. page, but after getting another user agent switcher it will at least load pipelight but then netflix just throws up the something went wrong page.

I've confirmed silverlight is still working by running the ball test, but i can't figure out what has happened with netflix. I figured that someone here might ve able to point me in the right direction
Reply
Latest version of chrome has broken pipelight

https://bugs.launchpad.net/ubuntu/+sourc...ug/1307989
Reply
My version of chromium in xbmcbuntu is 32. It's held back by apt.

I'm baffled by this. I'm thinking the issue is something else updated outside of chromium but I have no idea what
Reply
  •   
  • 1
  • 39
  • 40
  • 41(current)
  • 42
  • 43
  • 86
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] NetfliXBMC - Unofficial Netflix Add-on (Win/OSX/Linux)7
This forum uses Lukasz Tkacz MyBB addons.