• 1
  • 18
  • 19
  • 20(current)
  • 21
  • 22
  • 46
Broken Crunchyroll [DMCA Takedown]
(2014-05-03, 21:03)le__ Wrote: I don't know if this is the best solution (don't know what else exactly uses the .m3u8), but you can set to XBMC force the "DVDPlayer" (it's the name of the internal player) to this particular extension, while you keep your external player for the normal usage.
I use this with DSPlayer, for example, where I use the DSPlayer as a default player, but the Crunchyroll addon will always use the DVDPlayer.

Create (or edit) the following file with this rule:
%AppData%/XBMC/userdata/playercorefactory.xml
Code:
<playercorefactory>
  <rules action="prepend">
    <rule filetypes="m3u8" player="DVDPlayer"/>
  </rules>
</playercorefactory>
Alright, well I tried this on my set up.
Code:
<playercorefactory>
<players>
   <player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
     <filename>C:\Program Files (x86)\Combined Community Codec Pack\MPC\mpc-hc.exe</filename>
     <args>"{1}" /fullscreen /close</args>
     <hidexbmc>false</hidexbmc>
     <hideconsole>false</hideconsole>
     <warpcursor>none</warpcursor>
   </player>
</players>
<rules action="prepend">
   <rule filetypes="m3u8" player="DVDPlayer"/>
   <rule filetypes="mkv" player="MPC-HC"/>
</rules>
</playercorefactory>

Attempt 1: Went in to No Game No Life and hit <Enter>. It displayed the loading indicator, then stopped, as usual.

Attempt 2: I tried again (pressing <Enter>) and this time, it played in the background! But I got this message:
Image
When I pressed OK, it exited out of the video.

Attempt 3: This time I used "Play using..." to force DVDPlayer, as follows:
Image
After the loading indicator, it works!
Image

So the issue persists. I've posted up the log here: link.

The timestamps for each of my three attempts are as follows:
Attempt 1: 12:27:37
Attempt 2: 12:31:48
Attempt 3: 12:35:08
Reply
(2014-05-03, 21:43)billyea Wrote: The timestamps for each of my three attempts are as follows:
Attempt 1: 12:27:37
Attempt 2: 12:31:48
Attempt 3: 12:35:08

update and try again.
I made the following change
Code:
player = xbmc.Player(xbmc.PLAYER_CORE_DVDPLAYER)
XBMC user since before that Music db hack.
Now with his 2nd DMCA Takedown
Reply
(2014-05-03, 22:27)yoshiofthewire Wrote:
(2014-05-03, 21:43)billyea Wrote: The timestamps for each of my three attempts are as follows:
Attempt 1: 12:27:37
Attempt 2: 12:31:48
Attempt 3: 12:35:08

update and try again.
I made the following change
Code:
player = xbmc.Player(xbmc.PLAYER_CORE_DVDPLAYER)

Weird, I'm getting a "Dependencies not met" when loading the zip from the Google drive link.

EDIT: Nevermind, just dumped the zip into my addons folder and am now testing it.

Okay so good news. It works by default! Sort of.

When launching a video, I now get this dialog that won't go away. (I was using a different skin before, switched back to Confluence to test if it was a skin issue)
Image

Attempting to make it go away (or hitting <Esc>) results in a familiar error.
Image
And clicking OK closes the video.

As usual, using "Play using..." results in no error.
However, playing from Yatse also shows the "Opening stream..." dialog indefinitely, but at least it can be cancelled (with a slight freeze in video). So it's a bit of a regression.
Reply
(2014-05-03, 21:43)billyea Wrote: ... I'm getting a "Dependencies not met" when loading the zip from the Google drive link.
Me too !
Reply
OK, so I know what is going on.
To install the plugin in XBMC12 I need to set a Variable to 2.1
To install the plugin in XBMC13 I need to set the same variable to 2.6

Calamity ensues, time to start a new repo
XBMC user since before that Music db hack.
Now with his 2nd DMCA Takedown
Reply
To Celebrate the launch of the forced beta for the new Crucnyroll;xbmc We are going nuts today.
Please post feedback so I can get things patched quickly.

Known Issues:
If you upgraded to a XBMC13 branch, you will need to manually install the Gotham Repo
Anyone still on XBMC12 will automaticlly moved to the new Frodo Repo
Anyone on XBMC11 will need to install the OLD Cruncyroll-Takeout located in the Frodo Repo.
Or you could just upgrade.

48 All Access Guest Codes:
AWE5UA8MAQK
5ZXYHFKBBRH
XBMC user since before that Music db hack.
Now with his 2nd DMCA Takedown
Reply
Congratulations on the new repo! Big Grin

By the way, not to temper the mood, but did you catch the feedback I posted earlier? Hope it wasn't lost after I edited it in. Still having the external player issues.
Reply
billyea, I think I am going to need some help recreating your setup.
What XBMC build are you using?
What platform are you running?
How did you enable external player support?
XBMC user since before that Music db hack.
Now with his 2nd DMCA Takedown
Reply
(2014-05-04, 02:35)yoshiofthewire Wrote: billyea, I think I am going to need some help recreating your setup.
What XBMC build are you using?
What platform are you running?
How did you enable external player support?

Thanks for getting back to me. I'm currently running Gotham RC1 on Windows 8.1 (x64).

As for external player support, I'm mainly copying from http://wiki.xbmc.org/?title=External_players and adjusting paths for my set up.
  • Firstly I got a copy of MPC-HC from here
  • Secondly, I hit Win+R and navigated to: %AppData%/XBMC/userdata
  • Thirdly, I created a playercorefactory.xml file in this folder and filled it with this text (replacing the bracketed part as indicated) and saved and relaunched XBMC:
Code:
<playercorefactory>
<players>
   <player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
     <filename>[insert path to MPC folder in Program Files]\mpc-hc.exe</filename>
     <args>"{1}" /fullscreen /close</args>
     <hidexbmc>false</hidexbmc>
     <hideconsole>false</hideconsole>
     <warpcursor>none</warpcursor>
   </player>
</players>
<rules action="prepend">
   <rule filetypes="mkv" player="MPC-HC"/>
</rules>
</playercorefactory>

What this did is tell MPC-HC to launch only for playing MKV files. Otherwise, the default xbmc internal player was used.

I'm thinking this might be a Gotham bug. "Play" (using <Enter>) and "Play Using..." (default player) should not have different behaviour.

Also, a bit more critical. I just got the latest version of the plugin from your new Gotham repository. It enabled in XBMC properly, but I got a Script Failed when attempting to start it (and it didn't start). Log output here.
Reply
OK, so on Win8.1, With 13CR1 with everything you have installed installed, I couldn't replicate the bug.

That said, I deleted my %AppData%/XBMC/ before testing.
The installed version from the Gotham Repo should be 0.9.10.7
The Gotham installs will always be a higher build then the Frodo builds, to force upgrades on install.
Delete this file: C:\Users\[Your_User_Name]\AppData\Roaming\XBMC\userdata\addon_data\XBMC13\cache\crunchyXBMC
This will reset your settings shelf, and should fix it.
That said, if you get an error like that, if you close and reopen, it should fix itself ... maybe.
XBMC user since before that Music db hack.
Now with his 2nd DMCA Takedown
Reply
(2014-05-04, 03:50)yoshiofthewire Wrote: OK, so on Win8.1, With 13CR1 with everything you have installed installed, I couldn't replicate the bug.

That said, I deleted my %AppData%/XBMC/ before testing.
The installed version from the Gotham Repo should be 0.9.10.7
The Gotham installs will always be a higher build then the Frodo builds, to force upgrades on install.
Delete this file: C:\Users\[Your_User_Name]\AppData\Roaming\XBMC\userdata\addon_data\XBMC13\cache\crunchyXBMC
This will reset your settings shelf, and should fix it.
That said, if you get an error like that, if you close and reopen, it should fix itself ... maybe.

No crashes or being kicked back to the episode list? Weird, I wonder what's wrong with my config.

Anyway, that's a good sign. I'll check it out when I get back home.
Reply
I know the source of the bug now.

When had I set XBMC to open Show Information before I play a title (Settings > Videos > File Lists > Default select action) and then Play from the Show Information screen, the error occurs.

Definitely a bug, But not as inconvenient. Thanks for the help.
Reply
OK, yeah, now I was able to replicate it.
And the same issue exists in 12.0 and 13rc1, so yeah there is some kind of issue.
XBMC user since before that Music db hack.
Now with his 2nd DMCA Takedown
Reply
(2014-05-03, 21:43)billyea Wrote: Image

Somewhat off topic here, but what is this theme?
Reply
(2014-05-04, 08:43)nbean Wrote:
(2014-05-03, 21:43)billyea Wrote: Image

Somewhat off topic here, but what is this theme?

Maximinimalism. Great theme which you can get off the official repo.

By the way, is it possible to revert the change for
Code:
player = xbmc.Player(xbmc.PLAYER_CORE_DVDPLAYER)
Sending the video to play from Yatse (on my Android) worked prior to this change, but now it causes the whole "opening stream" indefinitely thing. I don't think that code is necessary anymore now that we've found the root cause of this bug in the Show Information screen.

(Alternatively, it could be something else was changed, but the Yatse thing is a regression from 0.9.9.4)
Reply
  • 1
  • 18
  • 19
  • 20(current)
  • 21
  • 22
  • 46

Logout Mark Read Team Forum Stats Members Help
Crunchyroll [DMCA Takedown]5
This forum uses Lukasz Tkacz MyBB addons.