•   
  • 1
  • 47
  • 48
  • 49(current)
  • 50
  • 51
  • 68
  •   
[WIP] HTPC-Manager Beta, Manage XBMC, Sabnzbd, SickBeard with one app
For some reason small screen menu and desktop menu shows at the same time on your computer. Try reducing length of menu names and force browser cache
Reply
(2014-04-24, 20:36)hatton33 Wrote: Great new version. Only one issue, the mobile version struggles with 'other links'. For some reason, I can't click on any of the links I've added on the mobile version - the full Web version works fine though. Any ideas?

I have sendt a pr regarding your issue, should be fixed as soon as its merged.
Reply
Anyone have "Stats" working on Mac OS X?

I have installed psutil with "pip install psutil", but it doesn't work (psutil not found in the web ui).
Reply
Yes was working when i tested it. I cant remember what i did tho. I think i had to compile some c extensions. I see that the help page that i used (and as error logg referes to returns 404) after the project has been moved to github.
Reply
(2014-05-26, 14:53)hellow Wrote: Yes was working when i tested it. I cant remember what i did tho. I think i had to compile som c extensions. I see that the help page that i used (and as error referes returns 404) after the project has been moved to github.

Thanks for the reply,

I would think that it should be enough just installing psutil?

Maybe HTPC-Manager looks for psutil in another path than where it's installed on OS X?

I just used 'pip install psutil' and I'm not sure where that installs it.
Reply
I just compiled/installed psutil from source and it installs without problems, but it still doesn't work in HTPC-Manager.

Here is the install log, maybe this can give som hints about if stats.py needs to be updated to work on OS X:
Code:
python setup.py install
running install
running bdist_egg
running egg_info
writing psutil.egg-info/PKG-INFO
writing top-level names to psutil.egg-info/top_level.txt
writing dependency_links to psutil.egg-info/dependency_links.txt
reading manifest file 'psutil.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no previously-included files matching '*' found under directory 'docs/_build'
writing manifest file 'psutil.egg-info/SOURCES.txt'
installing library code to build/bdist.macosx-10.9-x86_64/egg
running install_lib
running build_py
creating build
creating build/lib.macosx-10.9-x86_64-2.7
creating build/lib.macosx-10.9-x86_64-2.7/psutil
copying psutil/__init__.py -> build/lib.macosx-10.9-x86_64-2.7/psutil
copying psutil/_common.py -> build/lib.macosx-10.9-x86_64-2.7/psutil
copying psutil/_compat.py -> build/lib.macosx-10.9-x86_64-2.7/psutil
copying psutil/_psbsd.py -> build/lib.macosx-10.9-x86_64-2.7/psutil
copying psutil/_pslinux.py -> build/lib.macosx-10.9-x86_64-2.7/psutil
copying psutil/_psosx.py -> build/lib.macosx-10.9-x86_64-2.7/psutil
copying psutil/_psposix.py -> build/lib.macosx-10.9-x86_64-2.7/psutil
copying psutil/_pssunos.py -> build/lib.macosx-10.9-x86_64-2.7/psutil
copying psutil/_pswindows.py -> build/lib.macosx-10.9-x86_64-2.7/psutil
running build_ext
building '_psutil_osx' extension
creating build/temp.macosx-10.9-x86_64-2.7
creating build/temp.macosx-10.9-x86_64-2.7/psutil
creating build/temp.macosx-10.9-x86_64-2.7/psutil/arch
creating build/temp.macosx-10.9-x86_64-2.7/psutil/arch/osx
cc -fno-strict-aliasing -fno-common -dynamic -I/usr/local/include -I/usr/local/opt/sqlite/include -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c psutil/_psutil_osx.c -o build/temp.macosx-10.9-x86_64-2.7/psutil/_psutil_osx.o
cc -fno-strict-aliasing -fno-common -dynamic -I/usr/local/include -I/usr/local/opt/sqlite/include -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c psutil/_psutil_common.c -o build/temp.macosx-10.9-x86_64-2.7/psutil/_psutil_common.o
cc -fno-strict-aliasing -fno-common -dynamic -I/usr/local/include -I/usr/local/opt/sqlite/include -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c psutil/arch/osx/process_info.c -o build/temp.macosx-10.9-x86_64-2.7/psutil/arch/osx/process_info.o
cc -bundle -undefined dynamic_lookup -L/usr/local/lib -L/usr/local/opt/sqlite/lib build/temp.macosx-10.9-x86_64-2.7/psutil/_psutil_osx.o build/temp.macosx-10.9-x86_64-2.7/psutil/_psutil_common.o build/temp.macosx-10.9-x86_64-2.7/psutil/arch/osx/process_info.o -o build/lib.macosx-10.9-x86_64-2.7/_psutil_osx.so -framework CoreFoundation -framework IOKit
building '_psutil_posix' extension
cc -fno-strict-aliasing -fno-common -dynamic -I/usr/local/include -I/usr/local/opt/sqlite/include -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -I/usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/include/python2.7 -c psutil/_psutil_posix.c -o build/temp.macosx-10.9-x86_64-2.7/psutil/_psutil_posix.o
cc -bundle -undefined dynamic_lookup -L/usr/local/lib -L/usr/local/opt/sqlite/lib build/temp.macosx-10.9-x86_64-2.7/psutil/_psutil_posix.o -o build/lib.macosx-10.9-x86_64-2.7/_psutil_posix.so
creating build/bdist.macosx-10.9-x86_64
creating build/bdist.macosx-10.9-x86_64/egg
copying build/lib.macosx-10.9-x86_64-2.7/_psutil_osx.so -> build/bdist.macosx-10.9-x86_64/egg
copying build/lib.macosx-10.9-x86_64-2.7/_psutil_posix.so -> build/bdist.macosx-10.9-x86_64/egg
creating build/bdist.macosx-10.9-x86_64/egg/psutil
copying build/lib.macosx-10.9-x86_64-2.7/psutil/__init__.py -> build/bdist.macosx-10.9-x86_64/egg/psutil
copying build/lib.macosx-10.9-x86_64-2.7/psutil/_common.py -> build/bdist.macosx-10.9-x86_64/egg/psutil
copying build/lib.macosx-10.9-x86_64-2.7/psutil/_compat.py -> build/bdist.macosx-10.9-x86_64/egg/psutil
copying build/lib.macosx-10.9-x86_64-2.7/psutil/_psbsd.py -> build/bdist.macosx-10.9-x86_64/egg/psutil
copying build/lib.macosx-10.9-x86_64-2.7/psutil/_pslinux.py -> build/bdist.macosx-10.9-x86_64/egg/psutil
copying build/lib.macosx-10.9-x86_64-2.7/psutil/_psosx.py -> build/bdist.macosx-10.9-x86_64/egg/psutil
copying build/lib.macosx-10.9-x86_64-2.7/psutil/_psposix.py -> build/bdist.macosx-10.9-x86_64/egg/psutil
copying build/lib.macosx-10.9-x86_64-2.7/psutil/_pssunos.py -> build/bdist.macosx-10.9-x86_64/egg/psutil
copying build/lib.macosx-10.9-x86_64-2.7/psutil/_pswindows.py -> build/bdist.macosx-10.9-x86_64/egg/psutil
byte-compiling build/bdist.macosx-10.9-x86_64/egg/psutil/__init__.py to __init__.pyc
byte-compiling build/bdist.macosx-10.9-x86_64/egg/psutil/_common.py to _common.pyc
byte-compiling build/bdist.macosx-10.9-x86_64/egg/psutil/_compat.py to _compat.pyc
byte-compiling build/bdist.macosx-10.9-x86_64/egg/psutil/_psbsd.py to _psbsd.pyc
byte-compiling build/bdist.macosx-10.9-x86_64/egg/psutil/_pslinux.py to _pslinux.pyc
byte-compiling build/bdist.macosx-10.9-x86_64/egg/psutil/_psosx.py to _psosx.pyc
byte-compiling build/bdist.macosx-10.9-x86_64/egg/psutil/_psposix.py to _psposix.pyc
byte-compiling build/bdist.macosx-10.9-x86_64/egg/psutil/_pssunos.py to _pssunos.pyc
byte-compiling build/bdist.macosx-10.9-x86_64/egg/psutil/_pswindows.py to _pswindows.pyc
creating stub loader for _psutil_osx.so
creating stub loader for _psutil_posix.so
byte-compiling build/bdist.macosx-10.9-x86_64/egg/_psutil_osx.py to _psutil_osx.pyc
byte-compiling build/bdist.macosx-10.9-x86_64/egg/_psutil_posix.py to _psutil_posix.pyc
creating build/bdist.macosx-10.9-x86_64/egg/EGG-INFO
copying psutil.egg-info/PKG-INFO -> build/bdist.macosx-10.9-x86_64/egg/EGG-INFO
copying psutil.egg-info/SOURCES.txt -> build/bdist.macosx-10.9-x86_64/egg/EGG-INFO
copying psutil.egg-info/dependency_links.txt -> build/bdist.macosx-10.9-x86_64/egg/EGG-INFO
copying psutil.egg-info/top_level.txt -> build/bdist.macosx-10.9-x86_64/egg/EGG-INFO
writing build/bdist.macosx-10.9-x86_64/egg/EGG-INFO/native_libs.txt
zip_safe flag not set; analyzing archive contents...
creating dist
creating 'dist/psutil-2.1.1-py2.7-macosx-10.9-x86_64.egg' and adding 'build/bdist.macosx-10.9-x86_64/egg' to it
removing 'build/bdist.macosx-10.9-x86_64/egg' (and everything under it)
Processing psutil-2.1.1-py2.7-macosx-10.9-x86_64.egg
Copying psutil-2.1.1-py2.7-macosx-10.9-x86_64.egg to /usr/local/lib/python2.7/site-packages
Adding psutil 2.1.1 to easy-install.pth file

Installed /usr/local/lib/python2.7/site-packages/psutil-2.1.1-py2.7-macosx-10.9-x86_64.egg
Processing dependencies for psutil==2.1.1
Finished processing dependencies for psutil==2.1.1
Reply
What does htpc manager log say?
Reply
(2014-05-26, 16:07)hellow Wrote: What does htpc manager log say?

Yes of course, that log would be relevant Smile

Here it is, strange that it says ' needs version 0.7' when I have installed version 2.1.1?

Code:
2014-05-26 15:55:50    modules.stats    ERROR    Psutil is outdated, needs atleast version 0,7
2014-05-26 15:55:43    modules.stats    ERROR    Could't import psutil. See http://psutil.googlecode.com/hg/INSTALL
Reply
I don't why it isn't working.. What os version? Can you import it manually?
Reply
(2014-05-26, 16:40)hellow Wrote: I don't why it isn't working.. What os version? Can you import it manually?

I'm using 10.9.3 - how do I import it manually?

Thanks
Reply
(2014-05-26, 16:47)Ayla Wrote:
(2014-05-26, 16:40)hellow Wrote: I don't why it isn't working.. What os version? Can you import it manually?

I'm using 10.9.3 - how do I import it manually?

Thanks


open terminal
write python and press enter
import psutil

do you get any error?
Reply
Look, since it's obvious you installed a valid version. Just comment out the sanity check:

PHP Code:
@cherrypy.expose()
    
def index(self):
        
#Since many linux repos still have psutil version 0.5
        
if psutil.version_info >= (07):
            
pass
        
else:
            
self.logger.error("Psutil is outdated, needs atleast version 0,7")

        return 
htpc.LOOKUP.get_template('stats.html').render(scriptname='stats'

To look like this:

PHP Code:
@cherrypy.expose()
    
def index(self):
        
#Since many linux repos still have psutil version 0.5
        #if psutil.version_info >= (0, 7):
        #    pass
       # else:
        #    self.logger.error("Psutil is outdated, needs atleast version 0,7")

        
return htpc.LOOKUP.get_template('stats.html').render(scriptname='stats'

And let us know how it works. I have an interest.

Reply
(2014-05-26, 20:38)hellow Wrote:
(2014-05-26, 16:47)Ayla Wrote:
(2014-05-26, 16:40)hellow Wrote: I don't why it isn't working.. What os version? Can you import it manually?

I'm using 10.9.3 - how do I import it manually?

Thanks


open terminal
write python and press enter
import psutil

do you get any error?

No errors, with 'import psutil'.

'psutil' gives:
Code:
>>> psutil
<module 'psutil' from '/usr/local/Cellar/python/2.7.5/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/psutil-2.1.1-py2.7-macosx-10.9-x86_64.egg/psutil/__init__.pyc'>

(2014-05-27, 04:05)MadClicker Wrote: Look, since it's obvious you installed a valid version. Just comment out the sanity check:

PHP Code:
@cherrypy.expose()
    
def index(self):
        
#Since many linux repos still have psutil version 0.5
        
if psutil.version_info >= (07):
            
pass
        
else:
            
self.logger.error("Psutil is outdated, needs atleast version 0,7")

        return 
htpc.LOOKUP.get_template('stats.html').render(scriptname='stats'

To look like this:

PHP Code:
@cherrypy.expose()
    
def index(self):
        
#Since many linux repos still have psutil version 0.5
        #if psutil.version_info >= (0, 7):
        #    pass
       # else:
        #    self.logger.error("Psutil is outdated, needs atleast version 0,7")

        
return htpc.LOOKUP.get_template('stats.html').render(scriptname='stats'

And let us know how it works. I have an interest.

Thanks for helping out,

I saw that check when I browsed the code, but I wasn't too keen on commenting it out, because then I would have to do it every time I update HTPC-Manager.

I'll try it and see if it works.

EDIT: It doesn't work, I just get this error now:
Code:
2014-05-27 10:01:21    modules.stats    ERROR    Could't import psutil. See http://psutil.googlecode.com/hg/INSTALL
Reply
Okei. I'll test it on a Mac later
Reply
Is there a way to delete wanted movies from Couchpotato through this interface? More specifically, if a movie is found and begins to download but fails to finish for some reason, the movie stays in a wanted state and cannot be deleted through the HTPC manager interface. If the movie is not found, it can be deleted.
Reply
  •   
  • 1
  • 47
  • 48
  • 49(current)
  • 50
  • 51
  • 68
  •   
 
Thread Rating:
  • 7 Vote(s) - 4.71 Average



Logout Mark Read Team Forum Stats Members Help
[WIP] HTPC-Manager Beta, Manage XBMC, Sabnzbd, SickBeard with one app4.717