•   
  • 1
  • 25
  • 26
  • 27(current)
  • 28
  • 29
  • 75
  •   
Release Picture Slideshow Screensaver
My bad looks like I running Gotham. I will download Kodi and see how that works. I assume the updated Screensaver add-on is linked to the version Kodi vs Gotham?
Thanks
Reply
(2014-12-04, 01:38)lowjumpingfrog Wrote: My bad looks like I running Gotham. I will download Kodi and see how that works. I assume the updated Screensaver add-on is linked to the version Kodi vs Gotham?
Thanks

yup, that's true.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
Same behavior in most recent Kodi Helix build with the Picture Slideshow Screensaver 2.0.10. There is a 5 second black screen in between every picture.
Reply
Hello. I know the BoxeeBox is not an officially supported platform at the moment, but has any testing been done with this add-on the BoxeeBox? It's mostly working for me with 1 issue. About 10% of the time the images do not display correctly. I get a black background with white blocks. I'm running XBMC Gotham. I think I'm using version 1.09 of the add-on, but i'm not in front of the BoxeeBox at the moment to confirm. I'm trying to determine if there is a problem with my images or if it's a add-on/Boxee compatibility issue. My best guess is an add-on/Boxee issue because it does not appear to be related to specific images. Sometimes an image works and sometimes it doesn't.

I have no problem with Gotham and the add-on when running it on my Macbook Pro with the same images.
Reply
(2014-12-05, 23:38)arjones67 Wrote: Hello. I know the BoxeeBox is not an officially supported platform at the moment, but has any testing been done with this add-on the BoxeeBox? It's mostly working for me with 1 issue. About 10% of the time the images do not display correctly. I get a black background with white blocks. I'm running XBMC Gotham. I think I'm using version 1.09 of the add-on, but i'm not in front of the BoxeeBox at the moment to confirm. I'm trying to determine if there is a problem with my images or if it's a add-on/Boxee compatibility issue. My best guess is an add-on/Boxee issue because it does not appear to be related to specific images. Sometimes an image works and sometimes it doesn't.

I have no problem with Gotham and the add-on when running it on my Macbook Pro with the same images.

not very likely to be an addon problem.
you could start by checking if the images display correctly in the pictures section of Kodi.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
(2014-12-06, 01:42)ronie Wrote:
(2014-12-05, 23:38)arjones67 Wrote: Hello. I know the BoxeeBox is not an officially supported platform at the moment, but has any testing been done with this add-on the BoxeeBox? It's mostly working for me with 1 issue. About 10% of the time the images do not display correctly. I get a black background with white blocks. I'm running XBMC Gotham. I think I'm using version 1.09 of the add-on, but i'm not in front of the BoxeeBox at the moment to confirm. I'm trying to determine if there is a problem with my images or if it's a add-on/Boxee compatibility issue. My best guess is an add-on/Boxee issue because it does not appear to be related to specific images. Sometimes an image works and sometimes it doesn't.

I have no problem with Gotham and the add-on when running it on my Macbook Pro with the same images.

not very likely to be an addon problem.
you could start by checking if the images display correctly in the pictures section of Kodi.

Found the problem and it's not an add-on issue. There were a bunch of hidden files in the directory with all my pictures. No clue where they came from. I got the weird black screen with white blocks when Kodi tried to display the hidden files.

Thanks for your help and all the great work on Kodi!
Reply
Hello,

Everythings was perfect with this slideshow screensaver since latest 1.0.9 version ... I was very happy Smile
But Suddently this morning...no more screensaver Sad Sad
When It want to lunch, I got a error "Erreur Echec du plugin: slideshow" (my xbmc is in french)

So I didn't change anything between the time it worked and now !! What's wrong with my xbmc ??
I'm running on the latest version of Gotham and latest version of slideshow !!

MERCI BEAUCOUP Smile
Reply
(2014-12-07, 18:22)aktarus Wrote: Hello,

Everythings was perfect with this slideshow screensaver since latest 1.0.9 version ... I was very happy Smile
But Suddently this morning...no more screensaver Sad Sad
When It want to lunch, I got a error "Erreur Echec du plugin: slideshow" (my xbmc is in french)

So I didn't change anything between the time it worked and now !! What's wrong with my xbmc ??
I'm running on the latest version of Gotham and latest version of slideshow !!

MERCI BEAUCOUP Smile

please put a Debug Log on pastebin, and i'll have a look.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
Hello,

Here you can download two log file to see what's happened with it..
I setup start to 1 minute.. when slideshow suppose to start, I got the "script error"
The screen become black ans everything except slideshow seem to work well (music playbak)
When I click "esc" on keyboard, Black screen gone and I return to home screen like supposed..

https://dl.dropboxusercontent.com/u/16822683/xbmc.log
https://dl.dropboxusercontent.com/u/1682...mc.old.log

Please help me because I really lover this screensaver !!

MERCI Smile
Reply
(2014-12-08, 02:34)aktarus Wrote: Hello,

Here you can download two log file to see what's happened with it..
I setup start to 1 minute.. when slideshow suppose to start, I got the "script error"
The screen become black ans everything except slideshow seem to work well (music playbak)
When I click "esc" on keyboard, Black screen gone and I return to home screen like supposed..

https://dl.dropboxusercontent.com/u/16822683/xbmc.log
https://dl.dropboxusercontent.com/u/1682...mc.old.log

Please help me because I really lover this screensaver !!

MERCI Smile

you recently installed (or updated) an addon that is conflicting with the screensaver:
Quote:18:51:16 T:1873765376 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.ImportError'>
Error Contents: No module named tlslite.utils
Traceback (most recent call last):
File "/mnt/internal_sd/Android/data/hk.minix.xbmc/files/.xbmc/addons/screensaver.xbmc.slideshow/default.py", line 12, in <module>
from utils import *
File "/mnt/internal_sd/Android/data/hk.minix.xbmc/files/.xbmc/addons/script.video.F4mProxy/lib/utils/cipherfactory.py", line 8, in <module>
from tlslite.utils import python_aes
ImportError: No module named tlslite.utils

that script.video.F4mProxy addon is doing some silly things that break the screensaver addon.
your only option is to get rid of it.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
More information on this ...
If I set the "Amount of seconds to display each image" to anything less than 5 seconds no images appear. If I set it for 6 seconds or greater then the images display for that amount of time less 5 seconds, eg. if "Amount of seconds to display each image" = 7 seconds the image displays for 2 seconds and then the screen is blank for 5 seconds before the next image appears.
System setup:
Raspberry Pi Model B
OpenElec 4.97.1
Picture Slideshow Screensaver 2.0.10
Pastebin Log File
I see errors in the log file but, not sure what they mean with regard to the Screensaver
Any ideas where I might go next?
Thanks
Reply
(2014-12-09, 20:32)lowjumpingfrog Wrote: More information on this ...
If I set the "Amount of seconds to display each image" to anything less than 5 seconds no images appear. If I set it for 6 seconds or greater then the images display for that amount of time less 5 seconds, eg. if "Amount of seconds to display each image" = 7 seconds the image displays for 2 seconds and then the screen is blank for 5 seconds before the next image appears.
System setup:
Raspberry Pi Model B
OpenElec 4.97.1
Picture Slideshow Screensaver 2.0.10
Pastebin Log File
I see errors in the log file but, not sure what they mean with regard to the Screensaver
Any ideas where I might go next?
Thanks

according to the log your images are corrupt and Kodi has problems displaying them

Quote:10:49:49 336.006378 T:2825008192 NOTICE: DecodeJpegToTexture: unable to decode to texture /storage/pictures/DSC00277.JPG 1620x1080
10:49:49 336.027863 T:2971661376 ERROR: COMXCoreComponent:Big GrinecoderEventHandler OMX.broadcom.image_decode - OMX_ErrorStreamCorrupt, Bitstream corrupt

it probably has nothing todo with this addon.
check if those images display correctly when you browse them through the pictures section in kodi.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
These images display just fine in the screensaver and in the Picture slideshow part of Kodi. In fact, the pictures in the Slideshow action from the Home Screen Picture menu display with a crossfade just perfectly. It is only the blank screen in between the images (displayed without error) on the Screensaver Slideshow that is a problem. I resampled the images to the screen resolution 1920x1200 and the blank screen in between images is almost no existent. I suspect the issue is that Picture Slideshow screen saver is using a software JPEG decoder and the the Home Screen Picture slideshow is using a hardware decoder. When the images are smaller the software decoder works faster and the delay between images is shorter. I think the bitstream corruption is nothing more than the software decoder did not finish the JPEG decoding in time for the screensaver app to us it.
Reply
(2014-12-10, 01:23)lowjumpingfrog Wrote: These images display just fine in the screensaver and in the Picture slideshow part of Kodi. In fact, the pictures in the Slideshow action from the Home Screen Picture menu display with a crossfade just perfectly. It is only the blank screen in between the images (displayed without error) on the Screensaver Slideshow that is a problem. I resampled the images to the screen resolution 1920x1200 and the blank screen in between images is almost no existent. I suspect the issue is that Picture Slideshow screen saver is using a software JPEG decoder and the the Home Screen Picture slideshow is using a hardware decoder. When the images are smaller the software decoder works faster and the delay between images is shorter. I think the bitstream corruption is nothing more than the software decoder did not finish the JPEG decoding in time for the screensaver app to us it.

i wouldn't be able to tell what causes your issue,
but keep in mind this addon does not do any of that.
basically it just creates a picture playlist. no more, no less.

the loading / decoding / rendering of the images is handled entirely by Kodi.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
Understood. This is probably not the right place to ask this question. but, is it possible to interact with Kodi from the command line in an ssh session. For example write a shell/python script that effects the screen display ...?? I presume it would be possible to turn the display off and on in some fashion from the command line? I am working my way through the Wiki and not getting to anything that looks or smells like this
Thanks
Reply
  •   
  • 1
  • 25
  • 26
  • 27(current)
  • 28
  • 29
  • 75
  •   



Logout Mark Read Team Forum Stats Members Help
Picture Slideshow Screensaver4
This forum uses Lukasz Tkacz MyBB addons.