black screen on video playback
#1
Hi all, I love XBMC and have been using it on 2 xboxs in my house for ages now and so I was excited to see a PC version. I have just used the installer that is referenced in these forums and its great, apart from the fact when i try to play a video all i get is a black screen, I have installed the divx codecs and xvid onto the PC but it made no difference, dont know if it makes a different or not but when i go into the video folder I do have thumbnails so somehting must be able to view the video....

Could it be an opengl issues? if so, how can i see if my graphics are opengl compatibleHuh i am running a dell optiflex 745 which has intel graphics on board...
Reply
#2
had to reply to my own thread because I cant edit my original, I have just found out my PC has Intel Q963/Q965 graphics chipset, i downloaded some opengl screensavers from http://www.reallyslick.com and they work so i am guessing that my pc is doing ok with opengl..... Any thoughts?

I treid to download the latest drivers from intel but when I run them the installer stops and tells me it is not for my machine, so i went to dell and got the intel drivers from there for my machine.

Still cant playback video though.
Reply
#3
I also can't play back and videos. I want videos so much so I can finally retire my xbox.
Reply
#4
another update, I wanted to see if something like the apple movie trailers or yahoo music plugins would play the video, I found out i was getting MSVCP71.dll error and so I downloaded that from the net, now when i try to watch a video I get Error, playlist playback aborted, too many consecutive failed items


When the heck does that mean?
Reply
#5
dapex Wrote:another update, I wanted to see if something like the apple movie trailers or yahoo music plugins would play the video, I found out i was getting MSVCP71.dll error and so I downloaded that from the net, now when i try to watch a video I get Error, playlist playback aborted, too many consecutive failed items


When the heck does that mean?

I also got that. Scripts don't seem to work on windows yet... Oo
Reply
#6
Dapex, out of curiosity, are you getting sound but no picture, or no picture and no sound?

Further, does the screen remain blank, or do you get kicked back to the xbmc screen?

Also, when playing video, if you click the menu button, does a menu pop up that you can see?

This issue that I see as most likely is some kind of conflict between xbmc and your video card driver's fullscreen support. Have you tried doing this test in both fullscreen and windowed mode?

Before you get too hopefully about my help (btw), I'm not a programmer for this project, but I have had my fair share of xbmc and video related fiascoes.
Reply
#7
natethomas Wrote:Dapex, out of curiosity, are you getting sound but no picture, or no picture and no sound?

Further, does the screen remain blank, or do you get kicked back to the xbmc screen?

Also, when playing video, if you click the menu button, does a menu pop up that you can see?

This issue that I see as most likely is some kind of conflict between xbmc and your video card driver's fullscreen support. Have you tried doing this test in both fullscreen and windowed mode?

Before you get too hopefully about my help (btw), I'm not a programmer for this project, but I have had my fair share of xbmc and video related fiascoes.

Hi, I have the same problem: blank screen when playing video. Sound is OK, menu is popping up, I can also forward and pause the movie, OSD is even OK, only the movie itself is missing. My videocard is Intel 945 Mobile.
Reply
#8
natethomas Wrote:Dapex, out of curiosity, are you getting sound but no picture, or no picture and no sound?

Further, does the screen remain blank, or do you get kicked back to the xbmc screen?

Also, when playing video, if you click the menu button, does a menu pop up that you can see?

This issue that I see as most likely is some kind of conflict between xbmc and your video card driver's fullscreen support. Have you tried doing this test in both fullscreen and windowed mode?

Before you get too hopefully about my help (btw), I'm not a programmer for this project, but I have had my fair share of xbmc and video related fiascoes.


Sound plays fine, can get the picture of the controller up and pause, rewind etc.. all sounds fine but the screen is black..... tried it in full screen and windowed mode and no difference...

it seems to be an intel issue i think?
Reply
#9
here is a link to my xbmc log in case it helps
http://pastebin.com/m4a9c1fd9
Reply
#10
Are you currently running one of the preset resolutions or are you running an unusual resolution? I noticed the 720p calibration is a bit unusually. Have you tried running a video in which you have not tweaked resolutions at all (either in XBMC or in Windows proper)? That was one of my first problems on the 1080i screen that I was using. XBMC only worked for me if I left it at 1080 by 1920.

I'm not sure why that should matter, but xbmc gets real touchy in its ultra beta state.

If that isn't the issue, I'm at a loss for now.
Reply
#11
Ah ha! If you look down a couple posts, there is a discussion on this where the screen is either black or white. Their solution is actually to try to find REALLY OLD drivers for your intel video device. I'm not sure why that might be, but sounds like an interesting solution.
Reply
#12
I'm also want to migrate from my xboxes so that I can do Hi-Definition. I've put together a MediaPC with an ASUS P5E-VM HDMI motherboard and had the movie 'black screen but with sound' problem. The onboard video is Intel G35 and the problem was solved when I downloaded and installed the latest drivers from the Intel site. I'll include this here in case it helps anyone.
Reply
#13
Kitehunter, can you post a link to the download... I have tried different drivers with no luck and will now try any drivers at allSmile
Reply
#14
dapex Wrote:Kitehunter, can you post a link to the download... I have tried different drivers with no luck and will now try any drivers at allSmile

Version 7.14.10.1295 works fine for me. I'm using a Mac Mini with a Intel 945.

Sorry, I don't have a download link, these drivers came with Boot Camp.

-- Phelps
Reply
#15
I have not been able to find a changelog or item on this forum on this specific subject, but as of version XBMCSetup-Rev14125.exe i'm able to playback video on my laptop with 945 chipset.
So i suppose they found what it is and fixed it. Great!
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
black screen on video playback00