•   
  • 1
  • 91
  • 92
  • 93(current)
  • 94
  • 95
  • 107
  •   
[WINDOWS] External Player Support Thread
So with TMT not being updated anymore are most of you now using PowerDVD? I have been using TMT but thinking about switching but not sure if I should.

Are there other solutions? I am using TMT to play all my true 3D.iso and BD.iso files.
Reply
(2014-12-03, 10:18)Blackkatt Wrote:
(2014-12-03, 10:07)Bytefire Wrote:
(2014-12-01, 13:47)Blackkatt Wrote: [...] I'll be posting a How-To for use with PowerDVD as external player later today

So wheres the PowerDVD Tutorial? Big Grin

Yeah sry about that, I got hold up. I do it today then =)

BTW, Kodi is real good so far at least image vise, so you'll see no image quality improvements compared to PowerDVD if that's what you are after, if not go for it =), guide should be up later today, I'll make a "light one" to get it up faster, I'll update that later as I progress.

So you get this ,How to guide done yet?
Reply
Can anyone tell me if there is a way to set a rule for directories?

For example i only want to use an external player if a file is located in D:\folder1\coolstuff\

but not for anywhere else

Looked on the wiki but didn't see anything about it.
Reply
Kodi/XBMC supports "vertical Shift/offset" option. However this option is (natuarally) not present when using external player (powerdvd in my case).
Is there any command/syntax available in kodi which would force video to play with vertical shift?

Basically, i need 2.35 video, when played on 16:9, should not have top black bar (but bottom black bar to be of double the normal height)


Thanks!
Reply
Any tutorial with power dvd?
Reply
I think I know this is not possible but I want to ask the question anyway.

Is it possible to configure KODI so that 1 profile invokes an external player while a second profile does not?

Essentially I want to have a couple of profiles, one for us "grown-ups" and one for the kids. For the kids one I want the next show to play automatically (and so use the KODI player as you can stop it) while for us I don't.
Reply
(2015-03-07, 03:15)essjay Wrote: I think I know this is not possible but I want to ask the question anyway.

Is it possible to configure KODI so that 1 profile invokes an external player while a second profile does not?

Essentially I want to have a couple of profiles, one for us "grown-ups" and one for the kids. For the kids one I want the next show to play automatically (and so use the KODI player as you can stop it) while for us I don't.

I take it the command below didn't work with MPC:

<playonestackitem>true</playonestackitem>
Definition: Whether playback should stop after playing one item that's part of a stack.

You could remove the player rules and just define the external player in the top section of playercorefactory.xml. That way, you can play any content by invoking the context menu and select "Play using," MPC.

Or, using the opposite approach, use the external player and play the kids shows using, C, Context Menu, then "Play using," DVDPlayer.

A last ditch effort would be the following (with example key combo):

<keymap>
<global>
<keyboard>
<esc mod="ctrl">SwitchPlayer</esc>
</keyboard>
</global>
</keymap>

Program this to a remote button, and you have a shortcut to the player selection menu.

Or, use File Renamer to add a suffix (e.g. kids) to end of the kids content and add this rule to playercorefactory.xml:

<rule filename=".*kids.*" player="DVDPlayer" />

Make sure you use the preview function in File Renamer before making changes if you go this route.
Reply
Hi there! I am hoping someone might lead me back onto the right path, literally or figuratively...

I suspect it might be a certain addon that's doing this but I restored a kodi backup to a mobile android device so I don't have to install all the addons from scratch. However, the only difference is, the mobile device has a playercorefactory.xml file so I can launch external players.

When this is working, I have a "play using" option on the context menu.

When it is not, it's missing YET the default MX Player Pro player still launches!!

What may I be missing here in order to reinstate the "play using" option which works on a fresh kodi install?

Thank you in advance.
Reply
I've just recently set up and configured Kodi, and have it pretty much how I want it. My library is functional, but there is one aspect missing from the whole set-up which is crucial: I want to be able to use MPC-HC as my player, for all video files, rather than Kodi's in-house player.

I've read up on the wiki, and the external players section, which seemed pretty conclusive and straightforward, so I went ahead and created my xml file and saved it as '*C:\Users\lewwatt\AppData\Roaming\Kodi\userdata\playercorefactory.xml*':

Quote: <playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\KCP\MPC-HC</filename>
<args>"{1}"</args>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
</playercorefactory>

It has enabled the context menu in Kodi, so I can select 'play with > MPC-HC', but once I select it, there is a brief, instantaneous flash of the screen where the program attempts to do something, before reverting back to Kodi, as it was.

Am I doing something wrong? Do I need additional programs or files?- I was under the impression that this was supported natively and that the playercorefactory xml file was all that was necessary.

Any help will be greatly appreciated, as this program is very promising, and I'm glad to have it running as I want it, after months of considering doing something about my ailing video library. I just need this part to work, and everything will fall together.
Reply
I want to play all videos through MPC-HC except DVD and DVD Isos.

No Matter what I do, I can't get it to work. Any ideas?

Code:
<playercorefactory>
    <players>
        <player name="MPC-HC" type="externalplayer">
        <filename>C:\Program Files (x86)\MPC-HC\mpc-hc.exe</filename>
        <args>"{1}" /fullscreen /close </args>
        <hidexbmc>true</hidexbmc>
        <hideconsole>false</hideconsole>
        <warpcursor>none</warpcursor>
        </player>
    </players>
    <rules action="prepend">
        <rule video="true" player="MPC-HC">
        <rule dvdimage="true" player="dvdplayer"/>
        <rule dvd="true" player="dvdplayer"/>
    </rules>
</playercorefactory>
Thanks,
JOe K.
Frodo Win 8 Pro x64
Fractal Design Node 605 (looks amazing)
i5 3570K, Asus P8Z77V LK
2x80GB Intel 320 SSD, 4TB NAS
GTX 670x2 SLI, 16GB GSkill Ares
Onkyo RC360 with Paradigm piece-by-piece 5.1 build
Nyxboard and AHK full controlled via XBox Controller
Reply
(2015-03-28, 18:05)lewwatt Wrote: I've just recently set up and configured Kodi, and have it pretty much how I want it. My library is functional, but there is one aspect missing from the whole set-up which is crucial: I want to be able to use MPC-HC as my player, for all video files, rather than Kodi's in-house player.

I've read up on the wiki, and the external players section, which seemed pretty conclusive and straightforward, so I went ahead and created my xml file and saved it as '*C:\Users\lewwatt\AppData\Roaming\Kodi\userdata\playercorefactory.xml*':

Quote: <playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\KCP\MPC-HC</filename>
<args>"{1}"</args>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
</playercorefactory>

It has enabled the context menu in Kodi, so I can select 'play with > MPC-HC', but once I select it, there is a brief, instantaneous flash of the screen where the program attempts to do something, before reverting back to Kodi, as it was.

Am I doing something wrong? Do I need additional programs or files?- I was under the impression that this was supported natively and that the playercorefactory xml file was all that was necessary.

Any help will be greatly appreciated, as this program is very promising, and I'm glad to have it running as I want it, after months of considering doing something about my ailing video library. I just need this part to work, and everything will fall together.

I think the problem might be in your <filename> line. It needs to be an actual full filename, usually the executable, for the program you want to use. For instance, mine is:

<filename>C:\Program Files (X86)\MPC-HC\mpc-hc.exe</filename>

Once you get that working, so it shows up as a choice under Play using... , then add this code to your playercorefactory.xml file to make it play all videos (above the ending </playercorefactory> tag):

<rules action="prepend">
<rule video="true" player="MPC-HC" />
</rules>
Reply
(2015-03-28, 18:52)pagali Wrote: I think the problem might be in your <filename> line. It needs to be an actual full filename, usually the executable, for the program you want to use. For instance, mine is:

<filename>C:\Program Files (X86)\MPC-HC\mpc-hc.exe</filename>

Once you get that working, so it shows up as a choice under Play using... , then add this code to your playercorefactory.xml file to make it play all videos (above the ending </playercorefactory> tag):

<rules action="prepend">
<rule video="true" player="MPC-HC" />
</rules>
Thanks for the speedy reply!

I actually did have the '.exe' at the end originally, but I must have lost that in one of my numerous copy-pastes of other people's configurations. But, I didn't know that the 'prepend' rule was a necessity, and I had removed that in my configurations, thinking that it was just an unnecessary condition for using MPC-HC, when I wanted it to be unconditional. I've implemented your suggestion, and the situation has been improved by the fact that MPC-HC is now clearly my default program upon pressing play, rather than having to use the context menu - but Kodi still only flickers away, then straight back, as if nothing happened. MPC-HC doesn't even get launched.

My playercorefactory.xml file now reads as such:

Quote:<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\KCP\mpc-hc.exe</filename>
<args>"{1}"</args>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<rule video="true" player="MPC-HC" />
</rules>
</playercorefactory>

If the information is of any relevancy, I have, in System > Video Output, enabled 'Use a fullscreen window rather than true fullscreen'. I am also running Windows 7, 64-bit.

Where should I turn to next?
Reply
(2015-03-28, 21:34)lewwatt Wrote:
(2015-03-28, 18:52)pagali Wrote: I think the problem might be in your <filename> line. It needs to be an actual full filename, usually the executable, for the program you want to use. For instance, mine is:

<filename>C:\Program Files (X86)\MPC-HC\mpc-hc.exe</filename>

Once you get that working, so it shows up as a choice under Play using... , then add this code to your playercorefactory.xml file to make it play all videos (above the ending </playercorefactory> tag):

<rules action="prepend">
<rule video="true" player="MPC-HC" />
</rules>
Thanks for the speedy reply!

I actually did have the '.exe' at the end originally, but I must have lost that in one of my numerous copy-pastes of other people's configurations. But, I didn't know that the 'prepend' rule was a necessity, and I had removed that in my configurations, thinking that it was just an unnecessary condition for using MPC-HC, when I wanted it to be unconditional. I've implemented your suggestion, and the situation has been improved by the fact that MPC-HC is now clearly my default program upon pressing play, rather than having to use the context menu - but Kodi still only flickers away, then straight back, as if nothing happened. MPC-HC doesn't even get launched.

My playercorefactory.xml file now reads as such:

Quote:<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\KCP\mpc-hc.exe</filename>
<args>"{1}"</args>
<hidexbmc>true</hidexbmc>
<hideconsole>true</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>
<rules action="prepend">
<rule video="true" player="MPC-HC" />
</rules>
</playercorefactory>

If the information is of any relevancy, I have, in System > Video Output, enabled 'Use a fullscreen window rather than true fullscreen'. I am also running Windows 7, 64-bit.

Where should I turn to next?

If using MPC-HC, I would turn to this guide:

HOW TO - Launch MPC-HC/MPC-BE with madVR as an External Player
Reply
(2015-03-29, 01:05)Warner306 Wrote: If using MPC-HC, I would turn to this guide:

HOW TO - Launch MPC-HC/MPC-BE with madVR as an External Player

Unfortunately, that guide almost entirely deals with setting up MPC-HC and its component parts; something which isn't a problem for me. My player works fine, and I can play videos selected via file explorer, it's just that Kodi refuses to send the URI to MPC-HC, of whatever media I select - or some other similar reason is preventing the use of MPC-HC as an functioning external player in Kodi. I've again amended my xml with an alternative configuration, but the same thing happens, with a brief screen flicker, as if it tried to do something, but instead did nothing. Here is my latest xml:

Quote:<playercorefactory>
<players>
<player name="MPC-HC" type="ExternalPlayer" audio="false" video="true">
<filename>C:\Program Files (x86)\KCP\mpc-hc.exe</filename>
<args>"{1}"</args>
<hidexbmc>true</hidexbmc>
</player>
</players>
<rules action="prepend">
<rule filetypes="mkv|mp4|avi|divx|mpg|wmv|flv|ts" player="MPC-HC"/>
</rules>
</playercorefactory>

I'm feeling as if I may have to give up on this program, as I can't see any weak point on my part, and I value MPC-HC over a nice library interface. Is there no possible solution to this?- just a random and incomprehensible incompatibility on my system?
Reply
Update to my previous post below:

After further investigation I think the reason why I no longer have the "play using..." option on the context menu is because the menu itself has become cluttered with all sorts of options added by various plugins I have installed.

Is there a way to be able to edit this list?


(2015-03-28, 17:12)Betelgeuse2112 Wrote: Hi there! I am hoping someone might lead me back onto the right path, literally or figuratively...

I suspect it might be a certain addon that's doing this but I restored a kodi backup to a mobile android device so I don't have to install all the addons from scratch. However, the only difference is, the mobile device has a playercorefactory.xml file so I can launch external players.

When this is working, I have a "play using" option on the context menu.

When it is not, it's missing YET the default MX Player Pro player still launches!!

What may I be missing here in order to reinstate the "play using" option which works on a fresh kodi install?

Thank you in advance.
Reply
  •   
  • 1
  • 91
  • 92
  • 93(current)
  • 94
  • 95
  • 107
  •   



Logout Mark Read Team Forum Stats Members Help
[WINDOWS] External Player Support Thread11
This forum uses Lukasz Tkacz MyBB addons.