Background when playing music over airplay
#1
I have disabled "Viualisation" (i.e., "none") in the music settings. However, when I airplay music to Kodi using Transparency!, it still displays some music-related artworlk in the background. Something it overlays this with the current artwork and sometimes it displays only this.

Any idea how this can be fixed? Thanks in advance!
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply
#2
probably the artist slideshow addon?
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#3
Nope, no artist slideshow addon installed.
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply
#4
Any other idea what is driving this unwanted behaviour? It really does not look nice, so would be great to see this addressed. Should be easy to replicate when turning off music visualization. Thanks in advance!!!
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply
#5
yeah, there's a button on the music osd that lets you fine-tune the background.
make sure all the options are disabled.

Image
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#6
This is weird. I actually do not get this OSD? Does this only work when you use the library? I am using airplay, so will not get this OSD? Or do I somehow need to enable it?
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply
#7
let me start by saying that i do not know anything about airplay :-)

when you play music in kodi, hit the 'tab' key on keyboard to switch to the fullscreen visualisation screen.
there you can hit the button with the rectangle icon on it, to bring up the visualisation background customizer.

when things don't work out for you, could you please post a screenshot of what you're trying to remove,
so i know we're talking about the same thing.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#8
Thanks, I tried what you suggest below, but my OSD looks very different (basically no functions besides play/stop/etc). This is both when using airplay and also when playing music in "file mode". My guess is that above menu will only come up when playing music in "library mode". Or it may be related to me already using Isengard. Let me see whether I can find a way to take a screenshot to illustrate.
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply
#9
I tried in library mode, but same issue. The OSD is very different from the one you are showing. Could it be that I am running Issengard and Transparency not being fully compatible yet?
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply
#10
(2015-04-25, 13:01)steve1977 Wrote: I tried in library mode, but same issue. The OSD is very different from the one you are showing. Could it be that I am running Issengard and Transparency not being fully compatible yet?

nope, T! is fully compatible.

screenshots please :-)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#11
I think I get it mostly working now. I got the OSD by pressing "enter" one more time. Once clicking "tab", I get to a different OSD and then need to press "enter" to get to the one you were posting the screenshot of.

Still one issue though - When I am in the home screen, the background now is black (bottom-right shows albumart and spinning disk). But the full background is not showing the "normal" fanart. It works when selecting movies, but the one not working is the main menu.

I need to find a way to post a screenshot from a remote desktop on mac, but hope my explanation is somewhat clear?
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply
#12
nope, not really. it's not clear to me what you want to achieve.

what kind of artwork do you want to be displayed on the homescreen?
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#13
Just the default one. T! displays very nice background art (movie theater with movie, a white living room with tvshow, etc.). All this is T! default and i Like it. However, after de-activating everything as you suggested, it is a black background screen when playing music. When stopping to play music, everything works as normal. Clearer or let me look for some tool or just take a photo with the iphone.
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply
#14
Settings > Skin Settings > Home window > Hide visualisation background
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#15
Brilliant, you are the best. This solved it both for regular musicplay and also for airplay.

Only thing unsolved is that the albumart does not display when palying airplay, but I believe this is not skin-related, but a restriction of the current airplay implementation?
Server: Asus Sabertooth Z77 | Intel Core i5 3.4 GHz | 16 GB DDR3 | 128 GB SSD, 82 TB (9 x 6 TB, 7 x 4 TB)
HTPC 1: Raspberry Pi 2 | HTPC 2: Raspberry Pi 2 | HTPC 3: Raspberry Pi
Reply



Logout Mark Read Team Forum Stats Members Help
Background when playing music over airplay0
This forum uses Lukasz Tkacz MyBB addons.