•   
  • 1
  • 23
  • 24
  • 25(current)
  • 26
  • 27
  • 504
  •   
Kodi DSPlayer – DirectShow Player for Windows
Thanks for the answer. I have a Samsung PS64D8000 and have disabled Cinema Smooth if that's what you are referring to by pulldown?
Black Levels are effected if I enable that setting, so have just disabled it. With my normal DSplayer version I'm using normal bitstream, but lipsync is not 100% in sync. I have not experience in what to set audio delay to have it more in sync-
Reply
@Bjur
you can just install 14.2 dsplayer without delete the folder in %appdata%/kodi because all 14.* version have the same db so there is no problem

then maybe for isengard you can make a fresh new install

for your problem with lipsync there is an easy solution, I also have a samsung tv and i have to set different delay to each refresh

i added the support to <latency><delay> with lav audio and ffdshow audio

you can read how to do here 1939234 (post)

with all my samsung tv i had to set 250ms with 24hz and 150ms with the others refresh
Reply
Thanks aracnoz for your work!

It seems that DSPlayer isn't using the Audio Renderer I have selected in the DSPlayer settings. DSPlayer is always using the renderer which is selected in Windows as default, it doesn't matter which renderer I select in DSPlayer settings. No problems with DVDPlayer.

Anyone can confirm?
Reply
@eltopo

u MUST select the audio first in windows (and configuration as the number of speakers), prior to be able to use it on Kodi.
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
(2015-04-28, 17:07)vicmanpergar Wrote: @eltopo

u MUST select the audio first in windows (and configuration as the number of speakers), prior to be able to use it on Kodi.

I don't think so... at least that is not the case if I use DVDPlayer instead of DSPlayer. Normally, the selected audio renderer in the DS Player settings should be the one to use. That is exactly the way it works with DVDPlayer, it doesn't care about the default audio output in Windows.
Reply
@eltopo yes, i can confirm. In Kodi dvdplayer i use two different sound devices. HDMI for my TV and a headphone. I can switch in the system configuration of Kodi.
If i change the default device in windows to the headphones, dsplayer uses the headphones. If i change the output in dsplayer to use HDMI the audio output is still the headphone.

No matter what i select in the dsplayer configuration, dsplayer always uses the default in windows.

I mentioned my issue two times but no one could give me an answer.
Reply
(2015-04-28, 14:27)aracnoz Wrote: i'm working on Isengard, any further update will be made only on this version, the first beta should be out in a few days and you'll be pleased to know that it works perfectly with all recent DSPlayer update

with isengard the team kodi added in "video - library" an option "Select first unwatched TV show season/episode" to select direclty the last unwatched episode when we enter in a serie folder, I found this option very useful and then I added an ulterior option "Select last TV show on first entry" to choose if select the last watched tvshow or played tvshow, when we enter the first time in Tv Show, in this way we have a total comfort Smile

@weirdinin

i added for Isengard DSPlayer an option to choose if change refresh only with DVDPlayer, only with DSPlayer or Both

maybe can be useful for someone else

Feeling like it's christmas already! Truly amazing work!
Current setup
HTPC: G4560 Kaby Lake, ASRock H110M-ITX, 8 GB, Win10
Server: G2120 Ivy Bridge, ASRock B75 Pro3-M, 8 GB, 22 TB HDD, Ubuntu 16.04.5 LTS
Audio&Visual: Marantz NR-1602, Dali Opticon 6 5.1, SVS PB12-NSD, Sony KD-65A1
Reply
Regarding TV settings, i've disabled everything except Motion plus, the video just seems to feel laggy and jerky without it.

What settings is recommended for Samsung TVs?
Reply
(2015-04-28, 18:20)_Andy_ Wrote: @eltopo yes, i can confirm. In Kodi dvdplayer i use two different sound devices. HDMI for my TV and a headphone. I can switch in the system configuration of Kodi.
If i change the default device in windows to the headphones, dsplayer uses the headphones. If i change the output in dsplayer to use HDMI the audio output is still the headphone.

No matter what i select in the dsplayer configuration, dsplayer always uses the default in windows.

I mentioned my issue two times but no one could give me an answer.

You could use ReClock. Your settings will never change. And I still think it's the best audio renderer. But you do have a point. If you can't adjust the output by remote, some functionality is lost.
Reply
(2015-04-28, 19:24)XTrojan Wrote: Regarding TV settings, i've disabled everything except Motion plus, the video just seems to feel laggy and jerky without it.

What settings is recommended for Samsung TVs?

I have all frame interpolation turned off and use the Cinema setting. You could try Smooth Motion in madVR. Even at 24hz, the video will get smoother. What you are looking at may be completely normal and cannot be cured until film makers start filming at 48hz.
Reply
(2015-04-28, 20:54)Warner306 Wrote:
(2015-04-28, 19:24)XTrojan Wrote: Regarding TV settings, i've disabled everything except Motion plus, the video just seems to feel laggy and jerky without it.

What settings is recommended for Samsung TVs?

I have all frame interpolation turned off and use the Cinema setting. You could try Smooth Motion in madVR. Even at 24hz, the video will get smoother. What you are looking at may be completely normal and cannot be cured until film makers start filming at 48hz.

Cinema setting uses noise reduction though and some anti-motion blur.

I doubt the 24P i watched is real 24P, it might be but it felt choppy, I've got "Film" mode with all crap turned off except Motion plus set to smooth.

I tried game mode but it gave same choppy effect.

MadVR smooth motion gave a lot of blurryness/motion blur, it also felt like the movie was played slower than usual.

It might be me enjoying a soap opera, but i honestly prefer smoothness over what they call 24P "Experience", which in my opinion is stupid. Knowing the cinema industry 2x more frames makes special effects suddenly cost nearly twice as more.

I'm not sure why everyone is QQing on smoothness = soap opera.
Reply
(2015-04-28, 20:53)Warner306 Wrote:
(2015-04-28, 18:20)_Andy_ Wrote: @eltopo yes, i can confirm. In Kodi dvdplayer i use two different sound devices. HDMI for my TV and a headphone. I can switch in the system configuration of Kodi.
If i change the default device in windows to the headphones, dsplayer uses the headphones. If i change the output in dsplayer to use HDMI the audio output is still the headphone.

No matter what i select in the dsplayer configuration, dsplayer always uses the default in windows.

I mentioned my issue two times but no one could give me an answer.

You could use ReClock. Your settings will never change. And I still think it's the best audio renderer. But you do have a point. If you can't adjust the output by remote, some functionality is lost.

The main problem is not that the audio renderer can't be changed by remote. The main problem is that DSPlayer doesn't care about the audio renderer which is selected in the DSPlayer settings, it always uses the Windows default device.

Perhaps aracnoz can change this wrong behaviour in the Isengard release.
Reply
Could someone who knows tell me the rules that allows SVP with mp4? or for all files for that matter. Got it working in mkv under different rules, but can get it to work with mp4.
Reply
(2015-04-28, 16:14)aracnoz Wrote: @Bjur
you can just install 14.2 dsplayer without delete the folder in %appdata%/kodi because all 14.* version have the same db so there is no problem

then maybe for isengard you can make a fresh new install

for your problem with lipsync there is an easy solution, I also have a samsung tv and i have to set different delay to each refresh

i added the support to <latency><delay> with lav audio and ffdshow audio

you can read how to do here 1939234 (post)

with all my samsung tv i had to set 250ms with 24hz and 150ms with the others refresh

Thanks for your help. I will definately try it outSmile
Reply
(2015-04-28, 15:35)oldpoem Wrote:
(2015-04-28, 14:52)neeto33 Wrote:
(2015-04-28, 14:47)oldpoem Wrote: To be able to use DSplayer with DVD folder (ifo) you need to config dvd navigator as source AND splitter. But then it's not working 100% some dvd won't play so convert iso to mkv seem to be best option.

Yep got dvdnavigator as both source AND splitter.
Any clue on why some work and some don't? anything to do with them being on smb mount on NAS?

It just don't work with some DVD structure even with using other directshow based player (MPC-HC etc.). Since DVD Navigator filter is not in development anymore and no replacement filter for it, that's the end of dvd ifo playback.

Ok here's the answer - it will & does work fine for DVD structures on the local host with the following configs

<
Reply
  •   
  • 1
  • 23
  • 24
  • 25(current)
  • 26
  • 27
  • 504
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347