•   
  • 1
  • 36
  • 37
  • 38(current)
  • 39
  • 40
  • 506
  •   
Kodi DSPlayer – DirectShow Player for Windows
aracnoz, considering I had the stopping problem with black screen, what would be the recommended version to download in order to give it another try?
For troubleshooting and bug reporting please make sure you read this first.
Reply
(2015-05-16, 06:55)Warner306 Wrote: Just stopped in to say the new madVR is giving me a green screen on some titles. This might have to do with me using the new Direct3D 11 presentation path with fullscreen exclusive mode to take advantage of 10 bit output. My old 2007 Panasonic plasma is a 12 bit display, so I've attempted playback with D3D11 + FSE, as this is required for 10 bit output. Changing the bit depth to 8 bits doesn't seem to fix the problem.

Usually green screen occurs when something wrong with DXVA or D3D when in use. Whether it's a bug in drivers or implementation. I doubt it has anything to do with higher bit output though. And from my past experience it occured a lot on Intel graphics system. Try disable HW decoding to see if it makes any difference.
Reply
(2015-05-15, 17:02)oldpoem Wrote: I think it's the same problem as djoole. I can hear the sound of gui & kodi accept any command through keyboard & remote. The latest build has a little bit different behaviour though, now it most of the time it won't be backscreen part of gui showed up usually some topbar / status bar of skin and when press power button the shutdown menu sometimes popupped but the rest of screen stay black. Seem like not all GUI was restored. I'd try to created debug log next time it happened.

Also I'm not using any other inputs just wireless keyboard & mce remote. Most of the time keyboard stay off and only remote is used.

if you have the gui partially showed means that you had a problem with textures, so your the debug log could be useful to see if there is some error while restoring textures and which threads are working on stop
this not exclude the fact that maybe sometime you have also another problem more similar to djoole

(2015-05-15, 23:15)djoole Wrote: I've just found out that there was an option "pause during refresh rate" that was activated in the CEC peripheral options in Kodi.

So now we know who was pausing Smile

I'll try some videos to see if the black screen problem was coming from that but I have good hope Smile

i was thinking that maybe pulse eight was the problem even if you don't use how remote, but it does not make sense to me... it's just a try
anyway in your case, now that we have solve all problems related to the texutres, seems that it's a problem with focus because when you go in taskmanager and then back to kodi you have the gui properly rendered without any glitches, i'm right? I can reproduce this issue removing a part of the code on stop

Code:
m_pVideoWindow->put_Visible(OAFALSE);
m_pVideoWindow->put_Owner((OAHWND)NULL);

this part serves to make madvr's window not visible and to remove from kodi... then you should have the focus on kodi.

so maybe it could be useful to call this just before/after during the stop, but again it does not make sense to me :\

(2015-05-16, 06:55)Warner306 Wrote: Just stopped in to say the new madVR is giving me a green screen on some titles. This might have to do with me using the new Direct3D 11 presentation path with fullscreen exclusive mode to take advantage of 10 bit output. My old 2007 Panasonic plasma is a 12 bit display, so I've attempted playback with D3D11 + FSE, as this is required for 10 bit output. Changing the bit depth to 8 bits doesn't seem to fix the problem.

i also have some kind of problem with latest madVR and switching refresh+fse+dx11, just for now if you want test these features you could try to enable to change refresh with both kodi and madVR
to see if solves the issue, i will wait that madshi updates the api to manage the new options without the tryicon, this it's the signal that madVR has reached more stability with these new features

(2015-05-16, 11:58)ashlar Wrote: aracnoz, considering I had the stopping problem with black screen, what would be the recommended version to download in order to give it another try?

you have to upgrade kodi to isengard dsplayer and then replace the exe with latest test build posted, for any kind of problem even if you think that are similar to other cases you should post your debug log
Reply
I've unchecked the option in libCEC settings in Kodi, still black screen, still onPause after a video stopped by itself.
I've deactivated libCEC peripheral in Kodi, still onPause in logs, still black screen.

Here are the logs (end at 00:22:58) : http://pastebin.com/EX4vC0Hc

I tried to launch a video, go just a few sec before the end, and let it finish... I've still got onPause before onStop, bu tno black screen.
It seems I get black screen after watching for quite a time a video. I get it almost 100% when watching a serie episode and letting finish by itself.

You don't have onPause in this case?

And to answer your question, no more texture problems. Once i open taskmanager and focus back to Kodi, everything is normal.
It's just that after stopping, and screen refreshing back to 60Hz, black screen.
Reply
@djoole

i prepared another test build

http://www.mediafire.com/download/y8ybpq...ngard6.rar

i tried to force madvr to exit from exclusive mode before to stop... maybe could be useful to maintain the right focus

@Warner306

i added a new option in video to change the refresh a little bit before... this should fix the problem with dx11 fse
Reply
I'll try the new build tomorrow.

In the meantime, I'd like to submit a new issue : each time a pause a video, GPU load is increasing from 55% to 96%.
I found out about this because GPU fans speed is rising and the computer is making a noise like is going to take off Smile

It's systematic regarding the video paused, the skin used (tried with Aeon MQ5 and Confluence)

In the following screenshot, you can see the phase with GPU load @96 (the video is paused) and then the load @57 (video is playing) and then load nearly 0 (video stopped)
Image

Is this a known issue?
Reply
yeah it's a known issue, madshi should do something for this with one of the next releases

this not happens on other players as mpc because there is no gui to render while pause..
Reply
OK thanks.
As I don't have this issue with MPC+MadVR, I thought it was only DSPlayer related.
Reply
(2015-05-16, 12:55)oldpoem Wrote:
(2015-05-16, 06:55)Warner306 Wrote: Just stopped in to say the new madVR is giving me a green screen on some titles. This might have to do with me using the new Direct3D 11 presentation path with fullscreen exclusive mode to take advantage of 10 bit output. My old 2007 Panasonic plasma is a 12 bit display, so I've attempted playback with D3D11 + FSE, as this is required for 10 bit output. Changing the bit depth to 8 bits doesn't seem to fix the problem.

Usually green screen occurs when something wrong with DXVA or D3D when in use. Whether it's a bug in drivers or implementation. I doubt it has anything to do with higher bit output though. And from my past experience it occured a lot on Intel graphics system. Try disable HW decoding to see if it makes any difference.

Yes, the answer was Intel graphics + D3D11 + hardware acceleration. Software decoding fixed this issue.

I find upscaled 12-bit color quite beautiful. It is a bigger upgrade than a small increase in image sharpness. Bringing up the filters list during playback and selecting ReClock will tell you the output being received by the TV.

Edit: I think the actual output is 10-bits and the difference is more placebo. I don't watch this television as much. It is the plasma color engine more than anything.
Reply
(2015-05-17, 00:55)aracnoz Wrote: @djoole

i prepared another test build

http://www.mediafire.com/download/y8ybpq...ngard6.rar

i tried to force madvr to exit from exclusive mode before to stop... maybe could be useful to maintain the right focus

@Warner306

i added a new option in video to change the refresh a little bit before... this should fix the problem with dx11 fse

It's worse with this build.
I get black screen and Kodi not answering.
I've played only one video with this build, and it's several files named XXXX.part1.avi, XXXX.partn.avi
The blackscreen/freeze occured when Kodi was supposed to play part 2.
Maybe it's something specific to multipart files and not relating to our previous problem..

I'll try more tests.
In the meantime here are the logs, stop of part 1 at 19:29:52 : http://pastebin.com/U5qKBcMF


EDIT : Definitely an issue with multi parts video.
Sometimes I get blackscreen and Kodi frozen after part1, sometimes i get the sound of part2 but I see the navigation screen.

I'll try to watch some series tonight to see if stopping problem is solved Wink
Reply
(2015-05-17, 00:55)aracnoz Wrote: @djoole

i prepared another test build

http://www.mediafire.com/download/y8ybpq...ngard6.rar

i tried to force madvr to exit from exclusive mode before to stop... maybe could be useful to maintain the right focus

@Warner306

i added a new option in video to change the refresh a little bit before... this should fix the problem with dx11 fse

I'm not sure what to say but I'ven't got blackscreen with this build yet. I tried many files in short time but all is good. Will try more later, but then no log file till the problem surface.
Reply
(2015-05-17, 19:42)djoole Wrote: It's worse with this build.
I get black screen and Kodi not answering.
I've played only one video with this build, and it's several files named XXXX.part1.avi, XXXX.partn.avi
The blackscreen/freeze occured when Kodi was supposed to play part 2.
Maybe it's something specific to multipart files and not relating to our previous problem..

I'll try more tests.
In the meantime here are the logs, stop of part 1 at 19:29:52 : http://pastebin.com/U5qKBcMF

here the problem it's the second playstart not the stop... madVR fails to enter in fullscreen exclusive mode, to find out why it could be useful generate a madvr freeze report by pressing and hold CTRL+SHIFT+ALT+BREAK/PAUSE while kodi appear frozen

i just added a new options to madVR in Video - Playback - "Change refresh before playstart" to anticipate a little this process that sometimes could influence madvr while it's entering in exclusive mode, for example i have a blackscreen if I try to enter in fullscreen exclusive mode with madVR 0.88.8 and d3d11

(2015-05-17, 19:42)djoole Wrote: sometimes i get the sound of part2 but I see the navigation screen.

yeah, this it's a strange behavior of dsplayer, even with evr, when play next file... i have to investigate, you can go back until the video appear

(2015-05-17, 19:42)djoole Wrote: I'll try to watch some series tonight to see if stopping problem is solved Wink

(2015-05-17, 19:53)oldpoem Wrote: I'm not sure what to say but I'ven't got blackscreen with this build yet. I tried many files in short time but all is good. Will try more later, but then no log file till the problem surface.

finger crossed Smile


p.s.

i'm testing a workaround to avoid gpu load while pause (thx tiben20) but we cannot have everything because the way that madVR manage the pause state... so with this solution the gpu load it's not so high but the GUI animation like windows transition, mouse movement etc etc are not so smooth as we would like, but i think that it's more important to preserve the gpu from heat that have super smooth gui during pause Smile
Reply
I watched 3 videos tonight and no black screen at the end.
As it was almost systematic, I would say this is the one Smile

As for multi parts videos, you say "you can go back until the video appear".
What do you mean by go back?
Reply
Quote:p.s.

i'm testing a workaround to avoid gpu load while pause (thx tiben20) but we cannot have everything because the way that madVR manage the pause state... so with this solution the gpu load it's not so high but the GUI animation like windows transition, mouse movement etc etc are not so smooth as we would like, but i think that it's more important to preserve the gpu from heat that have super smooth gui during pause Smile
The best way would be to be able to use the frame limiter built in kodi that caps the fps during pause. But its easier said than done
Reply
aracnoz
Thanks a bunch for dsplayer and these later builds

I'm coming late to party - but was having occasional blank screen issues on stopping (with 14.2 Helix and MadVR 08721)

Upgraded all to 15 Beta 1 and then your builds (b2) and all seems to be working well with no blank screen as yet (couple of hours of testing)

Thanks
Reply
  •   
  • 1
  • 36
  • 37
  • 38(current)
  • 39
  • 40
  • 506
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347