•   
  • 1
  • 76
  • 77
  • 78(current)
  • 79
  • 80
  • 505
  •   
Kodi DSPlayer – DirectShow Player for Windows
(2015-08-19, 01:18)oldpoem Wrote:
(2015-08-18, 20:27)Cinder Wrote: So I got xyvsfilter to load and work (I can turn working subtitles on/off from the xysubfilter settings window), but I still find that really few embedded subtitles in mkv containers actually work.
I can see 4 different subs for a movie in the Kodi subs menu, as well as in the DirectVobSub context menu, but none of them work when selected.
With the Kodi standard DVDPlayer I can see only 2 subs in the Kodi menus for the same movie, but they both work.

Anyone know why this is? Both xysubfilter and xyvsfilter seem to have the same problem described above.

This is not normal. Is this happens only to specific files or most files. How did you encoded the file, which softwares did you use? What does MediaInfo tell you about the problem file? Then upload some samples of problem file for others to see. The file you mentioned might be wrongly created.

Need a lot more information. Also Kodi DVDPlayer actually a very reliable in playing subtitles. Also you can try other player to see if the file indeed has 4 subtitles selectable tracks or not.

Also try to remux the file with MKVToolnix to possibly correct wrongly created media file.

It happened at least with two files that I tested, didn't have time to look through more.
I didn't encode the files myself which are bluray remuxes. MediaInfo says that there are actually only two subtitles in the file mentioned above, meaning that Kodi DVDPlayer is correct in displaying only the two. So that raises the question of where the other two subs come from, and of the two that are actually in the file only one works in xysubfilter/xyvsfilter.

Tried opening the file in MPC-HC and its the same there - only two subs present in the file. I will post the info from MediaInfo tonight when I get home.
Reply
(2015-08-19, 08:19)Cinder Wrote: It happened at least with two files that I tested, didn't have time to look through more.
I didn't encode the files myself which are bluray remuxes. MediaInfo says that there are actually only two subtitles in the file mentioned above, meaning that Kodi DVDPlayer is correct in displaying only the two. So that raises the question of where the other two subs come from, and of the two that are actually in the file only one works in xysubfilter/xyvsfilter.

Tried opening the file in MPC-HC and its the same there - only two subs present in the file. I will post the info from MediaInfo tonight when I get home.

Try using MKVToolnix to remux the file, carefully / properly select subtitles properties. If it's just 2 files randomly downloaded off the net, I'd say if newly remuxed file doesn't work like it should, don't bother too much on this subject. I haven't encountered this problem in my whole library and my problem with subtitles seem to be different than yours.
Reply
(2015-08-18, 22:40)Warner306 Wrote: What are your render queues when madVR stats are enabled? They should report 3-4/8 or 4-5/8. If these queues are not filling, your settings might be too aggressive. Try a range of content you are familiar with to test.

I use 16 as render queue. With kodi DSPlayer 15.0, I get full queues and no frame drops. With 15.1 RC1 the render queue shows 1-3/16, I get massive frame drops, and thing I did not pay attention to before, a lot of "presentation glitches" that do not happen with 15.0 either. This happens with all files regardless of filetype or resolution.

This is not a a problem with Madvr settings, since MPC-HC and Kodi DSPlayer 15.0 work perfectly fine. It must be incompatibility with SVP. I understand perfectly if SVP compatibility is not a priority, worst case I'l just keep using the older build or revert to external player.

edit: While testing I noticed if I exit and re-enter full screen the problem goes away.
Reply
(2015-08-19, 09:24)IT007 Wrote: edit: While testing I noticed if I exit and re-enter full screen the problem goes away.

Then you should provide full debug log for Aracnoz. Seem like it is fixable and problem might be on initialization.
Reply
(2015-08-19, 10:06)oldpoem Wrote:
(2015-08-19, 09:24)IT007 Wrote: edit: While testing I noticed if I exit and re-enter full screen the problem goes away.

Then you should provide full debug log for Aracnoz. Seem like it is fixable and problem might be on initialization.

Ok, if I understood this corectly, I put <loglevel>2</loglevel> in advancedsettings.xml and started a video file with the problematic build 15.1 RC1. I copied kodi.log here:
http://xbmclogs.com/pvooszgwc

Problem: a lot of dropped frames
Setup: Windows 10, Kodi Dsplayer 15.1 RC1, Madvr, Lav Filters, Reclock, Xysubfilter, ffdshow Raw, SVP (frame interpolation)
Reply
I am interested in trying Dsplayer for the first time... I have been a long time user of xbmc/kodi and would like the benefits of using Kodi dsplayer. This will be a learning curve for me so the question I have is am I able to have my current Kodi type setup (standard windows version) that I am using now and then switch to Dsplayer so I can learn to use it and tweak settings, and then be able to switch between the two?
Reply
(2015-08-19, 16:34)markus3000 Wrote: I am interested in trying Dsplayer for the first time... I have been a long time user of xbmc/kodi and would like the benefits of using Kodi dsplayer. This will be a learning curve for me so the question I have is am I able to have my current Kodi type setup (standard windows version) that I am using now and then switch to Dsplayer so I can learn to use it and tweak settings, and then be able to switch between the two?

U can have both versions if u do a portable installation on one of them.
Search the wiki. Works the same way except the userdata folder is in the same installation folder.
HTPC
Silverstone Grandia GD05 - Intel i5 3570k -Asus H61M-G Micro-ATX - Unidad Blu-ray
MSI GTX970 4GB GDDR5 - 8 GB RAM DDR3 - AVR Denon X3400H Atmos - LG  OLED 55C7V
Reply
(2015-08-19, 08:32)oldpoem Wrote:
(2015-08-19, 08:19)Cinder Wrote: It happened at least with two files that I tested, didn't have time to look through more.
I didn't encode the files myself which are bluray remuxes. MediaInfo says that there are actually only two subtitles in the file mentioned above, meaning that Kodi DVDPlayer is correct in displaying only the two. So that raises the question of where the other two subs come from, and of the two that are actually in the file only one works in xysubfilter/xyvsfilter.

Tried opening the file in MPC-HC and its the same there - only two subs present in the file. I will post the info from MediaInfo tonight when I get home.

Try using MKVToolnix to remux the file, carefully / properly select subtitles properties. If it's just 2 files randomly downloaded off the net, I'd say if newly remuxed file doesn't work like it should, don't bother too much on this subject. I haven't encountered this problem in my whole library and my problem with subtitles seem to be different than yours.

It seems like the issue might be pgs subtitles, as these don't work with some other mkv files I've tried as well. Is there some compatibility issue with xyvsfilter/xysubfilter and PGS subtitles?
I tried files with srt and ass subtitles, they all worked fine, but pgs subtitles don't display on the movie. They're found in the menu, but when selected don't work. All subs work in MPC-HC which I assume uses another subs filter.
Any ideas, fellas?

Oh and just one thing I was wondering about - what are the big benefits of using xysubfilter/xyvsfilter compared to the internal filters of Kodi/DSPlayer? Are there big differences at all? Wondering if my tinkering will be worth anything in the end Wink
Reply
(2015-08-19, 18:16)Cinder Wrote: It seems like the issue might be pgs subtitles, as these don't work with some other mkv files I've tried as well. Is there some compatibility issue with xyvsfilter/xysubfilter and PGS subtitles?
I tried files with srt and ass subtitles, they all worked fine, but pgs subtitles don't display on the movie. They're found in the menu, but when selected don't work. All subs work in MPC-HC which I assume uses another subs filter.
Any ideas, fellas?

Oh and just one thing I was wondering about - what are the big benefits of using xysubfilter/xyvsfilter compared to the internal filters of Kodi/DSPlayer? Are there big differences at all? Wondering if my tinkering will be worth anything in the end Wink

I had problem with PGS /Vobsub which are graphic subtitles with XySubfilter it just won't showed up on some files I have. I resolved it by switch to XyVSFilter and haven't got any problem since.

Old / internal DSplayer subtitle renderer was based on old Media Player Classic subtitle code IIRC. It has been abandoned for a long time but in most case is usable. The benefits of XySubfilter / XyVSFilter seem to be most affect on complex subtitles like ASS which usually founded in those fansub anime. If you don't watch this kind of subtitles you should be fine with internal subtitle of DSPlayer. But I'm not sure if it's working with recent Aracnoz Kodi DSPlayer now since most attention went to make XySubfilter / XyVSFilter works with Kodi/MadVR.
Reply
(2015-08-17, 09:45)Bjur Wrote:
(2015-08-16, 22:23)Warner306 Wrote:
(2015-08-16, 03:07)aoe2exp Wrote: So I fixed all my performance issues and the not wanting to play files by not using xysubfilter. I don't really care about subs, so I'll leave it like that.

I wanted to thank you guys for this amazing work.

Why don't you try xy-VSFilter .zip Archive (32-bit) instead? You might run into subtitles at some point.

I wonder if something has changed with the recent build of XySubFilter to cause these problems?
What specific versions of xysubfilter/xyvsfilter are people running??
I would like to try and see if that's causing the crash for me.
And also is it v. 15.0 or 15.1 rc?

Again. People that are running XYSubfilter or xyvsfilter and running 64 bit windows what version are you using.

What I have found for now. If I use XYSubfilter 3.1.0.705 (x86 beta2) I get Kodi crashing.
If I use XYSubfilter 3.1.0.546 (betav2) Kodi don't crashes, but when I download a subtitle it doesn't change.
If I afterwards goes from fullscreen window to window I get the correct subtitle loaded but if there's other subtitles in the directory it doesn't show when pressing "l" for changing subtitle however the downloaded subtitle is shown correctly.

If I press "l" and change a subtitle before downloading a subtitle the new subtitle is shown correctly but the other subs are again gone.

I'm running latest 15.1 rc and also with 15.0.
aracnoz helpSmile
Reply
(2015-08-19, 18:34)oldpoem Wrote:
(2015-08-19, 18:16)Cinder Wrote: It seems like the issue might be pgs subtitles, as these don't work with some other mkv files I've tried as well. Is there some compatibility issue with xyvsfilter/xysubfilter and PGS subtitles?
I tried files with srt and ass subtitles, they all worked fine, but pgs subtitles don't display on the movie. They're found in the menu, but when selected don't work. All subs work in MPC-HC which I assume uses another subs filter.
Any ideas, fellas?

Oh and just one thing I was wondering about - what are the big benefits of using xysubfilter/xyvsfilter compared to the internal filters of Kodi/DSPlayer? Are there big differences at all? Wondering if my tinkering will be worth anything in the end Wink

I had problem with PGS /Vobsub which are graphic subtitles with XySubfilter it just won't showed up on some files I have. I resolved it by switch to XyVSFilter and haven't got any problem since.

Old / internal DSplayer subtitle renderer was based on old Media Player Classic subtitle code IIRC. It has been abandoned for a long time but in most case is usable. The benefits of XySubfilter / XyVSFilter seem to be most affect on complex subtitles like ASS which usually founded in those fansub anime. If you don't watch this kind of subtitles you should be fine with internal subtitle of DSPlayer. But I'm not sure if it's working with recent Aracnoz Kodi DSPlayer now since most attention went to make XySubfilter / XyVSFilter works with Kodi/MadVR.

Do you have any idea what the problem with PGS might be, since I am actually running XyVSFilter, and they still don't work properly?
Thanks for the clarification about the filters as well.
Reply
(2015-08-19, 20:45)Cinder Wrote: Do you have any idea what the problem with PGS might be, since I am actually running XyVSFilter, and they still don't work properly?
Thanks for the clarification about the filters as well.

I don't have any idea since all my movies works fine and 95% of them has PGS subtitles which is working fine with XyVSFilter. As I said try to use MKVToolnix to remux the problematic files. If it still has problem , ditch those downloaded files.

Also make sure no stupid setting like "Enable Forced Subtitles only" checked.

Also make sure you run xyVSfilter 32-bit even if you run Windows 64bit.
Reply
What version are you using oldpoem of xyvsfilter?`
Reply
(2015-08-20, 11:29)Bjur Wrote: What version are you using oldpoem of xyvsfilter?`

3.0.0.306 (32 bit)
Reply
Does XyVSFilter render subtitles on black bars (think 2.35:1 movies) with madVR?
For troubleshooting and bug reporting please make sure you read this first.
Reply
  •   
  • 1
  • 76
  • 77
  • 78(current)
  • 79
  • 80
  • 505
  •   
 
Thread Rating:
  • 47 Vote(s) - 4.43 Average



Logout Mark Read Team Forum Stats Members Help
Kodi DSPlayer – DirectShow Player for Windows4.4347