•   
  • 1
  • 24
  • 25
  • 26(current)
  • 27
  • 28
  • 32
  •   
[RELEASE] Amazon Prime Instant Video (US/UK/DE)
this is a repository. have you never installed a repo? please look at xbmc wiki.
Reply
(2015-09-19, 10:41)Ed76 Wrote: this is a repository. have you never installed a repo? please look at xbmc wiki.

Yes I have. The link provided downloads a single file called "addon.xml" with no instructions what it does or where to place it. All other addons I have worked with have information and instructions. I was under the impression these forums were for help with questions and problems.
Reply
(2015-09-19, 15:30)blueribb Wrote:
(2015-09-19, 10:41)Ed76 Wrote: this is a repository. have you never installed a repo? please look at xbmc wiki.

Yes I have. The link provided downloads a single file called "addon.xml" with no instructions what it does or where to place it. All other addons I have worked with have information and instructions. I was under the impression these forums were for help with questions and problems.
Download the .zip, not the addon.xml.
Reply
(2015-09-20, 15:38)locoguano Wrote:
(2015-09-19, 15:30)blueribb Wrote:
(2015-09-19, 10:41)Ed76 Wrote: this is a repository. have you never installed a repo? please look at xbmc wiki.

Yes I have. The link provided downloads a single file called "addon.xml" with no instructions what it does or where to place it. All other addons I have worked with have information and instructions. I was under the impression these forums were for help with questions and problems.
Download the .zip, not the addon.xml.

Thanks. I installed the zip file, Amazon Plugin & chose Browser Launcher. I configured the browser launcher and chose Firefox. I ran the Amazon program, selected a video and it installed & launched the browser and took me to Amazon.de webpage. When exiting Kodi, there was almost a 10-second delay. Before this, it only took a second to exit Kodi.

Is there a way to switch the language to English and be taken to Amazon.com instead of Amazon.de ?
Reply
I spent a couple hours playing with different configurations and settings for the Amazon Plugin and Browser Launcher. None offered me a satisfying experience. Not to mention the 5 to 10 second exit delay caused by the Amazon Plugin. The Amazon Prime Video Addon (when working) was a far better experience. I'm hoping the Amazon Prime Instant Video Addon is back up and running in the future.

Thanks for the help everyone.
Reply
(2015-09-20, 20:55)blueribb Wrote: I'm hoping the Amazon Prime Instant Video Addon is back up and running in the future.

+ 1. Back to HD
Reply
(2015-09-20, 20:55)blueribb Wrote: I spent a couple hours playing with different configurations and settings for the Amazon Plugin and Browser Launcher. None offered me a satisfying experience. Not to mention the 5 to 10 second exit delay caused by the Amazon Plugin. The Amazon Prime Video Addon (when working) was a far better experience. I'm hoping the Amazon Prime Instant Video Addon is back up and running in the future.

Thanks for the help everyone.

Were you able to get amazon.com to work (instead of .de)?
Reply
(2015-09-21, 00:12)locoguano Wrote:
(2015-09-20, 20:55)blueribb Wrote: I spent a couple hours playing with different configurations and settings for the Amazon Plugin and Browser Launcher. None offered me a satisfying experience. Not to mention the 5 to 10 second exit delay caused by the Amazon Plugin. The Amazon Prime Video Addon (when working) was a far better experience. I'm hoping the Amazon Prime Instant Video Addon is back up and running in the future.

Thanks for the help everyone.

Were you able to get amazon.com to work (instead of .de)?

Yes and No. I could not figure out how to launch the browser directly to Amazon.com. I could go there using my mouse since it was just like being on a computer with an open browser window. I had a hard time exiting a couple different browsers since there was no X in the top corner to exit. This was on a Windows 10 computer which I use to test Kodi add-ons before putting them in my Intel NUC with OpenELEC. The text inside Kodi before the browser launch was in a different language on some of the information pages and I didn't see an option for English in any of the settings.
Reply
I installed the repo and amazon prime. But all of the lists are empty, and no browser opens like others discuss in the thread. What am I missing?
Living Room: Ubuntu 16.10 x64 | BayTrail-M SOC | Krypton | Hitachi 55L6 | Yamaha RX-V665 | 7.1 Polk Surround
Den: RetroPie 4.1 | Raspberry Pi 3 | Krypton | VIZIO XVT553SV
Bedroom: OSMC 2017.02-1 | Raspberry Pi 3 | Krypton | VIZIO E370VA
HP Chromebook 14: Ubuntu 16.04 x64 | Celeron 2955U | Jarvis
NAS: Windows 10 | 20TB on DrivePool | Emby DB | Subsonic | Plex
Reply
(2015-09-21, 02:20)VanillaXtract Wrote: I installed the repo and amazon prime. But all of the lists are empty, and no browser opens like others discuss in the thread. What am I missing?

Yes, it's very confusing since there are no step-by-step instructions.

Are you sure you installed the Amazon plugin authored by Sandmann ?

Did you configure it with "Browser Launcher" ?
Reply
I have made the installation mentioned in that post: http://forum.kodi.tv/showthread.php?tid=...pid1993947 and for me it works.
seems that AddonScriptorDE is busy as he is away since long time so probably check out the post and it should be fine.
rebuilding ....
Reply
Anyone actually working on a U.S. solution for Amazon?
Reply
(2015-09-21, 17:03)locoguano Wrote: Anyone actually working on a U.S. solution for Amazon?

Or a UK one?
I can see that the base URL is from common.py file - does it all need recompiling with different addresses? (not alot of knowledge with python)
Reply
I've been tinkering around with the AJAX results from the Amazon.com US pages on XLordKX repo and have found that the results have changed. I made the following modifications to the default.py script that helped me with the issue of only retrieving the Original Series "Casanova" and "Sneaky Pete."

Modify the default.py script as follows:

find "def listMovies(url):"
and replace the code:
Code:
match = re.compile('csrf":"(.+?)"', re.DOTALL).findall(content)
with
Code:
match = re.compile('csrfToken":"(.+?)"', re.DOTALL).findall(content)

Also, find "if match and ">Prime Instant Video<" in entry:"
and replace with:
Code:
if match and ">Prime Video<" in entry:

making these modifications allowed me to view the movies again.

I will continue looking into the code for the TV shows and see if I can get those to come back up as well. I don't think this works for the watchlist or the playlist. I will look into those as well and post back. If someone else could make these modifications and let me know if it worked for them.

Thanks,

lwrcase.
Reply
This worked for me too. I was able to see the list of movies and played a couple. After that, they ALL gave an error message: "Too Many Concurrent Streams". I hope the original author of this add-on continues working on this. HD Audio and Video would be nice too.

Note: This was on a Windows 10 computer and also with OpenELEC.

I figured out how to use SSH and Putty to access and edit the default.py file. Smile
Reply
  •   
  • 1
  • 24
  • 25
  • 26(current)
  • 27
  • 28
  • 32
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Amazon Prime Instant Video (US/UK/DE)6
This forum uses Lukasz Tkacz MyBB addons.