•   
  • 1
  • 85
  • 86
  • 87(current)
  • 88
  • 89
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
(2015-09-22, 13:39)Milhouse Wrote: Debug-enabled #0921x builds uploaded: RPi / RPi2

Edit: @parcel/@Leopold: This bookmark crash definitely starts with #0919, ie. #0918 does not have this problem?

#0918 have problem.
Same bookmark didn't raise problem between different build, #0919 did but didn't in #0920.

http://xbmclogs.com/p8shges10
Is /dev/sda1 being checked because the mount count has been exceeded? You can change that with "tune2fs -c # /dev/sda1", and disable the mount-count check entirely with "tune2fs -c 0 -i 0 /dev/sda1".

You can also completely disable the boot-time fsck by adding "nofsck" to cmdline.txt, although obviously you do this at your own risk etc. etc.

However if /dev/sda1 is being checked because it has errors, you probably need to start a new thread...
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-09-23, 01:40)parcel Wrote: #0918 have problem.
Same bookmark didn't raise problem between different build, #0919 did but didn't in #0920.

http://xbmclogs.com/p8shges10

Yes, it appears to be somewhat random, or at least hard to reproduce. Unfortunately knowing the exact build when this problem started is likely to be the best/quickest way to a solution, so if you're able to go back through the builds that would be great, although it's likely to be a slow process.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-08-21, 06:19)illiac4 Wrote: In this sample file subtitles are shown on wrong side of the screen (left in the middle and not at the bottom) (you have to enable it if they are not shown). I know that in older versions it was playing fine but can not say when.
Using omx player.
File (size 13mb): http://bite-in.com/debug/24Kitchen-HD.ts

From #0917 to the last build, Can't Play this sample ts file normally. The video freezed.
(2015-09-23, 02:37)Milhouse Wrote:
(2015-09-23, 01:40)parcel Wrote: #0918 have problem.
Same bookmark didn't raise problem between different build, #0919 did but didn't in #0920.

http://xbmclogs.com/p8shges10

Yes, it appears to be somewhat random, or at least hard to reproduce. Unfortunately knowing the exact build when this problem started is likely to be the best/quickest way to a solution, so if you're able to go back through the builds that would be great, although it's likely to be a slow process.

Problem appears #0920.
Until #0919, it seem to be ok.
(2015-09-23, 01:18)bagofcrap24 Wrote: OK regarding the previously mentioned issue of live TV getting green pixelated patches and odd graphical glitches like seen in the test video for the other live TV problem.
It appears that is due to running the tvheadend server on the pi2 also.
I've just moved the server to it's own x86 machine and no longer seeing any graphical glitches at all.
Though the image freeze after a few seconds is still present.
I've always run the tvheadend server on a separate Pi and I still get the green pixelated patches. Moving to VDR seems to have helped but it does still occasionally happen.
Could it be an arm issue with tvheadend? I run it on an x86 box and don't have this problem.
(2015-09-23, 01:18)bagofcrap24 Wrote: OK regarding the previously mentioned issue of live TV getting green pixelated patches and odd graphical glitches like seen in the test video for the other live TV problem.
It appears that is due to running the tvheadend server on the pi2 also.
I've just moved the server to it's own x86 machine and no longer seeing any graphical glitches at all.
Though the image freeze after a few seconds is still present.

With tvheadend on the Pi2, does it help if you disable deinterlace (or use bob deinterlace)?
(2015-09-23, 02:47)startv Wrote:
(2015-08-21, 06:19)illiac4 Wrote: In this sample file subtitles are shown on wrong side of the screen (left in the middle and not at the bottom) (you have to enable it if they are not shown). I know that in older versions it was playing fine but can not say when.
Using omx player.
File (size 13mb): http://bite-in.com/debug/24Kitchen-HD.ts

From #0917 to the last build, Can't Play this sample ts file normally. The video freezed.

Thanks. Can reproduce and there will be a (firmware) fix in tonight's build.
(2015-09-23, 01:18)bagofcrap24 Wrote: I've just moved the server to it's own x86 machine and no longer seeing any graphical glitches at all.

I think what really happened is that you relocated the USB receiver dongle from the Pi to another machine, but with a stable USB chipset. Those glitches are imho dropped data on the USB bus. Hence the discontinuity warnings in recorded MPEG transport streams. Not fixable by anyone other than the Pi foundation, because that thing is buried deep. Could be certain USB dongles for live TV only of course. In summary if you want stable live TV and DTS HD MA bitstreaming, you need to switch to x86.
(2015-09-23, 13:16)MarkT Wrote:
(2015-09-23, 01:18)bagofcrap24 Wrote: I've just moved the server to it's own x86 machine and no longer seeing any graphical glitches at all.

I think what really happened is that you relocated the USB receiver dongle from the Pi to another machine, but with a stable USB chipset. Those glitches are imho dropped data on the USB bus. Hence the discontinuity warnings in recorded MPEG transport streams. Not fixable by anyone other than the Pi foundation, because that thing is buried deep. Could be certain USB dongles for live TV only of course. In summary if you want stable live TV and DTS HD MA bitstreaming, you need to switch to x86.

@popcornmix
is that right?
(2015-09-23, 14:19)polo_joe Wrote: @popcornmix
is that right?

I don't believe so. USB DVB are widely used successfully on the Pi.
Of course this may depend on the actual USB DVB device.
I think there is currently an issue with 1080i advanced deinterlace causing packet loss.
Adding " dwc_otg.fiq_fsm_mask=0xF" to cmdline.txt can help with some devices.
(2015-09-21, 21:01)Milhouse Wrote: Wait for a new build, or unzip the add-on at the ssh command line:
Code:
cd /storage/.kodi/addons
rm -fr service.multimedia.vdr-addon
wget http://milhouse.openelec.tv/builds/addons/RPi2/vdr-addon/service.multimedia.vdr-addon-6.0.1.zip -O /tmp/vdr-addon.zip
unzip /tmp/vdr-addon.zip
and restart Kodi after installation.

Are there any good instructions anywhere for setting up VDR on the RPi? I installed the addon as described above and enabled the addons, disabled the tvheadend ones but couldn't get it to work. Do I have to access a GUI through my browser to set it up, like tvheadend, or do it some other way?
Video freezes after 9 seconds with VideoAddons - Audio 4 sec. later on build #922.
Same problem like build befor, but much more and on all Songs.
(2015-09-23, 17:25)doveman2 Wrote:
(2015-09-21, 21:01)Milhouse Wrote: Wait for a new build, or unzip the add-on at the ssh command line:
Code:
cd /storage/.kodi/addons
rm -fr service.multimedia.vdr-addon
wget http://milhouse.openelec.tv/builds/addons/RPi2/vdr-addon/service.multimedia.vdr-addon-6.0.1.zip -O /tmp/vdr-addon.zip
unzip /tmp/vdr-addon.zip
and restart Kodi after installation.

Are there any good instructions anywhere for setting up VDR on the RPi? I installed the addon as described above and enabled the addons, disabled the tvheadend ones but couldn't get it to work. Do I have to access a GUI through my browser to set it up, like tvheadend, or do it some other way?
Please discuss in a seperate thread.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 85
  • 86
  • 87(current)
  • 88
  • 89
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510