•   
  • 1
  • 22
  • 23
  • 24(current)
  • 25
  • 26
  • 270
  •   
Release skin helper service
I expected the answer to be no, and fully agree with the reasons why that would be. (And no, it's not a zip problem - its the extracted folder, due to the way that Mac apps and services essentially are just folders with a particular extension Smile)
Reply
Hi Marcel, I noticed a copy/paste error and submitted a PR but closed it due to it now having conflicts. Can you change the below in libraymonitor:

if data.has_key("rottenCache"):
self.streamdetailsCache = data["rottenCache"]

Cheers
Reply
(2015-09-28, 23:48)im85288 Wrote: Hi Marcel, I noticed a copy/paste error and submitted a PR but closed it due to it now having conflicts. Can you change the below in libraymonitor:

if data.has_key("rottenCache"):
self.streamdetailsCache = data["rottenCache"]
Aha! There you have your answer for the non working cache ;-)
Reply
this is where all begin
https://github.com/marcelveldt/script.sk...bf537623c2
before it was ok

Newest from github doesent fix bug
Edit::

yes I always uninstall script & delete Folder user data\addon_data

I try Newest " disable youtube search for pvrthumbs by default " not fixed too
XBoxMediaCenter (Kodi Leia) 18.0 , LibreElec RasPi3 Libreelec-Leia Skin AeonMQ6
Reply
(2015-09-28, 23:52)Angelinas Wrote: this is where all begin
https://github.com/marcelveldt/script.sk...bf537623c2
before it was ok

Newest from github doesent fix bug

Log please! It's all working OK in 3 of my testsetups so I must see what error there is in your log.
You also might want to try to flush the cache: just delete the folder script.skinhelper.service in the userdata\addon_data directory
Reply
I don have bug just dont work see video

Now is ok -video dellete by me Smile

Same " few more fixes " latest sorry ,tomorow is now for me...bit a litle late ...I know you find the isue....good luck Smile

And tnx for traying to solve this puzzle SmileWink
XBoxMediaCenter (Kodi Leia) 18.0 , LibreElec RasPi3 Libreelec-Leia Skin AeonMQ6
Reply
(2015-09-29, 00:53)Angelinas Wrote: I don have bug just dont work see

No errors in your log ? There might have been some silent errors...

Please take latest git as I made a few changes and wipe the cache files in addon_data. After resetting the cache start Kodi and try again...
Reply
Hi Marcel,

Is it possible there's missing infolabels in your "TV Channel" list in widgets ?
Actually, when I set :

Code:
$INFO[ListItem.StartTime]$INFO[ListItem.EndTime, - ,]

in the itemlayout / focusedlayout, only ListItem.EndTime is showing ? EDIT : Also ListItem.ChannelName returns empty. I can still use ListItem.Label but it then displays something else in case it's not PVR.

EDIT 2 : Ah, got it by looking at the PluginContent.py. Seems it needs to be ListItem.Property(StartTime) and ListItem.Property(ChannelName). Any reason it's not set as li.setInfo like others ? Moreover these properties return time as HH:MM: SS instead of HH:MM AM/PM or HH:MM in 24h format(not sure it's usefull to have the seconds showing).

Also I noticed that using ListItem.Icon returns your generated thumbs which is pretty nice Smile But since I have most of them in cache, is there still needs to use the multiimage control to generate them or is it also generated in background for widget ?

Thanks
[Skin] KOver - V1.1.0 Stable (Repo version)
[WIP] ReKOver - Skinning tool project

If I've been helpful or you like my work, hit "THANK USER" button ;) ...
Reply
ok tested your version and have some progres,maybe you use this way to show thumb...(this is to slow and I was very disappointed in this new showing for thumbs)

PHP Code:
<control type="multiimage">
    <
width>300</width>
    <
height>300</height>
    <
imagepath>plugin://script.skin.helper.service/?action=getthumb&path=$INFO[ListItem.Title] $INFO[ListItem.ChannelName]</imagepath>
    
<aspectratio>keep</aspectratio>
</
control

I use code for images (now is broken)
PHP Code:
        <control type="image">
        <
posx>780</posx>
        <
posy>428</posy>
        <
height>85</height>
        <
texture background="true">$INFO[Window(Home).Property(SkinHelper.PVR.Poster)]</texture>
        <
bordertexture border="-12">musicframe.png</bordertexture>
        <
fadetime>FanartCrossFadeTime</fadetime>
        <
aspectratio>keep</aspectratio>
        <
visible>Control.IsVisible(50)</visible>
        </
control>
        <
control type="image">
        <
posx>1058</posx>
        <
posy>428</posy>
        <
height>85</height>
        <
texture background="true">$INFO[Window(Home).Property(SkinHelper.PVR.Thumb)]</texture>
        <
bordertexture border="-12">musicframe.png</bordertexture>
        <
fadetime>FanartCrossFadeTime</fadetime>
        <
aspectratio>keep</aspectratio>
        <
visible>Control.IsVisible(50)</visible>
        </
control>> 
and for fanart
PHP Code:
        <texture background="true">$INFO[Window(Home).Property(SkinHelper.PVR.Fanart)]</texture

old way doesent work enymore ,I dont have images.(this is faster and much much easyer for coding).For widget and for PVR Windows.
Please find the way to back that code in Action

old way was working for DialogPVRGuideInfo.xml ,PVR and EPG windows,also for Home.xml

(2015-09-29, 21:28)im85288 Wrote: If it helps I'm experiencing exactly the same behaviour as described above in that the get thumb works fine but no PVR skin property's are being populated.
It help me , I thought that this happens only to me ..... I thought I did something wrong . tnx
XBoxMediaCenter (Kodi Leia) 18.0 , LibreElec RasPi3 Libreelec-Leia Skin AeonMQ6
Reply
If it helps I'm experiencing exactly the same behaviour as described above in that the get thumb works fine but no PVR skin property's are being populated.
Reply
This is strange... Works perfectly fine on my testsetup. Hmmm... Just remember I use Isengard for testing... Are you all on Jarvis?
Reply
The background props are way faster than the multiimage approach btw. You can use the multiimage on other places where you need a thumb, in pvr I suggest to use the window props
Reply
I am on Isengard 15.1......
Have you this code for your skin in git hub....for poster ,thumb,fanart in PVR ..just to see how work this in your skin ?
Now download your skin from github and I'm interested to see is this work there [php]$INFO[Window(Home).Property(SkinHelper.PVR.Poster)][/php


Where to enable PVR thumbs Huh
in skin xml ?
I didnt enable ,i see this in readme ,but was working without this.
XBoxMediaCenter (Kodi Leia) 18.0 , LibreElec RasPi3 Libreelec-Leia Skin AeonMQ6
Reply
And you did enable the setting to enable the pvr thumbs? See readme
Reply
I think I forgot to mention that you need to enable the pvr thumbs now in your skin...
Reply
  •   
  • 1
  • 22
  • 23
  • 24(current)
  • 25
  • 26
  • 270
  •   
 
Thread Rating:
  • 18 Vote(s) - 4.56 Average



Logout Mark Read Team Forum Stats Members Help
skin helper service4.5618