Empty EPG / Missing channels
For the last week or so I've had a completely blank EPG. It just says "TV Channels (1) No guide entries". If I select Radio instead of TV though, it shows 28 channels and the programmes. I tried clearing the guide data, clearing all the TV data and even deleting the EPG.db but none of that has helped. The web interface, under Configuration - Channel/EPG shows all the TV and radio channels and the Electronic Programme Guide tab shows the programmes. I've noticed that my tuners (dual DVB-T USB device) keep disappearing from under Configuration - DVB Inputs - TV adapters though. I originally had the tuner plugged into a hub but now have it plugged directly into the RPi v2 and it still keeps happening. I've got max_usb_current=1 set in my config.txt. I've pasted my log here: http://pastebin.com/hSTRedRz

My brother also has a RPi v2 with the same tuner device plugged into the same hub that I have and he isn't having any problems with the tuners disappearing. However, I just set up the channels for him and everything is showing on the RPi EPG except for E4+1. This is mapped and shows under Configuration - Channel/EPG but does not appear under the Electronic Programme Guide tab. His log is here: http://pastebin.com/479iWxbr
Can you enable trace debugging in the addon and provide a new log? Don't play any channel while you have tracing enabled, it will produce an insane amount of log data.
(2015-10-09, 16:02)negge Wrote: Can you enable trace debugging in the addon and provide a new log? Don't play any channel while you have tracing enabled, it will produce an insane amount of log data.

I just discovered the cause of one of my problems was something stupid! The view mode was set to Channel. Not sure why that would only show "TV Channels (1) No guide entries" but after changing it to Timeline it showed what it should. It's not easy to bring up the menu to change this mode, at least with the skin I'm using (AppTV) and my TV's CEC remote, as I have to scroll all the way back to the start of the timeline, which goes right back to about 6am, before it opens. I don't know what just happened but now the EPG only shows the channels, no programmes and even switching to Confluence hasn't helped. The EPG in the web interface is still populated, even though the tuners have disappeared again but maybe this only causes the Kodi EPG to lose the programmes.

With my disappearing tuner problem, that seems to be either a problem with the backend or something in OE itself, as the tuners show up sometimes under TV adapters and then when I check later (normally after I've tried to watch TV and got an error about "no tuners found") they've vanished, so I'm not sure a trace log for the frontend will be much help will it? I tried disabling and re-enabling the backend but that doesn't make the tuners reappear and they don't always reappear after rebooting either, so it seems quite random whether they show up or not. It was working quite stably a couple of weeks ago, so I doubt it's a hardware problem. I was using testbuild #908 but I tried going back to that and it didn't help. I could try build #825 as that's what my brother's running and he doesn't seem to be having this problem with the same hardware but as #908 isn't working for me anymore, I'm sceptical that #825 will be any better.

With my brother's problem of E4+1 not showing up in the EPG, the problem also seems to be in the backend as the channel doesn't show up in the browser interface EPG, not just the OE/Kodi one, despite the service being listed and mapped to a channel, so will the frontend trace be of any use?

Logout Mark Read Team Forum Stats Members Help
Empty EPG / Missing channels0
This forum uses Lukasz Tkacz MyBB addons.