•   
  • 1
  • 41
  • 42
  • 43(current)
  • 44
  • 45
  • 56
  •   
WIP Windows DirectX 11 upgrade test thread
i have deinterlacings bugs @ dx 11 builds Confused

sporadic deinterlacing not active, slight stutter @ 1080p 50p @ Live TV
anybody same bugs ?
Reply
Nobody knows - cause you did neither post your Debug Log, nor did you say anything about your hardware nor the content you are watching.

Here, verify with: http://solidrun.maltegrosse.de/~fritsch/...samples.ts and http://solidrun.maltegrosse.de/~fritsch/..._h264-2.ts and post a Debug Log while playing them.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
gpu am r9 270x , Windows 10 x64, newest catalyst driver , newest kodi dx build 22.10.15 , cpu core i5 sandy bridge , ambibox active for ambilight

well I see it in Formula 1 when I switch to channel the video starts also runs five seconds liquid after 5 secs jerky, it looks the same when deinterlacing has been disabled

2 kodi log files in the zip file kodi.log your ts tests file , kodiformel1.log the formel 1 ts live stream via Mediaportal PVR

http://www.filedropper.com/showdownload.php/log_2

is this the problem ?

00:25:19 T:3316 NOTICE: fps: 0.000000, pwidth: 1920, pheight: 1080, dwidth: 1920, dheight: 1080
00:25:19 T:3316 NOTICE: D3D: rendering method forced to DXVA processor
00:25:19 T:3316 NOTICE: DXVA::CProcessorHD::InitProcessor - Supported deinterlace methods: Blend:no, Bob:yes, Adaptive:yes, MoComp:yes.
00:25:19 T:5884 NOTICE: CDVDPlayerAudio::OutputPacket duplicate 3 packets of duration 32
00:25:19 T:5884 NOTICE: Previous line repeats 1 times.
00:25:19 T:5884 NOTICE: CDVDPlayerAudio::OutputPacket duplicate 2 packets of duration 32
00:25:19 T:5884 NOTICE: CDVDPlayerAudio::OutputPacket skipping a packets of duration 32
00:25:26 T:3316 NOTICE: Previous line repeats 3 times.
00:25:26 T:3316 NOTICE: fps: 25.000000, pwidth: 1920, pheight: 1080, dwidth: 1920, dheight: 1080
Reply
I noticed that the "Picture Slideshow" and "Multi Slideshow" screensave addons dont work with the DX11 based versions of Kodi (15.2 or Alpha 16.0). They just give a blank screen instead of the pictures. Is this something that needs to be fixed in Kodi or in the Addons??
Thanks
Reply
(Using Jarvis alpha 4, Windows 8.1 x64)


I noticed the same thing, the slideshow screensavers don't work. The maintainer of the Picture Slideshow has filed a bug report with corresponding logs etc. so that's that.


Another question concerning screensavers:
On my Windows 8.1 HTPC, the general Windows screensaver gets activated after some inactivity instead of the Kodi screensaver. Is this normal behaviour?

(Because the slideshow screensavers don't work, I have set the Kodi screensaver to Dim. With Isengard the Windows screensaver never activated, instead the Kodi screensaver would start.)



Also, after I press a key to return to the Kodi screen, Kodi crashes. I'll try and make a debug log later tonight.

I'm not sure this should be in the DX11 thread, but somehow I suspect it's involved so I posted it here.
Reply
Ever since upgrading from the latest stable build to Jarvis alpha 4 I've been getting crashes related to the following error: DXGI_ERROR_DEVICE_REMOVED

I'm using Windows 10, and the latest WHQL nvidia drivers.

Debug log: http://www.xbmclogs.com/pafssaaii

I noticed there's a ticket on trac about this error in connection with dvd playback, but I'm having this problem with other content as well, including but not limited to blu-ray remux and content downloaded from Youtube.
Reply
I have a random collection of debug logs as well as dmp and stacktrace files from recent Jarvis nightlies including 20151108-6c008a3. I have no idea if all are related to DX 11 but I believe at least some are. Maybe they can help or they can be passed along to anyone who may find them useful.

Not really much to describe as a crash can happen browsing the library or rewinding and pressing play or after being paused for a little bit and continuing playback, in other words pretty random so I cannot be more specific. Some of the logs also contain the error mentioned in the post above.

Link to the logs
Reply
@edrikk, @Jayz2K
Please try to reproduce issues with latest nightly.

@F_B_W
Sure, a PR is wellcome!
Reply
(2015-11-01, 01:17)R3N3 Wrote: http://www.filedropper.com/showdownload.php/log_2
where a Debug Log is?

(2015-11-01, 18:20)i0zjh02 Wrote: I noticed that the "Picture Slideshow" and "Multi Slideshow" screensave addons dont work with the DX11 based versions of Kodi (15.2 or Alpha 16.0). They just give a blank screen instead of the pictures. Is this something that needs to be fixed in Kodi or in the Addons??
Thanks
Both of them are python based addons and should works as expected. If the doesn't work it's a not DX related issue. In any case I'll check whats wrong.

(2015-11-04, 14:25)willemd Wrote: Another question concerning screensavers:
On my Windows 8.1 HTPC, the general Windows screensaver gets activated after some inactivity instead of the Kodi screensaver. Is this normal behaviour?

(Because the slideshow screensavers don't work, I have set the Kodi screensaver to Dim. With Isengard the Windows screensaver never activated, instead the Kodi screensaver would start.)



Also, after I press a key to return to the Kodi screen, Kodi crashes. I'll try and make a debug log later tonight.

I'm not sure this should be in the DX11 thread, but somehow I suspect it's involved so I posted it here.
Activating system screensaver is normal behavior.Just disable system screensaver.
Did you make a Debug Log?

(2015-11-07, 05:12)sialivi Wrote: Ever since upgrading from the latest stable build to Jarvis alpha 4 I've been getting crashes related to the following error: DXGI_ERROR_DEVICE_REMOVED

I'm using Windows 10, and the latest WHQL nvidia drivers.

Debug log: http://www.xbmclogs.com/pafssaaii

I noticed there's a ticket on trac about this error in connection with dvd playback, but I'm having this problem with other content as well, including but not limited to blu-ray remux and content downloaded from Youtube.
Please upload your Debug Log again to pastebin.com. Your link was expired. Also please describe steps to reproduce an issue.

(2015-11-10, 10:41)mikesilvo164 Wrote: I have a random collection of debug logs as well as dmp and stacktrace files from recent Jarvis nightlies including 20151108-6c008a3. I have no idea if all are related to DX 11 but I believe at least some are. Maybe they can help or they can be passed along to anyone who may find them useful.

Not really much to describe as a crash can happen browsing the library or rewinding and pressing play or after being paused for a little bit and continuing playback, in other words pretty random so I cannot be more specific. Some of the logs also contain the error mentioned in the post above.

Link to the logs
Thanks. I'll take a look when I have time enough.
Reply
Small update to the prev message.
Python screensavers should work perfectly in the latest nightly http://trac.kodi.tv/ticket/16361
Reply
Not being able to download, 404 page not found.
Reply
(2015-11-11, 17:17)afedchin Wrote:
(2015-11-07, 05:12)sialivi Wrote: Ever since upgrading from the latest stable build to Jarvis alpha 4 I've been getting crashes related to the following error: DXGI_ERROR_DEVICE_REMOVED

I'm using Windows 10, and the latest WHQL nvidia drivers.

Debug log: http://www.xbmclogs.com/pafssaaii

I noticed there's a ticket on trac about this error in connection with dvd playback, but I'm having this problem with other content as well, including but not limited to blu-ray remux and content downloaded from Youtube.
Please upload your Debug Log again to pastebin.com. Your link was expired. Also please describe steps to reproduce an issue.

New log: http://pastebin.com/FSyWgs23 (I've truncated the log, because it was several mb in size due to being stuck in a loop, complete log can be downloaded below)
Crash dump and complete log: https://dl.dropboxusercontent.com/u/4172...EMOVED.rar

Steps to reproduce the issue is a bit of a problem cause I'm not really seeing a pattern yet, it seems random. Sometimes I can play an entire file without crashing, other times the same file will result in a crash, a 3rd time the same file might crash in a completely different part of the video.

I simply start playing a video file (the format doesn't seem to make a difference), and randomly the screen goes black (this is when the DXGI_ERROR_DEVICE_REMOVED error occurs) and only the audio keeps playing. At this point 1 of 3 things happen when I try to stop the playback:

1) The playback stops, but the Kodi UI is now only partially working, most images are not shown
2) The application shuts down and an error message pops up, "ERROR: Exception caught on main loop. Exiting"
3) The application is unresponsive, and the log file starts growing very fast, clearly stuck in a loop
Reply
Anyone has a working download link? The official is now 404.
A Confluence ZEITGEIST (Modernized Confluence Skin)
Reply
you can also grab a nightly build of upcoming v16 to test DirectX11
Reply
Thanks for the hint. But i want to use it to test an 15.2 Isengard Skin.
A Confluence ZEITGEIST (Modernized Confluence Skin)
Reply
  •   
  • 1
  • 41
  • 42
  • 43(current)
  • 44
  • 45
  • 56
  •   
 
Thread Rating:
  • 6 Vote(s) - 3.5 Average



Logout Mark Read Team Forum Stats Members Help
Windows DirectX 11 upgrade test thread3.56