• 1
  • 52
  • 53
  • 54(current)
  • 55
  • 56
  • 57
XBMC Video Server: stream/download your library contents
Thank you, I wasn't sure it was just me or if it was actually a prblem. Just tried it out and it works now.
Reply
I was wondering if having the server setup on a more powerful computer would make a difference as far as streaming from outside the network even without transcoding. I currently have the server set up on a lil zotac AQ-01 quad core A4-5000 processor with an integrated HD 8330 gpu. Would switching the server to my gaming PC with an FX-8350 8 core CPU / R9 290X GPU / 16GB 1866MHz Ram computer make any difference? I think my real problem is TWC in my area only offers a max upload speeds of around 5mbps. I currently have 37 mbps download / 7 mbps upload.
Reply
Streaming uses close to zero resources, it's all about bandwidth.
Reply
Hi

I am very new to all this Kodi and such (just this week) and after spending a day I got everything figured out and working.

I can go to another family members house and play videos. My question is this...

Why do they not have a link to play in XBMC like I do in the watch/download? I know they have installed Kodi on their machine too after I told them about it. Is there a way to put a link in?

If not I guess I'll have them download VLC or something (unless anyone can recommend a better/different player?) But we both like kodi and want to start using it more.

Thank you for your hard work and time on this great project.

P.S. Are you talking donations?
Reply
The "Play in XBMC" button plays the media on the backend itself so if you press that while you're at a friend's house it will start playing at home. At the moment I can't really think of another solution than playing with VLC, that's what this application has been designed for initially.

I don't take personal donations, if you're feeling generous please donate to Kodi directly instead.
Reply
I was wondering if someone could help me with VLC as its never been a player I have used. When I go to play video at a friends house it skips all over the place. I have watched a lot of videos on increasing the buffer and such but most of then seem out dated.

Also when I try to restart the stream and try to go to the point were the skipping started... Its even worse... It seems it only likes to watch from the beginning again and hope it does not start to stutter again.

And with all the options VLC has am not sure what ones to touch.. We are running VLC 2.2.1

Thank you for your time
Reply
(2015-11-13, 09:50)ZennMystic Wrote: Hi

I am very new to all this Kodi and such (just this week) and after spending a day I got everything figured out and working.

I can go to another family members house and play videos. My question is this...

Why do they not have a link to play in XBMC like I do in the watch/download? I know they have installed Kodi on their machine too after I told them about it. Is there a way to put a link in?

If not I guess I'll have them download VLC or something (unless anyone can recommend a better/different player?) But we both like kodi and want to start using it more.

Thank you for your hard work and time on this great project.

P.S. Are you talking donations?

I am not sure from you post wot ur trying to achieve by "play in xbmc"
Could you elaborate a bit?
Reply
Negge answered my question about the kodi player I thought? In that the kodi player link only plays the video on the host machine.

Yes the problem I having having is in playing the video like in VLC it skips a lot.... A LOT!! I am looking for ways to play back the stream as smooth as possible. I've never used VLC till now and there seems to be a lot of options/switches.
Reply
If the stream lags it's usually a) your upstream bandwidth is too low or b) you're trying to play AVI files. Do any of those sound familiar?
Reply
Yes is was an AVI file....
Reply
Hi negge,

Since the last Update, the time to open the home page of the movies is really faster, thanks ! but when i want to open the page of one movie it takes a long time (something about ~ 30 seconds). is it normal ? (i have Cache all API results checked).


Also, can we have two new features :
- can we let the users choose their home page ? (recently added for example).
- can you made a link of the Director in the page of a movie ?

thanks.
Reply
It definitely shouldn't take 30 seconds. Do you get anything in the log at all when it takes that long?

ubik Wrote:Also, can we have two new features :
- can we let the users choose their home page ? (recently added for example).
- can you made a link of the Director in the page of a movie ?

I'll look into these, both should be very easy to implement.
Reply
Thanks for the new features !


My xbmc-video-server running on a raspbian (raspberry pi 2+ arm frequence overclocked -> 1000 gpu mem -> 256)
My movies are on a NAS linked by reverse proxy.
For my timeout problem on a movie page, here is the logs :


My apache errog.log :
Code:
[Sat Nov 21 17:04:07 2015] [error] [client 192.168.1.1] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in /var/www/xbmc-video-server/src/protected/models/VideoLibrary.php on line 74, referer: http://xx.xx.xx.xx/xbmc-video-server/src/

The controller's fonction in VideoLibrary.php :
Code:
    /**
     * Returns a list of all actors.
     * @param string $mediaType the media type to fetch actors for (movies or
     * TV shows)
     * @return Actor[] the actors
     */
    public static function getActors($mediaType)
    {
        // Fetch the list of all works
        $works = array();
        
        if ($mediaType === Actor::MEDIA_TYPE_MOVIE)
            $works = VideoLibrary::getMovies(array('properties'=>array('cast')));
        elseif ($mediaType === Actor::MEDIA_TYPE_TVSHOW)
            $works = VideoLibrary::getTVShows(array('properties'=>array('cast')));

        // Build a list of all unique actors
        $actors = array();

        foreach ($works as $work)
#line 74 >>            $actors = array_merge($actors, $work->cast);

        // array_unique compares by string
        return array_unique($actors);
    }



The apache access.log :
Code:
"
192.168.1.1 - - [21/Nov/2015:17:03:37 +0100] "GET /xbmc-video-server/src/typeahead/getMovieNames HTTP/1.1" 200 665370 "http://77.133.243.149:5050/xbmc-video-server/src/" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36"
192.168.1.1 - - [21/Nov/2015:17:03:53 +0100] "-" 408 0 "-" "-"
192.168.1.1 - - [21/Nov/2015:17:03:53 +0100] "-" 408 0 "-" "-"
192.168.1.1 - - [21/Nov/2015:17:03:53 +0100] "-" 408 0 "-" "-"
192.168.1.1 - - [21/Nov/2015:17:03:53 +0100] "-" 408 0 "-" "-"
192.168.1.1 - - [21/Nov/2015:17:03:37 +0100] "GET /xbmc-video-server/src/typeahead/getActorNames?mediaType=movie HTTP/1.1" 500 410 "http://77.133.243.149:5050/xbmc-video-server/src/" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36"
192.168.1.1 - - [21/Nov/2015:17:03:39 +0100] "GET /xbmc-video-server/src/movie/details/1003 HTTP/1.1" 200 4400 "http://77.133.243.149:5050/xbmc-video-server/src/" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36"
192.168.1.1 - - [21/Nov/2015:17:04:08 +0100] "GET /xbmc-video-server/src/images/image-cache/088ccdeef042544ffa66bbb82d59de7e_434.jpg HTTP/1.1" 200 59006 "http://77.133.243.149:5050/xbmc-video-server/src/movie/details/1003" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36"
192.168.1.1 - - [21/Nov/2015:17:04:08 +0100] "GET /xbmc-video-server/src/images/xbmc-media-flags/50px-720.png HTTP/1.1" 200 2395 "http://77.133.243.149:5050/xbmc-video-server/src/movie/details/1003" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36"
192.168.1.1 - - [21/Nov/2015:17:04:08 +0100] "GET /xbmc-video-server/src/images/xbmc-media-flags/80px-Ac3.png HTTP/1.1" 200 3688 "http://77.133.243.149:5050/xbmc-video-server/src/movie/details/1003" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36"
192.168.1.1 - - [21/Nov/2015:17:04:08 +0100] "GET /xbmc-video-server/src/images/xbmc-media-flags/50px-6.png HTTP/1.1" 200 1882 "http://77.133.243.149:5050/xbmc-video-server/src/movie/details/1003" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36"
192.168.1.1 - - [21/Nov/2015:17:04:08 +0100] "GET /xbmc-video-server/src/images/placeholder-actor.jpg HTTP/1.1" 200 17189 "http://77.133.243.149:5050/xbmc-video-server/src/movie/details/1003" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36"
192.168.1.1 - - [21/Nov/2015:17:04:08 +0100] "GET /xbmc-video-server/src/images/image-cache/71f437156f3c13f2ed5181a5a9adb0da_160.jpg HTTP/1.1" 200 7745 "http://77.133.243.149:5050/xbmc-video-server/src/movie/details/1003" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36"
192.168.1.1 - - [21/Nov/2015:17:04:08 +0100] "GET /xbmc-video-server/src/images/image-cache/c7be68cdf345e60e1a598b4bbf7fe5bc_160.jpg HTTP/1.1" 200 7422 "http://77.133.243.149:5050/xbmc-video-server/src/movie/details/1003" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36"
192.168.1.1 - - [21/Nov/2015:17:04:08 +0100] "GET /xbmc-video-server/src/images/image-cache/977e6d5733d15a981663faab2057ae00_160.jpg HTTP/1.1" 200 5809 "http://77.133.243.149:5050/xbmc-video-server/src/movie/details/1003" "Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.71 Safari/537.36"
127.0.0.1 - - [21/Nov/2015:17:04:16 +0100] "OPTIONS * HTTP/1.0" 200 126 "-" "Apache/2.2.22 (Debian) (internal dummy connection)"

The 408 apache's error seems to be guilty.
Maybe the "Internal dummy conenction" too ?

My /xbmc-video-server/src/images/image-cache/ contains more than 2000 png.
It sounds very long to browse them all.
Maybe a different folder for actors, movies, tvshows can reduce the browsing access ?



EDIT : to temporarly solve my problem, i've reduce the "Request timeout" from 30 to 3 seconds.
Every movie appear quickly now. But i presume the problem is still here.
Reply
It's the retrieving of the actors that takes forever. That's why it's done asynchronously when you load the movie browse page. It shouldn't load it at all if you click on a movie. Can you try refreshing the details page of a movie a few times and see if it's that slow every time?
Reply
I guess I should just add a setting to disable actor typeahead functionality, it takes a long time even on a fast computer and it's not really necessary for the application to function properly (you can still search for actors even if suggestions are disabled).
Reply
  • 1
  • 52
  • 53
  • 54(current)
  • 55
  • 56
  • 57

Logout Mark Read Team Forum Stats Members Help
XBMC Video Server: stream/download your library contents9
This forum uses Lukasz Tkacz MyBB addons.