•   
  • 1
  • 37
  • 38
  • 39(current)
  • 40
  • 41
  • 75
  •   
Release Picture Slideshow Screensaver
(2015-11-16, 01:06)DJ_Izumi Wrote: I have a small feature request, but I wonder if it's behind the technical feature set of Kodi so it couldn't happen even if there was dev interest, but anyway. When an image that is much taller or wider than the screen is displayed, it's stretched out and dimmed in the background a second time to avoid black space, would it also be possible to apply a blur effect to background version? However, I've never seen any part of the Kodi interface feature a blur, so I wonder if it's not technically possible.

nope blurring images is not possible in kodi.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
(2015-11-16, 01:21)ronie Wrote: nope blurring images is not possible in kodi.

I had a feeling. Oh well.
Reply
despite being set to random, this is currently only going in order for my fanart. I've tried turning off random, closing out and going back in to set random again, but I'm just getting 100% reverse alphabetical order of my fanart for the screensaver. This wasn't the case even a couple weeks ago so I'm not sure if something was updated on the screensaver that broke it, or if it's my build of jarvis (beta2) or if it has anything to do with that I'm using Emby as a backend if something was updated on that end. Has anyone else experienced this or have any tips to get random back? I'm a bit tired of seeing zoolander, zombieland, etc. in the same order each time the screensaver comes up. Also makes "guess that movie" idle game much less interesting since we're pretty much certain what the first letter is at least
Reply
(2015-11-27, 17:56)lazyboy0172 Wrote: despite being set to random, this is currently only going in order for my fanart. I've tried turning off random, closing out and going back in to set random again, but I'm just getting 100% reverse alphabetical order of my fanart for the screensaver.

thanx, i think i've found the bug that could be causing this.
i've pushed v3.0.2 of the screensaver to the addon repo, you should get an update within the next day or so.
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
Love this screensaver that shows my photos randomized.
Sometimes I just get a black screen for one or more photos in a row. I see then the date and tags but no photo(s). After that period photos are being displayed as expected again.

What could be causing this?

Thanks.
Reply
I see this regularly too, the sporadic black screens with dates etc.
Addons I wrote &/or maintain:
OzWeather (Australian BOM weather) | Check Previous Episode | Playback Resumer | Unpause Jumpback | XSqueezeDisplay | (Legacy - XSqueeze & XZen)
Sorry, no help w/out a *full debug log*.
Reply
no idea, haven't seen this myself.

if you can reproduce it easily, a Debug Log would be appreciated
and perhaps a copy of the pictures that have this problem (in case it's always the same pictures).
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
(2015-12-04, 13:20)ronie Wrote: no idea, haven't seen this myself.

if you can reproduce it easily, a Debug Log would be appreciated
and perhaps a copy of the pictures that have this problem (in case it's always the same pictures).
Will post both later today when I get home.
Reply
(2013-02-01, 20:17)Unik Wrote: I have this addon installed and able to choose folder mode and to select my pictures folder (which is located on a network drive), but it is still shows video fanart data.

Hello I am seeing this "old" behavior but only on one of my systems: manually starting the slideshow from "Pictures/Options works"
* Desktop Gentoo Linux Kodi 15.2 - no issue
* rpi1 osmc (uptodate) Kodi 15.2 - this issue (from time to time)
* rpi2 osmc (uptodate) Kodi 15.2 - this issue (almost always)


Running Picture Slideshow Screensaver 2.19 on all 3 systems
Pictures are on my NAS and available through NFS,
* Desktop mounts NFS shares to local FS and then I chose the folder locally
* rpi 1 and rpi 2 directly use NFS share from within Kodi to access pictures (I. not not mounted locally on the rpis)



There is no info in the logs, but I'm willing to test things.

Regards,
Reply
does your nas spin down the drives (put them to sleep) after some period of inactivity?
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
Yes Caviar Red Drives that can be spinned down... But NFS mount on the desktop has never lead to such an issue... (only installed the 2 rpis in the past 3 weeks, have had the desktop and NAS for the past year and a half)

But after checking setup, hdd hibernation is not activated. Though sometimes desktop does wait a little while accessing the drives for the first time in a while
Reply
can you reproduce the issue on your pri2 (which almost always has the problem),
by first manually starting the slideshow (from picture > options), so we can be sure the nas driver are spinned up
and then start the picture screensaver?
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
Log output below doing what I understood you asked for:

1) Navigate to Pictures and manually start recursive slideshow
There are error messages in the logs during the slideshow, but the slideshow works just fine visually.
Code:
17:17:10 72136.578125 T:1417671712  NOTICE: Thread BackgroundLoader start, auto delete: false
17:17:28 72154.062500 T:1417671712  NOTICE: Previous line repeats 1 times.
17:17:28 72154.062500 T:1417671712  NOTICE: Thread BgPicLoader start, auto delete: false
17:17:28 72154.429688 T:1885336608   ERROR: COMXCoreComponent::DecoderEventHandler OMX.broadcom.image_decode - OMX_ErrorStreamCorrupt, Bitstream corrupt
17:17:30 72156.429688 T:1417671712   ERROR: COMXCoreComponent::WaitForOutputDone OMX.broadcom.egl_render wait event timeout
17:17:30 72156.429688 T:1417671712   ERROR: COMXTexture::Decode m_omx_egl_render.WaitForOutputDone result(0x80001011)
17:17:30 72156.429688 T:1417671712  NOTICE: DecodeJpegToTexture: unable to decode to texture nfs://192.168.1.5/volume1/media/Photos/XBMC/ALL/2011/Ete/IMAG0343.jpg 1804x1080
17:17:30 72156.429688 T:1417671712   ERROR: COMXCoreComponent::WaitForCommand - OMX.broadcom.image_decode failed with omx_err(0x8000100b)
17:17:32 72158.468750 T:1417671712   ERROR: COMXCoreComponent::WaitForCommand OMX.broadcom.egl_render wait timeout event.eEvent 0x00000000 event.command 0x00000000 event.nData2 2
17:17:32 72158.468750 T:1417671712   ERROR: COMXCoreComponent::WaitForCommand - OMX.broadcom.egl_render failed with omx_err(0x80001011)
17:17:43 72169.390625 T:1885336608   ERROR: COMXCoreComponent::DecoderEventHandler OMX.broadcom.image_decode - OMX_ErrorStreamCorrupt, Bitstream corrupt
17:17:43 72169.398438 T:1417671712   ERROR: COMXCoreTunel::Deestablish - Error WaitForCommand port 60 on component
OMX.broadcom.image_decode omx_err(0x8000100b)<

2) Manually stop manually started slideshow (hit OK button on the remote)
Code:
17:18:03 72189.109375 T:1417671712  NOTICE: Thread BackgroundLoader start, auto delete: false

3) Do nothing for a minute (time for screen svare to start)

4) Watch screensaver start and show video fanart instead of Pictures...
Code:
17:19:03 72249.312500 T:1417671712  NOTICE: Thread LanguageInvoker start, auto delete: false
17:19:04 72249.867188 T:1417671712  NOTICE: -->Python Interpreter Initialized<--
17:19:08 72253.703125 T:1254876192  NOTICE: Thread JobWorker start, auto delete: true
Reply
(2015-12-04, 13:57)heula Wrote:
(2015-12-04, 13:20)ronie Wrote: no idea, haven't seen this myself.

if you can reproduce it easily, a Debug Log would be appreciated
and perhaps a copy of the pictures that have this problem (in case it's always the same pictures).
Will post both later today when I get home.
I did not have the issue anymore so if it stays that way it's good but when it happens again I will report back here.
Reply
ronie, is it possible to add support for file deletion to this slideshow screensaver like you did it in this post?
Reply
  •   
  • 1
  • 37
  • 38
  • 39(current)
  • 40
  • 41
  • 75
  •   



Logout Mark Read Team Forum Stats Members Help
Picture Slideshow Screensaver4
This forum uses Lukasz Tkacz MyBB addons.