20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

  •   
  • 1
  • 161
  • 162
  • 163(current)
  • 164
  • 165
  • 168
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)
(2015-12-07, 16:56)gendo Wrote: no output..

So is there any way of checking if the autostart.sh script has run? Should it show up in the kodi.log?
(2015-12-08, 08:57)doveman2 Wrote:
(2015-12-07, 16:56)gendo Wrote: no output..

So is there any way of checking if the autostart.sh script has run? Should it show up in the kodi.log?

journalctl --no-pager | grep autostart
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Why are no further builds for 16 released as Kodi 16 is still in beta?
These are (were) builds of Kodi *master*, and master is now Kodi 17.0 alpha 1. These builds continue in a new thread.

I'm not planning on producing any releases based on the Kodi 16/Jarvis branch. The OpenELEC 7.0 beta cycle should be kicking in right about now, which is what you should be testing if you want Kodi 16.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I understand there won't be any updates to v16, but are the advanced deinterlacing features available here in these builds included in OE v7 versions?
HTPC 1: ASRock N3150DC-ITX, 8GB DDR3L, 64GB SSD, Ubuntu Server 16.04 LTS + Kodi v17 EGL
HTPC 2: RPi2 + HiFiBerry DIGI+, LibreElec
(2015-12-09, 16:45)gurabli Wrote: I understand there won't be any updates to v16, but are the advanced deinterlacing features available here in these builds included in OE v7 versions?

Advanced deinterlace is in stable OE 6.0 (and Milhouse Kodi 16.0 and Milhouse Kodi 17.0 builds).
Does Openelec 7 include 3D iso support as well?
(2015-12-09, 17:22)Caramba69 Wrote: Does Openelec 7 include 3D iso support as well?

All Milhouse builds do. Not in stable builds.
(2015-12-08, 13:09)Milhouse Wrote: journalctl --no-pager | grep autostart

Thanks. If I try that without doing anything else after rebooting (even re-running the command several times after waiting) I get nothing but if I do "sh .config/autostart.sh" and try again I get

OpenELEC:~/.config # journalctl --no-pager | grep autostart
: not found.config # autostart.sh: line 4:
is not currently loaded_usb_af9035

so it seems it's not running automatically on boot for some reason. I'm don't know why it's returning "is not currently loaded" now, when the tuner is shown properly in dmesg before running autostart.sh and before when I ran rmmod dvb_usb_af9035 it returned "module in use" and modprobe dvb_usb_af9035 gave no output, both of which gendo confirmed as correct.
autostart.sh always runs - if your isn't doing what you expect it's almost certainly not because it isn't running, but an error in the script.

Add some "echo" statements to autostart.sh and you should see them appear in journalctl.

Check the status of the autostart service with "systemctl status kodi-autostart".
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Hi, I think I'm in the right place ! Just installed the latest version via Leopold dev add-on and all is good on the system, the GUI is so smooth and responsive its like coming from pi to pi2 all over again Wink I have no playback issues or anything but what I am having issues with and unable to find any reports on is CEC. All versions upto Jarvis have worked perfect with my Samsung remote via CEC but after initial install of Jarvis it just won't work.
I install Jarvis and CEC remote works,so I set everything up and then after a reboot my CEC remote becomes...... Unresponsive only when I hard reset will CEC return. Has anyone had similar issue ?

Regards.
(2015-12-09, 18:01)Milhouse Wrote: autostart.sh always runs - if your isn't doing what you expect it's almost certainly not because it isn't running, but an error in the script.

Add some "echo" statements to autostart.sh and you should see them appear in journalctl.

Check the status of the autostart service with "systemctl status kodi-autostart".

So with autostart.sh as

#! /bin/sh
(sleep 10;
rmmod dvb_usb_af9035
modprobe dvb_usb_af9035) &

"systemctl status kodi-autostart" gives:

â kodi-autostart.service - Kodi user autostart script
Loaded: loaded (/usr/lib/systemd/system/kodi-autostart.service; disabled; vendor preset: enabled)
Active: active (exited) since Thu 1970-01-01 01:00:04 BST; 45 years 11 months ago
Process: 371 ExecStart=/bin/sh -c . /etc/profile; exec /bin/sh /storage/.config/autostart.sh (code=exited, status=0/SUCCESS)
Main PID: 371 (code=exited, status=0/SUCCESS)
CGroup: /system.slice/kodi-autostart.service

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

If I add a couple of echo commands like so:

#! /bin/sh
(sleep 10;
echo rmmod
rmmod dvb_usb_af9035
echo modprobe
modprobe dvb_usb_af9035) &

it gives

â kodi-autostart.service - Kodi user autostart script
Loaded: loaded (/usr/lib/systemd/system/kodi-autostart.service; disabled; vendor preset: enabled)
Active: active (exited) since Thu 1970-01-01 01:00:04 BST; 45 years 11 months ago
Process: 371 ExecStart=/bin/sh -c . /etc/profile; exec /bin/sh /storage/.config/autostart.sh (code=exited, status=0/SUCCESS)
Main PID: 371 (code=exited, status=0/SUCCESS)
CGroup: /system.slice/kodi-autostart.service

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

If I "sh .config/autostart.sh" I get:

: not found# .config/autostart.sh: line 6:
rmmod
is not currently loaded_usb_af9035
modprobe

and the cmdline prompt only re-appears when I press enter.
doveman output of lsmod please..
(2015-12-10, 14:12)doveman2 Wrote: #! /bin/sh

There should be no space between ! and /

(2015-12-10, 14:12)doveman2 Wrote: : not found# .config/autostart.sh: line 6:

Save the autostart.sh file in Unix format - don't save it with Windows line endings. Use an editor like Notepad++ or TextPad that understand Unix line endings. Or use vi or nano to create the file in ssh on the Pi itself.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-12-10, 14:17)gendo Wrote: doveman output of lsmod please..

Module Size Used by
rc_it913x_v1 1065 0
it913x 3720 2
regmap_i2c 2753 1 it913x
af9033 26349 2
8021q 15840 0
dvb_usb_af9035 15956 2
dvb_usb_v2 12163 1 dvb_usb_af9035
dvb_core 75397 1 dvb_usb_v2
rc_core 14676 4 rc_it913x_v1,dvb_usb_v2,dvb_usb_af9035
bcm2835_wdt 2713 0
bcm2835_gpiomem 2652 0
  •   
  • 1
  • 161
  • 162
  • 163(current)
  • 164
  • 165
  • 168
  •   
  Thread Closed
 
Thread Rating:
  • 10 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 16.0)510