•   
  • 1
  • 36
  • 37
  • 38(current)
  • 39
  • 40
  • 81
  •   
Release Experimental Google Music Addon
Could you please check if the songs missing have a different genre.
Reply
I've installed the addon, added the login credentials and set my google account to allow "less secure" apps. The addon launches no problem, I'm able to browse the stations, but when I pick a station and empty list is brought up so I can't play the station.

I currently us the Google Play Music app on my iphone and ipad as well as using the website on my PC. All work no problem. I'm using the free account (no paid subscription)...is that possibly the problem?
Reply
(2015-12-11, 03:55)foreverguest Wrote: Could you please check if the songs missing have a different genre.
Hi, sorry for the late reply, first chance to check it out. Hope I can help give you some debugging clues (I know it ain't easy!):

First off, as I view Artists in both Google Music EXP (GME) and in my play.google.com (GP) on my laptop, I note that it looks like a number of artists aren't showing up in the Kodi addon. However, these seem to be situations where the artist is on one song of a compilation album. These albums don't have an "album artist" tag. So, GME isn't showing them the same way

Looking deeper at this particular example, I have 2 disks in a set, each with 12 or more tracks. They are showing up in GP. However, only 3 of those songs are showing up at all in GME -- 1 from disk 1 and 2 from disk 2. I don't see anything different about genre or any tag info that would make these tracks special.

So, looks like the GME library is still just picking up a subset of what's in my gmusic. I don't see an obvious pattern -- feels like a random subset of the full library.

Is there anything you'd like me to do with the app settings, or is there any log you'd like me to share?

Not much info, but hope it helps. Cheers, Dennis
Reply
I can play all the songs I've purchased in my library ok. However, none of the free stations play. Is it normal?
I have a free account and I am on Jarvis beta 4
Reply
(2015-12-20, 03:51)eribs4e Wrote: but when I pick a station and empty list is brought up so I can't play the station.

Same issue. Sad
I added a couple of stations to My Library, then I updated library using pop-up menu, saw message "library update", opened a station... but list is still empty.
Could anybody please help with it?

Thank you!
Reply
(2015-12-23, 20:55)Metra Wrote:
(2015-12-20, 03:51)eribs4e Wrote: but when I pick a station and empty list is brought up so I can't play the station.

Same issue. Sad
I added a couple of stations to My Library, then I updated library using pop-up menu, saw message "library update", opened a station... but list is still empty.
Could anybody please help with it?

Thank you!

My issue (as mentioned just above the post) is slightly different. I went to browse the stations, the stations show up, the songs show up, but when I tried playing any of the songs from any of the stations, it refuses to play.

I have a free account and I am on Jarvis beta 4. Playing songs I've purchased works perfectly fine though.
Reply
springroll,
sorry, I concluded that issue is the same because you mentioned you see an empty list inside a station...

Now you see songs inside stations, right? Was it from the beginning, or you fixed it somehow?
Reply
Could you please check for any errors in kodi.log.
Reply
Hi! Thank you for your help!

I have a lot of such regular lines as:
Code:
10:40:07 T:139755685672704  NOTICE: [GoogleMusicEXP-1.6]  ARGV: ['plugin://plugin.audio.googlemusic.exp/', '26', '?path=playlists&playlist_type=radio']
10:40:07 T:139755685672704  NOTICE: [GoogleMusicEXP-1.6] PATH: playlists
10:40:07 T:139755685672704  NOTICE: [GoogleMusicEXP-1.6] Getting playlists of type: radio
10:40:08 T:139755685672704  NOTICE: [GoogleMusicEXP-1.6] Loading auth from cache

+ error-related lines a couple of times like:

Code:
10:40:58 T:139755031041792  NOTICE: [GoogleMusicEXP-1.6] *** NO TRACKS *** CallFailure('400 Client Error: Bad Request for url: https://mclients.googleapis.com/sj/v2.0w/radio/stationfeed?alt=json&include-tracks=true\n(requests kwargs: {\'url\': \'https://mclients.googleapis.com/sj/v2.0w/radio/stationfeed\', \'headers\': {\'Content-Type\': \'application/json\', \'Authorization\': \'<omitted>\'}, \'data\': \'{"contentFilter": 1, "stations": [{"numEntries": 100, "recentlyPlayed": [], "radioId": "0e118292-50ab-392a-a6cf-884bf824d08e"}]}\', \'method\': \'POST\', \'params\': {\'alt\': \'json\', \'include-tracks\': \'true\'}})\n(response was: \'{\\n "error": {\\n  "errors": [\\n   {\\n    "domain": "global",\\n    "reason": "badRequest",\\n    "message": "Bad Request"\\n   }\\n  ],\\n  "code": 400,\\n  "message": "Bad Request"\\n }\\n}\\n\')',)
Code:
10:45:07 T:139755685672704  NOTICE: [GoogleMusicEXP-1.6] Loading auth from cache
10:45:08 T:139755774297856 WARNING: CPythonInvoker(66, /home/kodi/.kodi/addons/plugin.audio.googlemusic.exp/default.py): the python script "/home/kodi/.kodi/addons/plugin.audio.googlemusic.exp/default.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon9xbmcaddon5AddonE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE,N9XBMCAddon7xbmcgui8ListItemE

I see lists of stations in general categories, but I don't see songs inside them and I don't see my saved stations as well. I have 2-step verification and logged in using application-specific password.
Reply
(2015-12-23, 22:35)Metra Wrote: springroll,
sorry, I concluded that issue is the same because you mentioned you see an empty list inside a station...

Now you see songs inside stations, right? Was it from the beginning, or you fixed it somehow?

I've always been able to see the songs inside the stations. I just couldn't play the songs in the stations. These are the free stations anybody can browse to.

I'm also in Canada.
Reply
springroll,
got it, thank you! Smile Yeah, your situation is quite different. I wish you a quick solution for it! Smile
Reply
I apologize for the double-post. I posted in another forum thread. However, It's possible I might get a better answer here.

Any way to associate Kodi .strm files (Gmusic\Youtube) externally with MPC-HC?
Reply
Just installed v. 1.6 on OpenElec newest version 6 for 64bit. System is running on an Intel NUC with an i5.

Installed fine, configured with my account info. I do not have a paid Google Music account, don't know if that matters.

Shows all the genres, shows stations etc., but when I try to enter into a genre or station, there are no files, nothing plays. Just the .. to take me up one level. This happens whether I want to browse stations, listen now, etc. Now music at all.

I think it's accessing my account, cause I went into my Google settings and I can see that an Android device (not my phone or tablet) was accessing my Google account.

Any idea? If you could point me to the log file location on OpenElec, I could post the relevant section. I figured out how to access my Kodi box with a file browser.
Reply
Can you tell me why the visibility condition Player.IsInternetStream does not work with this addon?

When launching the add-on, the first track is read correctly as an Internet stream. The next track(s) is not.

I am using this modded MusicVisualisation, which uses a separate layout for streaming sources such as Google Music. The streaming layout uses Player.IsInternetStream as the visibility condition.
Reply
Hi,

Thank you for a great add on. Really appreciate it. Set-up was pretty seamless.

I have one question/suggestion though?

Is it possible to download music? If you using the google play music application, a user is able to download an album so that it's possible to listen offline. I only ask, because, my internet connection is not great at all, and its not possible to stream all the time.

If this is possible, it would be absolutely brilliant!
Reply
  •   
  • 1
  • 36
  • 37
  • 38(current)
  • 39
  • 40
  • 81
  •   



Logout Mark Read Team Forum Stats Members Help
Experimental Google Music Addon17
This forum uses Lukasz Tkacz MyBB addons.