•   
  • 1
  • 25
  • 26
  • 27(current)
  • 28
  • 29
  • 146
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-01-01, 15:28)popcornmix Wrote: Ah - there is a bug in the error reporting. Need to add:
Code:
dialog = xbmcgui.Dialog()
before the
Code:
dialog.ok("ITV Player", "Sorry Cannot Resolve This Stream", "")
then you get the proper error dialog when stream fails.
Just realised that I forgot to mention a very important point in my previous post, that catch-up and live video streams "fail" and nothing is playing in kodi "at all" when using ITV Player with #1229 Blush

And if I add the suggested line in default.py, then ITV Player plugin does not correctly work at all.
http://sprunge.us/HZMJ

After removing the suggested added line in default.py I re-ran test again (#1229) for both catch-up and live TV with debug switched on. http://sprunge.us/PaUW

No ITV Player catch-up or Live stream play back in#1229, but with #1228 ITV Player streaming works fine?
RPi4, 16Gb SD, (Raspbian Buster & LibreELEC 9.2) Onkyo TX-SR608 AV Receiver, Philips 55PUS7304 4K TV
KVIM2 Pro, eMMC 32GB (Android 7) 8Gb SD (Varied OS) LG 27UD69-W 4K Monitor, AudioEngine A2+ Speakers
(2016-01-01, 12:40)envagyok Wrote: Other question :what is the best deinterlacing setting in SD and HD content?
How can I switch on full rgb mode?

You can set RGB full in the bootloader configuration file "config.txt" at the primary vfat partition

By linux shell:
# mount -o remount,rw /flash
# nano /flash/config.txt

add line "hdmi_pixel_encoding=2"

# sync && reboot

Or by SD card reader on PC
New OpenELEC Krypton build #0101: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.4.0-rc7 #1 Fri Jan 1 21:02:35 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Dec  8 2015 14:44:44
Copyright (c) 2012 Broadcom
version e591b5eb05e2cdb1b5ae25512b27d33127d7bee9 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20160101210145-#0101-gb66e64e [Build #0101]

# vcdbg log msg 2>&1 | grep DTOK
001718.808: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (b66e64e0, changelog) and tip of XBMC master (c852b64b, changelog) with the following modifications: Build Highlights:
  1. MVC, framepacking and 3D switching support merged
Build Details:
  1. OpenELEC:
    • iptables: Fix build failure due to race (PR:4552, 1 commit, 1 file changed)
    • iptables: avoiding building -j1 (PR:4556, 1 commit, 3 files changed)
  2. XBMC:
    • [rbp] Add support for MVC, framepacking and 3d switching (PR:8608, 7 commits, 15 files changed)
  3. newclock5:
    • Commits no longer in build:
      • Add settings option to enable MVC and frame packing support (55059b63)
      • Don't adjust 3d rectangles in bypass mode (1e77ac46)
      • Switch to using transform flags for 3d modes (3f6dd1be)
      • Remove unused Support3D function (583be1e4)
      • Avoid switching stereo mode based on current display mode (bfc22b74)
      • Drop reporting 3D modes and just use current rendering mode to request 3D signalling (8aea44e4)
      • Consider stereomode when creating a new window (937e1ad3)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2015-12-31, 21:46)popcornmix Wrote:
(2015-12-31, 18:36)movie78 Wrote: Green Microblock pixelation

Doesn't have debugging enabled, and no sign of trying to play a video file.

Also, can you say if this problem has always been present for you with these builds, or if it is a recently introduced problem?

The full Debug logs

Green pixel log
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A10 | NVIDIA SHIELD | SAMSUNG QLED QN75Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR | NAKAMICHI PRO 7.1.4 DTS:X/ATMOS 
Hello all,

i am new to this forum and english is not my first language,so i hope you understand me. :-)

First i have to say that you are awesome.
The Rasp2 is my first mediaplayer and you are doing a great job developing Kodi.

But i have little problem with the playback of files.
If i start a file,it will play but after a random time the audio starts to drop for a split second.
This goes for about 3-4 times,after that the file plays without any problems.

It looks like the hdmi audio port goes silent for those split seconds.
That is just a guess because my av receivers display changes the audio stats back and forth.
I tested it with passthrough enabled/disabled but with no changes in playback.

I am using the latest testbuild #0101.
All other builds had the same error.

Here is a debug log.

http://xbmclogs.com/pmwdnmmke

I stopped the playback right after the error occurred.
So the timestamp of the error must be between 12:38:57 -12:59:01
(2016-01-01, 16:31)MikeKL Wrote: No ITV Player catch-up or Live stream play back in#1229, but with #1228 ITV Player streaming works fine?

I've tracked it down to: 8525 (PR)

The ITV player was using a deprecated API for playback that is now removed. Edit default.py:
Code:
xbmc.Player(xbmc.PLAYER_CORE_MPLAYER).play(pl)
to
Code:
xbmc.Player().play(pl)

and
Code:
player = xbmc.Player(xbmc.PLAYER_CORE_AUTO)
to
Code:
player = xbmc.Player()
and I think it will work again.
Never mind my post.
I think it was a problem with my settings.

I disabled the sync playback with screen/monitor option.
And i disabled the Picture refresh frequency option.

Everything seems to be fine now.
(2016-01-02, 14:16)popcornmix Wrote:
(2016-01-01, 16:31)MikeKL Wrote: No ITV Player catch-up or Live stream play back in#1229, but with #1228 ITV Player streaming works fine?

I've tracked it down to: 8525 (PR)

The ITV player was using a deprecated API for playback that is now removed. Edit default.py:
Code:
xbmc.Player(xbmc.PLAYER_CORE_MPLAYER).play(pl)
to
Code:
xbmc.Player().play(pl)

and
Code:
player = xbmc.Player(xbmc.PLAYER_CORE_AUTO)
to
Code:
player = xbmc.Player()
and I think it will work again.
Thanks so very much with those specific edits to default.py; ITV Player catchup streaming working perfectly again BlushCool
Tested on build #0101
RPi4, 16Gb SD, (Raspbian Buster & LibreELEC 9.2) Onkyo TX-SR608 AV Receiver, Philips 55PUS7304 4K TV
KVIM2 Pro, eMMC 32GB (Android 7) 8Gb SD (Varied OS) LG 27UD69-W 4K Monitor, AudioEngine A2+ Speakers
just a quick question... is anyone having difficulties with tvheadend on the last (couple?) of builds? I can't seem to get the tvheadend service started
(no web interface presented and if I go in and try to start it from the
bin (~/.kodi/addons/service.multimedia.tvheadend/bin) directory it complains about:
./tvheadend: error while loading shared libraries: libssl.so.32: cannot open shared object file: No such file or directory
)
and the client is therefore not happy. Is there an upgrade that I need to do? If so where/how do I get it?

Thanks all,

stevegal.
Have you installed the latest tvheadend from addons?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New OpenELEC Krypton build #0102: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.4.0-rc7 #1 Sat Jan 2 22:32:57 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Dec  8 2015 14:44:44
Copyright (c) 2012 Broadcom
version e591b5eb05e2cdb1b5ae25512b27d33127d7bee9 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20160102223205-#0102-g25bebf2 [Build #0102]

# vcdbg log msg 2>&1 | grep DTOK
001717.868: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (25bebf2a, changelog) and tip of XBMC master (32b655e1, changelog) with the following modifications: Build Highlights:
  1. VideoPlayer updates
  2. Add extra debug logging for 3D stereo changes and slow start of playback
  3. [FFmpegImage] - fixed missing transparency of images with indexed colortables (visible in Dev Update addon)
Build Details:
  1. OpenELEC:
    • master: package updates (PR:4554, 3 commits, 33 files changed)
    • master: Package updates (PR:4559, 2 commits, 2 files changed)
    • master: package updates (PR:4561, 1 commit, 1 file changed)
    • xorg: prevent _XSERVTransTransNoListen error (PR:4560, 1 commit, 1 file changed)
    • master: package updates (PR:4562, 2 commits, 2 files changed)
    • License headers update (PR:4563, 4 commits, 460 files changed)
  2. XBMC:
    • [confluence][fix] get rid of view (ID: 51) in pvr channel window which cause issues with viewtypes (PR:8718, 1 commit, 1 file changed)
    • CApplication: fix playback of stacked videos after b0c7602dda8a9b53781176af0978261407085729 (PR:8729, 1 commit, 1 file changed)
    • Tests: Fix up TestTextureUtils.cpp after 932b0d2cec13970bf1f1e78cb6642e3890ce9d68 (PR:8726, 3 commits, 2 files changed)
    • [FFmpegImage] - fixed missing transparency of images with indexed colortables (PR:8739, 1 commit, 1 file changed)
  3. newclock5:
    • New commits in this build:
      • squahs count packets (f11e9163)
      • [mmalcodec] Don't send zero sized extradata (0c5833b0)
      • fix invisible buttons by delay checking for invalid menu buttons until after the player received them from the demuxer (a7225edb)
      • fix invisible menu overlays when corrected pts becomes negative after discontinuities (6e93e129)
      • temp: Add debugging for 3d stereomode changes (7442e04b)
      • [debug] Log when playback start takes too long (58bf3d18)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I updated my RPI1 to build 0101 and now Live TV in HD pauses every 2 seconds. RPI1 runs only tvheadend client, backend is WeTek_Play-tvheadend-4.1-1246.
(2016-01-02, 22:32)Milhouse Wrote: Have you installed the latest tvheadend from addons?

Super. This did the trick. thanks
(2016-01-03, 10:57)cert_ Wrote: I updated my RPI1 to build 0101 and now Live TV in HD pauses every 2 seconds. RPI1 runs only tvheadend client, backend is WeTek_Play-tvheadend-4.1-1246.

Did an earlier build not have this issue? If so can you identify the first build with the issue?
Any findings on the green microblocks issue?
MY CURRENT MEDIA PLAYER | MY HOME THEATER
MINIX NEO U9-H LIBREELEC v18 Leia | EGREAT A10 | NVIDIA SHIELD | SAMSUNG QLED QN75Q7 | Sony 43 Android TV HDR
XBOX ONE X UHD BLU-RAY | PS4 PRO 4K w/PSVR | NAKAMICHI PRO 7.1.4 DTS:X/ATMOS 
  •   
  • 1
  • 25
  • 26
  • 27(current)
  • 28
  • 29
  • 146
  •   
  Thread Closed
 
Thread Rating:
  • 6 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)56
This forum uses Lukasz Tkacz MyBB addons.