•   
  • 1
  • 82
  • 83
  • 84(current)
  • 85
  • 86
  • 295
  •   
Release skin helper service
(2016-01-17, 13:02)im85288 Wrote: The latest from GIT seems to be working correctly again for me, however it seems the wall backgrounds (Movies/TV Shows/Music) are not working correctly?

No issues here, working correctly. Maybe get latest Git (again) because I've been reworking some code last days and there might have been a bad checkin somewhere in between.
Current Git version is fully working as far as I can see.
Reply
@Marcel:
I've noticed that "plugin://script.skin.helper.service/?action=pvrchannels" won't provide ListItem.StartTime. ListItem.EndTime works well.
Main: Lancool II Mesh  - Ryzen 9 5900x - MSI x570 Unify - Zotac RTX 3080 AMP HOLO - 32GB Trident Z Neo 3600 CL16 -  EVO 960 M.2 250GB / EVO 940 250GB / MX100 512GB /  Crucial P1 2TB / WD Blue 3D Nand 2TB 
Sound: Saxx AS30 DSP - Beyer Dynamic Custom One Pro 
TV: Nvidia Shield 2019 Pro- Adalight 114x LEDs - Sony 65XG9505 - Kodi / Emby - Yamaha RX-V683 - Heco Victa 700/101/251a + Dynavoice Magic FX-4
Server: i3 Skylake - 8GB - OMV4 - 22TB Storage
Reply
(2016-01-17, 18:31)marcelveldt Wrote:
(2016-01-17, 13:02)im85288 Wrote: The latest from GIT seems to be working correctly again for me, however it seems the wall backgrounds (Movies/TV Shows/Music) are not working correctly?

No issues here, working correctly. Maybe get latest Git (again) because I've been reworking some code last days and there might have been a bad checkin somewhere in between.
Current Git version is fully working as far as I can see.

Still slow here, version i pointed out is fluid..
Reply
(2016-01-17, 18:39)sualfred Wrote: @Marcel:
I've noticed that "plugin://script.skin.helper.service/?action=pvrchannels" won't provide ListItem.StartTime. ListItem.EndTime works well.

Yeah, it turns out you can not set that infolabel from within python. As alternative the script will provide it in a property, so ListItem.Property(starttime) and ListItem.Property(endtime)
Reply
(2016-01-17, 19:02)badaas Wrote: Still slow here, version i pointed out is fluid..

Can you tell me what EXACTLY is slow ? So, what property, function, or list ?
Reply
Okay, thanks.
Is there anyway to increase the speed to fill that list?
If I use "plugin://script.skin.helper.service/?action=pvrchannels" as<content>, it'll take up to 2-3 seconds until content is visible.

pvr://tv/channels/all channels/ (40 channels) is instantly available.
Main: Lancool II Mesh  - Ryzen 9 5900x - MSI x570 Unify - Zotac RTX 3080 AMP HOLO - 32GB Trident Z Neo 3600 CL16 -  EVO 960 M.2 250GB / EVO 940 250GB / MX100 512GB /  Crucial P1 2TB / WD Blue 3D Nand 2TB 
Sound: Saxx AS30 DSP - Beyer Dynamic Custom One Pro 
TV: Nvidia Shield 2019 Pro- Adalight 114x LEDs - Sony 65XG9505 - Kodi / Emby - Yamaha RX-V683 - Heco Victa 700/101/251a + Dynavoice Magic FX-4
Server: i3 Skylake - 8GB - OMV4 - 22TB Storage
Reply
(2016-01-17, 19:13)sualfred Wrote: Okay, thanks.
Is there anyway to increase the speed to fill that list?
If I use "plugin://script.skin.helper.service/?action=pvrchannels" as<content>, it'll take up to 2-3 seconds until content is visible.

pvr://tv/channels/all channels/ (40 channels) is instantly available.

No, first of all because the plugin paths adds overhead and secondly because this method also grabs the thumbs which is slower.
For instant display just use the pvr:// method.

BTW: Latest Git version has some speed improvements for the dynamic content lists provided by the script, might help a bit.
Reply
Already tried it. No speed improvements for my usecase Sad
I use a custom window for an "All Channels" widget, where the PVR fanarts aren't available. But using the plugin as content provider will break my complete WindowOpen animation because of the delay.

Edit:
Any chance to get live scraper fanarts for a custom window by providing some <onload> values to the xml header?

Edit2:
Lol, your options are endless. Got it working by using the webservice method. Thanks for that damn masterpiece of an addon.
Main: Lancool II Mesh  - Ryzen 9 5900x - MSI x570 Unify - Zotac RTX 3080 AMP HOLO - 32GB Trident Z Neo 3600 CL16 -  EVO 960 M.2 250GB / EVO 940 250GB / MX100 512GB /  Crucial P1 2TB / WD Blue 3D Nand 2TB 
Sound: Saxx AS30 DSP - Beyer Dynamic Custom One Pro 
TV: Nvidia Shield 2019 Pro- Adalight 114x LEDs - Sony 65XG9505 - Kodi / Emby - Yamaha RX-V683 - Heco Victa 700/101/251a + Dynavoice Magic FX-4
Server: i3 Skylake - 8GB - OMV4 - 22TB Storage
Reply
Marcel, can you please check what conditions you have for the Rotating Pictures Background?
As I Said, the user has a library... so it must be something else..
Phenomenal™ Skin • ForumWebsiteGitHub
Reply
(2016-01-17, 19:23)sualfred Wrote: Lol, your options are endless. Got it working by using the webservice method. Thanks for that damn masterpiece of an addon.

hehe, glad you solved it.
Reply
(2016-01-17, 19:26)tomer953 Wrote: Marcel, can you please check what conditions you have for the Rotating Pictures Background?
As I Said, the user has a library... so it must be something else..

Well, the only thing I can think of is his folder structure. The service will only scrape images that are in the root or in a directory from the source. If his images are one level deeper it won't pick them up.
If that's not the case, any errors in the log ?
Reply
(2016-01-17, 20:32)marcelveldt Wrote:
(2016-01-17, 19:26)tomer953 Wrote: Marcel, can you please check what conditions you have for the Rotating Pictures Background?
As I Said, the user has a library... so it must be something else..

Well, the only thing I can think of is his folder structure. The service will only scrape images that are in the root or in a directory from the source. If his images are one level deeper it won't pick them up.
If that's not the case, any errors in the log ?

I tried again... no luck,
I took some pictures, and put under c:\temp folder.
can't find anything weird in the log: http://pastebin.com/e6Vx2DvU

Jarvis beta5
Phenomenal™ Skin • ForumWebsiteGitHub
Reply
(2016-01-16, 00:59)marcelveldt Wrote: Yes, it's prettu much the same.
Now I have problem and just you can resolve this !
I chose widget with buton and onclick change skinstring two things (target and widgets).
PHP Code:
                        <item>
                            <
icon>-</icon>
                            <
label>helper.RecentMedia</label>
                            <
onclick>Skin.SetString($INFO[Container(9000).ListItem.Property(name)].target,extras)</onclick>
                            <
onclick>Skin.SetString($INFO[Container(9000).ListItem.Property(name)].widgets,helper.recentmedia)</onclick>
                        </
item>
                        <
item>
                            <
icon>-</icon>
                            <
label>$LOCALIZE[31003] + $LOCALIZE[31527] - $LOCALIZE[31583]</label>
                            <
onclick>Skin.SetString($INFO[Container(9000).ListItem.Property(name)].target,video)</onclick>
                            <
onclick>Skin.SetString($INFO[Container(9000).ListItem.Property(name)].widgets,movie.tvshow.recent)</onclick>
                            <
visible>Library.HasContent(Movies) + Library.HasContent(TVShows)</visible>
                        </
item

With your script i can change-write one thing with 1 row I need to write two thing from one comand fom skinsettings.xml , is this possible to write something like this.

PHP Code:
<settings>
    <!-- 
widget chooser -->
    <
setting id="menu1.widgets" value="helper.recentmedia"  id="menu1.target" value="extras" label="recentmedia" condition="" icon="special://skin/extras/widgetthumbs/51.jpg" description="Widget from Marcel script"/>
    <
setting id="menu1.widgets" value="movie.random"  id="menu1.target" value="video" label="random" condition="" icon="special://skin/extras/widgetthumbs/52.jpg" description="Widget from BigNoid script"/>
.......
</
settings
Is this possible to make in script that this code work ? or something like this....
XBoxMediaCenter (Kodi Matrix ) 19.0 , AndroidBox -Matrix Skin AeonMQ6
Reply
(2016-01-17, 22:56)Angelinas Wrote: Is this possible to make in script that this code work ? or something like this....

Look a few posts back at the request of JayZ2K...
I have added an optional <onselect> element to the xml which will enable you to set muliple command if one setting is chosen.

PHP Code:
<setting id="HomeLayout_titantiles" value="1" label="$LOCALIZE[31033]condition="" icon="special://skin/extras/viewthumbs/homelayout_1.jpg" description="$LOCALIZE[31033]">
        <
onselect condition="True">Skin.Reset(OpenSubMenuOnClick)</onselect>
        <
onselect condition="True">Skin.SetString(widgetstyle,landscape)</onselect>
        <
onselect condition="True">Skin.SetString(widgetstyle.label,Landscape)</onselect>
    </
setting

Note that you can also use $Info labels for the ID and optional actions.
Reply
(2016-01-17, 20:49)tomer953 Wrote: I tried again... no luck,
I took some pictures, and put under c:\temp folder.
can't find anything weird in the log: http://pastebin.com/e6Vx2DvU

I really can't reproduce the error. I even tried with a folder with all kinds of unicode characters in the filenames and foldernames.
All working.

The images are .jpg or .png ?
Reply
  •   
  • 1
  • 82
  • 83
  • 84(current)
  • 85
  • 86
  • 295
  •   



Logout Mark Read Team Forum Stats Members Help
skin helper service18
This forum uses Lukasz Tkacz MyBB addons.