•   
  • 1
  • 52
  • 53
  • 54(current)
  • 55
  • 56
  • 146
  •   
  Thread Closed
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)
Just noticed a crash in build #0123 that does not happen in #0122:

When I browse a bluray iso file and manually choose a m2t file from the folder 'BDMV/STREAM/' it crashes even before the playback starts - in #0122 this is working without a problem.

Here's a crashlog (enabled debug log in case it helps) : crash log #0123

And here's a normal debug enabled logfile from the same steps in #0122: log from #0122

And this time the bluray iso isn't aacs protected Wink
(2016-01-24, 16:31)rewsteruk Wrote: Hi Millhouse
#0110b Works perfectly, on a quick test exactly like #1126, it seems to fix the other issue I mentioned where after watching a show the next show has a working notification and I need to stop then retry. You can see this in the logs for the episode called ‘The one where they build a house’

The log uploader did not work in #0123, had to downgrade to #0110b to upload, no popup to say do you want to upload. Might be related to the popups and notications missing I reported in #10123.

The Logs for #0123 are here http://xbmclogs.com/p4bche913 , there I no WOL popup at all, not even the 'Working' notification, I cannot move the cursor until it has timed out, the is NO remove file prompt. I used the episode ‘Good Grief’ for this test

Thanks. I've alerted the developer responsible for PR7030 to your issue, hopefully additional updates can be added that clear up these remaining WOL issues.

(2016-01-24, 18:05)doveman2 Wrote: PR7030 was indeed the problem for me with the Kodi 16.0 builds 2186917 (post)

Do you still have WOL problems with build #0123?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-01-24, 16:31)rewsteruk Wrote: The log uploader did not work in #0123, had to downgrade to #0110b to upload, no popup to say do you want to upload. Might be related to the popups and notications missing I reported in #10123.

The Logs for #0123 are here http://xbmclogs.com/p4bche913 , there I no WOL popup at all, not even the 'Working' notification, I cannot move the cursor until it has timed out, the is NO remove file prompt. I used the episode ‘Good Grief’ for this test

Actually that log is from #0110b which is no good as it doesn't include the change that is causing the problem. I need a debug log (wiki) from build #0123 where the problem is reproduced. Enable debug logging, reproduce the issue, then upload the log using ssh: "cat .kodi/temp/kodi.log | paste".
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-01-24, 22:06)nalor Wrote: Here's a crashlog (enabled debug log in case it helps) : crash log #0123

Thanks - should be a fix for that in tonight's build.
New OpenELEC Krypton build #0124: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.4.0 #1 Sun Jan 24 21:26:00 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Jan 15 2016 17:31:09
Copyright (c) 2012 Broadcom
version 50b1ff57f80db9c96b78757d2d2cfc226ed71f93 (clean) (release)

# lsb_release
OpenELEC (Milhouse) - Version: devel-20160124212510-#0124-g62ed698 [Build #0124]

# vcdbg log msg 2>&1 | grep DTOK
001737.444: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of OpenELEC master (62ed6983, changelog) and tip of XBMC master (a5456677, changelog) with the following modifications:
  • Includes newclock5 patches
  • Excludes the OpenELEC linux-01-RPi_support patch in favour of sourcing these and possibly more recent patches directly from kernel branch rpi-4.4.y
  • Default setting for "Show RSS Feed" changed to disabled (new installs only) [patch details]
  • Disabled "Total Duration" in Confluence (see build #0221 for details)
  • Includes latest dcadec master (0e074384, ahead +139)
  • Includes latest kodi-platform master (fed924e7, ahead +4)
  • Includes latest libcec master (6d68d212, ahead +52)
  • Includes latest libnfs master (d8274472, ahead +43)
  • Includes latest platform master (38343e0a)
  • Includes latest addons: adsp.basic (598900a9, +2), adsp.biquad.filters (d63d8ac6), adsp.freesurround (990fee29, +2), asplib (2fac1bf3), pvr.argustv (74918d5a, +4), pvr.demo (555e1d7a, +3), pvr.dvblink (6616a0bb, +4), pvr.dvbviewer (8a005dd8, +4), pvr.filmon (b80ced90, +4), pvr.hdhomerun (888f19e0, +4), pvr.hts (8df9d59a, +6), pvr.iptvsimple (bd52b624, +7), pvr.mediaportal.tvserver (118d605f, +12), pvr.mythtv (bb00bf7b, +8), pvr.nextpvr (2b695f7d, +4), pvr.njoy (29881492, +3), pvr.pctv (a6974b23, +4), pvr.stalker (70e23ecd, +4), pvr.vbox (1326eca9, +4), pvr.vdr.vnsi (2483db98, +10), pvr.vuplus (aaada55a, +4), pvr.wmc (70001bd3, +4)
  • Includes commits from service.openelec.settings/, ahead +1 (OpenELEC)
  • Exclude [env] libnfs-master.patch: Already merged upstream
  • Include [env] e7cbe9cb: xf86-video-intel: explicitely disable TearFree and TripleBuffer
  • Include [env] ed774729: Intel: Implement Passthrough-Range
  • Include [env] f26415ab: libass: bump to 0.13.1
  • Include [env] 3a6268c9: VAAPI: Enable EGL
  • Include [env] 4c703425: update platform (drop obsolete patches)
  • Include [env] 98c65e6a: Kodi: Use Limited Range by default
  • Include [env] 518f5e6f: FFmpeg: Bump to 2.8.5-Jarvis-rc1
  • Include [env] 858f6461: xf86-video-intel: bump to 371219c
  • Include [env] 3161e391: mkpkg: binary-addons: add p8-platform
  • Include [env] patch: Clean Kodi view cache on startup
  • Include [env] patch: ffmpeg: Drop unpack()
  • Include [env] patch: Enable other binary addons
  • Include [env] patch: Fix libcec imx6 patch
  • Include [env] patch: kodi: update to 17.0
  • Include [env] patch: Add experimental splash video
  • Include [env] patch: Enable pvr addons, disable pvr updates
  • Include [env] PR:4537: [scripts] Add PKG_SOURCE_NAME for non-standard package tarballs
  • Include [pkg] PR:7030: CNetwork - implement IPv6
  • Include [pkg] PR:8254: FIX: Only handle 3D bitmap subs in TAB
  • Include [pkg] PR:8645: [video] Add season/TV show artwork to episodes/seasons even if they have their own fanart.
  • Include [pkg] PR:8822: Implement ignore url options in CFileItemList
  • Include [pkg] PR:8824: videodb: fix smart playlists not honoring "Show empty TV shows" setting.
  • Include [pkg] PR:8922: [guiinfo] extend ranges for listitem properties
  • Include [pkg] PR:8923: [GUI] Replace thumb size with images res
  • Include [pkg] PR:8946: [profiles] don't save skin settings on master profile when it was only loaded to switch between two other profiles
  • Revert [pkg] PR:8896: [pvr] add IsRealTimeStream to api (Reason: Allow PVR addons to update - ends on Monday 25 Jan)
  • Revert [pkg] PR:8924: VideoPlayer: detect if pvr input stream is real-time (Reason: Dependends on PR8896)
Build Highlights:
  1. VideoPlayer updates
  2. Bluray ISO crash fix
Build Details:
  1. OpenELEC:
    • repository.unofficial.addon.pro: change kodi minversion to allow beta… (PR:4649, 1 commit, 3 files changed)
  2. XBMC:
    • [guiinfo] fix content types for plugins (PR:8849, 1 commit, 3 files changed)
    • Fix import/export of episode bookmarks (PR:8940, 1 commit, 4 files changed)
    • Add consistency checks to use of musicbrianz id tags (PR:8904, 1 commit, 4 files changed)
    • fix regression after PR8865 (PR:8950, 1 commit, 1 file changed)
    • VideoPlayer: passthrough improvements (PR:8936, 4 commits, 17 files changed)
  3. pvr.hts:
    • Update to libp8-platform (PR:177, 2 commits, 14 files changed)
  4. pvr.mythtv:
    • 4.1.0 (PR:54, 2 commits, 4 files changed)
  5. newclock5:
    • New commits in this build:
      • fixup! ssif: tidy up the logic for merging ssif packets (1e045728)
    • Commits no longer in build:
      • VideoPlayer: refactor audio player (9edb6eb1)
      • VideoPlayer: make AudioCodecPassthrough handle pts (c51add75)
      • AE: improve sync by using pause bursts (23095945)
      • AE: AddPause to sink interface (063f423a)
      • ssif: Discard packets older than 10 seconds (2a703ea5)
      • Revert "ssif: Discard packets older than 10 seconds" (c11d19f3)
      • AE: fix TrueHD (3bcc2dff)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
There have been more audio passthrough changes. Report here is dts/ac3 is working.
Check if receiver indicates dts/dolby or pcm when paused.
Check if you have dropouts when resuming.
Movie total duration on playing time progressbar is totally erroneous on this build for BD 3D ISO.
So I can't go to a precise timestamp.
3D MVC mkv still perfect.
(2016-01-24, 23:09)Milhouse Wrote: Do you still have WOL problems with build #0123?

I haven't tried that yet but it seems fine with #0120, wakes when I go to TV Shows. I haven't noticed any problems since #1213 but I do skip a lot of builds.
(2016-01-25, 00:30)popcornmix Wrote: There have been more audio passthrough changes. Report here is dts/ac3 is working.

Sorry if this was mentioned often before, but i have only now found on my equipment. I have replaced my old receiver without HDCP2.2 connections with a new one. (HDMI2/HDCP2.2)
Now i have noises or rattles on DD5.1 or DTS if i switch KODI to passthrough-settings even with the latest build. The same settings have worked with the old receiver.
For now i'm driving the RPI without PT and via LPCM. Is this a known issue?
(2016-01-25, 14:56)querty1000 Wrote: Sorry if this was mentioned often before, but i have only now found on my equipment. I have replaced my old receiver without HDCP2.2 connections with a new one. (HDMI2/HDCP2.2)
Now i have noises or rattles on DD5.1 or DTS if i switch KODI to passthrough-settings even with the latest build. The same settings have worked with the old receiver.
For now i'm driving the RPI without PT and via LPCM. Is this a known issue?

Can you make sure this is an issue of the new passthrough code (which has already been merged).
Can you test latest build and enable omxplayer and confirm if passthrough works?
Can you test #0120 and confirm if passthrough works (with omxplayer disabled)?
(2016-01-24, 23:13)Milhouse Wrote:
(2016-01-24, 16:31)rewsteruk Wrote: The log uploader did not work in #0123, had to downgrade to #0110b to upload, no popup to say do you want to upload. Might be related to the popups and notications missing I reported in #10123.

The Logs for #0123 are here http://xbmclogs.com/p4bche913 , there I no WOL popup at all, not even the 'Working' notification, I cannot move the cursor until it has timed out, the is NO remove file prompt. I used the episode ‘Good Grief’ for this test

Actually that log is from #0110b which is no good as it doesn't include the change that is causing the problem. I need a debug log (wiki) from build #0123 where the problem is reproduced. Enable debug logging, reproduce the issue, then upload the log using ssh: "cat .kodi/temp/kodi.log | paste".

Here is the debug log for #0123, when I clicked the file the on screen CPU info froze for about 30 seconds.
http://sprunge.us/JIEE

After uploading I switched the skin to confluence just in case, didn't make a difference, but I could not change it back to mimic in #0123, had to go back to #0110b to do it.
(2016-01-25, 00:30)popcornmix Wrote: There have been more audio passthrough changes. Report here is dts/ac3 is working.
Check if receiver indicates dts/dolby or pcm when paused.
Check if you have dropouts when resuming.

Hi popcornmix,

if disable OMX player and activate only MMplayer in #0124:

mini DVD -> DTS 5.1 [AlanParsonsProjekt] and DVD9 ->DTS5.1 [Tina] works.
The Bug with the skip button is resolved.

But i am not able to play DTS - CD's.
Yamaha would shown the DTS Info on Display, but ther is nothing on my Speakers to hear - silence.
Great wave files are only playing in DTS if i select "play with Video Player" - no support of cue-files like foobar2000 or vlc-player?

btw: that is irrelevant to activate or disable OMX/MMplayer in that case - CD-Audio (16/[email protected]) don't work - only showing the DTS logo on Receiver.

I'm back to #1001

...hope i can help a litlle, at least Wink
(2016-01-25, 15:17)popcornmix Wrote:
(2016-01-25, 14:56)querty1000 Wrote: Sorry if this was mentioned often before, but i have only now found on my equipment. I have replaced my old receiver without HDCP2.2 connections with a new one. (HDMI2/HDCP2.2)
Now i have noises or rattles on DD5.1 or DTS if i switch KODI to passthrough-settings even with the latest build. The same settings have worked with the old receiver.
For now i'm driving the RPI without PT and via LPCM. Is this a known issue?

Can you make sure this is an issue of the new passthrough code (which has already been merged).
No, looks like a generell videoplayer problem - it is also in older builds.... but:
Quote:Can you test latest build and enable omxplayer and confirm if passthrough works?
Yes, with OMX-player it works flawlessy in #0120 and in #0124
Quote:Can you test #0120 and confirm if passthrough works (with omxplayer disabled)?
No, doesn't work with disabled OMX-player. I get white noise on DTS and rattling on DD5.1
I had on my setup omxplayer disabled because i had the opinion that omx-player is the old style and will in future disabled and videoplayer is the "new" way. And since i had this configured as LPCM i had never noticed that issue.
(2016-01-25, 18:44)doldi Wrote: But i am not able to play DTS - CD's.
Yamaha would shown the DTS Info on Display, but ther is nothing on my Speakers to hear - silence.
Great wave files are only playing in DTS if i select "play with Video Player" - no support of cue-files like foobar2000 or vlc-player?

Can you try DTS in a normal video file? e.g.
DTS-HD HR 7.1 (in MKV @ 1080p/29.970) from Samples (wiki)

Play with passthrough enabled/disabled.
Play with omxplayer enabled/disabled.
Report what works.

If it fails with passthrough and omxplayer disabled, then can you test #0120 and confirm if passthrough works (with omxplayer disabled)?
hi popcornmix.
this sample is working with (both) aktivated MM and OMC player.

only MMplayer ok, only OMXplayer also.

i need passtrouh, because my HDMI Splitter make the sound over optical S/PDIF, you know ;-)

...but if disable passtrough, it plays in Stereo (pcm) - it's your wish ;-)

The Probs with my Audio/Video DTS is present, also in #0120 (have tested last week).
But ok, have put #0120 on my Pi: mini.DVD - wishlist to play in DTS - after 15 seconds this would play in Dolby Digital. noGo but i know this.

i'm uploading a zip.file (800mb) if you want, belief me, choose DTS - playing DolbyDigital. #1001 all works fine
  •   
  • 1
  • 52
  • 53
  • 54(current)
  • 55
  • 56
  • 146
  •   
  Thread Closed
 
Thread Rating:
  • 6 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
OpenELEC Testbuilds for RaspberryPi (Kodi 17.0)56
This forum uses Lukasz Tkacz MyBB addons.