•   
  • 1
  • 218
  • 219
  • 220(current)
  • 221
  • 222
  • 258
  •   
Release YouTube (IMPORTANT - READ FIRST POST)
So just when I think I can access my subscriptions again. It breaks. I'm not sure what it is that changed in the update but applying my own api key/id to youtube-for-kodi-16 doesn't take me off bromix's api. I continue to get his api instead of mine. Whatever he did it has really left us without a definitive fix. I'd love to get my hands on .15 and .16 to see if that works but I didn't see the old github repository for it so I guess we're mostly shafted then?
Thank you Parcel

With his plugin I would get my subscriptions, but live and browse channels wouldn't work. If I then went in and put in my keys in all the places I could, then My subscriptions went away and live and browse would work.

Did some playing around, and found if I use Parcels plugin and just change the keys to my own keys for the "youtube-for-kodi-quota" section, then everything works for me now.

Tested this on my fire stick and kodi on windows 10.
(2016-02-23, 17:28)blueribb Wrote: Parcel's post above (#3266) contains 5.1.18b (rasberryrabbit) that fixes MY SUBSCRIPTIONS !

Uninstall 5.1.17 and install 5.1.18b. Don't forget to sign-out and sign-in again.

Edit: It looks like it kills the LIVE folder though Sad

It hard to debug it. It may enable more services on API key,
(2016-02-23, 21:40)Kolifanes Wrote:
(2016-02-23, 11:28)parcel Wrote: Update some generated API keys in script. Hope it helps. kodi 15/16/17 (on my repo, kodi 16/17 only)

https://github.com/rasberryrabbit/plugin...master.zip

Hello parcel,

Thanks for your amazing work, is working now! But can i ask you if you can fix the addons also for Kodi 14 and the Live section?

With this version the Live section is working http://offshoregit.com/finalmakerr/Fixed...5.1.17.zip

Thanks!

I guess it depends on API key services configuration. API configuration is key to work it.
easy way to fix it is to identify which key does each api call.

e.g. Youtube-TV is My subscriptions and something else.

then there are some others.

Jeff

[edited] Fixed from the awful grammar.
finalmakerr

Getting a blank My Subscriptions on my FireTV. Good thing is it's not bombing on my Mac so either it's limited to the android platform or my stuff is cached.

Checking the logs i'm getting this error.

Code:
0:38:31 T:18446744072322640528  NOTICE: [plugin.video.youtube] Running: YouTube (5.1.17) on Jarvis (16.0) with Python 2.6.5
20:38:42 T:18446744072308017224  NOTICE: Previous line repeats 3 times.
20:38:42 T:18446744072308017224   ERROR: Unable to find plugin
20:38:42 T:18446744072294497632   ERROR: static bool XFILE::CDirectory::GetDirectory(const CURL&, CFileItemList&, const XFILE::CDirectory::CHints&, bool) - Error getting plugin://
20:38:42 T:18446744072294497632   ERROR: CGUIMediaWindow::GetDirectory(plugin://) failed
20:38:58 T:18446744072314560664  NOTICE: [plugin.video.youtube] Running: YouTube (5.1.17) on Jarvis (16.0) with Python 2.6.5
20:39:23 T:18446744072294497632  NOTICE: Previous line repeats 6 times.
20:39:23 T:18446744072294497632   ERROR: static bool XFILE::CDirectory::GetDirectory(const CURL&, CFileItemList&, const XFILE::CDirectory::CHints&, bool) - Error getting plugin://plugin.video.youtube/sign/out/
20:39:23 T:18446744072294497632   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/sign/out/) failed
20:39:24 T:18446744072308136912  NOTICE: [plugin.video.youtube] Running: YouTube (5.1.17) on Jarvis (16.0) with Python 2.6.5
20:41:07 T:18446744072294497632   ERROR: Control 51 in window 10025 has been asked to focus, but it can't
20:41:07 T:18446744072322831912  NOTICE: [plugin.video.youtube] Running: YouTube (5.1.17) on Jarvis (16.0) with Python 2.6.5
20:43:04 T:18446744072323132616   ERROR: Unable to lookup host: ''
20:43:22 T:18446744072302598592  NOTICE: script.tv.show.next.aired: ### no prior data found
20:43:24 T:18446744072302598592  NOTICE: script.tv.show.next.aired: ### starting data update
20:44:06 T:18446744072318241832   ERROR: Unable to lookup host: ''
20:44:08 T:18446744072294497632   ERROR: static bool XFILE::CDirectory::GetDirectory(const CURL&, CFileItemList&, const XFILE::CDirectory::CHints&, bool) - Error getting nfs://
20:44:08 T:18446744072294497632   ERROR: CGUIDialogFileBrowser::GetDirectory(nfs://) failed
20:44:10 T:18446744072318241832   ERROR: Unable to lookup host: ''
20:46:53 T:18446744072294497632  NOTICE: NFS is idle. Closing the remaining connections.
20:47:46 T:18446744072324461680  NOTICE: [plugin.video.youtube] Running: YouTube (5.1.17) on Jarvis (16.0) with Python 2.6.5
20:48:23 T:18446744072294497632  NOTICE: Previous line repeats 1 times.
20:48:23 T:18446744072294497632   ERROR: static bool XFILE::CDirectory::GetDirectory(const CURL&, CFileItemList&, const XFILE::CDirectory::CHints&, bool) - Error getting plugin://plugin.video.youtube/sign/in/
20:48:23 T:18446744072294497632   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/sign/in/) failed
20:48:23 T:18446744072325266696  NOTICE: [plugin.video.youtube] Running: YouTube (5.1.17) on Jarvis (16.0) with Python 2.6.5

have a feeling it's something to do with that kodi-tv api call, what do you think?

Thanks
Jeff
I might be able to help you, i have the plugin with a date of Dec 22nd. Tell me where to send it to. It's 556K

Jeff


(2016-02-24, 02:14)pluginbroken Wrote: So just when I think I can access my subscriptions again. It breaks. I'm not sure what it is that changed in the update but applying my own api key/id to youtube-for-kodi-16 doesn't take me off bromix's api. I continue to get his api instead of mine. Whatever he did it has really left us without a definitive fix. I'd love to get my hands on .15 and .16 to see if that works but I didn't see the old github repository for it so I guess we're mostly shafted then?
Hello all. I have this youtube problem also. I am using a box that runs to tv using kodi on linux system. So im not sure but I think the fix I read here seems to be if your running it on a pc. Would anyone know how i would fix it in my situation. Thank you in advance
I wish the YouTube plugin was maintained by the core devs, it's very important to many people... I hope it's under consideration
(2016-02-24, 04:55)nycguy Wrote: Hello all. I have this youtube problem also. I am using a box that runs to tv using kodi on linux system. So im not sure but I think the fix I read here seems to be if your running it on a pc. Would anyone know how i would fix it in my situation. Thank you in advance

I run OpenELEC (Linux) and the fix (5.1.18b) worked for me. Just follow the instructions in prior posts.

You must have access to another computer with an internet browser. You will have to have the youtube.com/activate page open during this update.
I am having an issue where I went to see my subscription list to watch some videos, but suddenly I am greeted with an error saying "failed to login" and sometimes "script error" when I try to logout. I've already tried uninstalling/reinstalling the app with no luck in fixing it. My mom and I are trying to do research but I need some serious help here. I am running Kodi on Raspberry Pi and YouTube app version 5.1.17. All my networking is fine and the Pi has it's usual Network information. I haven't changed anything in the last week either except for updating the Pi through SSh but it's worked beside that.

EDIT:

I did a restore from a back up I had and was able to reactivate my login for YouTube. However, if that happens again, what should I do to fix the issue?
(2016-02-24, 03:10)parcel Wrote: I guess it depends on API key services configuration. API configuration is key to work it.

Found the issue. Please update the key for youtube-for-kodi-quota. If you do, Live and Channels working again! Thanks for the update for Kodi 14 Big Grin
I'm sorry but did we ever find out why an update was pushed in the official repository with no official communication here regarding it? It's not a trivial matter, we need to be confident that updates coming from the repository don't break things. What was the reasoning behind that push?
For troubleshooting and bug reporting please make sure you read this first.
(2016-02-24, 11:59)Kolifanes Wrote:
(2016-02-24, 03:10)parcel Wrote: I guess it depends on API key services configuration. API configuration is key to work it.

Found the issue. Please update the key for youtube-for-kodi-quota. If you do, Live and Channels working again! Thanks for the update for Kodi 14 Big Grin
Care to explain?

EDIT:

Got it. In login_client.py we have modified our Kodi version's section and nothing else. There are other entries where we can substitute the bromix keys with the ones we generated. I'll try that. Thanks for sharing.
For troubleshooting and bug reporting please make sure you read this first.
Correct. I used the key from finalmakerr fix and now Live Channel is working!
  •   
  • 1
  • 218
  • 219
  • 220(current)
  • 221
  • 222
  • 258
  •   



Logout Mark Read Team Forum Stats Members Help
YouTube (IMPORTANT - READ FIRST POST)20
This forum uses Lukasz Tkacz MyBB addons.