•   
  • 1
  • 32
  • 33
  • 34(current)
  • 35
  • 36
  • 70
  •   
[RELEASE] Flix2Kodi - Just another Netflix-Addon
I submitted 3 PR to github.

https://github.com/logi85/plugin.video.f...di/pull/34 - To fix error on deletion of chrome cookies
https://github.com/logi85/plugin.video.f...di/pull/35 - To fix login in my region as otherwise login fails claiming login information is incorrect, the additional parameters in the post data are according to the current netflix website behavior (I used fiddler to check)
https://github.com/logi85/plugin.video.f...di/pull/36 - A minor change to allow passing search parameter via plugin:// URL, this allows adding support for flix2kodi in the Meta video plugin I published a few days ago, as requested by one of the users here.

Would really appreciate it if these could be merged,
Thanks!
Reply
Is it possible to exclude the Youtube addon? The addon is discontinued by Bromix, see the topic. I have made the addon work again but after an update of flix2kodi the old youtube addon is back. Now I have to customize the youtube addon after every update.
Reply
Yesterday i installed the new version, but although i had selected my own user profile i saw the list of the primary user. Anyone else has the same problem?
Reply
try to reset chache from settings.
Reply
top work logi85
when i watch a film which button must i press to reverse to kodi
Reply
which add ons must i install under openelec to use this add on
Reply
I've cleared cache but it doens't seem to work. Yesterday with the old version it did work. My guess is there must have changed something in the API. I'll just wait for @logi85 to release a new version.
Reply
Hi,

same here after problems yesterday i received the update overnight, but it would play only on half of the screen and remote would not work.
I double checked that it can see Cookies fine.
I reinstalled the Addon, but know i am back to yesterdays problem. Flix2Kodi crash - relogin loop.

If i may couple of questions
1 - where are all data for this plugin stored. after i reinstalled the plugin all settings were still in username/password
2 - where is the debug log? i just can't find it. i look through the forum tried to find it on the disk, google and nothing

I am using KodiBuntu+Kodi 16

Thank you for a great work so far.
Reply
logi85, thanks for looking into making it work with Android as well, and for all the work you put into this app!

I have a Shield Android TV with the leanback/TV version of Netflix installed by default, and the tablet/phone version of Netflix sideloaded onto the device. Your code points to the sideloaded version, but it does not start the app (I also tried it on my android phone, and it does not work either). I did however try a different solution. I noticed that Chrome on Android is able to start the Netflix app, and jump right to the requested movie.

So I changed the code of the play.py file from

Code:
xbmc.executebuiltin("StartAndroidActivity(com.netflix.mediaclient,com.netflix.mediaclient.ui.launch.UIWebViewActivity,,"+url+")")

to

Code:
xbmc.executebuiltin("StartAndroidActivity(com.android.chrome,android.intent.action.VIEW,,"+url+")")

In addition, I had to change the netflix URL to not include www, from

Code:
self.launch_browser('https://www.netflix.com/watch/%s' % video_id)

to

Code:
self.launch_browser('https://netflix.com/watch/%s' % video_id)

Now everything works on Android, on my phone as well as on Android TV. When you select the movie in flix2kodi, it starts the Chrome Android app with the URL, which automatically starts the Netflix to play the movie/show. On the phone, you can use the regular Chrome and Netflix apps. On Android TV, you have to sideload Chrome and Netflix (com.netflix.mediaclient not com.netflix.ninja) onto your device, as they do not appear in the playstore for Android TV (only com.netflix.ninja does, which is not working)

I have no clue how to work with Github, unfortunately. Is it possible to add an 8th Browser option called "Chrome on Android" which uses the changed Android activity and delete the www in the netflix URL? I think this might be better than deleting the current Android option, just in case it works for someone.

Thank you very much!!!
Reply
I've followed the instruction and I can log into my netflix account through flix2kodi but when I click on something to watch, it looks like its trying to load the show but it just returns to the list.
If anyone can please help, I would very much appreciate it.
Here is the output to the log when the problem happens:

Code:
22:23:53 T:140601973278464  NOTICE:         m_deviceName      : default
22:23:53 T:140601973278464  NOTICE:         m_displayName     : Default (HDA ATI HDMI HDMI 0)
22:23:53 T:140601973278464  NOTICE:         m_displayNameExtra:
22:23:53 T:140601973278464  NOTICE:         m_deviceType      : AE_DEVTYPE_PCM
22:23:53 T:140601973278464  NOTICE:         m_channels        : FL,FR,BL,BR,FC,LFE,SL,SR
22:23:53 T:140601973278464  NOTICE:         m_sampleRates     : 32000,44100,48000,88200,96000,176400,192000
22:23:53 T:140601973278464  NOTICE:         m_dataFormats     : AE_FMT_S32NE,AE_FMT_S16NE,AE_FMT_S16LE
22:23:53 T:140601973278464  NOTICE:     Device 2
22:23:53 T:140601973278464  NOTICE:         m_deviceName      : hdmi:CARD=HDMI,DEV=0
22:23:53 T:140601973278464  NOTICE:         m_displayName     : HDA ATI
22:23:53 T:140601973278464  NOTICE:         m_displayNameExtra: HDMI
22:23:53 T:140601973278464  NOTICE:         m_deviceType      : AE_DEVTYPE_HDMI
22:23:53 T:140601973278464  NOTICE:         m_channels        : FL,FR,BL,BR,FC,LFE,SL,SR
22:23:53 T:140601973278464  NOTICE:         m_sampleRates     : 32000,44100,48000,88200,96000,176400,192000
22:23:53 T:140601973278464  NOTICE:         m_dataFormats     : AE_FMT_S32NE,AE_FMT_S16NE,AE_FMT_S16LE,AE_FMT_LPCM,AE_FMT_DTSHD,AE_FMT_TRUEHD,AE_FMT_EAC3,AE_FMT_DTS,AE_FMT_AC3,AE_FMT_AAC
22:23:53 T:140601964885760    INFO: CActiveAESink::OpenSink - initialize sink
22:23:53 T:140601964885760   DEBUG: CActiveAESink::OpenSink - trying to open device ALSA:default
22:23:53 T:140601964885760    INFO: CAESinkALSA::Initialize - Attempting to open device "default"
22:23:53 T:140601964885760    INFO: CAESinkALSA::Initialize - Opened device "default"
22:23:53 T:140601964885760    INFO: CAESinkALSA::InitializeHW - Your hardware does not support AE_FMT_FLOAT, trying other formats
22:23:53 T:140601964885760    INFO: CAESinkALSA::InitializeHW - Using data format AE_FMT_S32NE
22:23:53 T:140601964885760   DEBUG: CAESinkALSA::InitializeHW - Request: periodSize 2048, bufferSize 8192
22:23:53 T:140601964885760   DEBUG: CAESinkALSA::InitializeHW - Got: periodSize 2048, bufferSize 8192
22:23:53 T:140601964885760   DEBUG: CAESinkALSA::InitializeHW - Setting timeout to 186 ms
22:23:53 T:140601964885760   DEBUG: CAESinkALSA::GetChannelLayout - Input Channel Count: 2 Output Channel Count: 2
22:23:53 T:140601964885760   DEBUG: CAESinkALSA::GetChannelLayout - Requested Layout: FL,FR
22:23:53 T:140601964885760   DEBUG: CAESinkALSA::GetChannelLayout - Got Layout: FL,FR (ALSA: FL FR)
22:23:53 T:140601964885760   DEBUG: CActiveAESink::OpenSink - ALSA Initialized:
22:23:53 T:140601964885760   DEBUG:   Output Device : Default (HDA ATI HDMI HDMI 0)
22:23:53 T:140601964885760   DEBUG:   Sample Rate   : 44100
22:23:53 T:140601964885760   DEBUG:   Sample Format : AE_FMT_S32NE
22:23:53 T:140601964885760   DEBUG:   Channel Count : 2
22:23:53 T:140601964885760   DEBUG:   Channel Layout: FL,FR
22:23:53 T:140601964885760   DEBUG:   Frames        : 2048
22:23:53 T:140601964885760   DEBUG:   Frame Samples : 4096
22:23:53 T:140601964885760   DEBUG:   Frame Size    : 8
22:23:53 T:140601973278464   DEBUG: CActiveAE::ClearDiscardedBuffers - buffer pool deleted
22:23:53 T:140601544697600   DEBUG: RunQuery took 0 ms for 0 items query: select * from movieview
22:23:53 T:140601544697600   DEBUG: RunQuery took 1 ms for 0 items query: select * from episodeview
22:23:53 T:140602444220352   DEBUG: ------ Window Deinit (MyVideoNav.xml) ------
22:23:53 T:140602444220352   DEBUG: ------ Window Init () ------
22:23:53 T:140602444220352   DEBUG: Activating window ID: 10025
22:23:53 T:140602444220352   DEBUG: ------ Window Deinit () ------
22:23:53 T:140601433507584    INFO: CPythonInvoker(23, /home/nas/.kodi/addons/plugin.video.flix2kodi/addon.py): script successfully run
22:23:53 T:140601433507584    INFO: CPythonInvoker(23, /home/nas/.kodi/addons/plugin.video.flix2kodi/addon.py): waiting on thread 140601544697600
22:23:53 T:140602444220352   DEBUG: ------ Window Init (MyVideoNav.xml) ------
22:23:53 T:140602444220352   DEBUG: CGUIMediaWindow::GetDirectory (plugin://plugin.video.flix2kodi/?mode=list_episodes&series_id=70299043&url=1)
22:23:53 T:140602444220352   DEBUG:   ParentPath = [plugin://plugin.video.flix2kodi/?mode=list_episodes&series_id=70299043&url=1]
22:23:53 T:140602444220352   DEBUG: StartScript - calling plugin Flix2Kodi('plugin://plugin.video.flix2kodi/','17','?mode=list_episodes&series_id=70299043&url=1')
22:23:53 T:140602444220352   DEBUG: WaitOnScriptResult - waiting on the Flix2Kodi (id=24) plugin...
22:23:53 T:140601425114880  NOTICE: Thread LanguageInvoker start, auto delete: false
22:23:53 T:140601425114880    INFO: initializing python engine.
22:23:53 T:140601425114880   DEBUG: CPythonInvoker(24, /home/nas/.kodi/addons/plugin.video.flix2kodi/addon.py): start processing
22:23:53 T:140601425114880  NOTICE: -->Python Interpreter Initialized<--
22:23:53 T:140601425114880   DEBUG: CPythonInvoker(24, /home/nas/.kodi/addons/plugin.video.flix2kodi/addon.py): the source file to load is "/home/nas/.kodi/addons/plugin.video.flix2kodi/addon.py"
22:23:53 T:140601425114880   DEBUG: CPythonInvoker(24, /home/nas/.kodi/addons/plugin.video.flix2kodi/addon.py): setting the Python path to /home/nas/.kodi/addons/plugin.video.flix2kodi:/home/nas/.kodi/addons/script.module.requests/lib:/usr/lib/python2.7:/usr/lib/python2.7/plat-x86_64-linux-gnu:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload:/usr/local/lib/python2.7/dist-packages:/usr/lib/python2.7/dist-packages:/usr/lib/python2.7/dist-packages/PILcompat:/usr/lib/python2.7/dist-packages/gtk-2.0
22:23:53 T:140601425114880   DEBUG: CPythonInvoker(24, /home/nas/.kodi/addons/plugin.video.flix2kodi/addon.py): entering source directory /home/nas/.kodi/addons/plugin.video.flix2kodi
22:23:53 T:140601425114880   DEBUG: CPythonInvoker(24, /home/nas/.kodi/addons/plugin.video.flix2kodi/addon.py): instantiating addon using automatically obtained id of "plugin.video.flix2kodi" dependent on version 2.1.0 of the xbmc.python api
22:23:53 T:140602444220352   ERROR: Control 503 in window 10025 has been asked to focus, but it can't
22:23:53 T:140601425114880    INFO: CPythonInvoker(24, /home/nas/.kodi/addons/plugin.video.flix2kodi/addon.py): script successfully run
22:23:53 T:140602444220352   DEBUG: WaitOnScriptResult- plugin returned successfully
22:23:53 T:140601416722176  NOTICE: Thread BackgroundLoader start, auto delete: false
22:23:53 T:140601416722176   DEBUG: Thread BackgroundLoader 140601416722176 terminating
22:23:53 T:140601425114880    INFO: Python script stopped
22:23:53 T:140601425114880   DEBUG: Thread LanguageInvoker 140601425114880 terminating
22:23:53 T:140601433507584    INFO: Python script stopped
22:23:53 T:140601433507584   DEBUG: Thread LanguageInvoker 140601433507584 terminating
22:23:54 T:140602444220352   DEBUG: ------ Window Init (Pointer.xml) ------
22:24:03 T:140602444220352    INFO: Python, unloading python shared library because no scripts are running anymore
22:24:03 T:140602444220352   DEBUG: UnloadExtensionLibs, clearing python extension libraries
22:24:04 T:140602444220352   DEBUG: ------ Window Deinit (Pointer.xml) ------
Reply
I think I have found a bug:
Profiles which is set as "Kids" in Netflix, no longer works with Flix2Kodi.

It just crashes and ask for a re-login in an endless loop.

Have tried on 2 workstations now - can someone else verify or tell if the error is well known

Logs: Will get them, when I have some spare time later tonight

/Morten
Reply
(2016-03-09, 16:12)mhoogenbosch Wrote: Yesterday i installed the new version, but although i had selected my own user profile i saw the list of the primary user. Anyone else has the same problem?

(2016-03-13, 15:49)msj33 Wrote: I think I have found a bug:
Profiles which is set as "Kids" in Netflix, no longer works with Flix2Kodi.

It just crashes and ask for a re-login in an endless loop.

/Morten

I think I'm getting a combination of these two issues. Just tried installing for the first time today, so pardon if I've made any obvious mistakes.

First, tried installing the addon from http://forum.kodi.tv/showthread.php?tid=211574
It wouldn't download any metadata, so I uninstalled it.

I installed Flix2Kodi, configured user/pass, Browser=Chrome, Multi-user account (Single-user is deselected), Show profile each start selected, left the rest at defaults.

Now when I start the addon, it goes to the Moves/Shows/Suggestions screen. When I choose a selection, it says, "Flix2Kodi crashed. Try to refresh your login?" If I choose "Yes", it then lets me choose the profile, but regardless of which one I pick, it immediately gives me an error in the bottom right saying there was an error and to check the log file. As hinted at above, the first profile on my list is my child's, and is set to kids-mode.

Would appreciate any suggestions if I'm doing something wrong, and relevant log content is at http://xbmclogs.com/pnabd39qc.

Edit: Oh, and once I had this issue, I went into the configure settings and did 'Delete cache', 'Delete cookies / session', and 'Reset Addon', same issue.
Reply
Hi, just uploaded version 0.5.9, please read changelog @ first page.
@tmdb: marcelveldt uploaded a version which uses skinhelper. will test it and release in a few days(weeks?)
@metate: thx
@vulpecula: removed
@mhoogenbosch: please try again, and supply logfile if not works
@Reaper_1980: it should be backspace, with openelec I cannot help, but search in thread, someone wrote something about at some page ;-)
@mrfreddy: sounds like you're missing a window-manager, please search in this thread. about login, please try again with new version. I guess you use linux, so the settings-folder would be ~/.kodi/userdata/addon_data/plugin.video.flix2kodi , and the logfile ~/.kodi/temp/kodi.log
@dorf: integrated your changes, please checkout in new version. thx for supplying changes
@stin: please try again with new version. please try also to press enter instead of clicking.
@msj33: kids-profiles should work now
@vizoere: should work now

@all others: if you wait for an answer for a question posted before last post by me, please post again. I can only read from last post to current time.

/logi85
Reply
Hey, tnx for your new version, i'll check it tonight.

Did you manage to add my (updated) dutch translation from post #440 so the new ID's are there as well?
Reply
(2016-03-14, 22:12)mhoogenbosch Wrote: Hey, tnx for your new version, i'll check it tonight.

Did you manage to add my (updated) dutch translation from post #440 so the new ID's are there as well?

Oh no, sorry, hat not much time last weeks and skipped your post (as also many others)
Just uploaded version 0.6.0 and added new dutch & french translation, thx!
Reply
  •   
  • 1
  • 32
  • 33
  • 34(current)
  • 35
  • 36
  • 70
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Flix2Kodi - Just another Netflix-Addon8
This forum uses Lukasz Tkacz MyBB addons.