•   
  • 1
  • 34
  • 35
  • 36(current)
  • 37
  • 38
  • 70
  •   
[RELEASE] Flix2Kodi - Just another Netflix-Addon
(2016-03-14, 21:51)logi85 Wrote: Hi, just uploaded version 0.5.9, please read changelog @ first page.
@vizoere: should work now

Seems that I've still got the same, or similar issue. Every time I log in, I get an "flix2kodi error, check the log" popup, and repeatedly get told that Flix2Kodi crashed, would I like to refresh my logon.

Updated logs here: http://xbmclogs.com/pcshwiznz

Running Win10 Education x64 with Kodi 16.0 Jarvis.
AMD A4-6300 w/8GB RAM, Radeon HD 6450

I completely deleted all things flix2kodi or netflixbmc from:
%appdata%\kodi\addons
%appdata%\kodi\addons\packages
%appdata%\kodi\userdata\addon_data

Reinstalled flix2kodi 0.6.0 from Logi's repo, re-added signin info, left all other settings at default.

If it helps to see what's going on, I used Microsoft's PSR tool to record the process from install through error. Zip file with .mht file at: https://drive.google.com/open?id=0B-JYUj...0lCZkJFWXM

I appreciate your help,
Jeremy
Reply
Hi.

does the script work for anybody ?
cant get it to work on latest Kodi tried with all browsers
i get to the point where i can choose what to play but when i click on it the screen blinks and comes back to the list of videos
Reply
I just installed this addon and put my login info into the config. When i browse the app and try to play something it gives an error "error launching browser". I have chrome selected in the settings of the addon and i have chromelauncher and the chrome.apk installed on my Fire Tv. Anyone else have experience with the Fire tv and this addon?
Reply
Look inside the chromium.sh script, path to chromium browser is probably wrong.
Reply
Oh andi see u are using chromium launcher... Also check all chromihm launcher scrips to check if path to chromium browser is correct. You do not have to use the launcher btw.
Reply
I did some debug on my raspberry. Seems that the process = subprocess.Popen(callstr, startupinfo=info, shell=True) return 1 if I replace it by process = subprocess.check_call(callstr, startupinfo=info, shell=True). So more than likely a problem with the launch of the chromium.sh script. I have added some echo in the script but didn't see anything so I guess that's the call itself that cause a problem.
Code:
callstr= u'sh /home/osmc/.kodi/addons/plugin.video.flix2kodi/resources/scripts/launcher/linux/chromium.sh http://netflix.com/watch/80079265'
Reply
anyone work on windows 10 x64?

test on win10 x64 not work keep crash but win7 x64 perfect work
Reply
It worked for me since 0.5.8. I haven't used it for a couple of days so i haven't yet update to last release. I will test when at home
Reply
First, thank you for all the hard work put into this add-on. Really impressive level on integration with Kodi. That being said, I hesitated to post here, since my question is not really in the spirit of this add-on, but I don't know where else to ask (I know you posted earlier not to make changes to the scripts because they will be wiped in updates, but here goes anyway).

Is there a way to have the add-on just launch netflix.com/browse? Specifically, is there a way to have the add-on launch the website directly and then exit cleanly?

I can pretty easily get netflix.com/browse to launch, however, I either still have to go through the directories and select a movie or tv show before it will launch; or if I try to set it to launch without browsing first, it will create a loop on exit where it will close the browser, return to Kodi, then launch the browser again.

I am a novice when it comes to Python and Kodi add-ons, so any help would be greatly appreciated.


Background (for those interested):
When sitting >10ft away, reading each title is strenuous on the eyes and scrolling through them waiting for the metadata to be scraped and an image to be downloaded is slow. I would like to use the Netflix UI to browse titles instead of the Kodi directories.

I am on Windows 10 using Chrome and Kodi 16.
Reply
i get

Flix2Kodi crashed
Try to refrech your login?
Reply
Addon works quite well during the last two weeks. What i discovered, some titles in "my list" (series) sometimes disappear. Only in 1 out of 5 times they are shown. Namely doctor house and doctor who. Maybe flix2kodi has something against doctors? :-)
Second it's impossible to get into kids section. It crashes with every attempt. But that's not that important.
Win10 x64, Kodi Matrix 19.1 (nightly) 
somehow able to use Windows...
Reply
(2016-03-03, 10:00)laukarlueng Wrote:
Quote:- Kodibuntu (and other Linux distrubutions) without window-manager?

sirhcjw posted the following lines:
(2015-12-30, 23:08)sirhcjw Wrote: All working like a charm for me now thanks for all the hard work.

Anyone on kodibuntu to get this working in full screen just install blackbox window manager and official chrome browser

Then make these changes to the launchBrowser.sh script on my instalation the path is

.kodi/addons/plugin.video.netflix/resources/launchBrowser.sh

Code:
#!/bin/bash

# copy from https://github.com/andrewleech/plugin.video.netflixbmc/blob/master/browser.sh

# Managed to resolve the issues with, but will leave this here anyway, as its a good fallback
CHROME_STARTED=`ps -ef | grep google-chrome | grep -v "grep" | wc -l`
if [ $CHROME_STARTED -gt 0 ]; then
        exit 1;
fi

# lets find out if xdotool actually exist before we try to call it
command -v xdotool >/dev/null 2>&1
XDOTOOL=$?

url=$1

# start window manager to make fullscreen work
/usr/bin/blackbox &

# move mouse pointer to bottom right of screen
if [ $XDOTOOL -eq 0 ]; then
        # no point sleeping if xdotool is not installed.
        #sleep 5
        xdotool mousemove 9999 9999 click 1
else
        echo "xdotool is not installed, can't remove cursor"
fi

# notice no ampersand to keep google chrome in front so remote works
/usr/bin/google-chrome --start-maximized --disable-translate --disable-new-tab-first-run --no-default-browser-check --no-first-run --kiosk "$url"

# kill window manager so we exit back to kodi
killall blackbox >/dev/null 2>&1

Can't find the launchBrowser.sh. Do I need to create it or modify a different file?

Go to /addons/plugin.video.flix2kodi/resources/scripts/launcher/linux/chromelauncher.sh and do the changes. Worked for me.
If you want audio, add "--alsa-output-device=plughw:0,8" just before the "$url" part in the line that launches chrome. 0,8 is your output device from aplay -l, change it to what your audio output device is.
Reply
(2016-03-21, 04:06)yoropico Wrote: anyone work on windows 10 x64?

test on win10 x64 not work keep crash but win7 x64 perfect work

Sorry for the delay, it works for me like a charm. Win10 pro 64bit with last rel. Of flix2kodi of course
Reply
(2016-03-23, 03:10)bjarque Wrote:
(2016-03-03, 10:00)laukarlueng Wrote:
Quote:- Kodibuntu (and other Linux distrubutions) without window-manager?

sirhcjw posted the following lines:

Can't find the launchBrowser.sh. Do I need to create it or modify a different file?

Go to /addons/plugin.video.flix2kodi/resources/scripts/launcher/linux/chromelauncher.sh and do the changes. Worked for me.
If you want audio, add "--alsa-output-device=plughw:0,8" just before the "$url" part in the line that launches chrome. 0,8 is your output device from aplay -l, change it to what your audio output device is.

mind you that if you use --alsa.... when returning to kodi, you might not always have sound.
and you should disable 'keep audio alive (or something)' in kodi, because this hijacks the audio device and --alsa will not work (keep it at never or once a minute for roulette style audio :o) )
when you force video with edid this issue should not occur.
Reply
(2016-03-23, 03:10)bjarque Wrote:
(2016-03-03, 10:00)laukarlueng Wrote:
Quote:- Kodibuntu (and other Linux distrubutions) without window-manager?

sirhcjw posted the following lines:

Can't find the launchBrowser.sh. Do I need to create it or modify a different file?

Go to /addons/plugin.video.flix2kodi/resources/scripts/launcher/linux/chromelauncher.sh and do the changes. Worked for me.
If you want audio, add "--alsa-output-device=plughw:0,8" just before the "$url" part in the line that launches chrome. 0,8 is your output device from aplay -l, change it to what your audio output device is.
I have tried this solution on my raspberry but get :
Code:
Error: Can't open display: (null)
Failed creating new xdo instance
bt::Display: failed to open display ''
Does blackbox require an X11 server ? I'm not sure my OSMC has a X11 server installed by default. I have installed xorg xinit blackbox and matchbox.
Reply
  •   
  • 1
  • 34
  • 35
  • 36(current)
  • 37
  • 38
  • 70
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Flix2Kodi - Just another Netflix-Addon8
This forum uses Lukasz Tkacz MyBB addons.