•   
  • 1
  • 17
  • 18
  • 19(current)
  • 20
  • 21
  • 187
  •   
  Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
(2016-05-04, 00:04)Milhouse Wrote:
(2016-05-03, 23:24)walkerx Wrote: Links for the output from the command line for each title, I think I have noticed the problem. On OpenElec I had told it to remove non-existent titles (as moved distro location for media) but it seems it is still showing the old location for media titles as well as the new location.

Looks like you've got the same episodes scraped from two different sources, eg.:
Code:
"file": "smb://FREENAS/TV Series/Battlestar Galactica (2003)/Specials/Battlestar Galactica (2003) - S00E01E02.mkv",
...
"file": "smb://MEDIASERVER/TVSeries/Battlestar Galactica (2003)/Specials/Battlestar Galactica (2003) - S00E01E02.mkv",

Drop "smb://FREENAS" or drop "smb://MEDIASERVER".

I just performed a clean of the database to be on safe side which resolved the problem - was odd it was only the tv series shown incorrectly as all my media was originally on the freenas unit and moved to the mediaserver
(2016-05-04, 13:38)b0mb Wrote: @Roby77

Does the GUI still crash now for you?


Crash continue, played a youtube video but crash after some minuts ....
(2016-05-04, 17:12)samehvirus Wrote: okay, i got what make it crash , i don't know the reason .. did something change in the builtin function activatewindow ..

could you try this ?

in the eastuty home window , select the search button in the upper left , press on it then select search youtube . did it crashed ?

First of all, thanks for totally ignoring what I asked - no crashlog, or confirmation that build #0501 has this problem. Rolleyes

Secondly, it doesn't crash for me. What does happen is that the Kodi UI locks up when clicking on "Search YouTube", requiring a "systemctl restart kodi". This is reproducible on both Generic and RPi builds, suggesting some sort of main thread deadlock.

So, we definitely have a deadlock, which is bad (possibly worse than a crash actually) but no evidence of any crash, other than your word. If you are experiencing a crash then post your crashlog, or stop claiming you are experiencing a crash.

I am able to confirm this problem starts with build #0501 - maybe it's:
(2016-05-02, 00:21)Milhouse Wrote:
  • XBMC:
    • guilib: only dialogs are allowed to call ProcessRenderLoop (PR:9664, 3 commits, 27 files changed)
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
sorry , i didn't mean to ignore what you asked for , i just thought it's some thing not related to my setup , and if you can reproduce it , my log would be useless .

i'm not the expert here , i'm not claiming anything , or mean any harm . i'm just report what i can understand from what i see , hope that i could help you to keep this great work up by reporting the problems i encounter when use your build.

you are the expert , you can translate what i say to more advanced tech words (kodi ui locks or whatever) , for me kodi stoped responding, so i said it crashed ( becouse that what i thought , or even can't find other word to describe on my mind , even english not my mother language) . i would add that system is still accessible from ssh , or samba share .

please let me know if you still need the crash log , and what the steps needed to obtain it correctly , or whatever you need that could help.
Is the xbmc.gui Version in the latest Generic 5.11 or 5.12 ?? I cannot install latest Aeon Nox 5 from Git.
ASRock Beebox J3160 4GB RAM 120GB SATA SSD - Harmony Elite BT
Intel NUC Kit DN2820FYKH 4GB RAM 120GB SATA SSD - Harmony Smart Control BT
all @ Libreelec Testbuild
HP N54L @ Ubuntu 14.04.4 Minimal Server / MySQL DB
HP N40L @ Ubuntu 14.04.4 Minimal Server
(2016-05-04, 22:54)john.cord Wrote: Is the xbmc.gui Version in the latest Generic 5.11 or 5.12 ?? I cannot install latest Aeon Nox 5 from Git.

5.12.0 since #0502.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-05-04, 22:20)samehvirus Wrote: you are the expert , you can translate what i say to more advanced tech words (kodi ui locks or whatever) , for me kodi stoped responding, so i said it crashed ( becouse that what i thought , or even can't find other word to describe on my mind , even english not my mother language) . i would add that system is still accessible from ssh , or samba share .

That's the thing, I can't translate, as I'm not sat alongside you seeing what you see. Quite often people refer to "bootloops" (whole device restarting) when they actually mean "crashloops" (only the Kodi application is restarting) - these are two totally different things.

A deadlock (which you are experiencing) is very different from an application crash. I have to trust your descriptions so it's a little frustrating when people describe a completely different failure and don't provide any information (logs) to back up their description. It's no wonder that people who don't provide suitable logs are often ignored - "no debug log, no problem" etc.

(2016-05-04, 22:20)samehvirus Wrote: please let me know if you still need the crash log , and what the steps needed to obtain it correctly , or whatever you need that could help.

Thanks, but I don't need the crashlog because you're not experiencing a crash. See the first post (note #4) which details how to upload a crashlog.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
New LibreELEC.tv Krypton build #0504: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.6.0-rc5 #1 SMP Wed May 4 21:33:27 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160504213208-#0504-gbc45a62 [Build #0504]

Based on tip of LibreELEC.tv master (bc45a620, changelog) and tip of XBMC master (afab40a0, changelog) with the following modifications: Build Highlights:
  1. NOTE: DVD playback remains temporarily disabled
  2. VideoPlayer: fix c/p error in RenderManager
  3. PR:9576: [network] improvements to the webserver implementation
  4. No longer include libinput switch PR:200
Build Details:
  1. LibreELEC.tv:
    • distro-tool: Workaround packages that call exit (PR:292, 1 commit, 1 file changed)
    • docker: update to 1.11.1 (PR:280, 1 commit, 3 files changed)
    • tinc: bump to 1.1pre14 (PR:291, 1 commit, 1 file changed)
    • dispmanx_vnc: move config to addon (PR:285, 1 commit, 8 files changed)
    • dispmanx: bump PKG_REV to 101 (PR:293, 1 commit, 1 file changed)
  2. XBMC:
    • [EPG] CGUIEPGridContainer cleanup, incl. Coverity fix (PR:9743, 4 commits, 3 files changed)
    • [cmake] Fix *.cmake files install after 3e19e40 (PR:9741, 1 commit, 1 file changed)
    • cmake: Handle generated files in core_add_test correctly (PR:9692, 3 commits, 3 files changed)
    • fixed: regression from a00a747b6c1ba633e8d83adcf50f93ce888f65dd (PR:9751, 1 commit, 3 files changed)
    • [cmake] Packaging for OSX (PR:9716, 8 commits, 12 files changed)
    • [settings] fix linux.xml after ee40239798bf6 (PR:9752, 1 commit, 1 file changed)
    • [aml] Fix includes in amcodec/codec.h to make them relative (PR:9745, 1 commit, 2 files changed)
    • fix rating / votes infolabels (PR:9740, 1 commit, 1 file changed)
    • wrap skin debug info (PR:9722, 1 commit, 1 file changed)
    • cosmetics - display correct window name (PR:9737, 1 commit, 1 file changed)
    • VideoPlayer: fix c/p error in RenderManager (fb0b2f81)
  3. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] patch: Drop readbufferfactor: Category and property names have changed, but we're already using the default value so no need to set anything
    • Added: [env] PR:286: Upstream changes
    • Added: [pkg] PR:9576: [network] improvements to the webserver implementation
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Are those with remote control issues (missing buttons, no auto-repeat in lists etc.) happier with #0504?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-05-04, 23:51)Milhouse Wrote: Are those with remote control issues (missing buttons, no auto-repeat in lists etc.) happier with #0504?

Yes
I don't know...
I am locking up almost immediately.
In the GUI

Build 0504

[email protected]'s password:
##############################################
# LibreELEC #
# http://libreelec.tv #
##############################################

LibreELEC (community) Version: devel-20160504213208-#0504-gbc45a62
LibreELEC git: bc45a6201938279935b1a47aef5de8de22442594
media-center:~ # dmesg | pastebinit
http://sprunge.us/MdCA
media-center:~ # journalctl -a | pastebinit
http://sprunge.us/LYBK
media-center:~ # cat /storage/.kodi/temp/kodi.log | pastebinit
http://sprunge.us/TDLQ
media-center:~ # vainfo | pastebinit
libva info: VA-API version 0.39.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/va/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
http://sprunge.us/LUUZ
(2016-05-05, 03:25)smitopher Wrote: I don't know...
I am locking up almost immediately.
In the GUI

Build 0504

[email protected]'s password:
##############################################
# LibreELEC #
# http://libreelec.tv #
##############################################

LibreELEC (community) Version: devel-20160504213208-#0504-gbc45a62
LibreELEC git: bc45a6201938279935b1a47aef5de8de22442594
media-center:~ # dmesg | pastebinit
http://sprunge.us/MdCA
media-center:~ # journalctl -a | pastebinit
http://sprunge.us/LYBK
media-center:~ # cat /storage/.kodi/temp/kodi.log | pastebinit
http://sprunge.us/TDLQ
media-center:~ # vainfo | pastebinit
libva info: VA-API version 0.39.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/va/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
http://sprunge.us/LUUZ

We can only hope that the next kernel update will fix the problem :|
(2016-05-04, 23:51)Milhouse Wrote: Are those with remote control issues (missing buttons, no auto-repeat in lists etc.) happier with #0504?

No luck, still problems with repeating :-(
Is this also a kernel thing ?
Repeating keys work for me. There was no issue for me even with the libinput thing included.
(2016-05-05, 09:43)m_gl Wrote:
(2016-05-04, 23:51)Milhouse Wrote: Are those with remote control issues (missing buttons, no auto-repeat in lists etc.) happier with #0504?

No luck, still problems with repeating :-(
Is this also a kernel thing ?

could you please make me an example so i can test with harmony 650 and mce remote (hp) ?
  •   
  • 1
  • 17
  • 18
  • 19(current)
  • 20
  • 21
  • 187
  •   
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111