•   
  • 1
  • 47
  • 48
  • 49(current)
  • 50
  • 51
  • 81
  •   
Release Experimental Google Music Addon
Howly ur fast! Testing tomorrow
Reply
(2016-04-28, 22:09)foreverguest Wrote: Please test new version below:
plugin.audio.googlemusic.exp-1.9
- support for free radio
- improve search results
- add artist background in albums
- cache artist background art for store songs
- fix error when favourites file does not exist

fix error favourites is ok
add artist background in album is also ok, but now there's no background in artists...
Reply
I just updated to latest version 1.8.4 and then to 1.9.0 manually, from 1.7.0 and it doesn't work... I stll have the same error...

Error Type: <class 'sqlite3.OperationalError'>
Error Contents: no such table: songs

or

Error Contents: no such table: library_songs
Error Contents: no such column: tracknumber

the only thing that WORKS is "I feel lucky" it downloads songs list but it is impossible to playHuh?

After I clean cache, cookie and delete database manualy, it still doesn't work. Now even 1.7.0 doesn't work Sad After I run it it creates empty database file 0 bytes....

edit:

After I rebooted the box (and deleted everything) it read my library... but won't play songs Sad So browsing artists and albums works, but not songs or any playlist, etc....

error now is:
Error Type: <type 'exceptions.IndexError'>
Error Contents: No item with that key

and

Error Contents: ('sessiontoken',)

here is whole log:

Help! Smile
Reply
Please test fixes version below:
plugin.audio.googlemusic.exp-1.9.1
- add artist background in artists
- fix error when not a subscriber and free radio is not available (available only in us/canada?)
Reply
I made a backup of database and settings of 1.7 which worked. Now I can always return to working plugin by just copying these 2 files.

Funny thing is when I copy these files and update, it stops working! And when I install clean 1.9.1 it has database of 0 bytes. It is unable to download library or create database, hence the errors that table or what doesn't exist.

Is it possible that I'm the only one with these problems?

Even when i delete everything and install clean 1.7, sometimes it works sometime it doesn't... funny... any clues as to what tests can I do to pinpoint the problem?
Reply
Any errors in log?

If it only works with a reboot, probably there is an app or service in Android that is holding a lock in the file and when it is killed or restarted the file is released. This is just a guess based in the behavior you described, as I don't have any problem with my Android device.
Reply
it's not file lock. I can copy/delete files from my PC through Samba....
Reply
(2016-05-02, 18:51)foreverguest Wrote: Please test fixes version below:
plugin.audio.googlemusic.exp-1.9.1
- add artist background in artists
- fix error when not a subscriber and free radio is not available (available only in us/canada?)

Does this mean if i'm not a paid user, now with this update I can listen to the free radio stations?! Woot woot!
Reply
Yes, if you are in US or Canada.
Reply
(2016-05-05, 21:36)foreverguest Wrote: Yes, if you are in US or Canada.

I am not seeing any stations. I must be doing something wrong. Do I need to add stations to my library first? How do I browse for stations? I am in Canada.
Reply
You should see an option 'Browse Stations' when you open the addon.
If you don't, please upload your log and share the link so I can check for errors.
Reply
(2016-05-06, 15:46)foreverguest Wrote: You should see an option 'Browse Stations' when you open the addon.
If you don't, please upload your log and share the link so I can check for errors.

Hi - I can confirm that Browse Stations option doesn't exist when I opened the addon.
Here's the log http://xbmclogs.com/pqvhcbcd3

Let me know if there's anything else you need. Thanks!
Reply
Please check if thew addon debug option is enabled, in addon settings, as I can't see any log output from the addon.
Reply
Hi I would like to see if you can add the ability to save your Google play music songs to your kodi library
Reply
Looks like I am having an issue with 1.9.1 where it is attempting to open a non-existant table 'artists'. Do I need to set something up first to have this work? The error in the log is: "Error Contents: no such table: artists". Happens on all three instances of Kodi I have running.
Reply
  •   
  • 1
  • 47
  • 48
  • 49(current)
  • 50
  • 51
  • 81
  •   



Logout Mark Read Team Forum Stats Members Help
Experimental Google Music Addon17
This forum uses Lukasz Tkacz MyBB addons.