•   
  • 1
  • 69
  • 70
  • 71(current)
  • 72
  • 73
  • 231
  •   
Win Intel HTPCs/NUCs & Kodi-native 3D MVC Playback
(2016-05-14, 16:06)santiagodraco Wrote: A few updates (and some responses to questions above).

Regarding the audio issue (stereo only, no audio in Kodi):
1. Over HDMI I only get stereo audio. Windows audio settings are set correctly. If using mini-displayport to HDMI adapter I get full 7.1 with passthrough. IE eveything works with Displayport but NOT HDMI.
2. Kodi works and passes through HD audio great with Displayport.
3. Displayport is not a solution for me as it only gives 30hz and not 60hz. This could be an adapter issue but remains to be seen as I have not found one that states 60hz at 4k.
4. I've reinstalled graphics drivers to no avail. I have not yet tried a different HDMI adapter, will try that today.
5. WASAPI was selected. Note that I mentioned the audio issue is in Windows itself (and Kodi by extension).
6. 4k and 1080p both have the issue.

Regarding Kodi/3D:
1. Quality is excellent.
2. 3D movies start in over/under, not sure why. Driving me nuts. Once I hit the 3D button for the Samsung display it corrects.
3. HDMKV: how can I verify that I am running in 10bit 4k on the NUC? I don't see anywhere to enable 10bit vs 8. My hardware supports it (Denon 6200 and Samsung 8500).

(2016-05-19, 20:58)ciscostud Wrote:
(2016-05-19, 02:36)hifihedgehog Wrote:
(2016-05-18, 18:41)ciscostud Wrote: I am having the EXACT same problem with the Intel Skull Canyon NUC on Windows 10 that both of you describe above. I just received mine yesterday. You may or may not be happy to know that this problem with HDMI 5.1 or multichannel passthrough is effecting both my Yamaha 5600 sound bar and Yamaha 5100 AV Pre-Amp. So it is not just a Denon problem. It is a Yamaha problem too. I hear this may not be happening under Linux. It sounds to me like it is a Windows Driver Issue (Intel Display Audio?). I am also running the latest drivers with the Intel Driver Update Utility. I called this in also to Intel Support and they opened a case with the phone number above.

Cool! I have both a thread on the Intel support forums and a Reddit thread on the Intel NUC subreddit, linked below. Below also is a family member's Amazon review of the product. I will post a link to the fix at Reddit and the Intel support forums as soon as it comes.
https://www.reddit.com/r/intelnuc/commen...work_over/
https://communities.intel.com/thread/102165
http://www.amazon.com/review/R1I49QUJ7M4...6&store=pc

I see Intel on their forum is suggesting you try the display port with an adapter on their new Skull Canyon NUC for 5.1 passthrough. It very well could work, but this is a work around and not a fix. It needs to work on HDMI!!

See the topmost quoted comment. Displayport to HDMI has no problem outputting multichannel surround sound. The problem is the native HDMI port does not support multichannel surround sound. You are so right. A workaround is not a fix. They need to fix this $650 investment. Its HDMI sound is a mess.
Reply
(2016-05-20, 00:07)hifihedgehog Wrote:
(2016-05-14, 16:06)santiagodraco Wrote: A few updates (and some responses to questions above).

Regarding the audio issue (stereo only, no audio in Kodi):
1. Over HDMI I only get stereo audio. Windows audio settings are set correctly. If using mini-displayport to HDMI adapter I get full 7.1 with passthrough. IE eveything works with Displayport but NOT HDMI.
2. Kodi works and passes through HD audio great with Displayport.
3. Displayport is not a solution for me as it only gives 30hz and not 60hz. This could be an adapter issue but remains to be seen as I have not found one that states 60hz at 4k.
4. I've reinstalled graphics drivers to no avail. I have not yet tried a different HDMI adapter, will try that today.
5. WASAPI was selected. Note that I mentioned the audio issue is in Windows itself (and Kodi by extension).
6. 4k and 1080p both have the issue.

Regarding Kodi/3D:
1. Quality is excellent.
2. 3D movies start in over/under, not sure why. Driving me nuts. Once I hit the 3D button for the Samsung display it corrects.
3. HDMKV: how can I verify that I am running in 10bit 4k on the NUC? I don't see anywhere to enable 10bit vs 8. My hardware supports it (Denon 6200 and Samsung 8500).

(2016-05-19, 20:58)ciscostud Wrote:
(2016-05-19, 02:36)hifihedgehog Wrote: Cool! I have both a thread on the Intel support forums and a Reddit thread on the Intel NUC subreddit, linked below. Below also is a family member's Amazon review of the product. I will post a link to the fix at Reddit and the Intel support forums as soon as it comes.
https://www.reddit.com/r/intelnuc/commen...work_over/
https://communities.intel.com/thread/102165
http://www.amazon.com/review/R1I49QUJ7M4...6&store=pc

I see Intel on their forum is suggesting you try the display port with an adapter on their new Skull Canyon NUC for 5.1 passthrough. It very well could work, but this is a work around and not a fix. It needs to work on HDMI!!

See the topmost quoted comment. Displayport to HDMI has no problem outputting multichannel surround sound. The problem is the native HDMI port does not support multichannel surround sound. You are so right. A workaround is not a fix. They need to fix this $650 investment. Its HDMI sound is a mess.

Ok. I just ordered a display port 1.2 to HDMI 2.0a active adapter on Amazon. Reviews confirm it is 4K 60 HZ. Not expensive and going to use this work around until they fix HDMI. I feel it is not the hardware and just a matter of time.

http://www.amazon.com/Mini-DisplayPort-H...+2.0+4k+60
Reply
(2016-05-17, 22:12)hdmkv Wrote: No, tested on Beelink P2 w/May 12 build, and no issues. No add-ons, just local video playback.

I downloaded this version SadKodiSetup-20160512-7a1c835-msdk_mvc_wip) - http://mirrors.kodi.tv/test-builds/win32...vc_wip.exe
to Lenovo stick 300 .Is it the only May 12 Build , right?

Thank,
When you first insert the Stick you leave the windows 10 make updated or no need?
and about all the configuration on Kodi WIP from the first post here #1 , you need to do all the configurations or on 12 May version WIP is it build in ?

Thank.
Reply
(2016-05-19, 20:58)ciscostud Wrote:
(2016-05-19, 02:36)hifihedgehog Wrote:
(2016-05-18, 18:41)ciscostud Wrote: I am having the EXACT same problem with the Intel Skull Canyon NUC on Windows 10 that both of you describe above. I just received mine yesterday. You may or may not be happy to know that this problem with HDMI 5.1 or multichannel passthrough is effecting both my Yamaha 5600 sound bar and Yamaha 5100 AV Pre-Amp. So it is not just a Denon problem. It is a Yamaha problem too. I hear this may not be happening under Linux. It sounds to me like it is a Windows Driver Issue (Intel Display Audio?). I am also running the latest drivers with the Intel Driver Update Utility. I called this in also to Intel Support and they opened a case with the phone number above.

Cool! I have both a thread on the Intel support forums and a Reddit thread on the Intel NUC subreddit, linked below. Below also is a family member's Amazon review of the product. I will post a link to the fix at Reddit and the Intel support forums as soon as it comes.
https://www.reddit.com/r/intelnuc/commen...work_over/
https://communities.intel.com/thread/102165
http://www.amazon.com/review/R1I49QUJ7M4...6&store=pc

I see Intel on their forum is suggesting you try the display port with an adapter on their new Skull Canyon NUC for 5.1 passthrough. It very well could work, but this is a work around and not a fix. It needs to work on HDMI!!

That's not a viable work around and if that is their only solution it's bs. There are no 4k60hz adapters out there right now so you are going to be limited to 30hz. Secondly this should never have made it past QA. How hard is it to test this? Sorry, had to vent.

I sent mine back already and won't be buying another. I'll wait for new mATX boards to come out supporting 4k6hz HDMI (or adapters) and upgrade my already great HTPC system. Should have done that in the first place Wink
Reply
Thanks for the great info on this forum. Set up a Gigabyte Brix BXBT-1900 (Celeron J1900) \ 4GB \ 250 GB Samsung SSD, works with just a slight lip sync with 3D MVC playback with DTS-MA, this is with the 12 May build. Updated Intel Graphics to 10.18.10.4358 using device manager.

I had to use 'Windowed Full Screen' set to enabled (rather than disabled in the examples) to get the 3D MKVs to play at 24Hz, otherwise they played @ 30Hz on my LG passive 3D TV with a some juddering.

As I also required bitperfect CD audio playback from my Flac files but with wasapi in Kodi no sound is played to my Pioneer VSX-510 Receiver for music with sample rate of 44100 at either 16 or 24 bit (my 24/96000 files worked fine), this Intel Display Audio issue seems to have been around a while and reported in 2012. The workaround i used was to change the Kodi refresh rate to 30p, all my videos still play at the correct refresh rate after setting this. Only minor downside is the interface is not as smooth, but I changed the skin setting for sliding to off, it still looks excellent.

If you want to use a desktop music app with bitperfect audio, then change the refresh rate in the Intel Graphics Properties to 30p. This was tested with foobar2000 with wasapi addon, at 60p no sound, at 30p music plays bitperfect.

There was a Microsoft HDMI Audio driver mentioned in a forum, but when installed you loose Full HD audio bitstreaming.
Reply
J tried 12 may build on i7 3770k windows 10 , works well , but to achive proper 3D output on my pj hardware based mode must be selected , not same as movie . pq is awesome ,3d very good but j personally prefer 3d on RPI3 libreELEC or even mede8er med600x3d old but solid 3d box
Reply
(2016-05-21, 02:21)rewsteruk Wrote: Thanks for the great info on this forum. Set up a Gigabyte Brix BXBT-1900 (Celeron J1900) \ 4GB \ 250 GB Samsung SSD, works with just a slight lip sync with 3D MVC playback with DTS-MA, this is with the 12 May build. Updated Intel Graphics to 10.18.10.4358 using device manager.

I had to use 'Windowed Full Screen' set to enabled (rather than disabled in the examples) to get the 3D MKVs to play at 24Hz, otherwise they played @ 30Hz on my LG passive 3D TV with a some juddering.

As I also required bitperfect CD audio playback from my Flac files but with wasapi in Kodi no sound is played to my Pioneer VSX-510 Receiver for music with sample rate of 44100 at either 16 or 24 bit (my 24/96000 files worked fine), this Intel Display Audio issue seems to have been around a while and reported in 2012. The workaround i used was to change the Kodi refresh rate to 30p, all my videos still play at the correct refresh rate after setting this. Only minor downside is the interface is not as smooth, but I changed the skin setting for sliding to off, it still looks excellent.

If you want to use a desktop music app with bitperfect audio, then change the refresh rate in the Intel Graphics Properties to 30p. This was tested with foobar2000 with wasapi addon, at 60p no sound, at 30p music plays bitperfect.

There was a Microsoft HDMI Audio driver mentioned in a forum, but when installed you loose Full HD audio bitstreaming.

which "wasapi addon" you download ? do you have link ?(and 30p not set problem on video 3D playback ? )
How do you check that the music plays bitperfect ? in monitor of receiver or other way ?

and How you change the the kodi to 24HZ for 3D instead 30HZ?( or you did at on tv monitor and not on kodi ? )

Thanks.
Reply
(2016-05-21, 13:42)Neighbour Wrote:
(2016-05-21, 02:21)rewsteruk Wrote: Thanks for the great info on this forum. Set up a Gigabyte Brix BXBT-1900 (Celeron J1900) \ 4GB \ 250 GB Samsung SSD, works with just a slight lip sync with 3D MVC playback with DTS-MA, this is with the 12 May build. Updated Intel Graphics to 10.18.10.4358 using device manager.

I had to use 'Windowed Full Screen' set to enabled (rather than disabled in the examples) to get the 3D MKVs to play at 24Hz, otherwise they played @ 30Hz on my LG passive 3D TV with a some juddering.

As I also required bitperfect CD audio playback from my Flac files but with wasapi in Kodi no sound is played to my Pioneer VSX-510 Receiver for music with sample rate of 44100 at either 16 or 24 bit (my 24/96000 files worked fine), this Intel Display Audio issue seems to have been around a while and reported in 2012. The workaround i used was to change the Kodi refresh rate to 30p, all my videos still play at the correct refresh rate after setting this. Only minor downside is the interface is not as smooth, but I changed the skin setting for sliding to off, it still looks excellent.

If you want to use a desktop music app with bitperfect audio, then change the refresh rate in the Intel Graphics Properties to 30p. This was tested with foobar2000 with wasapi addon, at 60p no sound, at 30p music plays bitperfect.

There was a Microsoft HDMI Audio driver mentioned in a forum, but when installed you loose Full HD audio bitstreaming.

which "wasapi addon" you download ? do you have link ?(and 30p not set problem on video 3D playback ? )
How do you check that the music plays bitperfect ? in monitor of receiver or other way ?

and How you change the the kodi to 24HZ for 3D instead 30HZ?( or you did at on tv monitor and not on kodi ? )

Thanks.

To Install WASAPI In foobar2000
Library Menu > Configure > Components > Get More Components > Search for "WASAPI" > install the "WASAPI output support"
Configure foobar2000 to use WASAPI
Library Menu > Configure > Playback > Output > On the device dropdown select WASAPI: Name of Device (ie VSX-510)

Play a 16/44.1 FLAC file, you will get silence (because of the Intel issue), change the refresh to 30p and sound will be passed to the receiver. To test the digital stream is not being interfered with, try changing the volume on the windows task bar, it will not change and you will not hear the usual chime sound when you click different places on the volume control.

Kodi uses the same WASAPI method to pass lossless HD audio to be decoded by the receiver, so it is bitperfect.

Setting 30p for the interface/desktop does not cause an issue as the Adjust Display Refresh Rate = On Start / Stop Setting in Kodi will change the video refresh rate to the correct setting, ie for most files this will change to 24Hz (23.976), my PAL DVDs change to 50Hz etc.

Hope this helps
Reply
(2016-05-21, 16:12)rewsteruk Wrote:
(2016-05-21, 13:42)Neighbour Wrote:
(2016-05-21, 02:21)rewsteruk Wrote: Thanks for the great info on this forum. Set up a Gigabyte Brix BXBT-1900 (Celeron J1900) \ 4GB \ 250 GB Samsung SSD, works with just a slight lip sync with 3D MVC playback with DTS-MA, this is with the 12 May build. Updated Intel Graphics to 10.18.10.4358 using device manager.

I had to use 'Windowed Full Screen' set to enabled (rather than disabled in the examples) to get the 3D MKVs to play at 24Hz, otherwise they played @ 30Hz on my LG passive 3D TV with a some juddering.

As I also required bitperfect CD audio playback from my Flac files but with wasapi in Kodi no sound is played to my Pioneer VSX-510 Receiver for music with sample rate of 44100 at either 16 or 24 bit (my 24/96000 files worked fine), this Intel Display Audio issue seems to have been around a while and reported in 2012. The workaround i used was to change the Kodi refresh rate to 30p, all my videos still play at the correct refresh rate after setting this. Only minor downside is the interface is not as smooth, but I changed the skin setting for sliding to off, it still looks excellent.

If you want to use a desktop music app with bitperfect audio, then change the refresh rate in the Intel Graphics Properties to 30p. This was tested with foobar2000 with wasapi addon, at 60p no sound, at 30p music plays bitperfect.

There was a Microsoft HDMI Audio driver mentioned in a forum, but when installed you loose Full HD audio bitstreaming.

which "wasapi addon" you download ? do you have link ?(and 30p not set problem on video 3D playback ? )
How do you check that the music plays bitperfect ? in monitor of receiver or other way ?

and How you change the the kodi to 24HZ for 3D instead 30HZ?( or you did at on tv monitor and not on kodi ? )

Thanks.

To Install WASAPI In foobar2000
Library Menu > Configure > Components > Get More Components > Search for "WASAPI" > install the "WASAPI output support"
Configure foobar2000 to use WASAPI
Library Menu > Configure > Playback > Output > On the device dropdown select WASAPI: Name of Device (ie VSX-510)

Play a 16/44.1 FLAC file, you will get silence (because of the Intel issue), change the refresh to 30p and sound will be passed to the receiver. To test the digital stream is not being interfered with, try changing the volume on the windows task bar, it will not change and you will not hear the usual chime sound when you click different places on the volume control.

Kodi uses the same WASAPI method to pass lossless HD audio to be decoded by the receiver, so it is bitperfect.

Setting 30p for the interface/desktop does not cause an issue as the Adjust Display Refresh Rate = On Start / Stop Setting in Kodi will change the video refresh rate to the correct setting, ie for most files this will change to 24Hz (23.976), my PAL DVDs change to 50Hz etc.

Hope this helps

Thanks very much . it is very helpful.

about your sentence : "change the refresh to 30p and sound will be passed to the receiver"
you mean to change to "30p" on Kodi / Intel graphic card setting / LG TV Setting ?

I have denon 1200 receiver - on WASAPI: Name of Device (ie Denon 1200 ) ?

you install the WIP version and do all the settings change like post #1 or you only install and play the 3D iso and it works ?

I have 24p Cinema option on LG UF850 4K 3D - I need to use that on my Lenovo stick 300 with 3D ISO content on Kodi WIP or just standart setting will do the same job ?

Do you have any addons that I can install on Kodi that will bring me fron NAS all the FLAC albums with CD charts and image ?

Thanks .
Reply
@Neighbour

Quote:you mean to change to "30p" on Kodi / Intel graphic card setting / LG TV Setting ?

Only Kodi (for lossless in Kodi) and Intel Graphic Card (for lossless in Foobar2000), your TV should adjust refresh to match output

Quote:you install the WIP version and do all the settings change like post #1 or you only install and play the 3D iso and it works ?

I used the 12 May WIP version, setting same as in post #1 except I only got 24Hz 3D playback in Full Screen Window = true, all my 3D files are MKV.

Quote:I have 24p Cinema option on LG UF850 4K 3D - I need to use that on my Lenovo stick 300 with 3D ISO content on Kodi WIP or just standart setting will do the same job ?

I did not need to change any settings on my TV to get 24p.

Quote:Do you have any addons that I can install on Kodi that will bring me fron NAS all the FLAC albums with CD charts and image ?

No addons required, but the album cover is in the album directory on the NAS, but did enable 'Fetch Additional Information during updates', this downloads artist info etc, but I dont this this is working on 12 May version.
Reply
(2016-05-21, 17:55)rewsteruk Wrote: @Neighbour

Quote:you mean to change to "30p" on Kodi / Intel graphic card setting / LG TV Setting ?

Only Kodi (for lossless in Kodi) and Intel Graphic Card (for lossless in Foobar2000), your TV should adjust refresh to match output

Quote:you install the WIP version and do all the settings change like post #1 or you only install and play the 3D iso and it works ?

I used the 12 May WIP version, setting same as in post #1 except I only got 24Hz 3D playback in Full Screen Window = true, all my 3D files are MKV.

Quote:I have 24p Cinema option on LG UF850 4K 3D - I need to use that on my Lenovo stick 300 with 3D ISO content on Kodi WIP or just standart setting will do the same job ?

I did not need to change any settings on my TV to get 24p.

Quote:Do you have any addons that I can install on Kodi that will bring me fron NAS all the FLAC albums with CD charts and image ?

No addons required, but the album cover is in the album directory on the NAS, but did enable 'Fetch Additional Information during updates', this downloads artist info etc, but I dont this this is working on 12 May version.

Thanks,

About - "post #1 except I only got 24Hz 3D playback in Full Screen Window" - it should be 24HZ in 3D playback or 30HZ? ( if I need to change How I do that ? )

if I play kodi from Openelec Version and not from windows via Solid-Run Cubox architecte , what I need to check on settings that FLAC albums will passthrough to Receiver ?

Thanks.
Reply
@Neighbour

Quote:About - "post #1 except I only got 24Hz 3D playback in Full Screen Window" - it should be 24HZ in 3D playback or 30HZ? ( if I need to change How I do that ? )

Sorry, it should be 24Hz NOT 30Hz, you would get juddering. The setting in Post #1 disable 3D in Full Screen Window, gave me the 30Hz, when enabled I smooth 24Hz playback.

Quote:if I play kodi from Openelec Version and not from windows via Solid-Run Cubox architecte , what I need to check on settings that FLAC albums will passthrough to Receiver ?

Not really sure on this one to be honest, you can hear remote sounds when they are enabled so some mixing is going on, but DD and DTS passthrough ok.
Reply
(2016-05-20, 23:13)santiagodraco Wrote:
(2016-05-19, 20:58)ciscostud Wrote:
(2016-05-19, 02:36)hifihedgehog Wrote: Cool! I have both a thread on the Intel support forums and a Reddit thread on the Intel NUC subreddit, linked below. Below also is a family member's Amazon review of the product. I will post a link to the fix at Reddit and the Intel support forums as soon as it comes.
https://www.reddit.com/r/intelnuc/commen...work_over/
https://communities.intel.com/thread/102165
http://www.amazon.com/review/R1I49QUJ7M4...6&store=pc

I see Intel on their forum is suggesting you try the display port with an adapter on their new Skull Canyon NUC for 5.1 passthrough. It very well could work, but this is a work around and not a fix. It needs to work on HDMI!!

That's not a viable work around and if that is their only solution it's bs. There are no 4k60hz adapters out there right now so you are going to be limited to 30hz. Secondly this should never have made it past QA. How hard is it to test this? Sorry, had to vent.

I sent mine back already and won't be buying another. I'll wait for new mATX boards to come out supporting 4k6hz HDMI (or adapters) and upgrade my already great HTPC system. Should have done that in the first place Wink

Incorrect. There have been UHD/4K 60 Hz capable DP to HDMI adapters since the early part of this year. See ciscostud's link for the second major adapter. The first such HDMI 2.0a adapter to be released was Club3D's.
Reply
(2016-05-21, 20:49)rewsteruk Wrote: @Neighbour

Quote:About - "post #1 except I only got 24Hz 3D playback in Full Screen Window" - it should be 24HZ in 3D playback or 30HZ? ( if I need to change How I do that ? )

Sorry, it should be 24Hz NOT 30Hz, you would get juddering. The setting in Post #1 disable 3D in Full Screen Window, gave me the 30Hz, when enabled I smooth 24Hz playback.

Quote:if I play kodi from Openelec Version and not from windows via Solid-Run Cubox architecte , what I need to check on settings that FLAC albums will passthrough to Receiver ?

Not really sure on this one to be honest, you can hear remote sounds when they are enabled so some mixing is going on, but DD and DTS passthrough ok.

Thanks,

You see if you have 30hz or 24HZ with info bottom on LG remote control ?

you have image of this feature disable 3D on full screen that I don't disable it ?

Thanks in advance.
Reply
@Neighbour

Quote:You see if you have 30hz or 24HZ with info bottom on LG remote control ?

Yes, if info button shows 30Hz on screen then enable Windowed Full Screen setting should then show 24Hz after change.

Quote: you have image of this feature disable 3D on full screen that I don't disable it ?

If it already shows 24Hz then just leave Window Full Screen setting as it is.
Reply
  •   
  • 1
  • 69
  • 70
  • 71(current)
  • 72
  • 73
  • 231
  •   
 
Thread Rating:
  • 10 Vote(s) - 4.3 Average



Logout Mark Read Team Forum Stats Members Help
Intel HTPCs/NUCs & Kodi-native 3D MVC Playback4.310