•   
  • 1
  • 44
  • 45
  • 46(current)
  • 47
  • 48
  • 70
  •   
[RELEASE] Flix2Kodi - Just another Netflix-Addon
in "my list" and "all shows"
Reply
(2016-05-23, 16:28)peppe_sr Wrote: in "my list" and "all shows"

OK, I'll take a look, might be that I missed those. At show, episode or season level ?
Reply
the context menu is active at show level, when you recall "recap" the addon return the search dialog not the show.
Reply
I have the issue with the screen inverting colours as well. No clue how to fix it. Happens as soon as netflix opens up the video. I press alt-tab which turns the colour inversion off for chrome only and makes kodi, and all of windows colour inverted. Its very weird. Any help?
Reply
First of all hi to all,
long time lurker and now finally registered to the forums Smile

I have an issue when using the most recent version.
It's running on an intel nuc x86 on openelec. I installed the unofficial repo for being able to use chromium.
When I start flix2kodi and hit any of the buttons (recently watched, search..) it is logging in and brings me to the profile selection screen. This profile selection (who is watching) has no entries and is completely empty.

The log throws the following:

Code:
09:42:49 T:139822945408768  NOTICE: [plugin.video.flix2kodi] Loading netflix: https://www.netflix.com/Login Post: None
09:42:51 T:139822945408768  NOTICE: [plugin.video.flix2kodi] Setting authorization url: xxxxxx
09:42:51 T:139822945408768  NOTICE: [plugin.video.flix2kodi] Loading netflix: https://www.netflix.com/Login?locale=en-DE Post: {u'rememberMe': u'true', u'authURL': 'xxxxxx', u'mode': u'loginPassword', u'action': u'loginAction', u'password': 'password', u'flow': u'websiteSignUp', u'email': '[email protected]', u'nextPage': u'', u'withFields': u'email,password,rememberMe,nextPage'}
09:42:51 T:139822945408768  NOTICE: [plugin.video.flix2kodi] Setting authorization url: xxxxxx
09:42:51 T:139822945408768   ERROR: [plugin.video.flix2kodi] Error setting Chrome-Cookie: Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/chrome_cookie.py", line 129, in set_netflix_cookies
                                                conn = connect()
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/chrome_cookie.py", line 117, in connect
                                                raise ValueError('Cannot find cookie-file in: '+db_path)
                                            ValueError: Cannot find cookie-file in: /storage/.config/google-chrome/Default/Cookies/storage/.kodi/userdata/addon_data/browser.chromium/profile
09:42:51 T:139822945408768  NOTICE: [plugin.video.flix2kodi] Loading netflix: http://api-global.netflix.com/desktop/account/profiles?version=2&withCredentials=true Post: None
09:42:52 T:139822945408768  NOTICE: [plugin.video.flix2kodi] {"profiles":[{"firstName":null,"guid":"xxxxxx","isAccountOwner":true,"isFirstUse":false,"isActive":true,"experience":"standard","defaultKidsProfile":false,"maturityLevel":1000000,"avatarName":"default","avatarImages":{"32":"http://......},"canEdit":true,"isDefault":true}]}
09:42:53 T:139822945408768   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ValueError'>
                                            Error Contents: Extra data: line 1 column 6181 - line 1 column 6182 (char 6181 - 6182)
                                            Traceback (most recent call last):
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/addon.py", line 90, in <module>
                                                if connect.do_login():
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/connect.py", line 233, in do_login
                                                return login.login()
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/login.py", line 69, in login
                                                profile_selection()
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/login.py", line 110, in profile_selection
                                                profiles.choose()
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/profiles.py", line 53, in choose
                                                switch_profile(selected_profile['token'])
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/profiles.py", line 26, in switch_profile
                                                profile_switch_url = generic_utility.profile_switch() + 'switchProfileGuid=' + profile_id + '&authURL=' + auth_id
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/utility/generic_utility.py", line 101, in profile_switch
                                                return profile_switch_url % (api_url, endpoints()['/profiles/switch'])
                                              File "/storage/.kodi/addons/plugin.video.flix2kodi/resources/utility/generic_utility.py", line 95, in endpoints
                                                return json.loads(get_setting('endpoints'))
                                              File "/home/stephan/projects/openelec-6.0/build.OpenELEC-Generic.x86_64-6.0.3/Python-2.7.3/.install_pkg/usr/lib/python2.7/json/__init__.py", line 326, in loads
                                              File "/home/stephan/projects/openelec-6.0/build.OpenELEC-Generic.x86_64-6.0.3/Python-2.7.3/.install_pkg/usr/lib/python2.7/json/decoder.py", line 369, in decode
                                            ValueError: Extra data: line 1 column 6181 - line 1 column 6182 (char 6181 - 6182)
                                            -->End of Python script error report<--
09:42:53 T:139824590645120   ERROR: GetDirectory - Error getting plugin://plugin.video.flix2kodi/?mode=list_viewing_activity&thumb&type=movie&url
09:42:53 T:139824590645120   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.flix2kodi/?mode=list_viewing_activity&thumb&type=movie&url) failed
09:42:53 T:139822945408768  NOTICE: Thread LanguageInvoker start, auto delete: false
09:42:53 T:139822945408768  NOTICE: -->Python Interpreter Initialized<--
[/quote]

Any help is highly appreciated Smile
Reply
Everything is working great so far! Though sometimes when watching something I'll get that lil Windows error box saying "Kodi has stopped working" I guess that's more of a Kodi issue?
Asrock Rog Z390-H | Intel i9 9900K | Windows 10 Pro x64 | Pop!_OS 20.10 |Nvidia Shield TV Pro (2019)
EVGA Hybrid FTW GTX 1070 | Corsair 16GB DDR4
Samsung 500GB SSD | 500GB Nvme SSD |500GB WD Black Nvme SSD |6TB HDD
Reply
Browing and playback is working for me, but I'm having the following issues during playback:

1. No sounds in Chrome in Windows. I guess this could be due to not booting into explorer.exe, but using kodi.exe as shell instead (using Launcher4Kodi: http://forum.kodi.tv/showthread.php?tid=136798). Any ideas how to get sound working?

2. Harmony remote not working in Chrome, only "ok"-button is working (as pause/play). I at least need to have a way to close Chrome. Any ideas?
Reply
sorry to bother you guys, but I'm having a terrible time getting this working.

I'm on Win7 x64 (soon to be win10). Latest Kodi. I used to run netflixbmc and had all the kinks worked out.

I'm now trying to setup Flix2Kodi. I'm having 2 issues:

1) Chrome Launcher isn't working. Do I have to install or set anything up to make this work?
2) The mouse cursor won't go away! I'm assuming "chrome launcher" helps alleviate this issue, but not sure though.

I figured out how to use EventGhost to setup my MCE remote's stop button to close the chrome window, and return back to kodi.

I've scoured this thread and re-read everything multiple times, but can't figure out how to fix my issue.
I did find this post:
(2016-01-15, 18:57)mhoogenbosch Wrote:
(2016-01-15, 18:52)druu Wrote: hey logi, sorry if i've missed this somewhere in the thread but I can't seem to use my remote to control flix2kodi. I still have previous netflix app installed that works fine but would like to move onto this new version.

Also, my cursor seems to stay on the screen with this version too. Running 0.5.1 on OE.
did you change the name of the plugin in the remotecontrol plugin? This should solve the cursor issue.

(2016-01-15, 19:03)druu Wrote: Do i just modify the settings.xml for that addon?





but I can't make heads or tails as to what is supposed to rename, or what a remotecontrol plugin is, or what would be changed in a settings.xml file i don't know exists.

thanks guys
Reply
Anyone having an issue with high CPU usage in the Kodi process while watching Netflix in IE under Windows? Tried Chrome and is was not high.

EDIT; Seems to have something to do with the script. I stripped it down to simply to IE startup (no loop) and all seems fine. Why does it wait anyhow? IN my setup IE is full-screen and active with Kodi sitting behind. Not sure what having the script wait for does ... I am exiting from IE and activating Kodi through eventghost.

Cheers, Tony.
Reply
Any thoughts on adding a 'sync library with MyList' option so that the Kodi library automatically has the MyList in it? I can do this manually one by one right now but then have to make sure I keep this in sync as I add to MyList ...
Reply
Hello, few suggestions:

1) open browsers chrome and chromium in app mode solve problem opening of multiple tab (multiple tab with netflix = netflix retourn error)
- /opt/google/chrome/google-chrome --start-maximized --disable-translate --disable-new-tab-first-run --no-default-browser-check --no-first-run --kiosk --app="$url" &
2) in Linux systems bash script must be made executable, and must repeat this procedure every update; you can open the browser directly from python:
- CHROMIUM = os.path.join('/', 'usr', 'bin', 'chromium')
if not os.path.isfile(CHROMIUM): CHROMIUM = os.path.join('/', 'usr', 'bin', 'chromium-browser')
subprocess.call([CHROMIUM , '--start-maximized','--disable-translate','--disable-new-tab-first-run','--no-default-browser-check','--no-first-run','--kiosk','--app=url'])
Reply
Thanks to @vania70 for the -app part. I am having a few issues in my environment with the scripts but have come to a solution that works. I have Windows 10 and were having issues as follows:

1. Could only get IE to open fullscreen.
2. IE does not play Netflix in 64-bit version (that comes with WIndows 10).
3. CPU usage is at 25% generally within Kodi when waiting for script to return (the 'loop' part).

So here is what I did:

A. Corrected built in script for chrome. It seems chrome in .cmd files only needs a single '-' and not the '--' to work.
B. Removed the entire 'loop' part.
C. Added the '-app' command line script argument.

So my chrome.cmd is now simply:

if %PROCESSOR_ARCHITECTURE%==x86 (
"%ProgramFiles%\Google\Chrome\Application\chrome.exe" -start-maximized -disable-translate -disable-new-tab-first-run -no-default-browser-check -no-first-run -kiosk -app=%1
) else (
"%ProgramFiles(x86)%\Google\Chrome\Application\chrome.exe" -start-maximized -disable-translate -disable-new-tab-first-run -no-default-browser-check -no-first-run -kiosk -app=%1
)

There is an error popup in Kodi indicating it could not update the play count but I can live with that!
Reply
Does anyone else have the colour issue? It's driving me nuts I can't figure it out
Reply
(2016-05-28, 20:49)mattress Wrote: 2) The mouse cursor won't go away! I'm assuming "chrome launcher" helps alleviate this issue, but not sure though.

I figured out how to use EventGhost to setup my MCE remote's stop button to close the chrome window, and return back to kodi.

I use Eventghost as well (for everything, it's amazing). You can set it up to relocate the mouse cursor to the upper left corner when Chrome gains focus, this works to hide the mouse pointer well enough for me.
Reply
(2016-05-29, 16:36)mack4999 Wrote: Does anyone else have the colour issue? It's driving me nuts I can't figure it out

If By colour issue you mean flipping colors, then yes, I am.
Reply
  •   
  • 1
  • 44
  • 45
  • 46(current)
  • 47
  • 48
  • 70
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Flix2Kodi - Just another Netflix-Addon8
This forum uses Lukasz Tkacz MyBB addons.