•   
  • 1
  • 73
  • 74
  • 75(current)
  • 76
  • 77
  • 187
  •   
  Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
New LibreELEC.tv Krypton build #0708: Generic
(Supercedes previous build)

Code:
# uname -a
Linux LibreELEC 4.7.0-rc6 #1 SMP Fri Jul 8 21:42:16 BST 2016 x86_64 GNU/Linux

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160708214019-#0708-g4cb4fca [Build #0708]

Based on tip of LibreELEC.tv master (4cb4fca3, changelog) and tip of XBMC master (63f605e8, changelog) with the following modifications: Build Highlights:
  1. Updated inputstream.mpd 1.1.8
Build Details:
  1. XBMC:
    • Revert "[android/packaging] Sync rtmp removal" (PR:10079, 1 commit, 1 file changed)
    • [cmake/linux] Increase link performance (GOLD, DebugFission) (PR:9924, 1 commit, 2 files changed)
    • player processinfo: set higher precision for FPS and DAR (PR:10077, 1 commit, 1 file changed)
    • VideoPlayer: Remove usused variables (PR:10084, 1 commit, 2 files changed)
    • [xbmc][fix] Fix theme xbt loading that broke during cleanup.in #9960 (PR:10073, 1 commit, 5 files changed)
    • mmaldec: Enable zero copy on decoder input buffers (PR:10085, 1 commit, 1 file changed)
    • [addons] repository code cleanup (PR:10059, 5 commits, 8 files changed)
    • [cmake/cpluff] Add generated artefacts to .gitignore (PR:10089, 1 commit, 1 file changed)
    • Revert "vdpau: refcount decoder with surfaces given to ffmpeg, align with vaa…" (PR:10092, 1 commit, 2 files changed)
  2. inputstream.mpd:
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I´d like to test this Version because of the HEVC support to watch some material with my new 4K TV and I´m still on openelec 6.0.3 and I like to know if I have to do a fresh install or can I just use the update file?
(2016-07-09, 10:07)ugotit Wrote: I´d like to test this Version because of the HEVC support to watch some material with my new 4K TV and I´m still on openelec 6.0.3 and I like to know if I have to do a fresh install or can I just use the update file?

Yes, you can update OE 6.0.3 by dropping the tar file into the Update folder and rebooting.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Is someone also having problems with opensubtitles in latest 708 build?

http://pastebin.com/njBvcynC
(2016-07-09, 13:24)illiac4 Wrote: Is someone also having problems with opensubtitles in latest 708 build?

http://pastebin.com/njBvcynC

Are you saying you don't have this issue with #0707, and only have it with #0708?
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Opensubtitles never worked for me in any of these builds...
Opensubs working OK for me, and always has. use it for dutch and English subs
But I do have an account with them ever since they inserted ads to their subs.
I'm running a CherryTrail Atom based box and was really happy when you included the fixes to the kernel to enable audio over HDMI - so first of all thank you. However, the nightlies since 4th July do not show HDMI as an available Audio Output Device - so only Bluetooth is available.

It looks to my untrained eye that the 4.7 rc6 Kernel doesn't include the CherryTrail fix for audio.

Any chance of a fix going forward?

Also (being cheeky now) any chance of getting WiFi working with the CherryTrail SoC?
(2016-07-09, 18:23)MadMeddler Wrote: I'm running a CherryTrail Atom based box and was really happy when you included the fixes to the kernel to enable audio over HDMI - so first of all thank you. However, the nightlies since 4th July do not show HDMI as an available Audio Output Device - so only Bluetooth is available.

It looks to my untrained eye that the 4.7 rc6 Kernel doesn't include the CherryTrail fix for audio.

Any chance of a fix going forward?

Also (being cheeky now) any chance of getting WiFi working with the CherryTrail SoC?

Yes you're right, and I should have mentioned the Cherrytrail patch has been dropped as it's not currently compatible with the 4.7 kernel. See PR:481 for details (and reply from piotrasd), as it may return if/when a compatible patch becomes available for the 4.7 kernel.

As for WiFi, if you know of a patch for this chipset and the 4.7 kernel then it could be included. However in the absence of any such patch you may want to treat yourself to a cheap Broadcom/Intel/Ralink USB WiFi dongle...
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Thanks Milhouse, awesome response.

I'll await the final 4.7 kernel, the nightly from 3rd July is working sweetly enough for me for now.

You're right about the WiFi dongle, but it'd be nice to have it all self-contained.
@MadMeddler i will continue Milhouse build for myself with keeping kernel 4.6
so i will send you link where actual build you will can download (im also added there few tweeks for CherryTrail)
That would be great piotrasd.
(2016-07-08, 23:53)Milhouse Wrote: New LibreELEC.tv Krypton build #0708: Generic
  • Revert "vdpau: refcount decoder with surfaces given to ffmpeg, align with vaa…" (PR:10092, 1 commit, 2 files changed)

Milhouse,

I noticed with builds after #703, seems to not exhibit this issue, that with an AMD APU (A6-3500) I noticed over time when watching shows there is tremendous LAG or stutter down the road. I saw this commit was reverted mentioned in the quote hoping it would fix the issue since #703 but no luck. I will try to get a debug log once the wife is done watching her shows but wanted to know if anyone else here experience the issue.

My RPI2/RPI3's aren't affected by the same issue and are running #708 perfectly fine.
@All: what's the state of lirc in these builds after reverting uinput in #0704? I know some of you had gone back to #0619 so may not be testing the latest builds.

I know auto-repeat is still an issue, but are remote control buttons still missing for some users? Or is IR working for everyone now (apart from auto-repeat, which is a separate issue)?

If you still have missing buttons with the latest build, please paste the output of the following command:
Code:
systemctl status | paste

Thanks.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-07-09, 21:45)pyrodex Wrote:
(2016-07-08, 23:53)Milhouse Wrote: New LibreELEC.tv Krypton build #0708: Generic
  • Revert "vdpau: refcount decoder with surfaces given to ffmpeg, align with vaa…" (PR:10092, 1 commit, 2 files changed)

Milhouse,

I noticed with builds after #703, seems to not exhibit this issue, that with an AMD APU (A6-3500) I noticed over time when watching shows there is tremendous LAG or stutter down the road. I saw this commit was reverted mentioned in the quote hoping it would fix the issue since #703 but no luck. I will try to get a debug log once the wife is done watching her shows but wanted to know if anyone else here experience the issue.

My RPI2/RPI3's aren't affected by the same issue and are running #708 perfectly fine.

I'm trying to parse your comment... are you saying you have a problem with builds after #0703 (ie. the problem starts with build #0704)? Or does the problem start with #0703?

PR10092 is reverting PR10075 which first appeared in build #0707 - the latter PR introduced a significant memory leak, which should now no longer be present. Since you say (if I'm reading your post correctly) that the lag/stutter problem started with #0704 (or maybe #0703) then I'm not sure I see any connection between the two PRs (PR10075 and PR10092), unless I've misunderstood your post. Smile

The obvious change in #0704 is the switch to kernel 4.7-rc6. If however you're saying the problem started with #0703, then the obvious change is ffmpeg 3.1.1.

Can you state the issue clearly, and when it first started. A debug log would be very useful.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
  •   
  • 1
  • 73
  • 74
  • 75(current)
  • 76
  • 77
  • 187
  •   
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111