TVDB are updating their site. Their site currently has a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are working to rectify the problems.

  •   
  • 1
  • 86
  • 87
  • 88(current)
  • 89
  • 90
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
(2016-07-13, 13:12)mr_hunter Wrote: Posted my config in this thread :

282059 (thread)
Thanks!

Could you also upload a kodi debug log where you press non-working keys?

so long,

Hias
(2016-07-13, 13:08)popcornmix Wrote:
(2016-07-13, 12:42)loggio Wrote: the spotify music addon is not working in latest nightlies.

Does it work if you revert to an older milhouse build? Can you identify the first build with the issue?

yes, narrowed it down.... Problem starts at #0619 2361114 (post)


EDIT**

ok so I've gone ahead and deleted my addon.db file and rebooted, enabling just the Spotify addon and it's now working correctly... so something was breaking this
i'll see how I go. Thanks and sorry for the false alarm.

Cheers,
Loggio.
(2016-07-13, 13:31)HiassofT Wrote:
(2016-07-13, 13:12)mr_hunter Wrote: Posted my config in this thread :

282059 (thread)
Thanks!

Could you also upload a kodi debug log where you press non-working keys?

so long,

Hias

If you tell me where i can find it Big Grin
(2016-07-13, 14:31)mr_hunter Wrote:
(2016-07-13, 13:31)HiassofT Wrote: Could you also upload a kodi debug log where you press non-working keys?
If you tell me where i can find it Big Grin
Enable debug logging as described here: Log_file/Advanced (wiki)
Then reboot
Press a few working and non-working keys on your remote
Ssh into the RPi and run the following command
Code:
cat /storage/.kodi/temp/kodi.log | paste
Post the URL you got from the command.

so long,

Hias
(2016-07-13, 11:54)HiassofT Wrote: Thanks a lot to all of you who posted details about their remote problems! This is valuable info and helps us a lot.

Now a question to all other lirc_rpi users:

If lirc_rpi is working fine for you on the latest Milhouse builds please let us know. The type of remote and the lircd.conf file (if you set it up manually) would be helpful.

so long,

Hias

I updated from #701 to #712 and my remote is working fine. It's an Emprex 3009URF https://www.amazon.co.uk/Emprex-3009URF-...B002A8HEFY

On the downside, TVheadend isn't seeing my DVB-T dongle after updating to #712 but I've had ongoing problems with that forever and have pretty much given up on using my RPi for TV.

I did have to manually configure the Lircmap.xml and remote.xml files when I first installed OE ages ago but I don't think I've ever touched lircd.conf and I'm not sure where that would be.

I actually stopped using the Emprex remote a while ago though, as I found the dongle was causing stutters when watching video, so perhaps it was sending some interrupt or something but I had no idea how to fix it so I had to settle for using my TV's CEC remote, which isn't ideal as it's pretty much limited to just the Directional Pad but it's better than stuttering video!

EDIT: In my lircmap.xml I have <select>KEY_OK</select> and <select>KEY_ENTER</select>. I think I found whatever I used originally stopped working after one build, so I probably added the other line and left them both there just in case it changed back again.
(2016-07-13, 13:08)HiassofT Wrote:
(2016-07-13, 12:51)dias0 Wrote: I change the KEY_OK with KEY_ENTER in lircd.conf and key ok on remote working now.
Tested with build #712 Rpi 3
Thanks, this is extremely helpful info!

Could you please upload a kodi debug log where you press the OK button? One log with OK mappped to KEY_OK and another one with OK mapped to KEY_ENTER would be great.

so long,

Hias

debug log OK mappped to KEY_OK http://sprunge.us/LASO
debug log OK mapped to KEY_ENTER http://sprunge.us/bBYM
(2016-07-13, 13:43)loggio Wrote:
(2016-07-13, 13:08)popcornmix Wrote:
(2016-07-13, 12:42)loggio Wrote: the spotify music addon is not working in latest nightlies.

Does it work if you revert to an older milhouse build? Can you identify the first build with the issue?

yes, narrowed it down.... Problem starts at #0619 2361114 (post)


EDIT**

ok so I've gone ahead and deleted my addon.db file and rebooted, enabling just the Spotify addon and it's now working correctly... so something was breaking this
i'll see how I go. Thanks and sorry for the false alarm.

Cheers,
Loggio.

Ok this is weird, if I deleted my addon.db and my ADS0.db then the spotify addon works. Then I go and manually enable a few addons and test spotify again and it's still working.

If i ssh to the RPi and do a killall -9 kodi.bin
Then try spotify it will break again.


It's as if either the ADSP0.db or ADDON.db is causing the issue
(2016-07-13, 12:51)dias0 Wrote:
(2016-07-13, 11:54)HiassofT Wrote: Thanks a lot to all of you who posted details about their remote problems! This is valuable info and helps us a lot.

Now a question to all other lirc_rpi users:

If lirc_rpi is working fine for you on the latest Milhouse builds please let us know. The type of remote and the lircd.conf file (if you set it up manually) would be helpful.

so long,

Hias
Hi
I change the KEY_OK with KEY_ENTER in lircd.conf and key ok on remote working now.
Tested with build #712 Rpi 3

just followed diass0's infos and can confirm it works with most recent build
New LibreELEC.tv Krypton build #0713: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.7.0-rc7 #1 Wed Jul 13 21:46:13 BST 2016 armv6l GNU/Linux

# vcgencmd version
Jul  8 2016 14:34:25
Copyright (c) 2012 Broadcom
version f9e71a2b696c48a14756c1e756f3cda6d6f87a07 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20160713214428-#0713-ga99b0e6 [Build #0713]

# vcdbg log msg 2>&1 | grep DTOK
002385.470: Kernel trailer DTOK property says yes

# Kernel device tree status: Enabled

Based on tip of LibreELEC.tv master (a99b0e68, changelog) and tip of XBMC master (dfe31edd, changelog) with the following modifications: Build Highlights:
  1. Update ffmpeg 3.1.1 commit
  2. Display progress information during database migrations
Build Details:
  1. LibreELEC.tv:
    • projects/imx6: update kodi patch (beautified for next kodi updates) (PR:536, 1 commit, 1 file changed)
  2. XBMC:
    • Fix out of memory crash in CArchive (PR:9225, 3 commits, 10 files changed)
    • IPlayer: properly sync playspeed with application (PR:10103, 4 commits, 18 files changed)
    • [OverlayRendererDX] Fix rendering overlays in TAB/SBS modes. (PR:10105, 1 commit, 1 file changed)
    • [D3D11] Hack to fix refresh rate issue in full screen exclusive mode. (PR:10083, 2 commits, 4 files changed)
    • Update usage of Crc32 after changing methods to static (PR:10107, 1 commit, 4 files changed)
  3. newclock5:
    • New commits in this build:
      • mmalrenderer: Execute callbacks from dedicated thread (9c7a46ab)
      • mmal: Remove renderer pointer from codecs (4b60091c)
      • mmalrender: Configure mmal lazily as packets are received (ca7d9d10)
      • mmalrender: Include dimensions in init_vout (4b67854f)
    • Commits no longer in build:
      • VideoPlayer: continue normal playback if seek fails (2ab6be44)
      • mmalrenderer: Execute callbacks from main thread (54f7015e)
      • mmalcodec: Add interlace state to mmal video buffer (e3361c56)
      • MMAL: Remove renderer pointer from codecs (c87ad6dd)
      • MMALRender: Configure mmal lazily as packets are received (3ef2af1b)
  4. Additional commits/pull requests/changes not yet merged upstream:
    • Updated: [env] patch: ffmpeg: bump 3.1.1
    • Added: [env] PR:537: kodi: database migration splash text
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I noticed a nasty bug - sometimes when I switch from Kodi's GUI to an HD TV channel, I get a lot of frame skips. If I go to Video settings and switch the deinterlacing off and the on again (or switch the deinterlace methods back and forth) - the frame skips are gone.

This issue seems to be present in most recent builds. Not sure which is the last good one. There is definitely no such issue in build #0625.
(2016-07-13, 11:54)HiassofT Wrote: Thanks a lot to all of you who posted details about their remote problems! This is valuable info and helps us a lot.

Now a question to all other lirc_rpi users:

If lirc_rpi is working fine for you on the latest Milhouse builds please let us know. The type of remote and the lircd.conf file (if you set it up manually) would be helpful.

so long,

Hias
Changing KEY_OK to KEY_ENTER worked for mine. Hauppauge 45 button remote on RPi 1 B custom lircd.conf, LibreELEC 7.90.003 (alpha 2) with Kodi 17.

All the buttons seemed to work except OK.

new lircd.conf at
http://sprunge.us/aPee
I ran into an interesting issue today - I was playing a 3D MVC ISO file that I ripped from my Blu-ray disk, and after being able to successfully play for a while, it abruptly stopped with about 25 minutes of the movie left (turns out that it stopped at the beginning of a new chapter). After trying to play that part multiple times with no success, I converted the ISO to an MKV (using makemkv) and I was able to play past the part where it had stopped earlier on VLC. When I try playing this file on Kodi, it plays fine but I can't fast forward/rewind/seek through the movie. The TV screen shows the frame for that second but remains stuck in that screen while the info bar shows that the movie is continuing to play. Is this a known issue?
(2016-07-14, 04:10)donbrew Wrote:
(2016-07-13, 11:54)HiassofT Wrote: Thanks a lot to all of you who posted details about their remote problems! This is valuable info and helps us a lot.

Now a question to all other lirc_rpi users:

If lirc_rpi is working fine for you on the latest Milhouse builds please let us know. The type of remote and the lircd.conf file (if you set it up manually) would be helpful.

so long,

Hias
Changing KEY_OK to KEY_ENTER worked for mine. Hauppauge 45 button remote on RPi 1 B custom lircd.conf, LibreELEC 7.90.003 (alpha 2) with Kodi 17.

All the buttons seemed to work except OK.

new lircd.conf at
http://sprunge.us/aPee

Changed KEY_OK to KEY_ENTER and it works for me as well. XBOX ONE REMOTE.
But it seems that some Keys also won't work for me:
KEY_LIST
KEY_CONTEXT_MENU
KEY_CHANNELUP
KEY_CHANNELDOWN
anyone else the same problems?
Running Pi2 with HifiBerry Digi and RemotePiBoard and XBOX ONE Remote
(2016-07-13, 10:55)hawkeyexp Wrote: Since 0618 i have some bugs with mce remote via gpio ir-receiver - up down left right etc. are working - ok fails...
Me too. Change KEY_OK to KEY_ENTER: same problem.
My custom lircd.conf here:

begin remote

name /storage/.config/lircd.conf
bits 16
flags SPACE_ENC|CONST_LENGTH
eps 30
aeps 100

header 9120 4484
one 591 1684
zero 591 543
ptrail 586
repeat 9105 2240
pre_data_bits 16
pre_data 0x10EF
gap 108146
toggle_bit_mask 0x0

begin codes
KEY_POWER 0x50AF
KEY_MUTE 0xB04F
KEY_INFO 0x06F9
KEY_VIDEO 0x8679
KEY_AUDIO 0x6699
KEY_UP 0x00FF
KEY_DOWN 0x807F
KEY_ENTER 0xF807
KEY_RIGHT 0x40BF
KEY_LEFT 0xC03F
KEY_BACK 0x38C7
KEY_HOME 0x30CF
KEY_MENU 0x58A7
KEY_VOLUMEUP 0x1AE5
KEY_VOLUMEDOWN 0xBA45
KEY_STOP 0xD02F
KEY_PLAYPAUSE 0xE01F
KEY_NEXT 0x26D9
KEY_PREVIOUS 0xC639
KEY_ESC 0x48B7
end codes

end remote
(2016-07-14, 12:39)sleuth Wrote:
(2016-07-14, 04:10)donbrew Wrote:
(2016-07-13, 11:54)HiassofT Wrote: Thanks a lot to all of you who posted details about their remote problems! This is valuable info and helps us a lot.

Now a question to all other lirc_rpi users:

If lirc_rpi is working fine for you on the latest Milhouse builds please let us know. The type of remote and the lircd.conf file (if you set it up manually) would be helpful.

so long,

Hias
Changing KEY_OK to KEY_ENTER worked for mine. Hauppauge 45 button remote on RPi 1 B custom lircd.conf, LibreELEC 7.90.003 (alpha 2) with Kodi 17.

All the buttons seemed to work except OK.

new lircd.conf at
http://sprunge.us/aPee

Changed KEY_OK to KEY_ENTER and it works for me as well. XBOX ONE REMOTE.
But it seems that some Keys also won't work for me:
KEY_LIST
KEY_CONTEXT_MENU
KEY_CHANNELUP
KEY_CHANNELDOWN
anyone else the same problems?
Running Pi2 with HifiBerry Digi and RemotePiBoard and XBOX ONE Remote

Changing KEY_OK to KEY_ENTER is working for me with mxe remote.

For example
KEY_LIST
KEY_CONTEXT_MENU
KEY_CHANNELUP
KEY_CHANNELDOWN
COLOR BUTTONS
* and #
are still not working with build 0713
  •   
  • 1
  • 86
  • 87
  • 88(current)
  • 89
  • 90
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319