TVDB are updating their site. Their site currently has a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are working to rectify the problems.

  •   
  • 1
  • 117
  • 118
  • 119(current)
  • 120
  • 121
  • 187
  •   
  Thread Closed
v17 LibreELEC Testbuilds for x86_64 (Kodi 17.0)
(2016-09-03, 03:11)nuc-LE Wrote: Milhouse is this patch bad for other users or there is a better fix in the works?

See post #1757 from _Spook_, and my reply.

The Chris Wilson patch will return tonight in #0903.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
I have a little Problem, with mp3-radiostreams (Internetradio) For Example: http://stream04.iloveradio.de/iloveradio2.mp3


Kodi crashed and restart.

Log:
http://pastebin.com/Jd1Ed8E5

Do you need other Information?
No (thanks), it's a known issue - got enough logs. Currently looking into it, but started with #0827, probably PR10236.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-08-17, 17:26)n2vwz Wrote: “Key Repeat” is no longer functional on the Skip Forward and Skip Backward keys:

Left Arrow (←) and Right Arrow (→)

This problem affects USB Keyboards in addition to Remote Controls.

The problem started with build #0729 and continues with current builds. I believe that this is the result of recently added “Long-Press” features disabling “key repeat” for these two keys.

The Long-Press feature changes the key function from skip forward with auto-repeat to 2X fast forward (or Rewind). The feature was intended for low cost Android Boxes with low key count remote controls that do not have Fast Forward and Rewind keys.

Skip Forward and Skip Back with auto-repeat are important functions that should not have been eliminated by the inclusion of “Long-Press” code.

This is a request to restore the previous functionality by removing or provide a simple method of disabling “Long-Press” code.

I'm the one that previously added that and I wanted to clarify some things.

1) The default was adapted for the sake of more common use-cases. The default skipsteps feature makes key-repeat on left/right unpractical, so I'm not sure why you are complaining about something that you could have still changed for your own use case.

2) Android boxes have nothing to do with it. The behavior is taken from the Apple remote (which is popular and used on all the platforms), and it used long-press on right/left for ff/rw since before 2010. (The Apple remote had long-press functionality because it sent a different IR signal when the button was held, hence not needing an XBMC/Kodi-specific feature for the action). We've had years of feedback on that behavior, and it was overwhelmingly positive.

That being said, I'm find with yielding to caution. Changing default keymaps is a tricky business, and it's hard to make everyone happy. I really just wanted to point out that it wasn't Android that inspired this particular change ;)
(2016-09-03, 10:35)Milhouse Wrote: No (thanks), it's a known issue - got enough logs. Currently looking into it, but started with #0827, probably PR10236.

OK, no Problem Shy
(2016-09-03, 07:01)Milhouse Wrote:
(2016-09-03, 03:11)nuc-LE Wrote: Milhouse is this patch bad for other users or there is a better fix in the works?

See post #1757 from _Spook_, and my reply.

The Chris Wilson patch will return tonight in #0903.

Removing the patch fixed my problem.

From what I understand the patch is for a 1080p problem? Since I use 4k does this patch take that in mind or just for 1080p and lower?
AppleTV 4K, LG 65E6 OLED TV, Marantz NR1606, Harmony Elite
Internet radio streaming issues (crashes etc.) should be fixed in tonight's build.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-09-03, 12:41)_Spook_ Wrote: Removing the patch fixed my problem.

From what I understand the patch is for a 1080p problem? Since I use 4k does this patch take that in mind or just for 1080p and lower?

Interesting. Hopefully @fritsch can pass on the information to Chris Wilson.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
With #0902 I have no vaapi deinterlace modes in the Video Options. (vaapi is active in the System Settings)
(2016-09-03, 13:51)Milhouse Wrote:
(2016-09-03, 12:41)_Spook_ Wrote: Removing the patch fixed my problem.

From what I understand the patch is for a 1080p problem? Since I use 4k does this patch take that in mind or just for 1080p and lower?

Interesting. Hopefully @fritsch can pass on the information to Chris Wilson.

His TV most likely only works when in 10 bit mode ... file a bug with the intel people as it is specific to your hardware and it needs to be fixed properly upstream.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
@spock: Use this bugreport: https://bugs.freedesktop.org/show_bug.cgi?id=97442 and tell that you have issues with your 10bit (whatever) TV when the patch from chris is applied as they want to backport that to stable branch.

For the "frameskips" issues: they need to calculate proper modelines when in 10 bit mode ... so two issues that arrised for upstream.

Now, everyone acts sane, provides logfiles and I hope upstream can figure it out :-)
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
(2016-09-03, 15:21)fritsch Wrote: @spock: Use this bugreport: https://bugs.freedesktop.org/show_bug.cgi?id=97442 and tell that you have issues with your 10bit (whatever) TV when the patch from chris is applied as they want to backport that to stable branch.

For the "frameskips" issues: they need to calculate proper modelines when in 10 bit mode ... so two issues that arrised for upstream.

Now, everyone acts sane, provides logfiles and I hope upstream can figure it out :-)
Thanks. I have filed a report in that thread.

Just put the patch in. I can just stick with a build I know works and test if needed.
AppleTV 4K, LG 65E6 OLED TV, Marantz NR1606, Harmony Elite
You missed all the kernel logs with drm.debug=0xe upstream won't boot le...
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
_Spook_ , yes please provide dmesg log with drm.debug=0xe enabled. I think the reason you're seeing the bug is because your system uses a non-standard pipeline setup. You have a DP->HDMI adapter somewhere in your chain - possibly on the motherboard.

I already reported the frame skip bug to Intel a few weeks ago (as part of the 44.1 kHz audio bug). The reason people get frame drops on 29.97fps content without the patch is because this mode switches your display to 59.940Hz for proper playback. Unfortunately, 59.940 is actually running at 59.89 without the patch, thus skipping a frame every 21 seconds. Funny this kernel bug has been there since late 2015 and nobody noticed till now? Guess most people play 24 fps content only or use audio resampling instead of passthrough.
Ok. Will try and get those logs. Never tried to get them with those parameters. How do I enable that? I linked to the DMESG logs I already made in here in the bugreport.

I know there is a chip in there and they have a plan for a driver in the kernel for support. I have reported a problem with that before:
https://bugs.freedesktop.org/show_bug.cgi?id=96382

They made a patch for that:
https://patchwork.freedesktop.org/series/8024/

And yes I use resampling also since passthrough has always caused audio out of sync issues.
AppleTV 4K, LG 65E6 OLED TV, Marantz NR1606, Harmony Elite
  •   
  • 1
  • 117
  • 118
  • 119(current)
  • 120
  • 121
  • 187
  •   
  Thread Closed
 
Thread Rating:
  • 11 Vote(s) - 3.91 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for x86_64 (Kodi 17.0)3.9111