•   
  • 1
  • 54
  • 55
  • 56(current)
  • 57
  • 58
  • 70
  •   
[RELEASE] Flix2Kodi - Just another Netflix-Addon
Not sure what I'm missing. Installed this addon today, installed chrome and logged in to Netflix through my browser. Then I put in my email and password in and selected Chrome in the addon settings.The addon won't even launch. I've tried rebooting, but it still throws an error. I'm sure I'm just missing something small.
Log file here: https://pastebin.ubuntu.com/23242602/
Reply
(2016-09-17, 04:29)charl.gale Wrote: I seem to have managed to break something somewhere during a reinstall
could someone please help or point me to where I could find the answer
regards
charl


ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type: <type 'exceptions.ImportError'>
Error Contents: DLL load failed: The specified module could not be found.
Traceback (most recent call last):
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\addon.py", line 10, in <module>
from resources import general
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\general.py", line 7, in <module>
import add
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\add.py", line 10, in <module>
from resources import library
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\library.py", line 9, in <module>
import get
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\get.py", line 18, in <module>
from resources import connect, video_parser
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\connect.py", line 15, in <module>
from resources import chrome_cookie
File "C:\Users\mediapc\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\chrome_cookie.py", line 16, in <module>
import win32crypt
ImportError: DLL load failed: The specified module could not be found.
-->End of Python script error report<--

(2016-09-17, 09:10)MaximusMJ Wrote: are you using windows?
you seem to be missing win32crypt... maybe do a reinstall, or download it (from github?)... I don't know, maybe that helps.

I myself got this error:
http://paste.ubuntu.com/23188007/
I've googled it, but it seems others having the same problem with 0.6.6 ..... Reinstalled it, don't know to fix it... Maybe an update will do it... I hope.

(2016-09-27, 17:15)dkplayaclub Wrote: Not sure what I'm missing. Installed this addon today, installed chrome and logged in to Netflix through my browser. Then I put in my email and password in and selected Chrome in the addon settings.The addon won't even launch. I've tried rebooting, but it still throws an error. I'm sure I'm just missing something small.
Log file here: https://pastebin.ubuntu.com/23242602/

Ran into the same issue of win32crypt not functoning on 2 Windows 10 boxes running 17.2. Dropped one back to 16.1 and worked. This would point to an issue with python in the Windows build on 17.2 but don't have the machines or time to confirm. If the OS and Kodi versions that the plugin works under can be confirmed we might have a bug to submit.
Reply
hey guys, is there a way to export the whole netflix database as .strm files? If not, can I somewhere see what has being added/removed from Netflix on a daily basis?
Reply
As Roman mentions in my pull request: https://github.com/logi85/plugin.video.f...di/pull/55 it seems that Netflix is using more of localstorage than cookies. This is beyond what I've dug into so I don't know how to proceed (and a bit low on time)
Reply
Any luck getting this to work on RPi?
Reply
Thought I would give this ago as I was feeling bored, but unfortunetely it is not working

https://pastebin.com/C4c6tFSL

Sorry about the size but I have a rather large library, any help gratefully appreciated.
My system details are in my signature below.
Reply
For anyone else that happens to run into the repo being "empty" and/or not seeing the addon after installing the repo - it's very likely that the addon is flagged as incompatible, and that in the context menu you have "Hide Incompatible Addons" enabled. As I just spent 15 minutes trying to dig that one out. My guess is since I've had Kodi installed since before it was Kodi, the Python dependency is outdated.

Just figured I'd save the one or two souls who googled their way here.
Reply
(2016-10-05, 01:42)Shadowrunner Wrote: For anyone else that happens to run into the repo being "empty" and/or not seeing the addon after installing the repo - it's very likely that the addon is flagged as incompatible, and that in the context menu you have "Hide Incompatible Addons" enabled. As I just spent 15 minutes trying to dig that one out. My guess is since I've had Kodi installed since before it was Kodi, the Python dependency is outdated.

Just figured I'd save the one or two souls who googled their way here.

Or maybe the version of Kodi you are using is no longer compatible, I'm using Kodi 17 Beta 3 and I have no problem in seeing this addon.
Oh and Hide Incompatible Addons is always enable.
Reply
(2016-10-05, 01:52)Pasado Wrote:
(2016-10-05, 01:42)Shadowrunner Wrote: For anyone else that happens to run into the repo being "empty" and/or not seeing the addon after installing the repo - it's very likely that the addon is flagged as incompatible, and that in the context menu you have "Hide Incompatible Addons" enabled. As I just spent 15 minutes trying to dig that one out. My guess is since I've had Kodi installed since before it was Kodi, the Python dependency is outdated.

Just figured I'd save the one or two souls who googled their way here.

Or maybe the version of Kodi you are using is no longer compatible, I'm using Kodi 17 Beta 3 and I have no problem in seeing this addon.
Oh and Hide Incompatible Addons is always enable.

I'dlove to believe it, but i literally just updated to the latest release. If it's not compatible with -the- latest release, we're kind of in a pickle. Anyways, here's my pastelog when I try to install it manually - for some reason it's trying to open some other zip? really weird...

http://pastebin.com/KZDuhaXE

EDIT: Eh, despite it throwing some jabber, it did manually install. Still shows up as incompatible in the repo list though - just now i can configure it.
Reply
(2016-10-05, 02:13)Shadowrunner Wrote:
(2016-10-05, 01:52)Pasado Wrote:
(2016-10-05, 01:42)Shadowrunner Wrote: For anyone else that happens to run into the repo being "empty" and/or not seeing the addon after installing the repo - it's very likely that the addon is flagged as incompatible, and that in the context menu you have "Hide Incompatible Addons" enabled. As I just spent 15 minutes trying to dig that one out. My guess is since I've had Kodi installed since before it was Kodi, the Python dependency is outdated.

Just figured I'd save the one or two souls who googled their way here.

Or maybe the version of Kodi you are using is no longer compatible, I'm using Kodi 17 Beta 3 and I have no problem in seeing this addon.
Oh and Hide Incompatible Addons is always enable.


I'dlove to believe it, but i literally just updated to the latest release. If it's not compatible with -the- latest release, we're kind of in a pickle. Anyways, here's my pastelog when I try to install it manually - for some reason it's trying to open some other zip? really weird...

http://pastebin.com/KZDuhaXE

EDIT: Eh, despite it throwing some jabber, it did manually install. Still shows up as incompatible in the repo list though - just now i can configure it.

Not sure why the zip file is in your main Kodi folder (C:\Program Files (x86)\Kodi\plugin.video.flix2kodi-0.6.6.zip) though? If you install it with the addon browser it will instal to your userdata fold
Reply
@logi85 any idea when or if this can be fixed?
Reply
@Pasado - that's because i put it there manually to try a manual install. Since the repo is showing incompatible due to dependencies (and the logs do not show anything about missing dependencies), I figured I'd just try a manual install to see what it would throw as an error - sadly, it didn't error. So I'm a bit confused :/
Reply
(2016-10-05, 02:47)Shadowrunner Wrote: @Pasado - that's because i put it there manually to try a manual install. Since the repo is showing incompatible due to dependencies (and the logs do not show anything about missing dependencies), I figured I'd just try a manual install to see what it would throw as an error - sadly, it didn't error. So I'm a bit confused :/

It hasn't worked since the update a month ago.
Reply
Ok well progress seems to have stopped both here on the GitHub, I'm hoping that this is not the end of Flix2Kodi.

Just a thought guys, have any of you devs spoken to the Netflix devs on GitHub to try to get this fixed?

Some links that might help (or not):
Reply
same here on kodi krypton beta 3

Code:
13:48:24 T:4104   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.ImportError'>
                                            Error Contents: DLL load failed: Le module sp�cifi� est introuvable.
                                            Traceback (most recent call last):
                                              File "C:\Users\Administrateur\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\addon.py", line 10, in <module>
                                                from resources import general
                                              File "C:\Users\Administrateur\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\general.py", line 7, in <module>
                                                import add
                                              File "C:\Users\Administrateur\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\add.py", line 10, in <module>
                                                from resources import library
                                              File "C:\Users\Administrateur\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\library.py", line 9, in <module>
                                                import get
                                              File "C:\Users\Administrateur\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\get.py", line 18, in <module>
                                                from resources import connect, video_parser
                                              File "C:\Users\Administrateur\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\connect.py", line 15, in <module>
                                                from resources import chrome_cookie
                                              File "C:\Users\Administrateur\AppData\Roaming\Kodi\addons\plugin.video.flix2kodi\resources\chrome_cookie.py", line 16, in <module>
                                                import win32crypt
                                            ImportError: DLL load failed: Le module sp�cifi� est introuvable.
                                            -->End of Python script error report<--
Reply
  •   
  • 1
  • 54
  • 55
  • 56(current)
  • 57
  • 58
  • 70
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Flix2Kodi - Just another Netflix-Addon8
This forum uses Lukasz Tkacz MyBB addons.