•   
  • 1
  • 55
  • 56
  • 57(current)
  • 58
  • 59
  • 176
  •   
  Thread Closed
WIP Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread
Ok thanks ill let you know tomorrow what happens as i changed them all on ember yesterday.
I hit a bug yesterday that I thought I'd pass along in case it hasn't been seen before. I'm currently running 1.4.8.0a23 (x64). I have a TV show where multiple episodes are combined within a single file. For example, Star Trek TNG Season 1, Episodes 1 and 2 are part of a single file.

I have Ember setup to update the file names to insert the episode name at the end of the file.

In this case I originally named the file Star Trek - The Next Generation S01E01E02.mkv. When I updated my library, Ember saw the original file and renamed it to Star Trek - The Next Generation S01E01E02 - Encounter at Farpoint (1) - Encounter at Farpoint (2).mkv. However, it didn't update the database entries with the new filename.

The next time I ran a library update, it created a second entry of the episodes in the database, this one with the new filename, while leaving the original, now incorrect, entry in the database.
(2016-10-13, 18:48)FordPrefect138 Wrote: I hit a bug yesterday that I thought I'd pass along in case it hasn't been seen before. I'm currently running 1.4.8.0a23 (x64). I have a TV show where multiple episodes are combined within a single file. For example, Star Trek TNG Season 1, Episodes 1 and 2 are part of a single file.

I have Ember setup to update the file names to insert the episode name at the end of the file.

In this case I originally named the file Star Trek - The Next Generation S01E01E02.mkv. When I updated my library, Ember saw the original file and renamed it to Star Trek - The Next Generation S01E01E02 - Encounter at Farpoint (1) - Encounter at Farpoint (2).mkv. However, it didn't update the database entries with the new filename.

The next time I ran a library update, it created a second entry of the episodes in the database, this one with the new filename, while leaving the original, now incorrect, entry in the database.

I've seen the same bug with movies on an installations of my friend, but I can't explain why the renamer now has this bug...
Looks like the renamer rename the file but don't update the path for the database. I will check that later again.
This use case - multiple episodes combined into a single file - is the only time I've run into this. The other use case - single episode in a single file - seems to be working just fine. I've had dozens of these cases lately and haven't hit a single one with this problem. Let me know if there's any logs that I can pull for you as I would be glad to do so.
I don't know if it's already reported but with the last Alpha 23 the "Rename Feature" doesn't work proper for me.

If I auto-rename a movie, the file will be renamed, but not the folder. EMM show a error message that the file was not found and I need to update library, remove the old entry and auto-rename again the new entry for the correct folder name.
(2016-10-17, 18:48)archiv Wrote: I don't know if it's already reported but with the last Alpha 23 the "Rename Feature" doesn't work proper for me.

If I auto-rename a movie, the file will be renamed, but not the folder. EMM show a error message that the file was not found and I need to update library, remove the old entry and auto-rename again the new entry for the correct folder name.

Please upload the full log file (.\Ember Media Manager\Log\DATE.csv) to pastebin.com.
Minor request: genre mapping.

Right now, some of my movies are coming in as "Science Fiction" and "Science-Fiction", whereas I'd like them all to be mapped to "Sci-Fi".
Bug 
Using 1.4.8.0 Alpha 23 x64:
  • Manually editing: after saving, everything in the columns is tabbed over, looks like it's reading the XML and not Trim()-ing the string element values properly.
  • Unable to process movie http://www.imdb.com/title/tt5629150/
  • Renamer module: inconsistent, shows year even when the folder pattern doesn't request it. Differing behaviors with Sort Title set or not.
    • Movie Name: The Terminal
    • Movie Year: 2004
    • Desired Result: Terminal, The (2004)
    • Empty Sort Title, Folder Pattern set to: $E => Terminal, The (2004) correct
    • Empty Sort Title, Folder Pattern set to: $E ($Y) => Terminal, The (2004) (2004) incorrect
    • Sort Title Set, Folder Pattern set to: $E => Terminal, The incorrect
    • Sort Title Set, Folder Pattern set to: $E ($Y) => Terminal, The (2004) correct
(2016-10-18, 20:41)fnwc Wrote: Minor request: genre mapping.

Right now, some of my movies are coming in as "Science Fiction" and "Science-Fiction", whereas I'd like them all to be mapped to "Sci-Fi".

Use the Genre Manager in Tools => Genre Manager.
(2016-10-18, 21:10)DanCooper Wrote:
(2016-10-18, 20:41)fnwc Wrote: Minor request: genre mapping.

Right now, some of my movies are coming in as "Science Fiction" and "Science-Fiction", whereas I'd like them all to be mapped to "Sci-Fi".

Use the Genre Manager in Tools => Genre Manager.

Ah thanks, didn't see that. I was looking in Settings => Genre Manager.
(2016-10-18, 22:16)fnwc Wrote:
(2016-10-18, 21:10)DanCooper Wrote:
(2016-10-18, 20:41)fnwc Wrote: Minor request: genre mapping.

Right now, some of my movies are coming in as "Science Fiction" and "Science-Fiction", whereas I'd like them all to be mapped to "Sci-Fi".

Use the Genre Manager in Tools => Genre Manager.

Ah thanks, didn't see that. I was looking in Settings => Genre Manager.

Has been moved out of settings. Do not make sense to goto settings only to manage genres.
(2016-10-17, 21:31)DanCooper Wrote:
(2016-10-17, 18:48)archiv Wrote: I don't know if it's already reported but with the last Alpha 23 the "Rename Feature" doesn't work proper for me.

If I auto-rename a movie, the file will be renamed, but not the folder. EMM show a error message that the file was not found and I need to update library, remove the old entry and auto-rename again the new entry for the correct folder name.

Please upload the full log file (.\Ember Media Manager\Log\DATE.csv) to pastebin.com.

http://pastebin.com/zGE0dbH4
ver 1.4.8.0 Alpha 23 x86
I keep getting "Value cannot be null. Parameter name: path1" when trying to export Movie/TV list.
I have set the path for the export to several different directories including c:\ but to no avail. Is this something that can be tweaked in a .cfg/.xml or does this require deeper workings?
(2016-10-25, 19:11)Hecatonchieres Wrote: ver 1.4.8.0 Alpha 23 x86
I keep getting "Value cannot be null. Parameter name: path1" when trying to export Movie/TV list.
I have set the path for the export to several different directories including c:\ but to no avail. Is this something that can be tweaked in a .cfg/.xml or does this require deeper workings?

I forgot to integrate the templates into the installer Big Grin
If you updated from an older version, just move the folders inside .\Ember Media Manager\Langs\html to .\Ember Media Manager\Modules\Templates and delete the html folder.
I've you don't have the old files, get it from here and extract the folder to .\Ember Media Manager\Modules.
That fixed the scanning!
But now it only appears to dump the index.html to the C:\Ember Media Manager BETA\Temp\Export directory.
Also, is TV series output not implemented yet? I only get Movie out put.

Thanks for the great work as always ! ! !


*** I started a "Generate HTML" export with a ModernWallCard template and it is currently dumping images for TV series.
*** I will update as to whether it updates the html or not when it finishes... Will be at least an hour lol...
  •   
  • 1
  • 55
  • 56
  • 57(current)
  • 58
  • 59
  • 176
  •   
  Thread Closed
 
Thread Rating:
  • 2 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Ember Media Manager 1.4.8.0 ALPHA - Discussion Thread52