•   
  • 1
  • 183
  • 184
  • 185(current)
  • 186
  • 187
  • 218
  •   
  Thread Closed
v17 LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)
I just updated to #1030 and I've got Kodi crashing on a library refresh with a new movie every time now. Since I used the LibreELEC build-in updater, I can't exactly tell from which version I came, but it will be one from a week or two ago.
By Kodi crashing I mean that the progress indicator hangs for a bit and then the screen goes black for a while, just until Kodi automagically boots again.

Anyone else experiencing this?
Does there happen to be a crash log generated somewhere by any chance?
MECOOL KIII Pro (S912)
Raspberry Pi 2 Model B, overclock mode: 'Pi2' (1000/500/500/2), gpu_mem_1024: '320'
(2016-10-31, 18:47)_Owl_ Wrote: since 3D playback of MVC streams are already working beautifully from MKVs and ISOs, is there any chance for a setting to switch left eye and right eye channel? Several movies have left and right eye swapped (i.e. The Hobbit, Edge of Tomorrow) so one has to wear the glasses wrongly. Big Grin

Yes, bring up the OSD when playing the file and in the 3D menu is option to invert eyes.
(2016-10-31, 18:55)Forage Wrote: I just updated to #1030 and I've got Kodi crashing on a library refresh with a new movie every time now. Since I used the LibreELEC build-in updater, I can't exactly tell from which version I came, but it will be one from a week or two ago.

If #1030 is bad and #1029 is good you are probably hitting the image allocation bug discussed in last few posts. Try again with tonight's build.
(2016-10-31, 19:32)popcornmix Wrote:
(2016-10-31, 18:55)Forage Wrote: I just updated to #1030 and I've got Kodi crashing on a library refresh with a new movie every time now. Since I used the LibreELEC build-in updater, I can't exactly tell from which version I came, but it will be one from a week or two ago.

If #1030 is bad and #1029 is good you are probably hitting the image allocation bug discussed in last few posts. Try again with tonight's build.
Those issues where introduced in last night's build and even though I didn't try #1029, my issue appears to start with #1028 instead. I haven't been able to reproduce it in #1027.

I'll wait for tonight's build either way and see if I can reproduce it. I'll do some more digging then if so.
MECOOL KIII Pro (S912)
Raspberry Pi 2 Model B, overclock mode: 'Pi2' (1000/500/500/2), gpu_mem_1024: '320'
(2016-10-31, 19:52)Forage Wrote: Those issues where introduced in last night's build and even though I didn't try #1029, my issue appears to start with #1028 instead. I haven't been able to reproduce it in #1027.

If kodi is crashing, there should be a crashlog in /storage/.kodi/temp which may narrow down the problem.
New LibreELEC.tv Krypton build #1031: RPi / RPi2
(Supercedes previous build)

Code:
# uname -a
Linux rpi512 4.8.6 #1 Mon Oct 31 21:22:49 GMT 2016 armv6l GNU/Linux

# vcgencmd version
Oct 25 2016 17:02:22
Copyright (c) 2012 Broadcom
version cd1ab218dc23c84d9e6d984385a57f2471600300 (clean) (release)

# lsb_release
LibreELEC (Milhouse) - Version: devel-20161031212148-#1031-gae704a7 [Build #1031]

# Kodi version
Kodi (17.0-BETA6 Git:14124fd). Platform: Linux ARM 32-bit

Based on tip of LibreELEC.tv master (ae704a71, changelog) and tip of XBMC master (14124fd2, changelog) with the following modifications: Build Highlights:
  1. New 4.8.6 kernel
  2. Fix crash when caching images (PR:10828)
  3. Avoid occasional systemd-tmpfiles-setup-dev.service error on startup
Build Details:
  1. XBMC:
    • AudioTrack: Workarounds (PR:10809, 2 commits, 3 files changed)
    • [AMLUtils] Update aml_permissions() to check for RW access to more paths (PR:10822, 1 commit, 1 file changed)
    • [cmake] 2 small fixes related to binary-addon build (PR:10825, 2 commits, 2 files changed)
    • fixed: used av_free when av_freep was intended in f5f9b8d and aadfc21d (PR:10828, 2 commits, 2 files changed)
    • [cmake/android] Attempt to fix binary-addon packaging (PR:10827, 1 commit, 1 file changed)
    • Hide passwords from advancedsettings log (PR:10790, 1 commit, 1 file changed)
    • [PVR] Guide window: Fix responsiveness on first open. (PR:10814, 2 commits, 1 file changed)
    • FIX: [amcs] get proper VideoView size (fixes #17032) (PR:10818, 1 commit, 9 files changed)
    • [xbmc][fix] Make CDirectory::Create create all the needed folders (PR:10811, 1 commit, 6 files changed)
  2. libcec:
    • break on first valid drm edid (PR:262, 1 commit, 1 file changed)
  3. inputstream.rtmp:
    • fix cross compiling on android and linux (PR:8, 1 commit, 2 files changed)
  4. kernel 4.8.y:
    • New commits in this build:
      • bcm2835: Increase coherent allocation to 1M for dwc_otg bounce buffers (73a06907)
      • dwc_otg: Warn if dma_alloc_coherent fails (6abac135)
    • Commits no longer in build:
      • clk: bcm2835: Skip PLLC clocks when deciding on a new clock parent (3513813a)
      • Merge pull request #1699 from notro/bcm270x-multi-1 (7ede3d57)
      • Merge pull request #1700 from notro/raspberrypi-power-1 (d8f7c2da)
  5. Additional commits/pull requests/changes not yet merged upstream:
    • Added: [env] 3c2d1813: linux: update to linux-4.8.6
    • Added: [env] 28bc8bb1: linux: drop Cherry Trail support until fixed up
    • Added: [env] 094361cc: i915: drop Valley View extended HDMI fix - incompatible
    • Added: [env] PR:898: systemd: machine-id.service is required for systemd-tmpfiles-setup-dev.service
    • Added: [pkg] PR:10832: [PVR] Fix local art lookup log spam. pvr recordings never have local art.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
(2016-10-31, 16:46)Aux_ Wrote: Addons menu no longer works, as soon as I with the remote control on Addon menu down scrol crashes kodi and reboot. Addons icons are also not visible.

http://pastebin.com/0A324M3f
http://pastebin.com/k9tG23E3

All seems to work again. except CEC
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on NanoPI M4 ]#[ Nextcloud 16.0.4 @ ODROID C2 ]
(2016-11-01, 02:04)Aux_ Wrote: All seems to work again. except CEC

Can you explain once more what your CEC problem is? I may have missed them, but I can't find any logs relating to your issue. Apparently it's something to do with something being turned on - is this the TV, or the RPi?

Have you seen this issue - do you have any other CEC-enabled devices connected to your TV, such as a PVR etc.? If so, try disconnecting all other CEC-enabled devices leaving only the RPi and TV connected, and see if the problem with the RPi continues.
Texture Cache Maintenance Utility: Preload your texture cache for optimal UI performance. Remotely manage media libraries. Purge unused artwork to free up space. Find missing media. Configurable QA check to highlight metadata issues. Aid in diagnosis of library and cache related problems.
Dear Milhouse and popcornmix, please let me start by thanking you for your dedicated work!

I loaded the current alpha release of LibreELEC on my old Raspberry Pi 1 with the goal of playing media from either Maxdome or Amazon Prime. The required inputstream.md got installed according to the instructions in the first post (
Code:
curl -Ls http://nmacleod.com/public/libreelec/getwidevine.sh | bash
).

The following excerpt of the log was created when trying to play some movie from Amazon using Sandmans' plugin:
Code:
[20:41:39 276.875031 T:1746924448  NOTICE: [Amazon] http://s3.lvlt.dash.eu.aiv-cdn.net/d/1$AOAGZA014O5RE,BCC08F2A/videoquality$1080p/prod/7386/e18b/cfdf/49fd-b7f5-14d87fa36fd5/08ff1f00-581c-46a4-af2c-8ed9d4e646b7_corrected.mpd
20:41:40 277.690460 T:1960222720  NOTICE: VideoPlayer: Opening: http://s3.lvlt.dash.eu.aiv-cdn.net/d/1$AOAGZA014O5RE,BCC08F2A/videoquality$1080p/prod/7386/e18b/cfdf/49fd-b7f5-14d87fa36fd5/08ff1f00-581c-46a4-af2c-8ed9d4e646b7_corrected.mpd
20:41:40 277.693512 T:1960222720 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
20:41:40 278.022583 T:1499460512  NOTICE: Creating InputStream
20:41:44 281.724854 T:1499460512   ERROR: AddOnLog: InputStream MPEG DASH: Could not open / parse mpdURL (http://s3.lvlt.dash.eu.aiv-cdn.net/d/1$AOAGZA014O5RE,BCC08F2A/videoquality$1080p/prod/7386/e18b/cfdf/49fd-b7f5-14d87fa36fd5/08ff1f00-581c-46a4-af2c-8ed9d4e646b7_corrected.mpd)
20:41:44 281.725952 T:1499460512   ERROR: CVideoPlayer::OpenInputStream - error opening [http://s3.lvlt.dash.eu.aiv-cdn.net/d/1$AOAGZA014O5RE,BCC08F2A/videoquality$1080p/prod/7386/e18b/cfdf/49fd-b7f5-14d87fa36fd5/08ff1f00-581c-46a4-af2c-8ed9d4e646b7_corrected.mpd]
20:41:44 281.736053 T:1499460512  NOTICE: CVideoPlayer::OnExit()
20:41:44 281.758118 T:1960222720   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.amazon/?asin=B00YQ4MGAI&sitemode=PLAYVIDEO&mode=play&adult=0&name=The+Interview&trailer=0]

Searching the web I found this german post here that says there is no Widevine library available for the Raspberry Pi 1 (arm6). Is this true and I should stop trying?

If you see a chance of having a Pi1B run one of the named plugins, I'll gladly upload a debug log.
Hi Milhouse, the problem occurs when TV is off and I turn it back on, then goes the CEC connection lost and I must on the TV the KODI (RPi) source again select.
The RPi3 is connected to the TV via AV receiver and the AV receiver Is also connected via CEC so I can switch everything with one remote control.

I use master-slave power strip, the TV is master therefore when I turn off the TV then the AV receiver is also off but RPi is not, RPi is connected via extra current source

I would try to generate a log but what should I turn on?
Thanks for your attention!
[1x RPi3]#[ AV Receiver - Marantz NR1506 ]#[ TV Panasonic TX-50EXW784 ]#[ NAS @ OMV 4.1.xx (Arrakis) on NanoPI M4 ]#[ Nextcloud 16.0.4 @ ODROID C2 ]
I found the reason for my "Screensaver not working" problem. It's the Bluetooth "Standby" function. I had this enabled previously and everything worked, remote went into standby after a while and screensaver worked as by default. I did remove the BT remote a few days ago since I needed it for a different RPi and then paired it again with the RPi3 running LibreELEC Testbuilds. Enabling Standby for this remote actually prevents it from going into standby and the screensaver from working. Leaving standby disabled and the remote goes into standby and the screensaver works normal.

One related question: I now have a blank device in the BT menu. I tried to connect to it and it seems to be my Chromecast v2. Chromecast doesn't have BT as far as I know though...
(2016-11-01, 12:17)PeterPablo Wrote: that says there is no Widevine library available for the Raspberry Pi 1 (arm6). Is this true and I should stop trying?

Yes. Widevine on Pi1 is not possible as there are no armv6 libs. Pi2/Pi3 support armv7 which makes it possible.
(2016-11-01, 13:01)Aux_ Wrote: Hi Milhouse, the problem occurs when TV is off and I turn it back on, then goes the CEC connection lost and I must on the TV the KODI (RPi) source again select.
The RPi3 is connected to the TV via AV receiver and the AV receiver Is also connected via CEC so I can switch everything with one remote control.

I use master-slave power strip, the TV is master therefore when I turn off the TV then the AV receiver is also off but RPi is not, RPi is connected via extra current source

I would try to generate a log but what should I turn on?
Thanks for your attention!

Enable debug logging and "libCEC" in component specific logging. Reboot pi.
Reproduce problem (e.g. switch TV off and then on and try to use CEC buttons).

I'd suggest you create an issue here: https://github.com/Pulse-Eight/libcec/issues
(including a link to the log) where the right developer will see.
HW: Pi3, hdmi to TV
SW: libreelec milhouse build #1031, Amazon VOD 0.2.8 (sandmann79)

Amazon Prime Video works so far, but some movies doesn't show video, there is just the sound to hear. What can I do to correctly this error?
@origpumu
there are some DRM-changes initiated by amazon. so it needs some adjustments in the inputstream add-on - hopefully the devs will find a way.....
  •   
  • 1
  • 183
  • 184
  • 185(current)
  • 186
  • 187
  • 218
  •   
  Thread Closed
 
Thread Rating:
  • 19 Vote(s) - 4.63 Average



Logout Mark Read Team Forum Stats Members Help
LibreELEC Testbuilds for RaspberryPi (Kodi 17.0)4.6319