TVDB are updating their site. Their site currently has a number of bugs that have broken the TVDB scraper and any add-on that relies on TVDB data. TVDB are working to rectify the problems.

  •   
  • 1
  • 3
  • 4
  • 5
  • 6(current)
  • 7
  •   
v17 Auto de-interlacing (in PVR streams) does not always work
#76
What exactly is it that the above new test build fixes?
Reply
#77
Hi have also the same problem, the last build did not sort it out. It happens mostly with some HD channels, not all and not all to the same degree. I guess a new graphic card would be in order. In the meantime I found that activating "Adjust Display Refresh Rate" and "Sync Playback to Display" sorts out for now the problem and the channels display ok.
Reply
#78
Despite the fixes from weeks ago, with the current nightly I still - once in a while - notice de-interlacing problems that are solved by turning off de-interlacing, then re-activating it again (to DXVA). (I haven't checked the build from two posts above this one, because I don't know what it does.) This is on my Windows 10 / AMD combination.

It's definitely better than when I first posted this thread, but not 100% perfect like it was with Jarvis.

I'll see if I can reproduce it again tomorrow and post a debug log!
Reply
#79
What do you think why I have posted the link to test build in this thread? Just for fun? No test no fix
Reply
#80
(2016-11-13, 22:43)afedchin Wrote: What do you think why I have posted the link to test build in this thread? Just for fun? No test no fix
Well of course not, but I assumed it had something to do with software rendering instead of DXVA. Because that was mentioned by the posts above. But I'll test it tonight. Smile
Reply
#81
As I said early sw rendering is not used for hw accelerated videos. selecting rendering method doesn't make sense at all. Render methods other than dxva are used only for sw decoding.
Reply
#82
Hi guys!

Finally I had free time to make some tests and give my contribution to this topic.

Clean install of the build provided by afedchin (thanks a lot for your effort!) on my notebook Intel Core i5 with Intel HD Graphics 4000 and running Windows 7 Professional 32 bit. I made the following three tests by playing the interlaced video (.ts) that was posted in this thread a couple of weeks ago:

- Started Kodi. Played with the video settings as they are from the clean installation (DXVA is set for de-interlacing). The result is that the videdo is NOT de-interlaced. Exited Kodi. See this log.
- Started Kodi. While playing the video, I just entered the video settings from the bottom menu and, without selecting or changing something, the video started do be correctly de-interlaced. Exited Kodi. See this log.
- Started Kodi. The video is correctly de-interlaced without any action on my side. It seems that after the step described in the previous test, everything is now working as expected. See this log.

Can someone else confirm/double check this behaviour?

I hope this can help you to further progress in finding the solution of this issue. Please tell me if you need come further tests.

Cheers,

Alex
Light IMDb Ratings Update - Keep updated the IMDb ratings for your movies and TV shows.
In case you found useful my work, feel free to offer me a cappuccino!
Reply
#83
Good work. So once de-interlacing is working, are you able to trigger the error case again with the same video?
Reply
#84
Fernet, I've wrote you in the slack about the issue.
Reply
#85
(2016-11-14, 22:00)FernetMenta Wrote: Good work. So once de-interlacing is working, are you able to trigger the error case again with the same video?

Hi FernetMenta! Thanks, is a pleasure to help!

What do you mean by trigger again? Put the de-interlacing on OFF, again on DVXA and see if the issue happens again as it would be in the case of a clean installation (i.e. my first test)?
Light IMDb Ratings Update - Keep updated the IMDb ratings for your movies and TV shows.
In case you found useful my work, feel free to offer me a cappuccino!
Reply
#86
I think Fernet meant repeat with full clean install.
Reply
#87
I have moved back to the v17 beta 5 from the build a few posts up (to get CEC working) and have noticed that axlt2002's trick works here too - if you enter the video menu, but don't toggle, deinterlacing is activated and remains active even after quitting Kodi and restarting. In fact I can't seem to get deinterlacing to fail even by switching between all types of media. Perhaps this is why I thought that playing with the processing mode worked. It may also be why I thought the test build worked too...
Reply
#88
(2016-11-14, 23:01)afedchin Wrote: I think Fernet meant repeat with full clean install.

I can confirm that uninstalling and installing again Kodi, the story is the same.
Light IMDb Ratings Update - Keep updated the IMDb ratings for your movies and TV shows.
In case you found useful my work, feel free to offer me a cappuccino!
Reply
#89
(2016-11-14, 23:30)axlt2002 Wrote:
(2016-11-14, 23:01)afedchin Wrote: I think Fernet meant repeat with full clean install.

I can confirm that uninstalling and installing again Kodi, the story is the same.

Once you opened the settings dialog the settings get persisted. The issue turned out to be the obsolete AUTO setting that still might be stored in the video db.

Looks like afedchin found the culprit.
Reply
#90
please try with this build http://mirrors.kodi.tv/test-builds/win32...vc_wip.exe
make sure that you have fully clean install
Reply
  •   
  • 1
  • 3
  • 4
  • 5
  • 6(current)
  • 7
  •   
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
Auto de-interlacing (in PVR streams) does not always work51