Win Recently Added to Library not displayed correctly, Kodi 17.1
#1
Hi Guys,

I'm hoping someone on here can help me. I'll try explain the issue as best as possible. I cannot get the "Recently Added Movies" to display correctly.

A. I have a HTPC in the lounge room where all the files are stored on that PC and runs Kodi.
B. I have a PC in my bedroom, which also runs Kodi, but I use SMB (share through the network) to create the library.
C. Both are running 17.1 Kodi and are just about identical in setup, with each having their own library (not synced or anything).

1. Both PC's, I use advancedsettings.xml which are pasted into the correct userdata folder.

Quote:<advancedsettings>
<videolibrary>
<recentlyaddeditems>100</recentlyaddeditems>
<dateadded>2</dateadded>
</videolibrary>
</advancedsettings>

2. Now, here's my problem. One computer displays it correct, and one displays it incorrectly. Originally, my PC in the bedroom was correct and the HTPC was wrong.

3, I decided to uninstalled Kodi from the HTPC including the userdata folder, to start fresh thinking that this was a weird bug.

4. HTPC --> I installed Kodi, copied over advancedsettings into the userdata folder, after setting up the library, I check the recently added movies, and its working as expected, fantastic.

4. Bedroom PC --> I removed my library, and reset it up thinking it would be fine. Turns out, its now not showing up correctly. It is now showing it incorrect, like the HTPC was originally doing..

I cannot for the life of me, figure out what is going on here. Can anyone help or figure this out for me? Basically I just need "recently added movies" to actually just show what I've added to my library, one PC does it, the other won't, I tried to fix it, and now they do the reversal, the one that worked correct now doesn't, and the one that didn't, now does.

Bedroom PC - Incorrect
Image

HTPC - Correct
Image

Even if I remove advancedsettings from the folder, the view doesn't change, its like <dateadded>2</dateadded> does nothing, whether it is 0, 1, 2
<recentlyaddeditems> works fine and changes, but <dateadded> doesn't do anything.

Thoughts?

Cheers
Reply
#2
OK, so for the Bedroom PC (one that was showing incorrectly)...

1. First I took away advancedsettings.xml
2. Re-opened Kodi
3. Removed Library
4. Re-added Library using SMB
5. Checked and seems to be showing correctly.
6. Added in advancedsettings.xml and showing correctly with additional movies (96) which is correct.

Seems a bit strange, its like Kodi doesn't really need my <dateadded>2</dateadded> in the advancedsettings.xml or something.

I think the problem happens when...

A. advancedsettings.xml is in the folder, and then you scan the library, it doesn't display properly.
B. if advancedsettings.xml does not exist, and then you scan the library, it displays properly. Then adding advancedsettings.xml changes the recentlyadded figure. I don't think changing <dateadded> does anything.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Recently Added to Library not displayed correctly, Kodi 17.100